Jump to content

My Game is Freaking Out!!! (Glitch?)


Bcl235501

Recommended Posts

Bcl235501

Today, I was excited for another session of GTA 4 (TBoGT). I downloaded a few mods, like Simple Gang War and Riot Mode, along with ScriptHook.net. But, I've run into some issue. Issues that are not fixed, will hinder whether or not I complete the game. Firstly, I noticed that I couldn't take cover while using my controller. Instead, if I pressed it, there would be a little movement, as if Niko/Luis/Johnny wants to go into cover. But, nothing happens. Then, I realized that if I crouched then press the button, the PC (Player Character) would just get up. So, I became suspicious that one of the mods that I downloaded was the culprit for my problems. Nope. I deleted all the mods one by one then loaded the game back up. Nothing solved. Then, I believed that ScriptHook was the culprit, so I deleted that, too. Turns out that that solved it. But then, another problem occured, this one far worse. When I walked around and wanted to bring up my phone (up on D-Pad), nothing happened. So, I held the button down. Then, suddenly, my character began going through their weapons. So, I went to my keyboard and pressed the up arrow. Nothing happened. So, I brought everything back. The problem still persisted. I don't know what to do. I don't want to reinstall and downgrade the game all over again, which I've had to do once before. Can scripthook.net cause these glitches? Has this been a reported issue with it? I hope someone can help me through this process. I just want to enjoy this game with mods. I hope there's an easy way out of this 'hell'. P.S.: Yes, I do have Fusion Fix, Zolika Patch, DXVK, etc. installed (in case if anyone wants to know :)).

Link to comment
Share on other sites

Bcl235501
Posted (edited)

Update: Decided to reinstall the game, loaded up recent save, only to see that the issue still remained. So, I just loaded up an older save from the day before, and I got my phone back. This was before I installed ScriptHook.Net. So, I guess this means that this is a save issue. Huh. Weird.

Edited by Bcl235501
New Updates
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.