Jump to content

Cannot find 800x600x32 video mode


leonardosharp

Recommended Posts

leonardosharp

Hello,

 

I've bought GTA SA on Steam and when I try to start it I get the following error: "Cannot find 800x600x32 video mode".

 

What I've tried so far:

  • SilentPatch
  • WideScreen Fix
  • Setting compatibility mode on WinXP SP2
  • Starting directly from "gta-sa.exe" instead of pressing "Play" on Steam

 

My system's highlights (Lenovo IdeaPad S340-15IWL):

  • NVIDIA GeForce MX 230 GPU
  • Intel Core i7-8565U CPU
  • 8 GB RAM

 

When I've installed SilentPatch the error changed from "Cannot find 800x600x32" video mode to "Cannot find 1536x864x32 video mode".

Edited by leonardosharp
Link to comment
Share on other sites

1 hour ago, leonardosharp said:

Hello,

 

I've bought GTA SA on Steam and when I try to start it I get the following error: "Cannot find 800x600x32 video mode".

 

What I've tried so far:

  • SilentPatch
  • WideScreen Fix
  • Setting compatibility mode on WinXP SP2
  • Starting directly from "gta-sa.exe" instead of pressing "Play" on Steam

 

My system's highlights (Lenovo IdeaPad S340-15IWL):

  • NVIDIA GeForce MX 230 GPU
  • Intel Core i7-8565U CPU
  • 8 GB RAM

 

When I've installed SilentPatch the error changed from "Cannot find 800x600x32" video mode to "Cannot find 1536x864x32 video mode".

You also tried deleting gta_sa.set located in Documents\GTA San Andreas User Files?

What was your resolution, when did this start happening? Right when you bought the game and installed it clean it couldn't open?

Along with silent patch and widescreenfix, did you put asi loader too?

In the GTASA.WidescreenFix.ini file or some other, you can edit it and change resolution and aspect ratio I think, I don't remember but it's what I see with mine, have you tried that?

Edited by 44Orca

 2dQaqi9.png purple-diamond-gem.gif

Link to comment
Share on other sites

leonardosharp
1 hour ago, 44Orca said:

You also tried deleting gta_sa.set located in Documents\GTA San Andreas User Files?

What was your resolution, when did this start happening? Right when you bought the game and installed it clean it couldn't open?

Along with silent patch and widescreenfix, did you put asi loader too?

In the GTASA.WidescreenFix.ini file or some other, you can edit it and change resolution and aspect ratio I think, I don't remember but it's what I see with mine, have you tried that?

I don't have any "gta_sa.set" file. Yes, it started happening as soon as I downloaded the game. Yes, ASI Loader is installed. I will try to find the screen resolution setting in the .ini file and update you.

Link to comment
Share on other sites

leonardosharp

So, what I'm editing is:

 

[MAIN]
; Use this option to override the game resolution (-1|0|*).
ResX = 0
ResY = 0

 

in GTASAWidescreenFix.ini inside GTA San Andreas/scripts.

 

I've setted it to "-1" and it still displayed me "Cannot find 1536x864x32", then I tried setting it to "*" and it simply didn't start, without displaying any error messages.

Edited by leonardosharp
Link to comment
Share on other sites

@leonardosharp So you tried this? depending on your resolution, change the 0 to something else then check the ini file as "read me only" from properties, and 16:9 or whatever you have. Nothing else. Just aspect ratio and ResX/ResY.

I myself not sure if I put them there correctly but they do change my resolution

GAkdPgu.png

 

I'll put my folder here too (only see the stuff you have in your folders not the other ones, if you placed them in correct folders), modloader also works but these don't affect game files so you're good:

Spoiler

CcYwtYo.png    FV0k6EI.png

 

unmodded:

Spoiler

PBiZsaC.png

I don't know other than this, you could always verify game files from the game's steam options or try downgrading. Hope you find a solution.

 

Edited by 44Orca

 2dQaqi9.png purple-diamond-gem.gif

Link to comment
Share on other sites

leonardosharp
21 hours ago, 44Orca said:

@leonardosharp So you tried this? depending on your resolution, change the 0 to something else then check the ini file as "read me only" from properties, and 16:9 or whatever you have. Nothing else. Just aspect ratio and ResX/ResY.

I myself not sure if I put them there correctly but they do change my resolution

GAkdPgu.png

 

I'll put my folder here too (only see the stuff you have in your folders not the other ones, if you placed them in correct folders), modloader also works but these don't affect game files so you're good:

  Hide contents

CcYwtYo.png    FV0k6EI.png

 

unmodded:

  Hide contents

PBiZsaC.png

I don't know other than this, you could always verify game files from the game's steam options or try downgrading. Hope you find a solution.

 

I had placed SilentPatch inside the "scripts" folder. Now I've moved it to the main folder and I've tried your .ini settings, obviously changing the resolution to 1920x1080.

 

What's changed is that the game now just won't give me an error message, it simply won't start ahahaha

 

How can I downgrade?

Edited by leonardosharp
Link to comment
Share on other sites

Carl Theft Kumar

I had this problem in my old laptop once, I fixed it by searching up how to add custom resolutions in my PC and then I added 800x600x32.

unnamed.gif.524901f96c241fadbb2681e1b7c6

We're bad!

Link to comment
Share on other sites

leonardosharp

Seems like Windows Update is having some sort of problem with installing Intel Integrated Graphics' drivers on my specific laptop model.

 

Just fixed it by installing the drivers manually.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.