Jump to content

RDR2 pc crashing daily 2023


Ragnar22

Recommended Posts

ERR_GFX_STATE Error appearing daily,Β 

i have tried many things from internet to fix this but not solved yet.

i am playing it on 16gb Ram, RTX3050 4gb gpu and Ryzen 5-4600h laptop

and The game RDR2 bought on offer from Steam.

can someone help it. Thank you in Advance.

Link to comment
Share on other sites

24 minutes ago, Ragnar22 said:

ERR_GFX_STATE Error appearing daily,Β 

i have tried many things from internet to fix this but not solved yet.

i am playing it on 16gb Ram, RTX3050 4gb gpu and Ryzen 5-4600h laptop

and The game RDR2 bought on offer from Steam.

can someone help it. Thank you in Advance.

What of removing the sga files (or at least cut and paste outside of that folder) like it says in many other sites, that didn't work?

They are located inΒ C:\Documents\Rockstar Games\Red Dead Redemption 2\Settings

Β 

These are some comments, I don't know if you have seen them.

None of these worked from elsewhere? What about going to nVidia GeForce Experience and set optimum settings for rdr2, then in game change Vulkan to DirectX 12?

Set the game on lowest possible settings?

The other is:
3. Edit the system.xml file in documents/rdr2 folder and replace API Settings "Vulkan" to "DX12"
4. Save system.xml
5. Right Click-->Properties-->Security and set Disallow on Writing permission for all users. Apply/OK.

Edited by 44Orca

Β 2dQaqi9.pngΒ purple-diamond-gem.gif

Link to comment
Share on other sites

On 11/25/2023 at 7:54 PM, 44Orca said:

What of removing the sga files (or at least cut and paste outside of that folder) like it says in many other sites, that didn't work?

They are located inΒ C:\Documents\Rockstar Games\Red Dead Redemption 2\Settings

Β 

These are some comments, I don't know if you have seen them.

None of these worked from elsewhere? What about going to nVidia GeForce Experience and set optimum settings for rdr2, then in game change Vulkan to DirectX 12?

Set the game on lowest possible settings?

The other is:
3. Edit the system.xml file in documents/rdr2 folder and replace API Settings "Vulkan" to "DX12"
4. Save system.xml
5. Right Click-->Properties-->Security and set Disallow on Writing permission for all users. Apply/OK.

Thank you for reply, for now i deleted sga files and changed to directx12, but full screen not coming, before i was like applying troubleshoot method all at once instead one by one. so working for now lets see till how long it will work,Β  will update here. Thank you!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.