Jump to content

I can't get past the Activation Required message?


Emmi

Recommended Posts

Hi, two days ago I re-installed RDR2 on PC (Steam) and since then it won't let me play the game! After the loading screen (Rockstar Logo) the message comes ACTIVATION REQUIRED ... but I own the game, I am running the Rockstar Games Launcher and I'm connected to the internet all the time. WHAT IS GOING ON? I tried several solutions to solve this but nothing worked. Please help!

Link to comment
Share on other sites

@EmmiΒ If on PC this happens often for people, happened to me a few times as well, the game can start working on its own after a day or so so it's not big issue if it's the same problem. It's like a similar problem with GTA Online, which what fixes it for me is unplugging router and putting it back, or at least try to restart the router.

The other is try cut and pasting or deleting the System XML file outside of Documents\Rockstar Games\Red Dead Redemption 2\Settings, and launch the game.

Also what solutions did you try?

  • Like 1

Β 2dQaqi9.pngΒ purple-diamond-gem.gif

Link to comment
Share on other sites

On 6/3/2023 at 4:31 PM, 44Orca said:

@EmmiΒ If on PC this happens often for people, happened to me a few times as well, the game can start working on its own after a day or so so it's not big issue if it's the same problem. It's like a similar problem with GTA Online, which what fixes it for me is unplugging router and putting it back, or at least try to restart the router.

The other is try cut and pasting or deleting the System XML file outside of Documents\Rockstar Games\Red Dead Redemption 2\Settings, and launch the game.

Also what solutions did you try?

I re-installed the game again and tried every possible solution I could find on the internet and your suggestion with the system xml file but again nothing worked. I also tried to restart it a dozen of times but it did not work. What can I possibly do to fix this issue and be able to play the game again I BOUGHT???

Link to comment
Share on other sites

I think it's time to contact Rockstar themselves, I believe there's a specific category for your predicament.

Link to comment
Share on other sites

The Rockstar Support was actually able to solve this problem.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.