Jump to content

Red Dead 2 won’t launch from any platform


m0nstaLulz

Recommended Posts

Hi guys. I’m hoping someone has insight or can help with this issue. 
 

I bought Red Dead 2 on the rockstar launcher  a week ago and I’ve been trying to play it, and it just won’t launch.

 

Whenever I hit the play button, it’s stuck on loading. Here’s a picture. 
 

spacer.png

 

I’ve uninstalled and reinstalled multiple times. Uninstalled rockstar launcher and everything related to it. Tried launching the program as administrator.


I bought it from Steam with the Autumn sale, and it still doesn’t work. 

I’ve even downloaded a pirated version to see if it would launch (maybe it’s the rockstar launcher), and it won’t launch. 
 

I’m on Windows 11 and have a 7900x and a 3080. I’m thinking it’s the 7900x, because it’s a new platform? 

 

If anyone can help, I would appreciate it. Thank you. 

Link to comment
Share on other sites

SM00V 0PERAT0R

Could just be a bug with windows... I mean, it is Windows 11...

 

But I've encountered the lockout from their social media stuff and it's usually something in windows not loading properly or something that was disabled. Did you disable any startup stuff through System Configurator? Any background programs maybe conflicting with Rockstars bloatware connecting?

 

Did you ever figure it out?

Edited by Montana Actual
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.