Jump to content

[WORKAROUND] Lots of Audio Missing after Unlocking Shoreside Vale -- It's As Weird As it Sounds


Invader115
Go to solution Solved by Invader115,

Recommended Posts

EDIT, Dec. 3rd 2021: Using re3 (the reverse-engineered GTA3 project that's got R* all pissy) and a mod that unlocks all the islands from the start of the game, I managed to make a save in re3 from the Staunton Island safehouse with the lift bridge active. The audio works perfectly in re3. This has me curious if I somehow screwed up my DSOAL & EAX Alchemy Fix configuration. I don't want to keep using re3 because I'd lose my save, and because most mods don't work with re3, but I consider this progress.

 

 

 

I had a GTA 3 install that was working perfectly until I unlocked Shoreside Vale. Now GTA 3's audio is totally screwed up, and I think it's because of the lift bridge and its obnoxious ringing sound.

 

What happens is every time I load the game from the Staunton Island safehouse, vehicle door opening/closing and engine sounds are gone (for my vehicle and AI vehicles), but some sounds like vehicle collisions, the garage door's sound, the radio, and gunshots still play. If I drive all the way to Portland, save at the safehouse there and load that new save, the audio comes back.

 

Most bizarre to me is how many things I've tried to fix this. I had a ton of mods installed at first, but I reconfigured the hell out of them, removing them one-by-one, the works. I deleted GTA 3 entirely and reinstalled it (via Steam) with no mods at all and the problem was still there. Hell, I installed GTA 3 on a totally different PC and it was still broken. The only thing the PC's have in common, that I know of, is they're both on the latest version of Windows 10. None of the compatibility mode settings helped, but that doesn't mean the OS isn't an issue -- but if it's Win 10, why doesn't anyone else seem to be complaining about the same problem?

 

Partway through troubleshooting this I had to reinstall Windows. It's pretty much the same version, just a fresh Windows 10 that's fully updated, but even that fresh slate didn't fix this. I've also tried deleting my settings file, and installing & tinkering with mods like DSOAL to change the audio settings. Those mods work fine, unlocking all the hardware accelerated audio settings and enabling their effects, but no combination of settings fixed my problem.

 

Earlier I mentioned I think it's the lift bridge bell. When I load at Staunton Island, right away I hear the bell cutting in and out for a moment, then it goes silent. With that audio glitch in mind, and the fact the game works fine when I load from the other safehouse, I'm convinced the bell noise is screwing with some audio processing or whatever. No idea what to do with that information, but it's my best guess.

 

Any help at all is appreciated. I have no idea what to try next.

 

 

 

EDIT: I forgot to include my PC specs like I'm supposed to.

 

CPU: Intel i9-10900k     GPU: Nvidia RTX 2080 Ti     RAM: 32GB DDR4 3200MHz     OS: Windows 10 x64 build 19043.1288     Motherboard: ASUS TUF Gaming Z490-Plus      I don't have a dedicated sound card and I only have stereo speakers.

 

 

I always play with the frame limiter enabled. Normally I play GTA 3 with the Framerate Vigilante mod installed, so I'll cap the framerate at 50 FPS, but I've troubleshooted this problem locked at the default capped framerate and that didn't change anything.

 

My post was also kinda light on specifics about my mod and settings configurations, but that's because I've tried a huge amount of configurations. It was a totally brute force approach, trying tons of combinations hoping I could get anything to change, so I'm confident but not certain the problem isn't related to my settings.

 

 

EDIT 2: Another thing I already tried, which I should mention, is making sure the game isn't trying to play audio in surround sound. I've gone through the settings in Windows to make sure the OS is only set to play sound in stereo and GTA 3's audio settings have only ever been set to stereo. My system's sound comes from a single 3.5mm audio jack on the motherboard so I don't think the system should be confused about how to play audio. Also, no other games or software have had anything like the problem GTA 3 is having.

Edited by Invader115
Link to comment
Share on other sites

It looks like a similar issue has been reported before. There are a couple of fixes in here.

 

 

KOIAEOY.png

Link to comment
Share on other sites

  • 2 weeks later...

I wish I'd seen your reply sooner, I only just checked this thread again today.

 

The SFX files that user said were missing are in my GTA 3 install like they should be (at ".../Grand Theft Auto 3/audio"). To make sure I wasn't using some weird version of the files from a mod or something I just deleted and redownloaded GTA 3 from Steam and they're definitely being included as part of the official download.

 

That said, when searching for extra info on those files just now I found a tool for changing GTA 3's sounds. I dicked around with the bridge bell's sound for a bit since my hunch is that it's the root of the problem, but I wasn't able to accomplish much. I mean, I was able to replace it with silence, and then I made a "bruh" bell that I might never uninstall, but it didn't have any effect on my audio problem. My guess is if the lift bell really is the problem, it would need to be removed via scripting, stopping the sound from existing at all in any state.

 

Thanks for the help regardless. I'll keep an eye out for any more leads but for now I'm still where I started.

Link to comment
Share on other sites

  • 1 month later...
  • Solution

Alright, this is a necropost AND a double-post but I've finally settled on a workaround. There's some new information on the problem as well, but I'm less interested in actually fixing it now. I'd rather get back to playing the damn game, which I can finally do now.

 

First, some more information about the problem: I'd been troubleshooting on and off over the last few months and something I realized weeks ago is that if I try to keep playing despite the audio being all screwed up the game crashes pretty quickly. I had, or at least I believe I had seen a few different error codes after these crashes but just today I spotted one that is remarkably consistent: "Unhandled exception: c0000005 At address: 0059f286". That exception ID is pretty well known with a lot of people claiming to have fixed it but none of the solutions I tried worked. The address ID seems like a more direct lead but Google comes up completely empty when I search it.

 

Triggering this crash is pretty easy, I just run up to the street and start shooting things. It seems like scaring a large group of peds is enough to trigger the crash, but if I just scare a few and then get into a shootout with the police it'll crash in less than a minute. It might be relevant that part of my audio problem is none of the peds talk or scream.

 

 

The workaround I settled on: I went to this thread:

and downloaded a fresh save from exactly where I was when the problems started (which was after finishing "A Drop in the Ocean"). Everything works perfectly now. Seems like whatever the problem was, it was directly related to my save file. Christ knows how a corrupt save would cause the problems I was having, but that's that. My stats and hidden package progress are obviously gone but I'm more than happy to keep playing from here.

 

I'm assuming I corrupted my save by changing around the mods I was using several times across my playthrough.

Edited by Invader115
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.