Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Contract
      2. Updates
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Blood Money
      2. Frontier Pursuits
      3. Find Lobbies & Outlaws
      4. Help & Support
    3. Crews

    1. Grand Theft Auto Series

      1. Bugs*
      2. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Classic GTA SA
      2. Guides & Strategies
      3. Help & Support
    6. GTA Vice City

      1. Classic GTA VC
      2. Guides & Strategies
      3. Help & Support
    7. GTA III

      1. Classic GTA III
      2. Guides & Strategies
      3. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

    2. Support

    3. Suggestions

GTAForums is very unstable on iOS 15 with the updated version of Safari


VideoTech
 Share

Go to solution Solved by Spider-Vice,

Recommended Posts

Just wanted to pop in a report that GTAFourms intends to occasionally fails to render replies in active topics and may at times result in the page from completely crashing. I found the last version of iOS to be way more stable here but since Apple made more useless updates to Safari (sigh), it’s made this site completely difficult to use now. 

 

 

Edited by VideoTech
  • Like 3
Link to comment
Share on other sites

Hey! This has been a struggle for more Invision site owners. A lot of users on Safari/iOS browse without issues, but another lot report occasional issues with the forums. We have had Support emails saying this is happening on other Invision forums too, so it's very likely an issue on their part, or Apple's part.


We have not been able to diagnose anything useful about this issue over the past few months unfortunately. It's nothing we have done ourselves. I believe this mostly happens in more complex topics where people post a lot of videos or images. I also do think this may be an Apple issue at least partially, as they are usually behind with adopting certain web standards in Safari, and its behaviour changes a lot between versions.

Even if you use Chrome, Apple does not allow external web renderers on their ecosystem, so it is still Safari with extra Chrome features.


We have had staff members test different iOS and Mac OS versions with differing results...

 

Cheers!

  • Like 2

image.pngut_dog.png   image.png

let your hopes and dreams turn into burning fire!

GTANet | Red Dead Network | kifflom 

black lives matter | stop Asian hate | trans lives = human lives

Link to comment
Share on other sites

Add me to the list of Apple users that struggle to view this site. iPhone. iPad. iMac. Different devices but same experience each time. It started happening about six months ago.

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

Not necessarily an iOS 15 issue. I'm still on iOS 14.7.1 and I've had this issue for like a year now. What I have noticed is that it only happens when you are logged in. When logged out or in incognito mode the forum works without an issue. I think this could be a lead, but I don't know if you guys looked at it before. Don't wanna say anything dumb without checking, but did you guys try to emulate iOS or did anyone try to connect an iOS device to pc for debugging purposes?

  • Like 1
Link to comment
Share on other sites

  • 4 months later...
ṼirulenⱦEqừinox

I tried going to a post reply notification I had gotten but when I was directed to the post the browser the page went white, then loaded but then suddenly reloaded went white again and then gave me the unable to connect to server error.

 

No issues on PC browser when going to same notifications

 

Animated GIF

 

@uNi

Edited by ṼirulenⱦEqừinox
Link to comment
Share on other sites

  • 3 weeks later...
ṼirulenⱦEqừinox
On 3/22/2022 at 6:58 AM, uNi said:

Is this still happening for you @ṼirulenⱦEqừinox ? Seems to be sorted on my end.

It’s still doing it for me this time in the us current events thread

Link to comment
Share on other sites

Haribokart

Every page takes forever to load, typing and responding can be slow as hell and performance is just terrible. Shame cos I love the place but it keeps me from posting a lot (good for everyone else!) but I have no issues on any other sites. I use Safari on MacOS and iOS.

 

Is it just happening for me or everyone?

Link to comment
Share on other sites

1 hour ago, Haribokart said:

I use Safari on MacOS and iOS.

 

This is a on going issue with MacOS and iOS.

 

 

Link to comment
Share on other sites

Haribokart

Damn, hopefully it can be sorted. Literally the only website I use that performs so poorly, everything else is super fast and smooth.

Link to comment
Share on other sites

19 minutes ago, Haribokart said:

Damn, hopefully it can be sorted. Literally the only website I use that performs so poorly, everything else is super fast and smooth.

 

The problem is it's been hard to find the issue with it. For me it works fine on MacOS but on iOS is just horrible most times.

 

 

Link to comment
Share on other sites

  • 1 month later...

Looks like after the latest ios update the problem is fixed 

Atleast for me

 

5WnOKldb.jpgmnMYrlSb.jpg5WnOKldb.jpg

Got Scamed by this Indian @AkshayKumar :(

Link to comment
Share on other sites

Yarrow

This site is so horribly optimized, have any of the mods checked this on mobile? I have a iphone 13 pro and it still falls behind. My old iphone would just crash all together. Fix your sh*t

Link to comment
Share on other sites

Len Lfc
5 hours ago, Yarrow said:

This site is so horribly optimized, have any of the mods checked this on mobile? I have a iphone 13 pro and it still falls behind. My old iphone would just crash all together. Fix your sh*t

Same... yeah, it's pretty crap on iPhone or iPad :/ 

  • Like 2
  • Best Bru 1

Countdown to annou... Oh, right...

The GTA VI Leak Archive | GTA VI Timeline of Events | Analyzing the Past

Link to comment
Share on other sites

Xquic
9 minutes ago, Len Lfc said:

Same... yeah, it's pretty crap on iPhone or iPad :/ 

Yeah I said the same thing months ago. Just poorly optimized on mobile. I have to reload page at least three times to see the new post lol

Link to comment
Share on other sites

Orthur

I think it's an iOS only issue, it works like a charm on Android for me.

 

That's not to say it's perfect, I still prefer the site on desktop because there's some issues on mobile browsers (sometimes you can't backspace after typing something, can't backspace a quote if you accidentally quoted someone, etc)...

  • Like 3
Link to comment
Share on other sites

Pete4000uk
11 hours ago, Yarrow said:

This site is so horribly optimized, have any of the mods checked this on mobile? I have a iphone 13 pro and it still falls behind. My old iphone would just crash all together. Fix your sh*t

 

All seems fine on my Android 

  • Like 2
Link to comment
Share on other sites

Uncle Sikee Atric
7 minutes ago, Pete4000uk said:

 

All seems fine on my Android 

 

I was going to say, I have no problem on Android either.... 

 

But then, maybe that's just me?

anigif_sub-buzz-942-1583079830-6.gif

 

 

MOaRJRr.jpg

Link to comment
Share on other sites

GN 92
12 hours ago, Yarrow said:

This site is so horribly optimized, have any of the mods checked this on mobile? I have a iphone 13 pro and it still falls behind. My old iphone would just crash all together. Fix your sh*t

Yeah f*cked up for mobile here as well. iOS user too.

Link to comment
Share on other sites

Gta6 fan
11 hours ago, Pete4000uk said:

 

All seems fine on my Android 

Yeah my android phone which was in -19 degree Celsius In freezer for 1 hour also seems okay.Just one thing is that the more time we spend in this forum the more the phone lags.To solve this,delete the tab and again open the forum.

Link to comment
Share on other sites

Working a lot better for me on 12 Pro Max with the latest updated.

 

 

Link to comment
Share on other sites

  • 2 weeks later...
  • Solution
Spider-Vice

We maaaaay have tracked down the issue to something as simple as one line of CSS (an "overflow: hidden" applied to a larger element) causing an issue because Safari truly is the Internet Explorer of Apple when it comes to stability and web standards lmao. Removing that CSS line we were using to work around a bug with the navigation sidebar, testing with several device simulators/emulators/streams online instantly showed a major improvement on my end. Unfortunately, removing that workaround also broke the navigation sidebar, so we'll be looking into that now in the next few days.

 

If this means iOS members can browse the site more quickly, then by all means, we'd rather have that and temporarily sacrifice the left hand sidebar than slow browsing.

 

I am still utterly puzzled as to why being logged on/off mattered (a staff member noted this a while back too), as both guests and members load the same styling content, perhaps the guest pages being mostly static HTML refreshed every X seconds helped there, no idea. Safari is one of the hardest browsers to debug issues with, as it can be literally the only browser to have issues with certain code that no other browser does due to Apple's restrictive rules.

image.pngut_dog.png   image.png

let your hopes and dreams turn into burning fire!

GTANet | Red Dead Network | kifflom 

black lives matter | stop Asian hate | trans lives = human lives

Link to comment
Share on other sites

VideoTech

Yup, I can confirm it’s working more stable than before on Pro Max 13. Thank you for your continued hard work! 

Link to comment
Share on other sites

Yarrow
1 hour ago, Spider-Vice said:

We maaaaay have tracked down the issue to something as simple as one line of CSS (an "overflow: hidden" applied to a larger element) causing an issue because Safari truly is the Internet Explorer of Apple when it comes to stability and web standards lmao. Removing that CSS line we were using to work around a bug with the navigation sidebar, testing with several device simulators/emulators/streams online instantly showed a major improvement on my end. Unfortunately, removing that workaround also broke the navigation sidebar, so we'll be looking into that now in the next few days.

 

If this means iOS members can browse the site more quickly, then by all means, we'd rather have that and temporarily sacrifice the left hand sidebar than slow browsing.

 

I am still utterly puzzled as to why being logged on/off mattered (a staff member noted this a while back too), as both guests and members load the same styling content, perhaps the guest pages being mostly static HTML refreshed every X seconds helped there, no idea. Safari is one of the hardest browsers to debug issues with, as it can be literally the only browser to have issues with certain code that no other browser does due to Apple's restrictive rules.

Thank you, finally smooth on my 13. It used to be completely unusable on my old phone lol

  • Like 1
Link to comment
Share on other sites

ART_TRA
5 hours ago, Spider-Vice said:

We maaaaay have tracked down the issue to something as simple as one line of CSS (an "overflow: hidden" applied to a larger element) causing an issue because Safari truly is the Internet Explorer of Apple when it comes to stability and web standards lmao. Removing that CSS line we were using to work around a bug with the navigation sidebar, testing with several device simulators/emulators/streams online instantly showed a major improvement on my end. Unfortunately, removing that workaround also broke the navigation sidebar, so we'll be looking into that now in the next few days.

 

If this means iOS members can browse the site more quickly, then by all means, we'd rather have that and temporarily sacrifice the left hand sidebar than slow browsing.

 

I am still utterly puzzled as to why being logged on/off mattered (a staff member noted this a while back too), as both guests and members load the same styling content, perhaps the guest pages being mostly static HTML refreshed every X seconds helped there, no idea. Safari is one of the hardest browsers to debug issues with, as it can be literally the only browser to have issues with certain code that no other browser does due to Apple's restrictive rules.

What is this feelings? it's very slippery. 

Thank you, i can’t waiting for iFruit version.

Link to comment
Share on other sites

Yarrow
1 hour ago, ART_TRA said:

What is this feelings? it's very slippery. 

Thank you, i can’t waiting for iFruit version.

Whats your mean?

Link to comment
Share on other sites

ART_TRA
Posted (edited)
27 minutes ago, Yarrow said:

Whats your mean?

iFruit i'm joking and it's really quickly after fixed sorry my English bad.:cringekek:

Edited by ART_TRA
  • KEKW 2
Link to comment
Share on other sites

Gravarty

You can't imagine how unfamiliar this site feels to me because of the missing sidebar. At first I thought I got automatically logged out or something :D But if this fixes the problems, i'm fine with that :D But I hope that this will be fixed in the near future 😛 

Link to comment
Share on other sites

touchedmysoul09

Oh my god this site is running SO MUCH BETTER now on both my iPhone and Mac. THANK YOU. Was basically unable to use the site without constant freezing and crashing beforehand.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • 5 Users Currently Viewing
    0 members, 0 Anonymous, 5 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.