Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Cayo Perico Heist
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA VI

      1. St. Andrews Cathedral
    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. Announcements

    2. Support

    3. Suggestions

Game crashes after following exact instructions on installing addon car.


That58Plymouth

Recommended Posts

That58Plymouth

My game crashes every time I try to load into single player after trying to install any addon car. I have followed the instructions perfectly in each readme for the cars as I have tried multiple mods. I was wondering if someone could point me in the right direction for what I am doing wrong.

Link to post
Share on other sites
LeeC22
39 minutes ago, That58Plymouth said:

My game crashes every time I try to load into single player after trying to install any addon car. I have followed the instructions perfectly in each readme for the cars as I have tried multiple mods. I was wondering if someone could point me in the right direction for what I am doing wrong.

 

Tell us what you are doing, tell us what mods you are doing it with and we might be able to see what you are doing wrong.

Link to post
Share on other sites
That58Plymouth
7 hours ago, LeeC22 said:

 

Tell us what you are doing, tell us what mods you are doing it with and we might be able to see what you are doing wrong.

I am trying to put addon cars into the game. The first time I tried this with a 1958 Plymouth mod from 5mods, the next with a 1958 Edsel Citation from the same place. For each car I put the correct line of code into dlclist.xml as well the mod folder with the dlc.rpf file in update/x64/dlcpacks. I hope that is clear. Not sure what I'm doing wrong

Just now, That58Plymouth said:

I am trying to put addon cars into the game. The first time I tried this with a 1958 Plymouth mod from 5mods, the next with a 1958 Edsel Citation from the same place. For each car I put the correct line of code into dlclist.xml as well the mod folder with the dlc.rpf file in update/x64/dlcpacks. I hope that is clear. Not sure what I'm doing wrong

Once I did this, the game crashes when I try to load in after pressing single player.

Link to post
Share on other sites
LeeC22
6 minutes ago, That58Plymouth said:

I am trying to put addon cars into the game. The first time I tried this with a 1958 Plymouth mod from 5mods, the next with a 1958 Edsel Citation from the same place. For each car I put the correct line of code into dlclist.xml as well the mod folder with the dlc.rpf file in update/x64/dlcpacks. I hope that is clear. Not sure what I'm doing wrong

Once I did this, the game crashes when I try to load in after pressing single player.

 

Did you download and install a modded gameconfig from that site as well? That's usually an essential part of modding and the game will often crash without one.

Link to post
Share on other sites
That58Plymouth
16 minutes ago, LeeC22 said:

 

Did you download and install a modded gameconfig from that site as well? That's usually an essential part of modding and the game will often crash without one.

I did not. I am actually unaware of having to do this. What is one I could download? 

Link to post
Share on other sites
LeeC22
3 hours ago, That58Plymouth said:

Using that didn't work. The game still crashes on loading

 

If you rename your mods folder to no_mods, does the game load?

Link to post
Share on other sites
MaurícioAl10
21 hours ago, That58Plymouth said:

Using that didn't work. The game still crashes on loading

this gameconfig is the best it has, but it is missing 2 mods that are needed and that are mentioned in the gameconfig description.
https://www.gta5-mods.com/tools/heap-limit-adjuster-600-mb-of-heap
https://www.gta5-mods.com/tools/packfile-limit-adjuster

Edited by MaurícioAl10
Link to post
Share on other sites
That58Plymouth

I still have no fix for this. Just tried more vehicles and got the same results. I'm doing everything right

 

Link to post
Share on other sites
That58Plymouth

Update: So after looking in the error log this is what I got ERROR 0xc0000005. A fix was to put the old dinput8 and other associated files from System 32 into the main game folder and that allowed the game to boot but then I couldn't open any trainers or anything. So then I put the dinput8 file from scripthook back in and the game crashed like always. I have exhausted literally all known options from tutorials and other posts where people discuss this issue. At this point I'd even consider paying someone for a fix. so for a recap, the game with a normal trainer and dinput8 with the addon car mod installed crashes on loading screen. With the original dinput8 and the car mod in the files the game boots buts obviously I cant actually access it when I'm in game. Please can someone offer a solution or just a suggestion. I've spent about 5 hours total trying to fix it

Link to post
Share on other sites
LeeC22

Let me repeat the question you still haven't answered... in a normal sized font.

 

If you install just the ScriptHookV files and rename your mods folder to no_mods, does the game work?

 

You have to diagnose the cause of the problem and you can't do that unless you eliminate potential causes from the equation. You have to determine if scripthookv is working and you can't do that while you keep throwing addon cars into the mix.

 

1) Check with just scripthookv with no other mod files in your game folder. Only ScriptHookV.dll and dinput8.dll

 

That will test if ScriptHookV is working. if that works...

 

2) Create a clean mods folder that only contains the update.rpf file with the modded gameconfig installed and OpenIV.asi installed in your game folder.

 

That will check if the mods folder is working. If that works...

 

3) Add a single car addon. Not 5 or 10 or 20, just one.

 

That will test if addons are working properly.

 

If you get to here, then you now know that scripthookv and your mods folder is working properly. If you decide to skip doing those steps, then you can't work out where the problem lies.

 

4) Install the heap adjuster and packfile limit adjuster linked above by MaurícioAl10 and then install a few more cars.

 

Doing all that will take you less than 10 minutes and will provide essential answers to the questions.

Link to post
Share on other sites
That58Plymouth

 

6 hours ago, LeeC22 said:

Let me repeat the question you still haven't answered... in a normal sized font.

 

If you install just the ScriptHookV files and rename your mods folder to no_mods, does the game work?

 

You have to diagnose the cause of the problem and you can't do that unless you eliminate potential causes from the equation. You have to determine if scripthookv is working and you can't do that while you keep throwing addon cars into the mix.

 

1) Check with just scripthookv with no other mod files in your game folder. Only ScriptHookV.dll and dinput8.dll

 

That will test if ScriptHookV is working. if that works...

 

2) Create a clean mods folder that only contains the update.rpf file with the modded gameconfig installed and OpenIV.asi installed in your game folder.

 

That will check if the mods folder is working. If that works...

 

3) Add a single car addon. Not 5 or 10 or 20, just one.

 

That will test if addons are working properly.

 

If you get to here, then you now know that scripthookv and your mods folder is working properly. If you decide to skip doing those steps, then you can't work out where the problem lies.

 

4) Install the heap adjuster and packfile limit adjuster linked above by MaurícioAl10 and then install a few more cars.

 

Doing all that will take you less than 10 minutes and will provide essential answers to the questions.

The problem lies in the any add on car I add. Scripthook works perfectly and the game starts up with no issues with the clean mods folder. When I add just a single addon car that's when the game crashes. I even have the packfile limit adjuster and the heap adjuster installed and that doesnt help me either. Hopefully that solves some things

Link to post
Share on other sites
LeeC22
1 hour ago, That58Plymouth said:

 

The problem lies in the any add on car I add. Scripthook works perfectly and the game starts up with no issues with the clean mods folder. When I add just a single addon car that's when the game crashes. I even have the packfile limit adjuster and the heap adjuster installed and that doesnt help me either. Hopefully that solves some things

 

Install this addon ped and let me know what happens. https://drive.google.com/file/d/18mPBAn1euOxjsC1Yd8THnLc1uxk8uD1t/view?usp=sharing

 

It's just a normal game ped renamed and converted into an addon. The point of it is that it isn't a car addon and I want to know if this also causes the game to crash.

 

You need to add this line to the dlclist.xml

<Item>dlcpacks:/testped/</Item>

 

So the bottom of your dlclist should look like this:

        <Item>dlcpacks:/testped/</Item>
    </Paths>    
</SMandatoryPacksData>

 

If it doesn't crash and you have a trainer installed, you can spawn it as a_f_y_tourist_03 to check it spawns ok as well.

Edited by LeeC22
Link to post
Share on other sites
That58Plymouth
4 minutes ago, LeeC22 said:

 

Install this addon ped and let me know what happens. https://drive.google.com/file/d/18mPBAn1euOxjsC1Yd8THnLc1uxk8uD1t/view?usp=sharing

 

It's just a normal game ped renamed and converted into an addon. The point of it is that it isn't a car addon and I want to know if this also causes the game to crash.

 

You need to add this line to the dlclist.xml

<Item>dlcpacks:/testped/</Item>

 

So the bottom of your dlclist should look like this:

        <Item>dlcpacks:/testped/</Item>
    </Paths>    
</SMandatoryPacksData>

 

The game loaded up perfectly.

Link to post
Share on other sites
LeeC22
11 minutes ago, That58Plymouth said:

The game loaded up perfectly.

 

Okay, now try this one https://drive.google.com/file/d/16kV2cZLVM45U_OZCDSSe4K4kAlicpwTX/view?usp=sharing

 

This is the same thing but now it is a car, I specifically chose one with no tuning options to keep everything to a minimum. Spawn with dilettante3 to check completely.

 

Add this to the dlclist

<Item>dlcpacks:/testcar/</Item>

 

Your dlclist should look like this at the bottom if you have both installed.

         <Item>dlcpacks:/testped/</Item>
         <Item>dlcpacks:/testcar/</Item>
    </Paths>    
</SMandatoryPacksData>

 

Link to post
Share on other sites
That58Plymouth
4 minutes ago, LeeC22 said:

 

Okay, now try this one https://drive.google.com/file/d/16kV2cZLVM45U_OZCDSSe4K4kAlicpwTX/view?usp=sharing

 

This is the same thing but now it is a car, I specifically chose one with no tuning options to keep everything to a minimum. Spawn with dilettante3 to check completely.

 

Add this to the dlclist

<Item>dlcpacks:/testcar/</Item>

 

Your dlclist should look like this at the bottom if you have both installed.

         <Item>dlcpacks:/testped/</Item>
         <Item>dlcpacks:/testcar/</Item>
    </Paths>    
</SMandatoryPacksData>

 

The game crashed like usual. Very interesting

Link to post
Share on other sites
LeeC22
1 minute ago, That58Plymouth said:

The game crashed like usual. Very interesting

 

Are you running the latest game version? I'm going to try adding these two addons to my clean version with no modded gameconfig to see what happens.

Link to post
Share on other sites
That58Plymouth
1 minute ago, LeeC22 said:

 

Are you running the latest game version? I'm going to try adding these two addons to my clean version with no modded gameconfig to see what happens.

I am running the latest version

Link to post
Share on other sites
LeeC22
5 minutes ago, That58Plymouth said:

I am running the latest version

 

Well now... there's interesting, my game crashed. :D

Link to post
Share on other sites
That58Plymouth
6 minutes ago, LeeC22 said:

 

Well now... there's interesting, my game crashed. :D

oh man haha

Link to post
Share on other sites
LeeC22
5 minutes ago, That58Plymouth said:

oh man haha

 

This was actually perfect, because it meant I had exactly the same problem to solve. I knew my game was fine because I had just disabled a 2GB dlc pack of trains to try this out.

 

The gameconfig I linked to at the top, which is currently v23. Use the gameconfig from the Stock Traffic (Means Gta base) folder. I installed that and my game now loads without crashing.

 

Edit: Just for reference, my heap adjuster and packfile adjuster settings are as follows:

HEAP_SIZE = 2048

 

packfile_list_size = 5208

Edited by LeeC22
Link to post
Share on other sites
That58Plymouth
Just now, LeeC22 said:

 

This was actually perfect, because it meant I had exactly the same problem to solve. I knew my game was fine because I had just disabled a 2GB dlc pack of trains to try this out.

 

The gameconfig I linked to at the top, which is currently v23. Use the gameconfig from the Stock Traffic (Means Gta base) folder. I installed that and my game now loads without crashing.

I am using the stock traffic one and it still crashes...

Link to post
Share on other sites
LeeC22
3 minutes ago, That58Plymouth said:

I am using the stock traffic one and it still crashes...

 

It looks like you are one of the few people that struggle to get a compatible gameconfig working in your system. You could try this one and see if that works. https://www.gta5-mods.com/misc/gameconfig-1-0-2060-ls-summer-special

 

If it doesn't, then it means you are going to struggle to get addon cars working in your game. I know nothing about gameconfigs, I create mods but I don't touch gamefiles, especially the gameconfig. I don't understand it and would break more than I could ever possibly solve.

 

Sorry I can't help much more than this, I have exhausted all my options I am afraid. :(

Link to post
Share on other sites
That58Plymouth
4 minutes ago, LeeC22 said:

 

It looks like you are one of the few people that struggle to get a compatible gameconfig working in your system. You could try this one and see if that works. https://www.gta5-mods.com/misc/gameconfig-1-0-2060-ls-summer-special

 

If it doesn't, then it means you are going to struggle to get addon cars working in your game. I know nothing about gameconfigs, I create mods but I don't touch gamefiles, especially the gameconfig. I don't understand it and would break more than I could ever possibly solve.

 

Sorry I can't help much more than this, I have exhausted all my options I am afraid. :(

That new config worked!!! Thanks man!

  • Like 1
Link to post
Share on other sites
leihebi
12 hours ago, That58Plymouth said:

Update: So after looking in the error log this is what I got ERROR 0xc0000005. A fix was to put the old dinput8 and other associated files from System 32 into the main game folder and that allowed the game to boot but then I couldn't open any trainers or anything. So then I put the dinput8 file from scripthook back in and the game crashed like always. I have exhausted literally all known options from tutorials and other posts where people discuss this issue. At this point I'd even consider paying someone for a fix. so for a recap, the game with a normal trainer and dinput8 with the addon car mod installed crashes on loading screen. With the original dinput8 and the car mod in the files the game boots buts obviously I cant actually access it when I'm in game. Please can someone offer a solution or just a suggestion. I've spent about 5 hours total trying to fix it

Program abnormal exit (flashback) code 0xc0000005

It's a good habit to look at the official r-star website, r-star will tell you that the current gta doesn't support certain things, so update your windows and video card drivers and restart your computer

Link to post
Share on other sites
That58Plymouth
8 minutes ago, LeeC22 said:

 

It looks like you are one of the few people that struggle to get a compatible gameconfig working in your system. You could try this one and see if that works. https://www.gta5-mods.com/misc/gameconfig-1-0-2060-ls-summer-special

 

If it doesn't, then it means you are going to struggle to get addon cars working in your game. I know nothing about gameconfigs, I create mods but I don't touch gamefiles, especially the gameconfig. I don't understand it and would break more than I could ever possibly solve.

 

Sorry I can't help much more than this, I have exhausted all my options I am afraid. :(

Oh no, now I put an actual car mod in and the game wont even boot. It says the files are corrupted

 

Link to post
Share on other sites
LeeC22
19 minutes ago, That58Plymouth said:

Oh no, now I put an actual car mod in and the game wont even boot. It says the files are corrupted

 

 

Maybe it's the car mod files that are corrupted. If they have built the addon wrong, that can cause that error.

Link to post
Share on other sites
That58Plymouth
3 minutes ago, LeeC22 said:

 

Maybe it's the car mod files that are corrupted. If they have built the addon wrong, that can cause that error.

well i just cleaned out my files of the mods and verified the game cache and its still corrupted. Im reinstalling the whole game now

 

Link to post
Share on other sites
LeeC22
Just now, That58Plymouth said:

well i just cleaned out my files of the mods and verified the game cache and its still corrupted. Im reinstalling the whole game now

 

You should never have to reinstall the whole game to fix a mod problem, deleting and re-creating a clean mods folder should remove any corruption in there. I mean I installed the game in 2015 and I have never had to do it since.

 

What you do need to be wary of, is any mods that install from an OIV. If someone makes a bad OIV, it can cause all sorts of problems.They can delete files you don't expect, they can replace files you don't expect and this can include gameconfig files. It won't even warn you it is going to do it either half the time.

 

If you have something like 7-Zip, you can open an OIV like a normal zipped file with it. Then you can extract the contents and install it manually.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 2 Users Currently Viewing
    0 members, 0 Anonymous, 2 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.