Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Cayo Perico Heist
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

      1. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

      1. GTANet 20th Anniversary
    2. Support

    3. Suggestions

New Invision layout is killing performance


Talisman_83

Recommended Posts

I'm using a Macbook Pro 2015, running Big Sur 11.1.

 

Ever since the layout changed, I can barely load the site at times on Safari.

Just clocked CPU at 125% for this site alone, with memory sitting just under 1Gb.

 

Any suggestions (other than use another browser) ?

Edited by Talisman_83
added browser
Link to post
Share on other sites

Hey there.

At no point during development of the site we have found CPU issues on Windows or Linux, we're not sure how this can be Mac specific as we're not using any special code. The only thing I can think about atm is that this may be Invision-specific, their own code, but I also can't think of what it could be.

 

Is there any specific page where this happens?

Link to post
Share on other sites
34 minutes ago, Spider-Vice said:

Hey there.

At no point during development of the site we have found CPU issues on Windows or Linux, we're not sure how this can be Mac specific as we're not using any special code. The only thing I can think about atm is that this may be Invision-specific, their own code, but I also can't think of what it could be.

 

Is there any specific page where this happens?

 

No specific page, Spider.

However, I think I might know what the issue is - on Safari, you can pin tabs.

I had GTAF pinned, however I have multiple windows open, so the site is basically running multiple times.

Now, this wasn't an issue pre-layout change, but perhaps something on Invision's end doesn't like it post-change.

Perhaps there's something not optimised with their scripts, who knows.

 

Anyway, I've removed this site as a pinned tab, just have one instance of it open now and its tentatively performing ok.

Will keep an eye on it.

 

Cheers

Link to post
Share on other sites
  • 4 months later...
LodwigRedemption
6 hours ago, Caffeination said:

God, this site has become so awful to use on phones

Finally someone said it! It gets so laggy and sometimes crashes as well! It was much better a few months ago.

  • Like 2
Link to post
Share on other sites
1 hour ago, LodwigRedemption said:

Finally someone said it! It gets so laggy and sometimes crashes as well! It was much better a few months ago.

Ever since they added the ads, the site is a nightmare to use. 

  • Like 3
Link to post
Share on other sites
1 hour ago, VideoTech_ said:

Ever since they added the ads, the site is a nightmare to use. 

 

What ads? I never see any.

Link to post
Share on other sites
Posted (edited)

We have no control over the ads that show up in the site, especially because some are regional and we can't repro them ourselves. If there's stuff like video that can't be closed etc please take it to the support forum (or PM Tank/email our support email with screenshots and if possible a link to the ad) so it can be reported to the provider.

 

As for lag issues, it's an issue on iOS and Safari for some reason that happens even with ads disabled and so far we cannot get to the bottom of it. Most complaints are iOS or Mac OS and Safari. It's the combination that seems to do it, except our theme is just some CSS changes to the Invision default and not much else, we haven't done anything special that could cause this. We're starting to blame Invision and their massively heavy JavaScript for this (especially in larger topics, and those that may contain images) because we literally have no errors or any performance issues to look into on other platforms. It's very very odd. (Also a good testament on how videogame QA can be hard if even QAing a site is!).

 

We've had staff members on Mac report similar issues and we cannot for the life of us do anything to reproduce this on Chrome/Firefox and Windows or Chrome and Android, or even Firefox and Linux. Just doesn't happen and neither the Dev tools help find anything. We've had a staff member on Mac OS X Catalina have zero issues but someone else on Big Sur having issues, it's really odd. We've gotten another one of our admins to bring out their old Macbook and they had no issues either...

 

Anyways. Please keep site issues to a support thread as it's more likely to be looked into by other admins etc.

 

EDIT: Moved posts into a support topic.

Edited by Spider-Vice
  • Like 1
Link to post
Share on other sites
LodwigRedemption
52 minutes ago, Spider-Vice said:

As for lag issues, it's an issue on iOS and Safari for some reason that happens even with ads disabled and so far we cannot get to the bottom of it.

Gotta correct you there, it's iOS in general. It's the same on Chrome, when I open pages with too much content to load, or even open a specific message to be redirected to in the page (a prime example is if I were to open a specific post from one of gonnaedaethat's Eastenders-like threads with all that media, but obviously it's not just that), not only does the page crash, but I then get a hard time opening even lighter pages or even the home page/other sites in some cases, and I have to restart the OS. It's not that common, to be honest, but when it does happen every now and then it's a pain in the ass

Link to post
Share on other sites

On iOS, AFAIK, all browsers are forced to use Safari's engine as per Apple's security restrictions. You have Chrome features, but the Safari renderer unfortunately. We understand the frustration but as you've noticed yourself, it's not all the time and we're absolutely struggling to get to the bottom of it. We used to think it was the ads, we tested it out with ads disabled or by exempting some groups from any ads so they could test their Macs/iPhones, nope, still happens, we're completely at a loss as no relevant errors show in the dev consoles, or anything of the sort.


Running performance profiling on a page also doesn't reveal anything critical, but I'm personally thinking it's the JavaScript Invision uses to build the pages that freaks out especially on iOS/Mac from time to time because it's heavy. Rest assured we want to get this fixed so it never happens at all, please don't think we're ignoring the issue, we're just struggling with it especially because it can be so random. Cheers for confirming it happens more often on larger pages though, that adds fuel to the "Invision's own rendering" fire. I personally run Windows and Android and I simply can't see those issues :( 


We might play around with enabling lazy loading for media despite it not having been a popular choice when we polled people on whether we should use it or not...

Link to post
Share on other sites
4 minutes ago, Nameless_Outlaw said:

Huh? I use gtaforums on safari and it works pretty well for me tbh

Same here

  • Like 1
Link to post
Share on other sites
2 hours ago, AmyStone said:

 

What ads? I never see any.

Almost every time I open a page on iOS there's a bloody annoying advertisement box which requires to be closed to even use scroll down the site. 

 

It probably depends on the device but I find the site so much easier to use with no ads cluttering up the entire site on PC. 

Link to post
Share on other sites
44 minutes ago, VideoTech_ said:

Almost every time I open a page on iOS there's a bloody annoying advertisement box which requires to be closed to even use scroll down the site. 

 

It probably depends on the device but I find the site so much easier to use with no ads cluttering up the entire site on PC. 

 

Try using the Brave browser. It eats up all the ads.

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 2 Users Currently Viewing
    0 members, 0 Anonymous, 2 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.