Jump to content

The game refuses to use my dedicated GPU, using the commandline to ignore the limits just make it worse.


daytime
Go to solution Solved by daytime,

Recommended Posts

I'm having trouble with my laptop which is an HP Gaming Pavilion 15, which has an i7-9750 CPU, 16 GB of RAM. For the GPU, has an integrated Intel HD Graphics 630 (128 MB) and dedicated NVIDIA GeForce GTX 1650 (4 GB).

 

The fact is that the game simply ignores the dedicated GPU, and even after enabling the option from the card's control panel to use the high performance NVIDIA GPU, it still uses the integrated one, complaining that it has only 500 MB of VRAM.

 

I tried using the commandline trick to bypass the limits of the graphics options, and after I raised everything to the highest avaible, now the game begins to have a "memory" issue, which the models and the textures of the game pop ups instantly in front of me and uses the lowest textures possible despite having everything maxed out.

 

What I should do to play this goddamn game? Hell, I hoped this laptop could finally manage me to play this game, but I guess I'll just dump the PC version of this awfully optimized game and just play it on the console version.

 

The commandline.txt that I use is the following: -nomemrestrict -norestrictions -availablemem 100 -framelimit 0

 

And I'm using "The Complete Edition", not the older DVD/EFLC version.

Link to comment
Share on other sites

  • Solution

Alright, so after tinkering with it for a while, I managed to fix the problem. It was quite simple, honestly, but it managed to make this terrible optimized game run without any issues!

 

First of all I used the following commandline: -novblank -norestrictions -noprecache -nomemrestrict -availablevidmem 4000.0

 

Many website and users misleads you by saying use -availablevidmem 20.0 and then raise it by 10.0 if the issue persist. That's FALSE! Because the value that you're raising are MEGABYTES, so if you use 20, the game thinks that you have a 20MB VRAM GPU installed. So, what you need to do is simply place the amount of your dedicated GPU VRAM in the line of -availablevidmem. Speaking of my case, I had a 4GB dedicated GPU, so I used the value "4000", because 4000MB equals 4GB.

 

Remember that 1GB is 1000MB, 2GB is 2000MB, and so on...

 

So, for example, if you have a 6GB GPU card, then your -availablevidmem line should look like this: -availablevidmem 6000.0

 

And lastly, many websites doesn't mention that these lines can be placed also in the "target" of the shortcut of the game itself or in the Steam/Rockstar Launcher launch parameters, as seen in the pictures below. Some installations might ignore what's written in the commandline.txt file, so if it ignores your configs, try adding those parameters in the shortcut of the game, or in the launch parameters options.

 

Spoiler

r52rG2o.png rsncxUa.png

 

The red box is the target where you can add the command configs, remember if you use the shortcut of the game .exe file, add a space after the quotation marks "" of the directory of the game launcher, and THEN you can add the commandlines, as you can see in the screenshot in the spoiler above.

 

If you use the .exe's shortcut then do it as I written below:

Example: "C:/Games/Rockstar Games/Grand Theft Auto IV/GTAIV.exe" -novblank -norestrictions -noprecache -nomemrestrict -availablevidmem 4000.0

 

If you use STEAM, or the Rockstar Launcher, then simply add in the text box of the launch options the commands directly as seen in the STEAM screenshot.

 

Obviously, if your game doesn't ignore the commandline.txt file, then you just simply use that text file as you normally do.

 

------

 

I hope someone finds this quick fix useful if they're having problems like mine. After this fix, I can manage to max out the game and have no single texture/models pop-ups or any weird artifacts during the game.

 

Note: VRAM means Video RAM. GPU means Graphics Processing Unit, aka your video/graphics card. Dedicated means and external GPU that you have installed or it's pre-installed (in a modern gaming laptop, for example). Internal means the GPU that's usually embedded with the motherboard of your computer or it's the "low power" GPU that your modern laptop uses, usually these kind of internal GPUs use Intel HD Graphics, as their chip.

Edited by daytime
  • Like 2
Link to comment
Share on other sites

  • 2 years later...
  • 11 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.