Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Contract
      2. Updates
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Blood Money
      2. Frontier Pursuits
      3. Find Lobbies & Outlaws
      4. Help & Support
    3. Crews

    1. Grand Theft Auto Series

      1. Bugs*
      2. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Classic GTA SA
      2. Guides & Strategies
      3. Help & Support
    6. GTA Vice City

      1. Classic GTA VC
      2. Guides & Strategies
      3. Help & Support
    7. GTA III

      1. Classic GTA III
      2. Guides & Strategies
      3. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

    2. Support

    3. Suggestions

[IV] ZolikaPatch


Zolika1351
 Share

Recommended Posts

Anyone knows if achievements for GFWL can be earned by disabling any option? I can score them only when patch is not installed.

  • Like 2
Link to comment
Share on other sites

On 10/23/2021 at 5:18 PM, MiesThies said:

I made the Complete Edition portable with this guide, so it def works.

As for the best version, it's no easy answer. Most people would say 1.0.7.0 I guess, which is what you need for Zolika patch as well. On the CE you have Fusion fix, which doesn't adress as many issues as ZP, but it works fine as well.

For ENB modding 1.0.4.0 would be best.

What I did, I just created multiple portable versions, so now I have a CE, a 1.0.7.0 and a 1.0.4.0 version. Also backups of these if I f*ck anything up. It's really a joy!

After trying to get 4 & DLC addons in certain versions, I just came to conclusion that I will stick with CE. Because there are a lot of stuff needs to be done, to get few more NICE TO HAVE features. 

Such confusing stuff with this game, editions, versions, patches, standalone DLCs and built-in. Too much for me. 

  • Like 2
Link to comment
Share on other sites

Hi, Zolika! 

 

Recently I've been modding GTA IV using your patch, and I really like it, but there is one problem (at least I think that the patch is causing this to happen) - the Uranus doesn't work with mods. Doesn't matter what mod I use to replace it, the original Uranus spawns on the streets with broken textures. From what I've gathered after skimming through the topic, the patch contains a revised car model which overrides the one in the files. Is there any way to make Uranus moddable again with your patch? Maybe there is a setting for it in the config file that I have missed? Thank you in advance! 

  • Like 2
Link to comment
Share on other sites

9 hours ago, SKTT said:

Hi, Zolika! 

 

Recently I've been modding GTA IV using your patch, and I really like it, but there is one problem (at least I think that the patch is causing this to happen) - the Uranus doesn't work with mods. Doesn't matter what mod I use to replace it, the original Uranus spawns on the streets with broken textures. From what I've gathered after skimming through the topic, the patch contains a revised car model which overrides the one in the files. Is there any way to make Uranus moddable again with your patch? Maybe there is a setting for it in the config file that I have missed? Thank you in advance! 

Fusion Fix comes with fixed vehicle models. Find the Fusion Fix .img file.

Edited by B Dawg
  • Like 3
Link to comment
Share on other sites

  • 2 weeks later...

Hi i caught some game crash problem i recorded a video its not a youtube video its google drive cause i uploaded so please if youre watching tell me what should i need i got that game gta 4 for free with steam stuff so i got that link if you know whats problem

https://drive.google.com/file/d/1Jd360ysfT5IPGjnpi_trtw1BbNf4_fbV/view?usp=sharing

Link to comment
Share on other sites

  • 2 weeks later...

I get an Assertion Failed message when I try to start the game. Any solutions? Here is a screenshot.

NGSuOXk.png

Edited by red84140
added error screenshot
Link to comment
Share on other sites

I've recently come to the conclusion that the "nothing works on CE" idea everyone has is actually patently false, frankly. I've yet to try a single ASI or SHVDN DLL mod that fails to work when using Ultimate ASI Loader's dinput8.dll, and not the original GTA IV dsound.dll ASI Loader (like, you don't want that in the directory at all, just dinput8.dll alongside the ScriptHook-specific stuff).

Edited by Akira1364
Link to comment
Share on other sites

1 hour ago, Akira1364 said:

I've recently come to the conclusion that the "nothing works on CE" idea everyone has is actually patently false, frankly. I've yet to try a single ASI or SHVDN DLL mod that fails to work when using Ultimate ASI Loader's dinput8.dll, and not the original GTA IV dsound.dll ASI Loader (like, you don't want that in the directory at all, just dinput8.dll alongside the ScriptHook-specific stuff).

I think he just means that it isn't supported, not that it wont work lol. He's basically just saying that if it doesn't work, tough sh*t.

Link to comment
Share on other sites

17 hours ago, zanesix said:

I think he just means that it isn't supported, not that it wont work lol. He's basically just saying that if it doesn't work, tough sh*t.

Yeah, that's fair, but in general people really do seem to believe that downgrading to an earlier patch is way more necessary than I personally think it is in reality. Even the claims that earlier patches "performed better" are dubious in my experience. Probably that was only true (if ever) years ago. On modern GPUs though I've found them all to be able to maintain the 60 FPS limit I set to avoid physics issues exactly the same way.

  • Like 2
Link to comment
Share on other sites

6 hours ago, Akira1364 said:

Yeah, that's fair, but in general people really do seem to believe that downgrading to an earlier patch is way more necessary than I personally think it is in reality. Even the claims that earlier patches "performed better" are dubious in my experience. Probably that was only true (if ever) years ago. On modern GPUs though I've found them all to be able to maintain the 60 FPS limit I set to avoid physics issues exactly the same way.

Well yeah, its never really been necessary for the average person unless if they're looking for something specific (eg. don't want to deal with the horrid rockstar games launcher). It is true that earlier patches usually have better performance however, this guy did a great analysis on it:

 

  • YEE 1
Link to comment
Share on other sites

On 11/28/2021 at 4:48 AM, zanesix said:

Well yeah, its never really been necessary for the average person unless if they're looking for something specific (eg. don't want to deal with the horrid rockstar games launcher). It is true that earlier patches usually have better performance however, this guy did a great analysis on it:

 

That linked thread is misleading as shadow quality has been increased by two options in 1060+ (shadowmap quality is 512x in 1040 very high and 1060+ medium but very high on 1060+ is actually 2048x) which is obviously going to affect performance a lot. I have yet to see a proper benchmark (using the video editor, not some bad attempt at the same movements with completely different traffic and peds affecting performance wildly) with this in mind and with all common versions being tested. This mod in particular as well as all of my other asi mods cannot and will not run on the "complete" edition no matter how hard you try. The only reason any other similar mods run is because of weird hacks to ScriptHook/ScriptHookDotNet to force them to, while none of my mods use either of those and are fully standalone plugins.

 

EDIT: Fine, I'll do it myself

 

Edited by Zolika1351
Link to comment
Share on other sites

13 minutes ago, NickMarkick said:

Why my game is not launching when i install zolika patch?

I'm assuming here you've already downgraded your installation from The Complete Edition to version 1.0.7.0 or 1.0.80? 

 

If so, did you change the "0" from this line to "1" in the ini file to allow you to launch the game through the Steam shortcut of GTA IV?

LaunchWithPlayGTAIV=1

 

Link to comment
Share on other sites

Rus_Game_Tactics

Dear friends. I am asking for your help. Just the other day I installed GTA 4, with patch 1.0.7.0. Decided to install the "ENB Masterpiece" graphics. The game works, ENB works just as well. But in the game, especially at night, you can see that when approaching some buildings where there are lighting lamps, they seem to dim or something, that is, the light from them becomes less, relatively speaking, as if they were turned off. I can't figure it out, this is how ENB works. or is it a problem of the game itself, maybe a crooked version of the game or it's a patch like that .. Simply by installing on a CryENB V3 license, this is not observed.

Help, if not difficult, you can just give some advice, or maybe something should be turned off in the ENB Masterpiece.

I honestly don't care what to play, pirate or license, but "ENB Masterpiece" looks better for me, a more comfortable atmosphere in it, but damn this problem with some light sources that as soon as the character drives up or approaches towards them, they begin to fade, as it were, I initially noticed when I drove into the tunnel in the daytime, there the side lighting seems to turn off, the light sources themselves seem to be on, but they become dimmer and throw less light. I would like to solve this problem.

I tried your "ZolikaPatch" but the problem persists. Maybe something needs to be configured, but I don't know what exactly.

Please, who knows how to solve the problem, a huge request, please give me a solution!

Link to comment
Share on other sites

2 hours ago, Rus_Game_Tactics said:

Dear friends. I am asking for your help. Just the other day I installed GTA 4, with patch 1.0.7.0. Decided to install the "ENB Masterpiece" graphics. The game works, ENB works just as well. But in the game, especially at night, you can see that when approaching some buildings where there are lighting lamps, they seem to dim or something, that is, the light from them becomes less, relatively speaking, as if they were turned off. I can't figure it out, this is how ENB works. or is it a problem of the game itself, maybe a crooked version of the game or it's a patch like that .. Simply by installing on a CryENB V3 license, this is not observed.

Help, if not difficult, you can just give some advice, or maybe something should be turned off in the ENB Masterpiece.

I honestly don't care what to play, pirate or license, but "ENB Masterpiece" looks better for me, a more comfortable atmosphere in it, but damn this problem with some light sources that as soon as the character drives up or approaches towards them, they begin to fade, as it were, I initially noticed when I drove into the tunnel in the daytime, there the side lighting seems to turn off, the light sources themselves seem to be on, but they become dimmer and throw less light. I would like to solve this problem.

I tried your "ZolikaPatch" but the problem persists. Maybe something needs to be configured, but I don't know what exactly.

Please, who knows how to solve the problem, a huge request, please give me a solution!

 

This sounds like what happens with Project2DFX, which may be part of that mod pack. It adds distant light sources to the map but they're not perfectly matched to the lights that load as you get closer. If you fiddle with your View Distance, Detail Distance, and edit the settings in IVLodLights.ini you might be able to achieve a smoother transition so the LOD lights fade out where the detail lights fade in, but I've been struggling with this myself. If you want to go really deep you could edit the individual light sources in IVLodLights.dat but that is not a casual undertaking.

Link to comment
Share on other sites

Rus_Game_Tactics
10 minutes ago, Magic_Al said:

This sounds like what happens with Project2DFX, which may be part of that mod pack. It adds distant light sources to the map but they're not perfectly matched to the lights that load as you get closer. If you fiddle with your View Distance, Detail Distance, and edit the settings in IVLodLights.ini you might be able to achieve a smoother transition so the LOD lights fade out where the detail lights fade in, but I've been struggling with this myself. If you want to go really deep you could edit the individual light sources in IVLodLights.dat but that is not a casual undertaking.

 

I just do not see these files in the root folder with the game or in another folder. Where can I find them? I downloaded this mod, but I didn't install it. These files are not present in the "ENB Masterpiece".

Link to comment
Share on other sites

On 3/30/2021 at 2:33 PM, GameKho said:

I found out with HighFPSSpeedupFix will cause some of the DLC cutscenes take a long period of times to end( bout 8-10 min ) and it back to normal when i set off the HighFPSSpeedupFix option.

 

 

 

My game was Complete Edition downgrade to 1.0.7.0 with FushionFix, ZolikaPatch v6.2, XLivelessAddon and Simple Native Trainer v.6.5 installed.

thanks for this. i just had this issue in TLAD

  • Like 2
Link to comment
Share on other sites

Hey guys I'm having a problem after I installed the mod my game stops working... It crashes on the launcher... Can I get the issue... v1.0.7.0 

Spoiler
Spoiler

 

 

 

 

Link to comment
Share on other sites

Hey guys,

 

does anyone have a tutorial on how to adapt cars to the Zolika patch using Zmodeler?

 

Because when I try to import the example car from Zolika (Romans Taxi) into Zmodeler, all I see is a green dot and not the entire model hierarchy.

 

I am trying to understand what you have to change on the car models to make the steering wheel work and turn correctly.

 

Can anyone help/advise?

Link to comment
Share on other sites

TWIST_OF_HATE
On 11/28/2021 at 3:37 PM, Zolika1351 said:

That linked thread is misleading as shadow quality has been increased by two options in 1060+ (shadowmap quality is 512x in 1040 very high and 1060+ medium but very high on 1060+ is actually 2048x) which is obviously going to affect performance a lot. I have yet to see a proper benchmark (using the video editor, not some bad attempt at the same movements with completely different traffic and peds affecting performance wildly) with this in mind and with all common versions being tested. This mod in particular as well as all of my other asi mods cannot and will not run on the "complete" edition no matter how hard you try. The only reason any other similar mods run is because of weird hacks to ScriptHook/ScriptHookDotNet to force them to, while none of my mods use either of those and are fully standalone plugins.

 

EDIT: Fine, I'll do it myself

 

duh

Who gives a flying f*ck about your "IDA findings" ?

People just want to play the game

And they better do it with patch 4

 

Here is why:

1) strongly degraded visual shadows quality on patch 6 and later

Yes, by visual quality I mean stencil shadows (thanks to your beloved increased resolution of shadows) instead of soft shadows on patch 4

And don't forget about broken tree shadows and "running black line" shadows bug on patch 6 and later

And after your fixed biker shadow on patch 4, and "no dynamic shadows from cars from 8 PM to 6 AM" - there should be no question of shadows quality superiority between patches at all

 

2) broken shaders on patch 6 and later

Broken lights at night I mean, and that tower

patch 4 has most bug free shaders between all patches

 

3) broken LODs on patch 6 and later

You fixed it only for buildings

 

4) better performance

patch 6 and later tanks GPU, especially at very high shadows quality

and while this may be not really noticeable on your modern gpu, it's still clear on low end pc's

Literally increase shadows quality in your test from medium to atleast high for patch 7 and 8, and it will be enough for patch 4 version to show better performance than patch 8

 

5) much better compatibility with mods on patch 4

 

6) some other minor advantages that I just forgot about

Night shadows also f*cked deeply on patch 6 and later, I can't remember if you fixed it or not

 

The only real advantage of patch 6 and later are EFLC and moon

But IV is better than EFLC anyway, so not a big deal

Edited by TWIST_OF_HATE
Link to comment
Share on other sites

4 hours ago, eljamon88 said:

Hey guys,

 

does anyone have a tutorial on how to adapt cars to the Zolika patch using Zmodeler?

 

Because when I try to import the example car from Zolika (Romans Taxi) into Zmodeler, all I see is a green dot and not the entire model hierarchy.

 

I am trying to understand what you have to change on the car models to make the steering wheel work and turn correctly.

 

Can anyone help/advise?

You cannot import openformats exported cars in ZM2.
Zolika made a 3ds max script which does everything automatically, why on earth do you even need to bother with ZM2...  

Link to comment
Share on other sites

42 minutes ago, orangebrains said:

You cannot import openformats exported cars in ZM2.
Zolika made a 3ds max script which does everything automatically, why on earth do you even need to bother with ZM2...  

I wanted to use ZM2 because it’s the only tool I‘m experienced to use so far.

 

Is there a tutorial for 3DS Max?

Link to comment
Share on other sites

6 minutes ago, eljamon88 said:

I wanted to use ZM2 because it’s the only tool I‘m experienced to use so far.

 

Is there a tutorial for 3DS Max?

 

Link to comment
Share on other sites

Just a very quick suggestion: Adding the ability to create a custom save and settings path would be very nice. I know xlivelessaddon has it but if Zpatch had it as well, I wouldn't have to use BOTH of them. Would be very nice, thank you :)

Link to comment
Share on other sites

Raposa hunter

One of the reasons I still want to use this version of the game, is for the achievements of GFWL, but this mod is affecting the achievements considering as cheat in GFWL, there is no way to fix this?
 

And another thing, There is a hard drive problem in the save game if I set the savefix option to 0. 
And you have to start all over again with a "different" save.
Is there a way to put the save fix without the hard disk error in vanilla game?

Link to comment
Share on other sites

15 hours ago, Raposa hunter said:

One of the reasons I still want to use this version of the game, is for the achievements of GFWL, but this mod is affecting the achievements considering as cheat in GFWL, there is no way to fix this?

You need to disable TryToSkipAllErrors and VSyncFix options in ZolikaPatch.ini and you need to delete GFWLDLC.asi. To get back DLCs, you should move all files from GTAIV\DLC\TBoGT\content to GTAIV\TBoGT and move all files from GTAIV\DLC\TLAD\content to GTAIV\TLAD.

Link to comment
Share on other sites

Raposa hunter
On 12/29/2021 at 1:09 PM, kubon352 said:

You need to disable TryToSkipAllErrors and VSyncFix options in ZolikaPatch.ini and you need to delete GFWLDLC.asi. To get back DLCs, you should move all files from GTAIV\DLC\TBoGT\content to GTAIV\TBoGT and move all files from GTAIV\DLC\TLAD\content to GTAIV\TLAD.

Ok, I will test it.
I hope it works, I'm having to replay the game from the beginning because the saves that used the ZolikaPatch savefix don't work, always gives a hard disk error and then, I had to make another one without the fix.
I will do that and continue the save from before.

Link to comment
Share on other sites

Raposa hunter
On 12/29/2021 at 1:09 PM, kubon352 said:

You need to disable TryToSkipAllErrors and VSyncFix options in ZolikaPatch.ini and you need to delete GFWLDLC.asi. To get back DLCs, you should move all files from GTAIV\DLC\TBoGT\content to GTAIV\TBoGT and move all files from GTAIV\DLC\TLAD\content to GTAIV\TLAD.

It didn't work, I just earned the achievement "That's How We Roll!" From brucie and I just got the achievement on steam.
Did I need to remove zolika's code? I just left it at 0 to disable it.
Also, I put the DLC folders in the root folder like you said and the play option is gone, are you sure this is right?

My game folder is like this if it helps: https://imgur.com/AWY1z2n

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • 2 Users Currently Viewing
    1 member, 0 Anonymous, 1 Guest

    • ItsClonkAndre
×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.