Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTA Online

      1. The Diamond Casino Heist
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

      1. Events
    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA 6

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
      5. GTA IV Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA SA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA VC Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA III Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. News

    2. Forum Support

    3. Site Suggestions

Spider-Vice

RDR2 PC Bug Report Thread

Recommended Posts

Spider-Vice

RDR2 on PC is now released on all the major gaming stores, and as every big open world game, and a PC game at that where every single configuration is different, it still has its kinks. Because we might even be helping Rockstar out with this by having an organised bug thread, list any issues you might be having with RDR2 PC. This is NOT  a thread for general bug or stability discussion, but merely a list, inspired by @DentureDynamite's GTA V bug list from back in the day.

 

Any general complaints will be deleted, as we only want an organised list of issues you might be having. Don't report story/mechanic issues, as those are 99% likely to not be PC specific issues but rather an all-platform thing, as the mission and gameplay scripts do not change between platforms, and thus a lot of those issues are also present on consoles. Control issues are excluded, obviously.

Don't report bugs with "game blurriness" or "sharpness" as this is how Temporal Anti-Aliasing works and if you want your game to be sharper than it's supposed to, then you should use your GPU manufacturer's sharpness settings.

 

-----------------------------------------------------------------------------------------------------------------------------

 

  • High tessellation settings cause mud surfaces in the Bayou to be broken and to look like a checkerboard pattern. Might be specific to modern AMD GPU architectures. Walking through them still deforms the surface but it doesn't make the glitch disappear.
  • On certain configurations, any frame-rate below the monitor's refresh rate will cause occasional hitching every second or so. This issue is alleviated by disabling VSync. I personally got this issue after updating to an AMD GPU, but there are reports of NVIDIA GPU's having the same issue. My CPU is more than capable, at 6 core 12 threads (Ryzen 5 3600). Preliminary investigation reveals this may be caused by input operations (mouse movement).
  • The game crashes at random intervals with either unspecified errors, or GFX errors. On NVIDIA cards, these crashes may corrupt the shader pipeline cache (coinciding with a driver crash seen in the Windows Event Log), causing crashes after the loading screen. AMD cards use its own proprietary shader compiler so behaviour is different.
  • The benchmark scenario is not consistent likely because the benchmark script is only spawning the player without a specific clothing style. Those who completed the epilogue will get John in the benchmark whereas those who are still in the main story will get Arthur. Clothing can change at random between your saved game clothing and the default player clothing, and so can camera angles once the protagonist shoots up the cop wagon and throws the molotov - sometimes the camera doesn't even turn. This skews benchmark results.
  • On certain configurations, accessing the Social Club UI to check your Feed or upload photos from the landing page will not work. The Social Club feed will not load, and you are not able to go back to the landing page without going into Settings first and then backing out.
  • Like 4

Share this post


Link to post
Share on other sites
P3REiRAA

Using no AA causes draw distance issues like popping vegetation and trees

Share this post


Link to post
Share on other sites
Hanzema

- Front view from weapon maintance cant zoom in im using (im using a DS4 Controller)

 

- Sometimes horse on my hunting wagon cant go backwards and instead goes sideways (wich does nothing but standing on the spot.

Share this post


Link to post
Share on other sites
Hanzema

People really should post their general bugs and problems here instead of creating new threads everytime. This thread should then also be linked and send to Rockstar support. Im sure that was Spider's intension.

  • Like 3

Share this post


Link to post
Share on other sites
Blendi-

good idea

Share this post


Link to post
Share on other sites
seldo

Let me report something here in the hope it fits this topic... :D

 

in St Denis, walking at night, on horse (haven't tried without), the shadow of my horse (of of me on top) only appears as I get in the centre of the light halo to the end of it, but in the first half of the halo, I get no shadow at all.

 

I'm not talking of possible double shadows from two adjacent lamps, that should create two shadows with different dims. I don't know if the game supports that feature. 

Share this post


Link to post
Share on other sites
Sir_Witcher

I got an error code 0x10001038 when new update come out. How to fix that?

Share this post


Link to post
Share on other sites
Andrea_23

 

Has anyone noticed the horse poop... popup on the roads?
I know it's a bit ridiculous, but also quite distracting ...

 

rdr2_2019_12_15_10_59ycjoq.jpg

rdr2_2019_12_15_10_59uxjgg.jpg

 

 

----------------------------------------------------------------------------------------------------

 

 

 

 Recently I've also found this issue:

 

1- Position yourself near the area of the Rhodes's gallows. Here:

rdr2_2019_12_09_21_26ggk73.jpg

 


2- look to the east. One of the mountains towards the horizon is bugged and disappears, you only see the "flying" trees.
rdr2_2019_12_09_21_2606jk6.jpgrdr2_2019_12_09_21_25hcju8.jpg

 

Different daily time:
rdr2_2019_12_10_21_41lyj3p.jpgrdr2_2019_12_10_21_413gjz4.jpg

 

 

Two videos of the clipping issue.

 

 

 

 

Edited by Andrea_23
  • Like 1

Share this post


Link to post
Share on other sites
Spider-Vice

- Smoke is missing from trains since the latest patch. Trains only - factories, fire, etc work fine.

- This is happening since before this patch, but occasionally some smaller props like tables disappear. May be related to streaming errors, e.g. I reached Emerald Ranch to sell stuff to Seamus and his table was completely missing. A second visit made it appear correctly.

  • Like 2

Share this post


Link to post
Share on other sites
Hanzema

- Vsync is completly broken and feels like a choppy 30 fps.

 

- Starting moonshine Missions/Deliveries very often causes infinite loading screen which forces a restart of the game.

 

- Bounty Hunting immediatly stops after starting it with the message on screen that a gang member left the mission.

 

- Animals are becoming hard to find and world often feels completly empty without any animal in sight (Server related?).

 

- Cripps often degrades camp for no reason and also sometimes camp wont get build.

 

- Coaches/Wagons become transparent/blurry from many distances.

 

- Enemies no longer lose limbs from dynamite.

 

Worst patch so far. This one broke my game. Havent had a problem with any former updates. Launch Version was the best for me. Give me feedback guys if any of those things also happened to you.

 

Edit: 

- Train smoke is also gone for me.

Edited by Hanzema
  • Like 1

Share this post


Link to post
Share on other sites
Mini144

From Online gaming, using Vulkan on Pascal architecture:

 

- FPS drops in Strawberry, especially on the road from Butcher to Jail

- Water flickering on LOW water refraction setting (especially noticeable on Heartlands ponds)

- When in Freeaim setting cannot join friends with autoaim setting (gets stuck on loading screen)

- Wagons still flicker sometime when you approach them, i think that was partially fixed in this update but still happens

- Overall Frame instabillity

- Still there are problems with camp pitching

- Starting moonshine sell missions sometimes gives infinite black screen and the product is lost

 

Edited by Mini144
additional info

Share this post


Link to post
Share on other sites
Pointi1978

Parralax Occlusion Mapping on Ultra still bugs out sometimes and produces some weird black rectangles and squares around the player

Share this post


Link to post
Share on other sites
Legion of Hell

The game occasionally crashed in a saloon (the one with the rat problem) in Saint-Denis at night with the error being both err_gfx_state and Exceptional Breakpoint

 

This is problematic when starting the mission "Icarus and Friends" because the game crashed as soon as the cutscene is over

 

Althought this can be solved by turning the setting to low and skipping the cutscene

Share this post


Link to post
Share on other sites
Abel Tesfaye

All of a sudden the lod somehow has some serious problem and buggy as hell in Valentine after this update.Some ped can disappear in front of my eyes and some's texture detail won't load until I walk very closer towards them

Share this post


Link to post
Share on other sites
Ghetzi

I have noticed that since the latest patch the front of oncoming wagons lose all details for a moment, and then the textures pop back in.  I thought it was a one-time glitch when it first happened, but now I'm seeing more often.  Anyone else notice that?

  • Like 2

Share this post


Link to post
Share on other sites
Andrea_23

Added a second video (2k resolution, this time) of the issue:

 

On 12/15/2019 at 11:36 AM, Andrea_23 said:

 

Two videos of the clipping issue.

 

 

 

Share this post


Link to post
Share on other sites
Legion of Hell

After Chapter 6, Arthur's hair and clothes starts flickering for some reason. I also can't spin my sidearms anymore

 

Edit: These issues seems to fix itself after Chapter 6 though

Edited by Legion of Hell
Solution

Share this post


Link to post
Share on other sites
UpTheDowngrade

Anyone else have the bug where you cannot melee at all during a mission where you're required to? Like when you're at that camp north of Rhodes where you and Charles beat up the two men who've taken Trelawny? I ended up skipping that section, because of this. Or the the stranger quest where you fight the tiny headed freak in Van Horn? Restarting from checkpoint twice didn't fix it, so, eventually, I just mashed a bunch of buttons near WASD, while clicking left mouse button and Arthur (inconsistently) threw punches, but only one or two every few beatings he'd take. I've never had an issue doing melee attacks on console, or in any other scenario on pc, other than these two instances. Very odd.

Edited by UpTheDowngrade

Share this post


Link to post
Share on other sites
puredorian

Man, it's the holiday season and the game is barely playable for me.

 

The last patch was a disaster in my opinion, don't get me wrong, the game is still semi-playable, but compared to the release Nov 5 patch it's just unbearable at this point, FPS is all over the place, sudden FPS drops(that didn't happened to me at all before and graphics options didn't changed since that), controls are glitching, like when played with M&KB the control inputs would swap to DS4 button layout randomly, breaking the inputs (like pressing E to mount the horse), Vulkan started to crash with famous error too, DX 12 seems a bit more stable but still far from perfect.

 

What happened? 

The worst part is, there won't be any hotfix/patch in a weeks surely, since everyone at the team is having a good holiday time right now.

 

I feel like I'm the only one person in the ocean with this(because of how varied everyone PC is and the software), but still, they had so much time to optimize the game before releasing a PC port, and it's just getting worse after each patch.

I can't seriously play it anymore, because issues are just happening every play session, one way or another.

I can record a video with fpsmonitor to showcase this, the FPS grapth is just constant jaggies like up/down line, instead of a more stable and idle line in the graph, doubt it would help anyone though.

Share this post


Link to post
Share on other sites
StrafeFTW

Is the game on PC still having issues today?

Share this post


Link to post
Share on other sites
mas0764

Stage coaches/carts/wagons - anything on the road that is pulled by a horse, as far as i can tell, flashes or flickers like the texture didn’t load properly. Usually just once but still annoying. Thought I saw this reported elsewhere but couldn’t find it again to see if there was a resolution. Anyone know of any?

Share this post


Link to post
Share on other sites
Darimas
Posted (edited)

12 hours in support chat, 4 days downloading and re-downloading the game, have made the following changes at the request of chat support: changed permissions, disabled startup services, created firewall and AV exceptions, created new windows profiles, verified SFC scans, verified video drivers, verified updated OS and BIOS, provided DXDIAG / MSINFO / logs repeatedly, uninstalled and re-installed RGL repeatedly as well (thru uninstaller and manual deletes), unplugged all USB devices accept keyboard and mouse, set 2 core affinity for RDR2.exe, and then was forced to repeat many of these steps as they swapped in 5 different techs before they finally gave up and sent me to email support.

 

So for StrafeFTW id say hell no.

Edited by Darimas

Share this post


Link to post
Share on other sites
TwistedEndz

once you get disconnected choosing to respawn at camp your in a never ending loading screen , same if you're playing and just click ESC to choose to spawn at camp 

Share this post


Link to post
Share on other sites
trulex47

Whats the logic of snow on +18 celsius? 

I like snow effect on whole map on Christmas day, but now on 5th january this is anoying. Btw there is snow area on game if you want that atmosphere.

 

Qx1LJBN.jpg

Share this post


Link to post
Share on other sites
Spider-Vice

This is not a PC specific issue as the temperatures are weird in all platforms, please use one of the existing threads in the RDO section to discuss the snow. It seems to be gone now either way, this is the first work day for Rockstar and many others after the holidays.

 

https://gtaforums.com/topic/941907-winter-weather-warning-on-the-frontier-december-19th/?do=getLastComment 

  • Like 1

Share this post


Link to post
Share on other sites
Koltos

The most strange bug is particles.


For example, i had my settings in particales on ultra and others but when i restart first mission in game ( where Arthur, Dutch and Mika find the house ) and I remember clearly that when I was on this mission in november patch there are were smoke with fire ash from the chimney of the house.

 

Nowadays i tried to reload this mission and check this effect but chimney is not provided this. 

 

What happened? It is loss in visuals for sure!

Share this post


Link to post
Share on other sites
Hanzema
12 minutes ago, Koltos said:

The most strange bug is particles.


For example, i had my settings in particales on ultra and others but when i restart first mission in game ( where Arthur, Dutch and Mika find the house ) and I remember clearly that when I was on this mission in november patch there are were smoke with fire ash from the chimney of the house.

 

Nowadays i tried to reload this mission and check this effect but chimney is not provided this. 

 

What happened? It is loss in visuals for sure!

Try medium settings. 

Share this post


Link to post
Share on other sites
Koltos
3 minutes ago, Hanzema said:

Try medium settings. 

I tried every settings.

Chimney is dead in first mission now)

Share this post


Link to post
Share on other sites
Gforce

Tonight I have had non stop crashing whenever I go into any missions, bounties or random NPC meetings of any kind, this is in single player, since around 7pm until now 4.42am it's been terrible, I've had roughly 25 crashes with 2 complete system lockups, I am now 95% convinced that it's DRM/server related, nothing else can possibly explain why I can play fine during the day UK time yet as soon as evening comes and the kiddies in the US get home from school and go online it become an unstable mess.

this problem is not related to my PC specs nor is it related to my internet speeds

nc1hZCf.png
rOrJ3V2.png

the sheer instability of this game during blatantly obvious peak server times and the fact the game hasn't been beaten by the Jack Sparrows, and the crashes constantly coinciding with obvious trigger/checkpoint/autosave/NPC dialogue trigger/Mission checkpoint,autosave,checkpoint aspects of the game, it all points to R*'s DRM punishing legit single player gamers while it's server struggles to validate all those drm checkpoints.

I have a massive collection of games spread across numerous platforms going back decades to the 80's and this is without a doubt the most unstable game I have ever owned, I still have Amiga games running from 30yr old floppies on a 30yr old A1200 that are more stable than RDR2, NO JOKE !!!

congrats :r*:  on protecting your game from the Jack Sparrows for so long through the launch window and Holiday season, but how about dump the constant online drm and focus on letting your legit players enjoy the game without it crashing during peak server times, your ongoing Online cashcow requires people to pay for the phucking game anyway, still so poor from all those lost GTA V sales after it fell to pirates on day one, no it made you a sh*t ton of sales and online cash and made it the biggest selling digital entertainment product of all time, and the copy protection was bypassed on day one !!!

the sooner this game falls to Jack Sparrow and his friends the sooner we'll get a stable single player game !!

Edit: This latest crash during a bounty pretty much confirms the issue being related to online DRM afaic, so fed up with this "Always Online DRM" culture that constantly punishes legit players, the exact time the game crashed, Social Club was phoning home ....................... the smoking gun imho.

bDxeD4O.png
Evl817D.png

Edited by Gforce
  • Like 1

Share this post


Link to post
Share on other sites
TomilovSenya

- Sound acts weirdly: it can turn mono or get positioned in right or left channel from time to time. It happens in Red Dead Online a lot more frequently than in Story Mode. In fact, not only game's sound does, but also sound of other applications. It might be because of my audio card, which is Creative Sound Blaster Z, but I'm obviously not changing it because R* f*cked up the PC version of the game (since I never got no issues with other games or apps).

Edited by TomilovSenya

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.