Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
      4. Frontier Pursuits
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. DLC
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
      7. The Diamond Casino Heist
    2. Grand Theft Auto Series

    3. GTA 6

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA IV Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA SA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA VC Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA III Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

Deputydog857

So I'm the ONLY one crashing????????? FOUND FIX!!

Recommended Posts

Deputydog857

Just bought a brand new gaming PC to play Red Dead Redemption 2. The specs are - Intel Core I9-9900K 3.60GHZ 8/16 16 MB Cache, ASROCK Z390 Legend ATX MB, NVIDIA GeForce RTX 2070 8GB GDDR6,  ASUS STRIX Soar 7.1, 16GIGs Ram and Windows 10. EVERY time I try to run the game from the Rockstar Loader it crashes out and says The Rockstar Games Launcher exited unexpectedly, please visit the support site. And now it also says The instruction at 0x00007FF7036975A9 referenced memory at (another long ass number). The memory could not be written. WTH is this mess? When I try to run it from the game Icon it just quits out to desktop. ALL drivers are up to date. Windows 10 is up to date. NO Antivirus onboard. Can anyone one help with this please. Getting a little ticked after spending over $2,000 for a new system and close to 80 bucks for the game.

Share this post


Link to post
Share on other sites
Mexicola9302

I think there is some kind of problem with some CPU's that have more than 6 cores / 12 threads, maybe try disabling Hyperthreading in your BIOS, UEFI or whatever the newest version is called. Maybe this way you get your game started if it doesn't help, just turn HT back on.

 

Or you could somehow just turn off 2 of your CPU cores temporary if there is no other way.

 

I got i7-4930K 6 Cores 12 Threads and no problem. Maybe it just doesn't like 8 Cores 16 Threads.

Edited by Mexicola9302

Share this post


Link to post
Share on other sites
ert90

Now that i completed the story mode and started my online character, i became pretty much numb to the initial crash i get after EVERYFREAKING TIME during the first couple of minutes after getting in game. Usually it happens  after giving my horse a medicinal/stimulant tonic, opening my map, or getting into my mount and running away. Then i sign back on free roam and have no issues . For some reason i rarely have problems on missions, mini games or story events.

The error is 0x21002001, meaning rockstar services have issues, THEY HAVE ISSUES. Rockstar only replied to me claiming that is MY internet connection fault and that i should reset my modem and another bunch of BS. How come i can play real sanbox/military simulators like Arma 3/DayZ/SCUM (who might not demand that much GPU but CPU drains it fast)with more than 50 players in mil sim events;we are all together in the same simple and mundane homegrown server playing in a real single instance event in a 100km2 map. Meaning everything happens at once, doesn't matter if some player is fighting a group of enemies 40 miles north and you are stuck defending a fort from the main horde of enemies with 39 players in the same place. I get 40-60 fps (because its that brutal to my i7 8700k and the server) and ZERO internet related crashes. RDR2 might have superior graphics than Arma 3 but in complexity terms RDR2 is still a CARTOON/arcade, not a realistic sandbox simulator. Im pretty sure the problems i experienced in SP were also related to the damn perma internet connection DRM. That's why it never gave me an error code, because its single player, the internet is not expected to glitch the game (or so RS assumes). 

 

Otherwise, is a great game yet unbelievable they try to charge you 10+ gold bars to get a bounty hunter license... P2W with mediocre server/annoying internet DRM. They really try to piss on their PC costumers, the ones who gave them power (i don't think they remember).

Edited by ert90

Share this post


Link to post
Share on other sites
jackrobot
14 hours ago, Deputydog857 said:

Just bought a brand new gaming PC to play Red Dead Redemption 2. The specs are - Intel Core I9-9900K 3.60GHZ 8/16 16 MB Cache, ASROCK Z390 Legend ATX MB, NVIDIA GeForce RTX 2070 8GB GDDR6,  ASUS STRIX Soar 7.1, 16GIGs Ram and Windows 10. EVERY time I try to run the game from the Rockstar Loader it crashes out and says The Rockstar Games Launcher exited unexpectedly, please visit the support site. And now it also says The instruction at 0x00007FF7036975A9 referenced memory at (another long ass number). The memory could not be written. WTH is this mess? When I try to run it from the game Icon it just quits out to desktop. ALL drivers are up to date. Windows 10 is up to date. NO Antivirus onboard. Can anyone one help with this please. Getting a little ticked after spending over $2,000 for a new system and close to 80 bucks for the game.

A fix that's known to work when crashing on loading is to go to your documents folder \ Rockstar Games \ red Dead Redemption 2 \ Settings and delete the 3 files that start with sga_vulkan. Then run the game.

 

Hopefully that will work for you.

  • Like 2

Share this post


Link to post
Share on other sites
Deputydog857
23 hours ago, jackrobot said:

A fix that's known to work when crashing on loading is to go to your documents folder \ Rockstar Games \ red Dead Redemption 2 \ Settings and delete the 3 files that start with sga_vulkan. Then run the game.

 

Hopefully that will work for you.

That worked for now. Thank you for that.

 

Jack

Share this post


Link to post
Share on other sites
jackrobot

Those 3 files will come back to your settings folder but shouldn't cause any more problems. Sometimes after an update, you may have the same issue but deleting those files again should fix it,

Share this post


Link to post
Share on other sites
Hanzema
4 hours ago, jackrobot said:

Those 3 files will come back to your settings folder but shouldn't cause any more problems. Sometimes after an update, you may have the same issue but deleting those files again should fix it,

You think they will eventually fix this? Cause i have to do this every game session. Its quite annoying tbh.

  • Like 1

Share this post


Link to post
Share on other sites
RedIndianRobin
4 hours ago, Hanzema said:

You think they will eventually fix this? Cause i have to do this every game session. Its quite annoying tbh.

I sense this has something to do with Nvidia. I kept having crashes and I had to delete the SGA files everytime I played. In my case, this was fixed after changing drivers. I was in RDR 2 GRD driver and I updated to the latest one now. 

Share this post


Link to post
Share on other sites
Hanzema
1 hour ago, RedIndianRobin said:

I sense this has something to do with Nvidia. I kept having crashes and I had to delete the SGA files everytime I played. In my case, this was fixed after changing drivers. I was in RDR 2 GRD driver and I updated to the latest one now. 

But i do have these crashes since the latest nvidia driver and rdr2 version.

Share this post


Link to post
Share on other sites
Pointi1978

I just LOVE it, when I play a long mission, lasting like 20 minutes, I try hard to do it perfect, I am at the last enemy before I can save the game again, charging out of cover to get the last one alive, and the game freezes.

 

Can R* PLEASE fix those random crashes?! 

Share this post


Link to post
Share on other sites
RedIndianRobin
On 12/10/2019 at 7:18 PM, Hanzema said:

But i do have these crashes since the latest nvidia driver and rdr2 version.

What I am trying to say is, keep changing the drivers if you can't seem to fix the crashes. Now you have the latest one installed, go back to GRD for RDR 2 and it should stop the crashes. That's what fixed it for me.

Share this post


Link to post
Share on other sites
Deputydog857

 

 Well, after a few sessions I am right back to the crashes when I try to run the game. I've tried everything from the current Nvidia Drivers to reverting back to the 144.13 and it STILL crashes. Deleted the three vga Vulcan files, crash. I have all windows protection turned off, crash. File verification, crash. Uninstall and re-install, CRASH!!!!!!!!!!! Can someone please assist with something that works? Is there a file I can post so you can see what the issue is? I shouldn't have to turn off CPU's or revert to year old video drivers. I'm asking the community since Rockstar apparently could give a sh*t based on the number of Help/Tech issues posted and NO responses or fixes.

 

Jack

Edited by Deputydog857

Share this post


Link to post
Share on other sites
Deputydog857

Ok, update. Tried to submit a ticket to get my $99 fkin game to work, THERE IS NO ticket selection. ROCKSTAR got my money so now I'm f'd. Anyone out there that can please help? out of thousands of players I can't be the only one that cant can't play.

 

Jack

Share this post


Link to post
Share on other sites
NativeX
28 minutes ago, Deputydog857 said:

Ok, update. Tried to submit a ticket to get my $99 fkin game to work, THERE IS NO ticket selection. ROCKSTAR got my money so now I'm f'd. Anyone out there that can please help? out of thousands of players I can't be the only one that cant can't play.

 

Jack

I also had a memory related problem and 16 GB RAM as well, but on Windows 7. I set the page file to let the system manage on the D drive (Games directory). After I did that, I was able to launch RDR2 without crashing. You could try setting the page file to let the system manage and see if it launches the game. Make sure it is on the drive where RDR2 is installed and that you have enough space for the 16GB pagefile. Best of luck!

Edited by NativeX

Share this post


Link to post
Share on other sites
Deputydog857

Like OMG! (80's Valley Girl reference) Found the fix for everyone, like me, that keeps having crashes upon trying to run the game. It's not the video, it's the AUDIO. Spent EIGHT hours today installing, deleting and re-installing the game, windows, Nvidia. Then, at the last search I found this gem. made the changes that the third Edit stated and BAM, she be working!! Hope it helps the rest...……….

 

I did some testing after I read comments on Reddit posts. Turns out, my speaker is the cause for the issue. Whether it's the Realtek drivers, Sonic Studio 3, or other drivers, I do not know - every sound device I plug into my machine crashes the launcher and the game.
When I unplugged my stereo speakers, everything worked fine again.

EDIT 2 Tested some more. Launcher has problems with realtek audio driver that causes the crash. Just switch to any other driver rather then realtek and it will work fine. Switched to my Asus rog PG348Q monitor speaker and everything worked fine.

EDIT 3 More testing discovered, that your default sound format should be 24 bits 48000hz, else the game crashes.

Share this post


Link to post
Share on other sites
Pointi1978
55 minutes ago, Deputydog857 said:

Like OMG! (80's Valley Girl reference) Found the fix for everyone, like me, that keeps having crashes upon trying to run the game. It's not the video, it's the AUDIO. Spent EIGHT hours today installing, deleting and re-installing the game, windows, Nvidia. Then, at the last search I found this gem. made the changes that the third Edit stated and BAM, she be working!! Hope it helps the rest...……….

 

I did some testing after I read comments on Reddit posts. Turns out, my speaker is the cause for the issue. Whether it's the Realtek drivers, Sonic Studio 3, or other drivers, I do not know - every sound device I plug into my machine crashes the launcher and the game.
When I unplugged my stereo speakers, everything worked fine again.

EDIT 2 Tested some more. Launcher has problems with realtek audio driver that causes the crash. Just switch to any other driver rather then realtek and it will work fine. Switched to my Asus rog PG348Q monitor speaker and everything worked fine.

EDIT 3 More testing discovered, that your default sound format should be 24 bits 48000hz, else the game crashes.

 

I am using 16 bits 48kHz and have rarely any crashes at the moment. 5.1 Surround Sound, using my Nvidia RTX 2060 as a SoundCard firing my Denon AVR-1912 who handles my Video aswell with just 1 HDMI Cable from PC to Receiver...

I have completely deactivated the Soundcard from my Mainboard in Devicemanager because I wanted to use only one cable from PC to Receiver.

Edited by Pointi1978

Share this post


Link to post
Share on other sites
Spider-Vice

My audio is 32-bit, 44100Hz and it doesn't crash, however it's not the first time I hear that Realtek drivers make the game crash. Realtek as a whole is pretty sh*tty with drivers in games tbh.

Share this post


Link to post
Share on other sites
Ron Damon

I use an external DAC here, so my Realtek driver was always disabled, that must be the reason that I never had crashes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 2 Users Currently Viewing
    0 members, 0 Anonymous, 2 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.