Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. Los Santos Tuners
      2. Updates
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Blood Money
      2. Frontier Pursuits
      3. Find Lobbies & Outlaws
      4. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

      1. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

      1. GTANet 20th Anniversary
    2. Support

    3. Suggestions

[ GTA V ] GIMS for 3dsmax 2017 - 2020


linkinforever
 Share

Recommended Posts

My 3 year student license term for 3ds Max 2016/2017 just expired a few weeks ago, and today I had to convert some models to RAGE MP. What a blessing that you worked on this!

 

Tested with 3ds Max 2021, works well.

Link to comment
Share on other sites

Why does Evo with 3DS max doubles (if lucky) vertices on export? Is there a way around it?

I am using triangles only

Link to comment
Share on other sites

On 6/4/2020 at 2:30 AM, MoravianLion said:

Why does Evo with 3DS max doubles (if lucky) vertices on export? Is there a way around it?

I am using triangles only

This is a mistake of the original author and it is not known whether he will fix it.


I checked this build again on 3ds max 2020.3. Import (sort of) is not bad, but the export takes a terribly long time and is completely wrong. The place of export of the character, I just got an "inflatable doll" which is tied to the main bone of the model and that's it.

Link to comment
Share on other sites

  • 3 weeks later...

Does this not work with 3ds max 2021? throws and error every time I open:

Cant start the shared core.

Compile error only throws without arguments are permitted in catch expressions

Compile error only throws without arguments are permitted in catch expressions

Link to comment
Share on other sites

9 hours ago, syltann said:

Does this not work with 3ds max 2021? throws and error every time I open:

Cant start the shared core.

Compile error only throws without arguments are permitted in catch expressions

Compile error only throws without arguments are permitted in catch expressions

It seems to work fine for me. Can you please try reading the readme and see if an installation step was missed?

Link to comment
Share on other sites

I got it working with 3DS max 2021. Not sure what the issue was probably because I was using an older version of GIMS I believe.

Link to comment
Share on other sites

  • 2 weeks later...
On 5/29/2020 at 12:51 AM, Tut Greco said:

My 3 year student license term for 3ds Max 2016/2017 just expired a few weeks ago, and today I had to convert some models to RAGE MP. What a blessing that you worked on this!

 

Tested with 3ds Max 2021, works well.

Please, can you share it? I too use 3ds max 2021. Download links are inactive. I have nowhere to download

Link to comment
Share on other sites

16 minutes ago, PashaStrayt said:

Please, can you share it? I too use 3ds max 2021. Download links are inactive. I have nowhere to download

I saw your initial question. I have asked forum moderation if I can send them a new link so that they can update the OP but waiting on a response. But given the OP has released it as open source, I don't think there'll be an issue adding a temporary fix for the download...

https://www.mediafire.com/file/zpglim0xmp3a1d7/GIMS_2016+_ManualInstall_v2.zip/file

  • Like 1
Link to comment
Share on other sites

6 minutes ago, Tut Greco said:

I saw your initial question. I have asked forum moderation if I can send them a new link so that they can update the OP but waiting on a response. But given the OP has released it as open source, I don't think there'll be an issue adding a temporary fix for the download...

https://www.mediafire.com/file/zpglim0xmp3a1d7/GIMS_2016+_ManualInstall_v2.zip/file

Many thanks, man! You saved me!

Link to comment
Share on other sites

added link to OP with working mirror as requested

Link to comment
Share on other sites

  • 3 weeks later...
2 hours ago, Azeezbna said:

This link is dead , can you or someone else reupload it please , thanks

Please visit the first page, the link was updated on OP

Link to comment
Share on other sites

Hey all, very new to this and with zero experience regarding modelling. I'm trying to modify some clothing items for Franklin to MP male using 3ds max 2021. I used a video tutorial, and everything worked well, however once I import the model back into GTA, it appears backwards on my character, and without movement. I haven't any clue as to how to fix this, and when I've asked other people who create models, I'm told to downgrade to the 2017 version of 3ds max because the new version 'has issues'. I'm on the free trial of the program, which won't allow you to download anything earlier than the 2018 version, and purchasing the 2017 one isn't really plausible for me.

I'm going to follow what another poster said earlier, about rotating it 180, and hope that works. Figured I'll post anyway just in case. 

Any ideas? Keep in mind, I am a potato who hasn't even looked at this program until a week ago. 

Link to comment
Share on other sites

  • 4 weeks later...

TEMP FREEZE FIX

 

ok, so, i had this "freezing" issue too in my 3ds Max 2020, i just installed the freeze fix but the problem still, but, since the first time i had this issue i accidentally found a tricky way to temporary fix it, temporary because when you reopen 3ds max you need to do the "fix" again, this is what i do:

 

-Open 3ds max and start GimsEVO for GTA 5 (Here it loads fine and fast)

-Import your models or open your project that have something ready to be exported, its good use a simple thing, complex entities (poly count) would take longer in next step

-Click to Export in GimsEVO and set the destination folder to proceed clicking in "Select Folder" in the dialog box

-Now it will freeze for some time (the freeze issue), after it comes back i cancel the export clicking in the Back arrow icon

-Now with nothing selected in the scene, i click in "Create object"

-(wait freeze ends) Now click in "Collisions"

-(wait freeze ends) Now click in "Mesh: Modifier"

-(wait freeze ends) You should now see a error message in GimsEVO because nothing was selected in scene, now click in the back arrow icon until you get back to main GimsEVO menu

 

Done, now if you try to Export something it will be fast as expected, also the Create button wont have the freeze anymore :)

 

Seems that when this error is caused by our mistake after trying to export something, the freeze bug is gone. It's odd and tricky but works.

  • Like 1
Link to comment
Share on other sites

On 8/2/2020 at 7:52 PM, ohtattoome said:

Hey all, very new to this and with zero experience regarding modelling. I'm trying to modify some clothing items for Franklin to MP male using 3ds max 2021. I used a video tutorial, and everything worked well, however once I import the model back into GTA, it appears backwards on my character, and without movement. I haven't any clue as to how to fix this, and when I've asked other people who create models, I'm told to downgrade to the 2017 version of 3ds max because the new version 'has issues'. I'm on the free trial of the program, which won't allow you to download anything earlier than the 2018 version, and purchasing the 2017 one isn't really plausible for me.

I'm going to follow what another poster said earlier, about rotating it 180, and hope that works. Figured I'll post anyway just in case. 

Any ideas? Keep in mind, I am a potato who hasn't even looked at this program until a week ago. 

It's just that this assembly is completely broken. If she still somehow copes with the import of models, then completely broken mods with the above error are exported. The original author doesn't give a damn about the update. The author of the mod looks the same.

Link to comment
Share on other sites

For some reason, the latest version of this updated script messes up skinned meshes. As shown in the image below, the default export options set the mesh file tags to "Skinned = False" by default, the bone count is also set to 0 no matter what and the vertex definition is also not the one used for skinned meshes. This mesh file ended up coming out 3 megabytes lighter than the one using the old exporter, probably because weighting data is missing. 

 

T7G97qJ.png

 

Also, the vertice count triples because the exporter splits all the faces based on the edges or something like that, I have no idea why this is done as Zmodeler doesn't need to do that, but if that could be somehow disabled it'd make ped modding with GIMS Evo a fully viable option now that we can make our own .YFT skeletons with CodeWalker.

 

Exporting with the first version of this updated script seems to be working fine though the weighting issues, mostly present on the facial bones, that have been pestering the whole ped porting thing for years is still present, the limit for bone weight link in the game's models is 4 and I made sure that all bones are under this constraint but it still happens so it could be related to the edge splitting function or something else, I just know that this is currently the biggest issue when it comes to porting peds with GIMS Evo from all the testing I've been doing since mid-2019.

 

1MboaWp.png

 

 

 

 

 

 

Link to comment
Share on other sites

  • 3 weeks later...

@linkinforever

There is a bug in your version, for some reason the lines are commented out that the weight of the model was NOT saved during export (gta v), and this version is not compatible with old assemblies. Someone Tosyk has fixed both of these problems.

GIMS Evo fixed 2009-2020 by Tosyk 

Edited by MARK2580
  • Like 2
Link to comment
Share on other sites

  • 2 months later...

@linkinforever I'm having a problem with using it on 3ds max 2019. The popup window just shows up black. The only thing I could figure is that it could *maybe* be is that the local folder is in my /C drive while 3dsmax is installed on my /D drive. but Idk. anyone else have this problem?

Edited by kwvance
Link to comment
Share on other sites

On 9/25/2020 at 7:45 PM, MARK2580 said:

@linkinforever

There is a bug in your version, for some reason the lines are commented out that the weight of the model was NOT saved during export (gta v), and this version is not compatible with old assemblies. Someone Tosyk has fixed both of these problems.

GIMS Evo fixed 2009-2020 by Tosyk 

Does this fix the bugged materials issue I'm getting in the viewports?

yqY5R0s.png

Link to comment
Share on other sites

On 12/18/2020 at 4:53 PM, Tut98 said:

Try disabling transparency in viewport display settings

I fixed it by using the High Quality render mode in the viewport options.

Link to comment
Share on other sites

  • 2 weeks later...
On 1/5/2021 at 2:40 AM, linkinforever said:

Hello everyone!

Sorry for the delay, Post are updated.

Cheers!

 

You were missed by many users I'm sure! Haha. :colgate:

Link to comment
Share on other sites

ArtemonchekYT

Hello everyone, what should I do if textures (objects are pink) do not work when importing some models? Earlier I had a similar problem, and as it turned out, textures from other archives were missing. Now I have learned with the help of codewalker to find all the textures for the model, and, for example, for this model (piece of beach) there are absolutely all the textures, but it is still pink. In map editor only two textures. Please, help!

3ds max 2021
latest version of gims

https://drive.google.com/drive/folders/1WhqaQ8MuBGvC30uuwhWdr_MqF4T0tKO6?usp=sharing

Link to comment
Share on other sites

1 hour ago, ArtemonchekYT said:

Hello everyone, what should I do if textures (objects are pink) do not work when importing some models? Earlier I had a similar problem, and as it turned out, textures from other archives were missing. Now I have learned with the help of codewalker to find all the textures for the model, and, for example, for this model (piece of beach) there are absolutely all the textures, but it is still pink. In map editor only two textures. Please, help!

3ds max 2021
latest version of gims

https://drive.google.com/drive/folders/1WhqaQ8MuBGvC30uuwhWdr_MqF4T0tKO6?usp=sharing

You may need to tell 3ds Max where your textures are found.

 

In the top side of the application select Customize -> Configure Project Path / User Path (doesn't matter how it's called)

 

In external files, add your folder to reference its location. Reload the scene and they should work.

Link to comment
Share on other sites

ArtemonchekYT
23 hours ago, Tut98 said:

You may need to tell 3ds Max where your textures are found.

 

In the top side of the application select Customize -> Configure Project Path / User Path (doesn't matter how it's called)

 

In external files, add your folder to reference its location. Reload the scene and they should work.

Hi, sorry, didn't help. I did everything as you wrote, reloaded the scene - it still doesn't work. Сan we contact you through some social network to make it easier to communicate?
Screen:
https://drive.google.com/file/d/1iFkOfu1QrSSWTM8seMLWWwqot2oisUaS/view?usp=sharing
Upd: I installed 3ds max 2018 (I have 2021) on another pc, and there is exactly the same problem.

Edited by ArtemonchekYT
Link to comment
Share on other sites

Is it just me or does anyone know of a ped shader that works with overlapping UVs? I am having issues trying to port a model to the game and when I use "ped" the normals are messed up:

y2dgmto.jpg

 

fNEoT93.png

 

I could use ped_hair_cutout_alpha as what I've seen with some models, but I doubt it would be ideal especially with the checkerboarding artefacts.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.