Jump to content

DragonFF - Blender GTA I/O


Parik

Recommended Posts

On 7/1/2021 at 8:13 PM, SunnyCruiser80 said:

try rotating its axis maybe

i have tried but no change, also sometimes the model messed up when i walk. 

 

https://imgur.com/0bsfEN9

Edited by Ngajet
add image
Link to comment
Share on other sites

Colbertson
On 7/1/2021 at 1:50 PM, Ngajet said:

i have tried but no change

Rotating in object mode isnt "permanent", you have to apply transforms with Ctrl+A.

Link to comment
Share on other sites

On 7/2/2021 at 3:31 AM, Colbertson said:

Rotating in object mode isnt "permanent", you have to apply transforms with Ctrl+A.

image 1

image 2

 

ok, just found where the problem is. i have join both models and delete old one, when in pose mode to move the bone, the skin did not moving just like in first image.

 

and i dont know how to attach bones and skin

Edited by Ngajet
correction
Link to comment
Share on other sites

Colbertson
On 7/2/2021 at 8:07 AM, Ngajet said:

how to attach bones and skin

This is called rigging, there are quite a few good tutorials about it on youtube. Ofcourse none for specifically SA but the idea is the same.

Link to comment
Share on other sites

MadeOfPuddin

When importing voodoo.dff, then exporting it as it is and plugging it into the game, some materials are switched (vehiclegeneric256 becomes glass for some reason), UVs get butchered and the camera height seems off. Also, the exported model is larger in size, even though I haven't done anything to it. Any idea how to overcome these issues?

 

Before

After

Different Material with Butchered UVs

Edited by MadeOfPuddin
Grammar; switched up before and after pics
Link to comment
Share on other sites

RACERNELEGALNY

how to bake lighting in vertex colours? 
----
Since Blender V2.92 Vertex Color baking from light is built-in using Cycles engine
Everything turned out to be just easier
 8BZevEE.png

Edited by RACERNELEGALNY
found a solution
Link to comment
Share on other sites

RACERNELEGALNY

When I import the model into the blender, everything is fine.
If I export the model to .dff And import it into the blender again, the sharps get lost, disappear.
It turns out that after exporting, the shading of the model becomes incorrect.
What am I doing wrong

how I do: https://imgur.com/a/cpkcQYV

after export: https://imgur.com/a/cEeBlSm 

Link to comment
Share on other sites

On 7/11/2021 at 11:24 PM, RACERNELEGALNY said:

how to bake lighting in vertex colours? 
----
Since Blender V2.92 Vertex Color baking from light is built-in using Cycles engine
Everything turned out to be just easier
 

Why bake color vertexes? You can just add them to the "ColorVertex List" and that's it, the script will do everything by itself.

Link to comment
Share on other sites

RACERNELEGALNY
On 7/16/2021 at 3:40 PM, Dmitrysass said:

Why bake color vertexes? You can just add them to the "ColorVertex List" and that's it, the script will do everything by itself.

yes, but in order for them to be created from a light source (sun, point, ...), and not made manually, you need to click the "Bake" button.

Link to comment
Share on other sites

RACERNELEGALNY

This is a standard gunbox. On the right is what I get after exporting. unnecessary sharps. I do not know why they appear. how can I fix this?
 ZlrfLAv.png

Link to comment
Share on other sites

On 7/17/2021 at 2:36 AM, RACERNELEGALNY said:

This is a standard gunbox. On the right is what I get after exporting. unnecessary sharps. I do not know why they appear. how can I fix this?
 

Uncheck "Use Edge Split" while importing. The DFF file doesn't store sharp information. While importing, the plugin will mark the duplicate vertices as sharp so you don't have to work with two sets of vertices (because the format doesn't support different materials/normals/etc. for the same vertex so they have to be duplicated).

   

 

 

Link to comment
Share on other sites

  • 2 weeks later...

That's cool and all but one question.
Animation support when
Using this plugin since 2.8 release, still have 2.79 for animations (and i hate it)

Edited by MCast1e
Link to comment
Share on other sites

  • 2 weeks later...

please help guys. don't know how to fix it. so with any model when importingzDDNCF3XesE.jpg?size=1280x720&quality=96&sign=5ab03169e7a51ede3dd7bbd01577aa04&type=album

Edited by motouboynyy
Link to comment
Share on other sites

  • 2 weeks later...
TheKatherineManiac

 This happends when i try to export a skin and bones model, is there a way to make it import it correctly?

 BC62gZN.png

Link to comment
Share on other sites

  • 3 weeks later...

Hey can someone help me? I'm totally new and I'm stumped. It's the first time i'm using blender and i've been trying to open a dff file in it. I downloaded the zip provided here and pointed to it in the add ons section and enabled it. But how do i open the dff file now? Trying to use file > open but I can't see the dff, it's like it's not detecting it.

Link to comment
Share on other sites

52 minutes ago, Colbertson said:

File > import

It's alright, I switched to 3DS max and figured it out. I'm now in unity, have applied the skin/texture (I believe) to the model, loaded the vrc sdk successfully, and need to figure out what's next

Link to comment
Share on other sites

  • 2 weeks later...
On 9/28/2021 at 12:37 PM, GLOT said:

after export, some cars (san andreas) without shade, how can i fix it?

It might help to see how the cars look, but I will assume you mean they have no shading - in this case, check that the materials has specular maps plugged in and that you're exporting vertex normals. Do not export vertex colors.

Link to comment
Share on other sites

2 hours ago, Tut98 said:

It might help to see how the cars look, but I will assume you mean they have no shading - in this case, check that the materials has specular maps plugged in and that you're exporting vertex normals. Do not export vertex colors.

after export

Spoiler

f67aae6eee1f.jpg

before export

Spoiler

2a2572401196.jpg

 

Edited by GLOT
Link to comment
Share on other sites

On 9/29/2021 at 10:30 PM, GLOT said:

after export

  Hide contents

f67aae6eee1f.jpg

before export

  Hide contents

2a2572401196.jpg

 

It looks like your new DFF is missing the original .col file. Vehicle models has their collisions embedded in their DFF. These collisions contain both collision mesh and shadow mesh.

Link to comment
Share on other sites

RACERNELEGALNY

What is the difference between environment, reflection and specular? I tried to apply them all in turn to the sunglasses object, only enivoriment is visible in the game

ZcW7o9a.png

Link to comment
Share on other sites

6 hours ago, RACERNELEGALNY said:

What is the difference between environment, reflection and specular? I tried to apply them all in turn to the sunglasses object, only enivoriment is visible in the game

ZcW7o9a.png

Environment mapping is used by objects and vehicles for the fake reflections seen on parts e.g chrome.

Only vehicles support Specular material and is used to show their normals while also adding a faint highlight on top of its surface.

I'm not really sure what the Reflection material is for, but I guess it's unused for GTA.

Link to comment
Share on other sites

BS_BlackScout

Is there a reason why by default the alpha output from the Image Texture isn't connected to the Principled BDSF alpha's input?
(Happens on ipl imports, unsure about dffs)

N1ze6sb.png

 

Side Effect:

ofc0tsC.png

Edited by BlackScout
Link to comment
Share on other sites

RACERNELEGALNY
On 11.10.2021 at 01:08, BlackScout said:

Есть ли причина, по которой по умолчанию альфа-выход из текстуры изображения не связан с альфа-входом Principled BDSF?
(Бывает при импорте ipl, неуверенный в dffs)

N1ze6sb.png

 

Побочный эффект:

ofc0tsC.png

7wKE8XV.png

  • Bruh 2
Link to comment
Share on other sites

BS_BlackScout
4 minutes ago, RACERNELEGALNY said:

7wKE8XV.png

Duh. Of course. The problem is that this should happen automatically.

There are dozens of textures with alpha channels. If I were to do this to every tree it would take me forever.

In fact, I have done it and it took me forever.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.