Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. Gameplay
      2. Missions
      3. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Arena War
      2. After Hours
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA Next

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

Sign in to follow this  
naiden

[SA] I need help with .dff modelling

Recommended Posts

naiden

I was trying to edit the nrg500 .dff with zmodeler 2.2.6 to make it look like this: 3a1J5K6.png 

 

(this variation cannot be generated by the game itself, its a custom .dff)

The problem I have is when I finish editing with zmodeler and replace the original dff file with the one I made and when I start the game, the nrg doesnt appear anywhere in the game. I checked all the spawn places, tried spawning it with a trainer, but no it's completely gone from the game. 😧

This is what I have done: StTBS9n.png

I need help :(

 

 

Share this post


Link to post
Share on other sites
naiden

MZFVTjj.jpg

Here's what I get now :D

Share this post


Link to post
Share on other sites
naiden

Edit:YBRfzlT.jpg 

I did it. 

But there's one issue, the headlight is missing: 9PQs3tG.jpg

 

And the dash texture is bugged somehow:w6nDI1m.jpg

Share this post


Link to post
Share on other sites
Ade GSF

Maybe you can find help from Automan or GTA  San Andreas Modder :^:

Share this post


Link to post
Share on other sites
Tut Greco

the 1-sided issue happens when turning on vehicle lights, it's nothing you have to worry about, happens for R* models too. I believe there's a patch somewhere though

Share this post


Link to post
Share on other sites
naiden

i dont think its caused by that, i installed other nrg mods that have the headlight texture there and dashboard texture working as well, theres something im doing wrong but i cant fix it :(

Share this post


Link to post
Share on other sites
Mysterdogg

@naiden, use the latest version of Zmodeler instead of the one you have, old versions causes the same and similar issues in exported models.

 

The last and current version of Zmodeler 2 it's 2.2.6 build 992 (you can easily find it on the web if you can't or don't want to buy it). You need to also have Silentpatch installed for fixing transparency bugs as@Tut Greco said.

 

The steps for making such variant for the NRG-500 are, in a wide range, "copy",  "mirror", "flip", "calculate" & "attach". Use Vehfuncs if your model has more than 6 extra parts. Don't forget to have all of the required textures in the same folder with the 3D model, preferably in DDS or TGA format, avoid BMP one. 

 

To avoid future problems when editing or making 3D models I suggest you read the basic and then advanced lessons of Zmodeler, there's also a good playlist of tutorials made by Ikey7 on YouTube. 

Share this post


Link to post
Share on other sites
naiden

I tried making it with 992 build, same issue, missing headlight and bugged dashboard texture fJsWXAV.jpg

Share this post


Link to post
Share on other sites
Tut Greco

sorry for going off topic, but are you aware if using silentpatch is supported for MTA? @Mysterdogg

Share this post


Link to post
Share on other sites
Mysterdogg

@naiden the model seems to be corrupted once you exported it, check which options are enabled and which are disabled in the exportation window.

 

Which are the steps you're doing to edit the model? if you can include pics of every step that will be really helpful. The edition you're making it's really simple so you shouldn't have all those problems, something is probably messing or missing there. 

 

@Tut Greco sorry but I don't play MTA so I don't know if Silentpatch works with it but as far as I know, SP it's made exclusively for the single player version of the game. You can of course ask that in the official topic or check it in Github for further information. 

Share this post


Link to post
Share on other sites
naiden

@Mysterdogg Do you have discord? it would be faster to show you there

Share this post


Link to post
Share on other sites
Mysterdogg
2 minutes ago, naiden said:

Do you have discord?

No, sorry, I used to. You can PM here if you want. It's preferable to post the pics here anyway so more users can see it and help you instead of only me. 

Share this post


Link to post
Share on other sites
naiden

I've all the textures needed, nrg500.dff and nrg500.txd put in the same folder.

vzDwIm9.png

When I open the nrg .dff I delete extra3 and extra2, make a copy of extra1, then mirror it, calculate, flip the mirrored extra1 and last I attach the both extra1 parts to each other and the attach it to chassis.

wHoZUky.png

After that I export it as a GTA San Andreas .dff with TGA textures.

mgH9c6n.jpg

It looks absolutely fine when I open it in GGMM.

Share this post


Link to post
Share on other sites
Mysterdogg

As seen in your Zmodeler screenshots, you're missing the generic textures from vehicles.txd. That could explain why you're having that issue with the lights & dashboard. 

Share this post


Link to post
Share on other sites
naiden

ive vehiclelights128.tga, vehiclegeneric256.tga, vehicleenvmap128.tga and vehicledash32.tga

can you try to do if possible?

Share this post


Link to post
Share on other sites
Mysterdogg

I can't make it for you, I'm on a vacations break without my computer so the only thing I can do is to suggest you this. Hopefully somebody else could make it if the model I suggested you isn't it what you want. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • 2 Users Currently Viewing
    0 members, 0 Anonymous, 2 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.