Jump to content
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. Los Santos Drug Wars
      2. Updates
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Blood Money
      2. Frontier Pursuits
      3. Find Lobbies & Outlaws
      4. Help & Support
    3. Crews

    1. Grand Theft Auto Series

      1. Bugs*
      2. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Classic GTA SA
      2. Guides & Strategies
      3. Help & Support
    6. GTA Vice City

      1. Classic GTA VC
      2. Guides & Strategies
      3. Help & Support
    7. GTA III

      1. Classic GTA III
      2. Guides & Strategies
      3. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

    2. Forum Support

    3. Suggestions

Cannot get GTA 4 ( to launch after installing any ENB


Recommended Posts

Hello everyone,


So, as shown in the title, I am unable to get GTA 4 to launch after installing any ENB modification. Full details are below, including what I have tried and my system info.






  1. I downloaded the game from Steam legitimately, i.e. I did not pirate the game. It was installed with version
  2. Then, I downloaded the patch from the official rockstar download page
  3. The installer ran successfully and the game was downgraded to (I checked by viewing the Details tab in the Properties of GTAIV.exe)
  4. I launched the game successfully and everything worked fine up to this point.
  5. I then quit the game and installed XLiveLess so I could load my saves, and I even installed ScriptHook and TrainerIV, and everything was working fine.


My commandline can be found here (note - the official memrestrict values never fixed texture loss for me, even on a vanilla game)


My stream.ini can be found here (its located in Grand Theft Auto IV\GTAIV\bin)


P.S. I downgraded the game properly with the paul.dll method which can be found here






  1. I downloaded and installed EyeCandy ENB V6 and extracted everything except commandline.txt into my game folder (C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV)
  2. Then, after checking that none of the files were blocked by Windows, I launched the game by running LaunchGTAIV.exe as administrator, not launching the game via steam.
  3. I click "Play" in the window that appears.
  4. Then, my mouse cursor shows the "Working" icon for a few seconds, then it stops.
  5. The game never launches, nothing happens.


A quick check in Task Manager shows that when I click "Play" the GTAIV.exe process spawns but then crashes / kills itself instantly.


All ENBs used to work properly and smoothly on previous versions of Windows 10 (1607). This issue started since Windows 10 version 1703.






PCPartPicker full component list


Relavant PC Specs:

  • i7 5820K @ 3.3Ghz
  • 16GB DDR4 2133Mhz RAM
  • 480GB SSD with 100GB free, where GTA IV is installed
  • GTX 980Ti 2-way SLI (each has 4GB VRAM)


My dxdiag.txt


Desktop and GTA IV resolution: 3840x2160 @ 60Hz


My windows version dialog


My windows version: 1803, build 17134.137




WHAT I HAVE TRIED TO FIX THE ISSUE (all of which have had no effect):


Buckle up, because this list will be very long...


  • Restarting my computer (with Fast Boot disabled in control panel and using the ALT + F4 dialog on the desktop to restart, so all processes are properly killed)
  • Running all of the installers that come with the game download (C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\Installers)
  • Using Display Driver Uninstaller in safe mode to wipe graphics drivers, then reinstalling the latest graphics drivers
  • Disabling SLI via Nvidia Control Panel
  • With SLI enabled, settings SLI bits to 0x43500405 as per this post in Nvidia Inspector. Didn't make a difference in this case but gives a great performance boost to vanilla unmodded GTA IV.
  • Adding d3dx9_26.dll and d3dx9_40.dll to my game folder as per this post
  • Installing DirectX after running Display Driver Uninstaller and reinstalling graphics drivers. It did actually load some files and say that they were "now ready for use" as if it repaired something, instead of reporting that "The latest version is already installed" (or words to that effect)
  • Setting the correct resolution in ENBSeries.ini as per this post
  • Using a resolution of 1920x1080 for both my desktop and GTA IV
  • Using a different ENB (on a clean install of GTA IV downgraded to - I've tried CryENB, ICEnhancer, Game4Video ENB, ProfeetENB, and the default ENBSeries for GTA 4.
  • Using every OS option listed under "Run this program in compatibility mode for:" in the Compatibility tab of the Properties for GTAIV.exe, gta4Browser.exe, LaunchGTAIV.exe and gtaBrowser.exe.
  • Setting GTAIV.exe, gta4Browser.exe, LaunchGTAIV.exe and gtaBrowser.exe to run as administrator in the Compatibility tab of the Properties for each .exe file
  • Only setting GTAIV.exe to run as administrator
  • Using the default values for stream.ini
  • Using no commandline.txt file
  • Using -memrestrict 681574400 in my commandline.txt and in my LaunchGTAIV.exe shortcut
  • Adding my commandline options to a shortcut for LaunchGTAIV.exe set to run as administrator
  • Using a pirated version of GTA 4 (I was desperate :P)
  • Putting the game into a folder called Grand Theft Auto IV instead of a folder called GTAIV inside a folder called Grand Theft Auto IV (default setup)
  • Disabling Full Screen Optimisations in the compatibility tab of GTAIV.exe's properties
  • Removing all script mods and hooks
  • Clean installing the game, downgrading to patch then retrying an ENB
  • Disabling all gaming settings in the Settings app
  • Uninstalling the Xbox app via Windows Powershell
  • Disabling shader cache in Nvidia Control Panel
  • Disabling VSync in Nvidia Control Panel
  • Clamping negative LOD bias in Nvidia Control Panel
  • Applying the 4GB patch to GTAIV.exe
  • Applying Large Address Aware to GTAIV.exe (after applying the 4GB patch, as that patch creates a new .exe file)
  • Completely quitting Steam before launching the game
  • Disabling the Steam overlay for GTA 4
  • Disabling all overlays for GTA 4 (thats the Steam Overlay and Nvidia Shadowplay)
  • Messing with all of the .ini files in the game folder.
  • Using a different monitor
  • Using my inbuilt graphics card
WHAT I HAVE TRIED TO FIX THE ISSUE (all of which have had an effect on the issue):
  • Not running LaunchGTAIV.exe as administrator (returned a SecuROM error, but did not solve the issue)
  • Removing d3d9.dll from my game install folder. The game successfully launches, however everything is fully black, as the ENB relies on this file.
I've tried pretty much everything I know.
I hope I've listed everything, but I may have forgotten some obvious points (both in the "What I've tried" and the "My System Information" sections)
I've been modding and playing the game for 5 years, and I know it inside out, but no response is "stupid".
All help is widely appreciated. Thanks in advance.
Here is what I think is causing the issue.
Edited by sjain
Fixed some text colors and added speculation
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.