Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    2. News

    1. Red Dead Redemption 2

    1. GTA Online

      1. After Hours
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

a bad day

[GTA SA] My gun sounds didn't work?

Recommended Posts

a bad day

I was testing to make a mod myself that replaces gun sounds. But when I tried it in-game, it didn't work! The original sounds still remain. I don't know how this happened.

 

I'm using modloader, then put in a folder called "GENRL", then inside that, "Bank_137", then there are the gun sounds I did are located.

The gun sounds are all .wav files.

Should I remove the titles? Titles still remain when the folder is sorted out as "Details".

Is it because of the bitrate?

 

Please anyone, help me. I'm new to making mods. Thanks in advance.

Share this post


Link to post
Share on other sites
CoolMods
Posted (edited)

Well, some weapon sounds may be bugged. Which sounds btw?

Edited by CoolMods

Share this post


Link to post
Share on other sites
𝙲olby
Posted (edited)

Make sure you save it as a mono, signed 16-bit PCM wav.

FfLKUVg.png

Edited by Mubber

Share this post


Link to post
Share on other sites
a bad day

Make sure you save it as a mono, signed 16-bit PCM wav.

FfLKUVg.png

That's what I exactly did. Still persists.

 

Anyways, I tried importing the sounds via Alci's SAAT. It saved successfully but when I go in-game then try to test the gun sounds, there were no sounds! Just the sounds of the bullet hitting the wall.

Share this post


Link to post
Share on other sites
a bad day

Well, some weapon sounds may be bugged. Which sounds btw?

Gun firing sounds

Share this post


Link to post
Share on other sites
Assasinge

Livin' up to your username I see.

 

Are you sure the sound files aren't corrupted or something?

Share this post


Link to post
Share on other sites
a bad day
Posted (edited)

Are you sure the sound files aren't corrupted or something?

Yeah. All are fully functional. Saved to WAV Signed 16-bit PCM via Audacity.

Edited by a bad day

Share this post


Link to post
Share on other sites
a bad day

no one helping? bump

Share this post


Link to post
Share on other sites
The_Human

Check your modloader log, it can help you troubleshoot the problem.

Share this post


Link to post
Share on other sites
a bad day

Check your modloader log, it can help you troubleshoot the problem.

Modloader didn't load the sounds. I used SAAT instead.

Share this post


Link to post
Share on other sites
a bad day

Another bump.

Share this post


Link to post
Share on other sites
MrFinger

Modloader didn't load the sounds. I used SAAT instead.

WTF? Modloader can load sounds.

Share this post


Link to post
Share on other sites
CoolMods

No, not at all. Modloader dosen't load all type of sounds properly, like uzi sound. it was bugged

Share this post


Link to post
Share on other sites
MrFinger

I have some sound pack on modloader and everything works properly

Share this post


Link to post
Share on other sites
a bad day

Oh, now it works. Deleted unnecessary deets. But when I tested it, it sounds like it's from a speaker bought from Wish. Dunno how to fix that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.