Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Cayo Perico Heist
      2. The Diamond Casino Heist
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA VI

      1. St. Andrews Cathedral
    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. Announcements

    2. Support

    3. Suggestions

gold_fish

[REL] KAM's GTA Scripts (2018) / UPD: 31.05.2020 /

Recommended Posts

El'azar

when I export my skin.dff the textures are messed up, but when I use the ped spec.asi the textures are fixed but i want to add normal maps to it and ped spec + normal maps dont work. https://imgur.com/a/422JIqg

Edited by El'azar

Share this post


Link to post
Share on other sites
El'azar

Just testing out versions of this script above 3.1 and skins export with weird textures. https://imgur.com/a/YXlLxps idk about these stuff but maybe its cause the MMC option was removed?

 

Edited by El'azar

Share this post


Link to post
Share on other sites
Tut98
17 hours ago, El'azar said:

Just testing out versions of this script above 3.1 and skins export with weird textures. https://imgur.com/a/YXlLxps idk about these stuff but maybe its cause the MMC option was removed?

 

I think MMC stands for Modulate Material Color (of which purpose lies within I have no idea), the issue with the export looks like a case of UV's being incorrectly exported

Share this post


Link to post
Share on other sites
cj2000
22 hours ago, Tut Greco said:

I think MMC stands for Modulate Material Color (of which purpose lies within I have no idea), the issue with the export looks like a case of UV's being incorrectly exported

MMC is defenetly not a flag that should be set by the user during export. The MMC flag is set automatically if one of meshs materials is textured and has a color walue!=(255, 255, 255, 255).

  • Like 2

Share this post


Link to post
Share on other sites
gold_fish

note (!)

If you mix materials after exporting the model

ZR4eC50d4KA.jpg

when exporting, tick the checkbox "UV pack"

 

bKgaiPWgVyE.jpg

 

 

@El'azar try to tick the checkbox "UV pack"

Edited by gold_fish

Share this post


Link to post
Share on other sites
El'azar
On 12/1/2019 at 7:23 AM, gold_fish said:

note (!)

If you mix materials after exporting the model

ZR4eC50d4KA.jpg

when exporting, tick the checkbox "UV pack"

 

bKgaiPWgVyE.jpg

 

 

@El'azar try to tick the checkbox "UV pack"

it works thank you :)

Share this post


Link to post
Share on other sites
breant55
On 11/22/2019 at 7:38 PM, gold_fish said:

I just fixed the import of models with a multiclump, initially the script doesn’t load them, and activates the multiclump re-import mode, which must be done manually for each dff, but I corrected a little code to automatically ignore other types of clumps except for the one containing the model itself ( later can add the import of the animation itself uv)

sir thank you for your this hardworr for gta sa maping in 3ds max...but sir can you sugess me whats about texturs whre i download texturs an dff.

Share this post


Link to post
Share on other sites
gold_fish
4 hours ago, breant55 said:

sir thank you for your this hardworr for gta sa maping in 3ds max...but sir can you sugess me whats about texturs whre i download texturs an dff.

what problems do you have with this?

Share this post


Link to post
Share on other sites
ZaikerHind

I have this same error, what is the solution?

 

  

On 26/3/2018 at 22:05, Gmer said:
Spoiler

 

Recibo [Error]: escribir geometría, cuando estoy tratando de exportar un modelo originalmente exportado con KAMS anteriores usando esto.

 

9HmBH9p.png

 

No realicé cambios en 3DS en el modelo, solo que esta fue mi primera prueba de importación y exportación con su versión actualizada de KAMS.

Los antiguos kams pueden hacer esta misma operación, ahora mismo, en el mismo modelo, sin problemas. Después de eliminar el error, el .DFF generado tiene un tamaño de 2,07 KB.

¿Algun consejo?

 

Editar: parece que no se produce un error cuando no selecciono el .DFF como colisión como lo intenté. Solía skip col y funciona, pero aún así ...

Edit2: incluso con omitir col, aunque el error desapareció, el modelo generado está dañado, porque GTA no puede cargarlo ... y aproximadamente 60kb menos de tamaño (como perder algo)

 

tal vez esto pueda ayudarte a descubrir qué falta en la exportación o qué sale mal, gold_fish:

 

volcado del árbol de la sección del modelo de trabajo original RWAnalyze: https://pastebin.com/KUvGiBbX

volcado del modelo skip-col exportado que GTA no puede cargar: https://pastebin.com/hVXBJVNq

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
gold_fish
3 hours ago, ZaikerHind said:

I have this same error, what is the solution?

 

  

 

Do you have a problem exporting a vehicle or object?

Share this post


Link to post
Share on other sites
ZaikerHind
1 hour ago, gold_fish said:

Do you have a problem exporting a vehicle or object?

 

When I try to export a skin, I have the following error, and the skin is perfectly fine.

79316547_1443635699146004_6231067299529359360_n.png

Share this post


Link to post
Share on other sites
breant55
On 12/16/2019 at 4:50 PM, breant55 said:

sir thank you for your this hardworr for gta sa maping in 3ds max...but sir can you sugess me whats about texturs whre i download texturs an dff.

sir all peoples set txd folder for before import ipl... and dff... my qustion... wherre i find this all txd and dff for use 3ds max gta sa mapping requird...

Share this post


Link to post
Share on other sites
breant55
On 12/16/2019 at 4:50 PM, breant55 said:

sir thank you for your this hardworr for gta sa maping in 3ds max...but sir can you sugess me whats about texturs whre i download texturs an dff.

sir i realy very sorry  i am ask wrong qustion to you.... sir i wana ask whats requid for gta sa mapping in 3ds max please sir anser here as make a video about that .

Share this post


Link to post
Share on other sites
El'azar
On 12/1/2019 at 7:23 AM, gold_fish said:

note (!)

If you mix materials after exporting the model

ZR4eC50d4KA.jpg

when exporting, tick the checkbox "UV pack"

 

bKgaiPWgVyE.jpg

 

 

@El'azar try to tick the checkbox "UV pack"

I'm having this problem with another model. I checked UV Pack and it looks the same.

 

Edited by El'azar

Share this post


Link to post
Share on other sites
sabaru
Posted (edited)

Hello. I installed the latest version of the script and when I try to run the MAP IO script I get this message. How to fix it?

 

cosjpg_qanpppa.jpg

 

 

Edited by sabaru

Share this post


Link to post
Share on other sites
Strs

guys someone knows why is this happening https://imgur.com/QKfUoEQ i use kam's script from here i am using 3dsmax 2020

Share this post


Link to post
Share on other sites
cj2000
On 1/20/2020 at 5:18 PM, Strs said:

guys someone knows why is this happening https://imgur.com/QKfUoEQ i use kam's script from here i am using 3dsmax 2020

I think to know what the problem could be, the root node seems to have rotation, but at least the old Kams script has always ignored that rotation, don´t know if gold_fish has fixed this problem.

Share this post


Link to post
Share on other sites
xiaogui319

No Kam envelope tools?

Share this post


Link to post
Share on other sites
breant55
On 11/26/2019 at 8:04 PM, El'azar said:

when I export my skin.dff the textures are messed up, but when I use the ped spec.asi the textures are fixed but i want to add normal maps to it and ped spec + normal maps dont work. https://imgur.com/a/422JIqg

sir this version no supppt resize please fix this.... thank you for your hard work.

Share this post


Link to post
Share on other sites
Walter Clements

hey can anyone help me? im pretty new to this, and i tried to import a csgo gun into 3ds. i then exported it without changing the export settings then i imported it back into 3ds, and it came out huge. did i miss a step here?

the red wireframe is the exported DFF, the highlighted model is the raw file (.smd)

huge-model-how-to-fix.png

or is it anything wrong with the source files

https://drive.google.com/open?id=14hhPkvjxSaou5MGwboNdNHkr5QyuXabr

 

here's the dff so you can check it out (well, if you care)

https://drive.google.com/open?id=1yMNuEV7gaJ8uaoZw0SuQR3XRgLmjOgkL

 

tia

Share this post


Link to post
Share on other sites
xiaogui319
21 minutes ago, a bad day said:

hey can anyone help me? im pretty new to this, and i tried to import a csgo gun into 3ds. i then exported it without changing the export settings then i imported it back into 3ds, and it came out huge. did i miss a step here?

the red wireframe is the exported DFF, the highlighted model is the raw file (.smd)

huge-model-how-to-fix.png

or is it anything wrong with the source files

https://drive.google.com/open?id=14hhPkvjxSaou5MGwboNdNHkr5QyuXabr

 

here's the dff so you can check it out (well, if you care)

https://drive.google.com/open?id=1yMNuEV7gaJ8uaoZw0SuQR3XRgLmjOgkL

 

tia

Please use Kam‘s max Scripts 2009 version

https://www.gtagarage.com/mods/show.php?id=9172

 

Or attach the old vertex

https://drive.google.com/open?id=1xMEpFmX--HJmrV-8x4cKxKo79m4RCcS1

  • Like 1

Share this post


Link to post
Share on other sites
Walter Clements
11 hours ago, xiaogui319 said:

i installed the 2009 version and it partially worked. the size is perfect, but the rotation is off.

3dsmax-tg-OGa-HWutd.png

also, with that dff you sent, it had some cubes (i don't know what those are, and what you are talking about, what are old vertices?)

i imported them to gta sa and the gun just disappeared, plus, I can run!

I then deleted the cubes and the gun appeared in-game, but it's black, and the rotation didn't get saved too.

Grand-Theft-Auto-San-Andreas-Screenshot-

the textures were working a while ago, though, and now it all just got to this point.

Share this post


Link to post
Share on other sites
xiaogui319
Posted (edited)
15 hours ago, a bad day said:

我安装了 2009 版本,它部分工作。The size is perfect but the rotation is closed.

3dsmax-tg-OGa-HWutd.png

In addition, with the dff you sent, it has some cubes (I don't know what those are, what are you talking about, what are the old vertices?)

I imported them into gta sa, and the gun disappeared. In addition, I can run away!

Then I deleted the cube and the gun appeared in the game, but it was black and the rotation was not saved.

Grand-Theft-Auto-San-Andreas-Screenshot-

However, texture began to work some time ago, and now everything is at this point.

The format I exported is VC

The original SA AK model,

Import into 3ds, delete the extra vertices, leaving only one vertex to attach to the ak model

Edited by xiaogui319

Share this post


Link to post
Share on other sites
Walter Clements
13 hours ago, xiaogui319 said:

The format I exported is VC

The original SA AK model,

Import into 3ds, delete the extra vertices, leaving only one vertex to attach to the ak model

I did that

3dsmaxasdasdasdasd.png

And now, the rotation is still not right, and the gun just became grey lol

grey-ak-hey-at-least-it-isn-t-pure-black

i dont think there is something wrong with the textures, because it worked fine before. it is definitely the model

Share this post


Link to post
Share on other sites
Tut98

The reason you're attaching the new model to an existing model is resetting the scale.

 

The right way is using 'Reset xForm' or resetting scale in Hierarchy panel. Doing the former method may also mess up materials and normals. 

https://knowledge.autodesk.com/support/3ds-max/learn-explore/caas/CloudHelp/cloudhelp/2016/ENU/3DSMax/files/GUID-3517352E-F61C-4713-B1A7-E46D297A1DFA-htm.html

 

Simply create a new standard material and assign your rifle texture to the bitmap slot. As for the rotation, load in AK47 from gta3.img if you want to mimic the exact rotation.

  • Like 2

Share this post


Link to post
Share on other sites
Walter Clements
Posted (edited)
On 4/7/2020 at 5:04 PM, Tut Greco said:

The reason you're attaching the new model to an existing model is resetting the scale.

 

The right way is using 'Reset xForm' or resetting scale in Hierarchy panel. Doing the former method may also mess up materials and normals. 

https://knowledge.autodesk.com/support/3ds-max/learn-explore/caas/CloudHelp/cloudhelp/2016/ENU/3DSMax/files/GUID-3517352E-F61C-4713-B1A7-E46D297A1DFA-htm.html

 

Simply create a new standard material and assign your rifle texture to the bitmap slot. As for the rotation, load in AK47 from gta3.img if you want to mimic the exact rotation.

Okay, I did the resetxform, and the scale and rotations were perfect.

The position is still not right though, also, are the materials supposed to look like this?

XFhmRbp.png

Edited by a bad day
I quite don't get the materials part.
  • Like 1

Share this post


Link to post
Share on other sites
sigit1994

how do i install this script to my 3ds max?

Share this post


Link to post
Share on other sites
Walter Clements
3 hours ago, sigit1994 said:

how do i install this script to my 3ds max?

simply copy the scripts folder to your 3ds max directory.

Share this post


Link to post
Share on other sites
sigit1994

owh owh... i found it. thanks 😀

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.