Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Cayo Perico Heist
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA VI

      1. St. Andrews Cathedral
    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. Announcements

    2. Support

    3. Suggestions

[REL] KAM's GTA Scripts (2018) / UPD: 31.05.2020 /


gold_fish

Recommended Posts

What has happened to the export of PEDs? when trying to export a PED (riggued), it does not export correctly (before with the corresponding steps it was perfectly done), now the exported peds are in lateral position and without any animation.

 

Has a new option been added? (box to mark) or is something else...

Link to post
Share on other sites
gold_fish
1 hour ago, xelono said:

What has happened to the export of PEDs? when trying to export a PED (riggued), it does not export correctly (before with the corresponding steps it was perfectly done), now the exported peds are in lateral position and without any animation.

 

Has a new option been added? (box to mark) or is something else...

check please the export as shown in the screenshot, import the standard skin, then immediately export

 

2QYEW.jpg

Edited by gold_fish
  • Like 1
Link to post
Share on other sites
1 hour ago, gold_fish said:

verifique la exportación como se muestra en la captura de pantalla, importe la máscara estándar y luego exporte inmediatamente

 

2QYEW.jpg

Thanks! :)

Link to post
Share on other sites
hansomegeorge

Hello sir I have a small problem. You see I'm trying to replace cj's head with another model head and I attached the mesh to the head-bone and when I hit export to skin/bones I keep receiving a message saying "Error: Skin Export" if you have any solutions let me know please thanks.

 

And one other thing. When making or replacing a model do you have to design your own bones? A week ago i was trying to replace cj's cornrows hairstyle with my custom model and try to wear it in the game to see if it works so i wouldn't have to replace his head but it would always crash. Come to find out, when I import a dff model I've made changes to, I just get the mesh and several green boxes where I assume the bones are suppose to be. Do you think it might be because of that or something else? It'll mean the world to me if you or anyone at least share me a link or something that may help out since I know you're probably very busy and can't read everyone's comments. Thank you so much for this great tool and I hope to hear from you anytime soon, take care sir.

Link to post
Share on other sites
gold_fish
13 hours ago, hansomegeorge said:

Hello sir I have a small problem. You see I'm trying to replace cj's head with another model head and I attached the mesh to the head-bone and when I hit export to skin/bones I keep receiving a message saying "Error: Skin Export" if you have any solutions let me know please thanks.

  

And one other thing. When making or replacing a model do you have to design your own bones? A week ago i was trying to replace cj's cornrows hairstyle with my custom model and try to wear it in the game to see if it works so i wouldn't have to replace his head but it would always crash. Come to find out, when I import a dff model I've made changes to, I just get the mesh and several green boxes where I assume the bones are suppose to be. Do you think it might be because of that or something else? It'll mean the world to me if you or anyone at least share me a link or something that may help out since I know you're probably very busy and can't read everyone's comments. Thank you so much for this great tool and I hope to hear from you anytime soon, take care sir. 

I admit honestly I have never worked with skins and even more so with the skin of the main character, so maybe the script is not fully adapted for exporting skins, in extreme cases, try old versions of scripts

  • Like 1
Link to post
Share on other sites
hansomegeorge
4 hours ago, gold_fish said:

I admit honestly I have never worked with skins and even more so with the skin of the main character, so maybe the script is not fully adapted for exporting skins, in extreme cases, try old versions of scripts

Ah I see well honestly thank you for taking the time out of your busy day to reply to me it means a lot haha. 

Link to post
Share on other sites
On 2/6/2019 at 3:21 AM, hansomegeorge said:

Hello sir I have a small problem. You see I'm trying to replace cj's head with another model head and I attached the mesh to the head-bone and when I hit export to skin/bones I keep receiving a message saying "Error: Skin Export" if you have any solutions let me know please thanks.

 

And one other thing. When making or replacing a model do you have to design your own bones? A week ago i was trying to replace cj's cornrows hairstyle with my custom model and try to wear it in the game to see if it works so i wouldn't have to replace his head but it would always crash. Come to find out, when I import a dff model I've made changes to, I just get the mesh and several green boxes where I assume the bones are suppose to be. Do you think it might be because of that or something else? It'll mean the world to me if you or anyone at least share me a link or something that may help out since I know you're probably very busy and can't read everyone's comments. Thank you so much for this great tool and I hope to hear from you anytime soon, take care sir.

Have you pressed that "skin the character" button when importing?

Link to post
Share on other sites
29 minutes ago, NoobDude- said:

Does it work well in older versions of 3ds max? I have 2016.

Yeah, man

On 3/24/2018 at 8:41 PM, gold_fish said:

 

This script was tested in 3ds max 2009 and 2012 and 2017.

Link to post
Share on other sites
gold_fish
8 hours ago, NoobDude- said:

Does it work well in older versions of 3ds max? I have 2016. 

I recommend using 2009

 

Link to post
Share on other sites
hansomegeorge
On ‎2‎/‎7‎/‎2019 at 10:01 AM, cj2000 said:

Have you pressed that "skin the character" button when importing?

No I don't believe so.

Link to post
Share on other sites
  • 2 months later...
Tut98

Oi @gold_fish are bump maps and dual texture supported ingame without scripts/plugins? If so, how exactly do I make it work ingame? I might be using the incorrect blend settings.

PS. is the dual texture method allowing you to paint with vertex alpha like this? If not, do you know how to use this method (if possible)

 

Link to post
Share on other sites
djdarko

I'm having trouble exporting my files with this. Everything seems to go fine, resulting in a dff with 3 chunks with bones that look correct, but when I try to apply it to the game it crashes right after the loading screen.

 

Here are the settings I'm using when exporting (note, these are shoes I'm exporting)

https://imgur.com/h4hZkFk

Link to post
Share on other sites
gold_fish

@Tut Greco gta sa by default supports bump maps and double textures  without additional plug-ins.

You just need to create a GTA material and specify the textures in the appropriate type of material effect, then export to dff and add textures to the txd

All "gta material" settings are similar to "RW material".

 

@djdarko Do you get errors when importing skins?

Edited by gold_fish
  • Like 1
Link to post
Share on other sites
djdarko
2 hours ago, gold_fish said:

@djdarko Do you get errors when importing skins?

No, I figured it out, I believe it was because I didn't have "Normals" checked.

  • Like 1
Link to post
Share on other sites

hmm, which material effect would I have to mess with to achieve the effects i am looking for? do you have some documentation on what each of the effects are for, and what you can achieve with them? this would really help. thanks in advance!

@gold_fish

Link to post
Share on other sites
gold_fish

@Tut Greco  all material effects except the normal map work as standard without plug-ins

jSJCAtCus-I.jpg

  • Like 1
Link to post
Share on other sites

i can't seem to get either dual map nor bump map to show anything. with bump map I am using a black/white image similar to that of the vehicle specular image. with diffuse i am using a brick texture.

Link to post
Share on other sites
gold_fish
8 hours ago, Tut Greco said:

i can't seem to get either dual map nor bump map to show anything. with bump map I am using a black/white image similar to that of the vehicle specular image. with diffuse i am using a brick texture.

Show with what settings in the script you export the model and show the material settings and show the export log (f11)

Link to post
Share on other sites
AdamBryant95

Hello, i have little problem about export. I donwloaded a Crown Victoria modell from GTA inside and Import it. When im done with the model i export:

 JO1MnzT.png

 

When i import again the saved model im disappointed.

efatqhF.png

 

I don't know what im done wrong, please help me.

Link to post
Share on other sites
gold_fish
1 hour ago, AdamBryant95 said:

Hello, i have little problem about export. I donwloaded a Crown Victoria modell from GTA inside and Import it. When im done with the model i export: 

 JO1MnzT.png

 

When i import again the saved model im disappointed.

efatqhF.png

 

I don't know what im done wrong, please help me.

1) select all vertices -> weld 0.001

2) select all polygons -> smoothing groups -> auto

Edited by gold_fish
Link to post
Share on other sites
  • 3 weeks later...

 

Hi, I have a problem Whenever I try to flip a part of a skin, when I export it, the part that was flipped returns to its normal shape

Link to post
Share on other sites
  • 4 weeks later...
On 3/24/2018 at 5:41 PM, gold_fish said:

This script was tested in 3ds max 2009 and 2012 and 2017.

Verified 100% working on 3DS Max 2020 after several weeks of testing

Link to post
Share on other sites
  • 1 month later...

Hey Goldfish, 

 

I have used your script to export models on numerous occasions. Lately I've been getting issues with faces gluing into other faces, as if something is corrupted on export. I have no idea why this occurs. Below is an example of the issue. 

Skrmbillede_5500.png

Link to post
Share on other sites
  • 3 weeks later...
gold_fish
On 8/12/2019 at 12:46 AM, Tut Greco said:

Hey Goldfish, 

 

I have used your script to export models on numerous occasions. Lately I've been getting issues with faces gluing into other faces, as if something is corrupted on export. I have no idea why this occurs. Below is an example of the issue. 

Skrmbillede_5500.png

is this bug present in older versions of 3DMax?

Link to post
Share on other sites

Yeah I was told it's because I am running a version of 2017. I wasn't aware that your script depends on items in 2018+. Thanks for your reply though.

Link to post
Share on other sites
gold_fish

-----------------------------------------------------------------------------------------------------

UPDATE

v 0.3.1

- added compatibility with MAP IO

- small fixes

download https://drive.google.com/open?id=1hjKlZzNjxilEBfDGrSIN2iJF-1xSwVxU

 

-----------------------------------------------------------------------------------------------------

Attention

After you import the map you may have a bug with the camera in 3D max. This is due to 2dfx which are located at a large distance from the model. You need to manually remove them. (go to display mode on the side, press Z, select all models, click Ctrl+I, after Delete )

Edited by gold_fish
  • Like 2
Link to post
Share on other sites
  • 2 weeks later...

It looks like the instructions are unclear, it doesnt work.
I select GTA Material (f), select color map "color.png", material effect "DUAL MAP" and then i select a dual map bitmap in the dual map settings, but the model gets exported with no dual map.
TXD Workshop shows that there is only 1 texture name in the model file, something must be wrong or forgotten.

 

[1] bsp_console1
     Verts: 112  Tris: 64
     - Light
     - UV1
     - [Warning] Vertex Color NOT EXIST. Defolt: 80
     - [Warning] Night Vertex Color NOT EXIST. Defolt: 10
     write data..
     - Dual map
     data writed
file:C:\Users\Einheit-101\Desktop\bsp_console1.dff exported!

 

Edited by Einheit-101
Link to post
Share on other sites
On 9/18/2019 at 12:16 AM, Einheit-101 said:

It looks like the instructions are unclear, it doesnt work.
I select GTA Material (f), select color map "color.png", material effect "DUAL MAP" and then i select a dual map bitmap in the dual map settings, but the model gets exported with no dual map.
TXD Workshop shows that there is only 1 texture name in the model file, something must be wrong or forgotten.

 

[1] bsp_console1
     Verts: 112  Tris: 64
     - Light
     - UV1
     - [Warning] Vertex Color NOT EXIST. Defolt: 80
     - [Warning] Night Vertex Color NOT EXIST. Defolt: 10
     write data..
     - Dual map
     data writed
file:C:\Users\Einheit-101\Desktop\bsp_console1.dff exported!

 

What TXD Workshop shows, has nothing to say, the tool is buggy and as far I know can´t even handle textures from MatFX.  If you really want to check how the "DUAL MAP" was exported, use RWAnalyze and look if there is MaterialEffectPLG section there with effect value of 4, which stands for "DUAL MAP".

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.