Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Cayo Perico Heist
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

      1. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

      1. GTANet 20th Anniversary
    2. Support

    3. Suggestions

[REL] KAM's GTA Scripts (2018) / UPD: 31.05.2020 /


gold_fish

Recommended Posts

GamingWithJumbo
On 4/20/2021 at 4:58 AM, Tut98 said:

Is it a GTA object or a custom model?

What type of DFF is it, a character model?

unknown.png

Link to post
Share on other sites
On 4/20/2021 at 5:18 AM, GamingWithJumbo said:

a character model

also can't seem to texture map io, i have every texture converted to png and everything, but still

Is it custom or default?

Some custom models exported using different plugins can cause issues. It could also be it's been locked. If you view the file in rwanalyze, does it look like a dff structure you'd see on a Rockstar dff?

 

Ok, just saw the pic - I assume it's default?

Have you tried orbiting your camera around the object? Maybe its normals are facing away from the camera so it can't be seen? If you click 7 on your keyboard, do you see any triangles/polygons statistics?

If you try importing using a different importer, does it show?

Have you tried resetting your scene and then importing again?

Edited by Tut98
Link to post
Share on other sites
GamingWithJumbo
9 hours ago, Tut98 said:

Is it custom or default?

Some custom models exported using different plugins can cause issues. It could also be it's been locked. If you view the file in rwanalyze, does it look like a dff structure you'd see on a Rockstar dff?

 

Ok, just saw the pic - I assume it's default?

Have you tried orbiting your camera around the object? Maybe its normals are facing away from the camera so it can't be seen? If you click 7 on your keyboard, do you see any triangles/polygons statistics?

If you try importing using a different importer, does it show?

Have you tried resetting your scene and then importing again?

i'll try reinstalling 3ds max, but yes it's a default model

orbiting the camera doesn't reveal anything new

there are no normals

and yes it does show if i try importing it in blender for example

Link to post
Share on other sites
GamingWithJumbo
13 hours ago, Tut98 said:

Is it custom or default?

Some custom models exported using different plugins can cause issues. It could also be it's been locked. If you view the file in rwanalyze, does it look like a dff structure you'd see on a Rockstar dff?

 

Ok, just saw the pic - I assume it's default?

Have you tried orbiting your camera around the object? Maybe its normals are facing away from the camera so it can't be seen? If you click 7 on your keyboard, do you see any triangles/polygons statistics?

If you try importing using a different importer, does it show?

Have you tried resetting your scene and then importing again?

unknown.png

still doesn't work, this is 2020

edit :and yes, tapping 7 on the keyboard reveals polygon statistics

 

Edited by GamingWithJumbo
Link to post
Share on other sites

Ok, I think it's possible it's missing textures so is invisible.

If you open material editor and click the eyedropper icon, then click the model Root, check how the material looks. If it's missing a texture, locate it and add it into the texture or bitmap slot.

Link to post
Share on other sites
GamingWithJumbo
6 hours ago, Tut98 said:

Ok, I think it's possible it's missing textures so is invisible.

If you open material editor and click the eyedropper icon, then click the model Root, check how the material looks. If it's missing a texture, locate it and add it into the texture or bitmap slot.

i'm not sure if i have done it correctly, but still

unknown.png

Link to post
Share on other sites
GamingWithJumbo
On 3/29/2018 at 2:24 PM, Vadim M. said:

Thanks for these tools!

 

I know about one pesky bug with Vice City ped models. If I want to use "IFP IO", the model doesn't show up. Is it possible to fix?

KQW1sdFm.png

this is, probably the same issue i too have

Link to post
Share on other sites
GamingWithJumbo

so i got it to load via some other dff importer, but now i can't apply any animations to it

unknown.png

there aren't any keyframes, any idea why?

Link to post
Share on other sites
17 hours ago, Tut98 said:

Check that you've exported normals. Do not export vertex colors.

thanks its worked!!

Link to post
Share on other sites
GamingWithJumbo

unknown.png

 

i even tried using ps2 dff files and convert them using librwgta but to no avail as i had seen someone on youtube do this

unknown.png

 

either i'm dumb or it's just that this script doesn't work

 

 

edit: someone else tried on 3ds max 2010

 

unknown.png

 

so now i know it's not only me

Edited by GamingWithJumbo
Link to post
Share on other sites
GamingWithJumbo

i found out something

unknown.png

 

the pelvis bone (actually all the bones under the pelvis) are infinite miles away from the origin

and i am unable to change them to 0 because it keeps on resetting to 10000000

does anyone have a workaround for this?

 

edit: i tried using some commands in the listener, and after changing them to 0, there still is no armature

Edited by GamingWithJumbo
Link to post
Share on other sites

Does anyone know why some models can't be changed?

I have a weapon model that i wanna edit but for some reason i cannot seem to change its position or scale the model, whenever i export it the model remains the same despite editing it previously (i can mess with vertex, faces, merge another model and edit anything else, but scaling and moving is not working) .

Link to post
Share on other sites
On 5/5/2021 at 9:29 AM, Bane712 said:

Does anyone know why some models can't be changed?

I have a weapon model that i wanna edit but for some reason i cannot seem to change its position or scale the model, whenever i export it the model remains the same despite editing it previously (i can mess with vertex, faces, merge another model and edit anything else, but scaling and moving is not working) .

Weapon model position depends on the model's pivot.

After adjusting pivot, rotation, scale, you will have to reset their values back to default. You can do so through Hierarchy panel -> reset transforms/scale. You can also add a Reset xForm modifier and apply it to the model.

Link to post
Share on other sites
On 5/7/2021 at 6:41 AM, Tut98 said:

Weapon model position depends on the model's pivot.

After adjusting pivot, rotation, scale, you will have to reset their values back to default. You can do so through Hierarchy panel -> reset transforms/scale. You can also add a Reset xForm modifier and apply it to the model.

Oh, i will make sure to check that option, thank you very much.

Link to post
Share on other sites
15 hours ago, El'azar said:

Whats best options to use in vertex settings for exporting skins?

I'm not sure what you mean by vertex settings.

Link to post
Share on other sites
3 hours ago, Tut98 said:

I'm not sure what you mean by vertex settings.

vertex color

Link to post
Share on other sites

Skins do not use vertex colors, only normals - for buildings, your export settings should be Day & Night and I believe 'use vertex alpha' too - it seems to add some extra vertex colors (not necessarily alpha) if I remember correctly.

Link to post
Share on other sites

After I try mass exporting models I get the following error:

 

More than 1 Hierarchy links were selected! Only 1 is allowed in dff.

Link to post
Share on other sites
3 hours ago, firedihm said:

After I try mass exporting models I get the following error:

 

More than 1 Hierarchy links were selected! Only 1 is allowed in dff.

Do your models have components? That could be a reason though I'm not sure.

If you have multiple models named the same that might also be a problem.

Link to post
Share on other sites
1 hour ago, Tut98 said:

Do your models have components? That could be a reason though I'm not sure.

If you have multiple models named the same that might also be a problem.

Yeah, they have dummies attached. I find it weird though that script cannot export multiple hierarchies like that

Link to post
Share on other sites
On 5/19/2021 at 7:05 PM, firedihm said:

Yeah, they have dummies attached. I find it weird though that script cannot export multiple hierarchies like that

You cannot export several hierarchies at once, select the entire hierarchy of models, or one model from the hierarchy

Link to post
Share on other sites
Posted (edited)
On 4/27/2021 at 11:20 AM, arminnas said:

hello again

everything was fine before I close 3ds max! after that every time I want to open 3ds max I get this error

http://www.imagebam.com/image/c904a31375949772

http://www.imagebam.com/image/1be07a1375949782

 

In my 2021 version, everything is fine, I recommend that you definitely run 3d max with administrator rights, it is also advisable to install 3d max it not on the system partition of the disk (C), but on another

 

Search Google for how to disable UAC through the registry, and such problems will disappear forever.

Edited by gold_fish
Link to post
Share on other sites
  • 2 weeks later...
On 5/24/2021 at 5:55 PM, gold_fish said:

 

In my 2021 version, everything is fine, I recommend that you definitely run 3d max with administrator rights, it is also advisable to install 3d max it not on the system partition of the disk (C), but on another

 

Search Google for how to disable UAC through the registry, and such problems will disappear forever.

I reinstalled 3ds max and every things goes fine.

thanks for help:colgate:

Link to post
Share on other sites
  • 2 weeks later...

The vertex color on models all messed up after been imported to 3ds max 2022.

Edited by playbour
Link to post
Share on other sites
Posted (edited)
On 6/13/2021 at 10:14 AM, playbour said:

The vertex color on models all messed up after been imported to 3ds max 2022.

 


This problem is present in newer versions. Check if the bug remains in the game if you immediately export the model to dff? I also recommend using 3ds max version below 2014

Edited by gold_fish
Link to post
Share on other sites
On 6/15/2021 at 9:23 PM, gold_fish said:

 


This problem is present in newer versions. Check if the bug remains in the game if you immediately export the model to dff? I also recommend using 3ds max version below 2014

Thank you for your reply. The result of the test is this: if the imported model exported immediately, the vertex colours on it would be correct. But after any changes made to the model, the vertex colours would be messed up in the game.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 2 Users Currently Viewing
    1 member, 0 Anonymous, 1 Guest

    • xiaogui319
×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.