Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. Los Santos Tuners
      2. Updates
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Blood Money
      2. Frontier Pursuits
      3. Find Lobbies & Outlaws
      4. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

      1. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

      1. GTANet 20th Anniversary
    2. Support

    3. Suggestions

[REL] KAM's GTA Scripts (2018) / UPD: 31.05.2020 /


gold_fish
 Share

Recommended Posts

@gold_fishunfortunately. but, when i run the controller.ms manually it worked

 

anyways, where the envelope helper?and why MEd can't load custom model with ur script?

 

Link to comment
Share on other sites

@gold_fish

 

Your script works on my 3ds Max though - no errors (starts GTA Tools menu automatically no problems).

2021.2, trial version (not cracked).

Maybe he needs to update 3DS Max 2021 if he didn't.

Edited by Zeneric
Link to comment
Share on other sites

1 hour ago, F_act said:

@gold_fishunfortunately. but, when i run the controller.ms manually it worked

 

 

Have you tried running 3dmax with administrator rights?

Link to comment
Share on other sites

 

Imported thousands of IPL lines (default and custom) on 3DS Max (for Project-Props) with your script. Works great. Makes the workflow easier/faster. The issue is exporting thousands of IPL lines all at once with default/custom ids inputted loaded from IDE. Imported IDE with kam's script included with your map IO. It inputted the ipl lines from IDE into objects' properties. But I'm unable to export the ipl lines out - generated IPL file came up empty. Am I missing something?

sbavuk.png

Edited by Zeneric
Link to comment
Share on other sites

8 hours ago, gold_fish said:

Have you tried running 3dmax with administrator rights?

yes, i run 3dsmax with administrator.

but, isn't solution to fix it 😢

Link to comment
Share on other sites

DapatkanCan I create a LOD object by Adding flags like in San Andreas Original LOD Which Has Flag on every IPL and Stream_IPL

Link to comment
Share on other sites

Hey, the IPL import does not work, I have it going to a DFF Path, and the DFFS are in there. The correct .ipl is used as well. 

r0x01QR.png

Happens every time :( 

 

8VPgIp4.png

Edited by deltaCJ
Link to comment
Share on other sites

Hey @deltaCJ can you check maxscript listener and see its output. It should say which DFF it's looking for. I'm not sure what IPL you're trying to import, but some DFF models are located in other IMG archives such as gta_int.img or cutscene.img.

Possibly try restarting Max.

If not resolved you're welcome to send the files over. PM is also fine.

Link to comment
Share on other sites

I exported the correct models from the IPL LAe2.ipl:

 

cine_mark_lae2,

cineblock1_LAe2,

autoshpblok_lae2,

 

And I made sure these are defined in the .IPL

Also I thought the DFF path meant to the path of the already exported DFFs, we're supposed to be redirecting it to the game directory? 

Kams never did that?

Link to comment
Share on other sites

5 hours ago, deltaCJ said:

I exported the correct models from the IPL LAe2.ipl:

 

cine_mark_lae2,

cineblock1_LAe2,

autoshpblok_lae2,

 

And I made sure these are defined in the .IPL

Also I thought the DFF path meant to the path of the already exported DFFs, we're supposed to be redirecting it to the game directory? 

Kams never did that?

Wrong IPL?

Maybe you need stream IPL's (lae2 stream 2 ipl obtainable from gta3.img - see top left corner of the picture).

44o484.png

Edited by Zeneric
Link to comment
Share on other sites

4 hours ago, deltaCJ said:

Also @gold_fish It seems clumps don't work?

It always imports random clumps for player models and doesn't ask for which clump to import

Probably bugged (I remember trying it too and couldn't select one of three clumps). You can try exporting a clump outta the 3 clumps dff via rw analyze into a new dff and have kam's import that clump / new dff only.

Link to comment
Share on other sites

6 hours ago, deltaCJ said:

Also @gold_fish It seems clumps don't work?

It always imports random clumps for player models and doesn't ask for which clump to import

Are you trying to import models with multiclumps?

Do you import these models in bulk or one model at a time? When you exporting a multiclump, the clumps button should be activated in the script interface, with which you can export each clump separately, as it was implemented in the old version of kam scripts

Edited by gold_fish
Link to comment
Share on other sites

Ah yes it seems @Zeneric is right, using RWAnalyze is the right way to go, but using Kam's original scripts also helped.

And Yes I am trying to import multiclump objects like player clothes, but I imported "vest.dff" by itself and it just gives me the ripped model. 

Thanks guys!

Link to comment
Share on other sites

  • 2 weeks later...
43 minutes ago, F_act said:

@gold_fish where the envelope helper tool?

 

 

Sorry, these utilities were in the old script, during the update I forgot to add them, besides, I didn't know what these helpers were for at all.
You can find these scripts in the old kams scripts in the directory

\\GTA_Tools\\GTA_Helper_v31.ms

\\GTA_Tools\\Kam_envelope_tools.ms

 

besides helping in the export of animation / skinning, do they still play a significant role?

Link to comment
Share on other sites

10 hours ago, gold_fish said:

 

Sorry, these utilities were in the old script, during the update I forgot to add them, besides, I didn't know what these helpers were for at all.
You can find these scripts in the old kams scripts in the directory

\\GTA_Tools\\GTA_Helper_v31.ms

\\GTA_Tools\\Kam_envelope_tools.ms

 

besides helping in the export of animation / skinning, do they still play a significant role?

I was wondering the same thing, I tried using the Envelope Helpers and there is no help at all about how to use them, what it's for, etc. 

 

Kams didn't really specify other than "Helps with Envelopes" which is basically in the name.

 

Does anybody know what they do? And if you do please let me know because I could use it 😛

Other than that, what's the purpose of the helpers?

Link to comment
Share on other sites

 

 

12 hours ago, gold_fish said:

Sorry, these utilities were in the old script, during the update I forgot to add them, besides, I didn't know what these helpers were for at all.
You can find these scripts in the old kams scripts in the directory

\\GTA_Tools\\GTA_Helper_v31.ms

\\GTA_Tools\\Kam_envelope_tools.ms

its worked. i don't think those script can run manualy before. XD

 

12 hours ago, gold_fish said:

besides helping in the export of animation / skinning, do they still play a significant role?

what about the object 2 dummy tool?its help to creating/converting a vehicle.maybe usefull  

Link to comment
Share on other sites

What happens to the position of the "dummy root" of the vehicles when exporting? After exporting they are always putting me at 0,0,0.
Is there a way to solve this, disable the "repositioning" function of the pivots?

I do not want my pivot in the 0,0,0 coordinates, mainly for a matter of adjustments regarding how the car is driving.

Link to comment
Share on other sites

Hello. I tried to make a col file out of a .dff model using Col IO but I don't get any faces/vertices in return. Am I doing something wrong?

The whole collision is empty. Using 3ds Max 2009 by the way.

https://imgur.com/a/8XaDPza

https://imgur.com/a/9FcCI3p

Edited by Splatty
Forgot sec screenshot
Link to comment
Share on other sites

On 11/7/2020 at 7:48 AM, Splatty said:

Hello. I tried to make a col file out of a .dff model using Col IO but I don't get any faces/vertices in return. Am I doing something wrong?

The whole collision is empty. Using 3ds Max 2009 by the way.

https://imgur.com/a/8XaDPza

https://imgur.com/a/9FcCI3p

Hi

 

To export a collision mesh you need to make sure it's either editable poly or editable mesh, else it cannot be selected. Your teapot is a primitive mesh and therefore isn't a valid collision mesh.

Link to comment
Share on other sites

6 hours ago, Tut98 said:

Hi

 

To export a collision mesh you need to make sure it's either editable poly or editable mesh, else it cannot be selected. Your teapot is a primitive mesh and therefore isn't a valid collision mesh.

Hello.

I tried converting the mesh to an Editable Mesh for the first attempt and to an Editable Poly for the second attempt before I exported the .col file but I still get the same result.

Edited by Splatty
Link to comment
Share on other sites

2 hours ago, Splatty said:

Hello.

I tried converting the mesh to an Editable Mesh for the first attempt and to an Editable Poly for the second attempt before I exported the .col file but I still get the same result.

It should look as such. Making sure that the collision mesh is selected both in the IO export setting and in viewport.

unknown.png?width=846&height=468

Link to comment
Share on other sites

1 hour ago, Tut98 said:

It should look as such. Making sure that the collision mesh is selected both in the IO export setting and in viewport.

unknown.png?width=846&height=468

I finally knew why I wasn't getting any collision! It turns out that I haven't selected the mesh from the export settings! After doing so, I got the collision I needed. Thank you!

xZnvOGi.png

Link to comment
Share on other sites

How are you! In my previous comment I expressed myself badly, sorry for that, I already deleted it. I was simply overwhelmed by the limitations that this great add-on currently has.

Getting to the point, as CleytonGames commented, the Script still contains some errors, I will comment on the one I found.

Well, after a while without achieving the results I wanted with the smoothing groups, I decided to manually adjust the smoothing using the normals modifier, I added a couple of soft curves leaving a slightly noticeable cut (At the junction of two parts of my vehicle, as you know Kams breaks some vertices in the import of a model), I took my whole model, I added the collision and exported, I did not notice any changes, I thought I had to keep adjusting, I was a few hours breaking my head, this It had never happened to me with the Original Kams, I thought I was doing something wrong, until I decided to export the model with the Saggeman plugin, FINALLY! I noticed the difference, I finally understood that this version of the Kams Scripts is not exporting the information of the normal ones. They should fix it, or if that's the case, someone explain to me how I can export the "changes in normals (Vertex Normal)".

Link to comment
Share on other sites

Not to derail the thread but if you want to import original smoothing groups and then export flawlessly, use The Hero's plugin. You can set it to read explicit normals on import, or alternatively have it autosmooth everything at X angle (default 45).

 

Neither Kam's script versions are fully functional in terms of normals. That's where The Hero's plugin works best.

 

Using Kam's script you'll have to weld vertices at 0,001 threshold (if in meter units) in order to modify smoothing groups.

Link to comment
Share on other sites

Even after welding verts, and re-adding smoothing groups back - normals remind broken (I always have to use SiniTools to rebuild meshes to repair broken normals).

 

You could try importing dff with The Hero's plugin and, on 3ds max, convert the dff to Kam's with The Hero's script called "GTA Helper" (that comes with the plugin), keeping smoothing groups/normals intact (and verts not broken).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.