Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. Los Santos Summer Special
      2. The Diamond Casino Heist
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA VI

      1. St. Andrews Cathedral
    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. Announcements

    2. Support

    3. Suggestions

gold_fish

[REL] KAM's GTA Scripts (2018) / UPD: 31.05.2020 /

Recommended Posts

lpgunit

I've been trying to import DFFs from the Re: Liberty City Stories mod as per a request from a dude over at discord, but while the bones and other stuff are (nominally) imported, I end up with this error:

Whole-screen.png

 

Here are the links to the DFF files in question:

https://www23.zippyshare.com/v/zZ6UJ50Y/file.html
https://www23.zippyshare.com/v/OsI2VSYI/file.html

Share this post


Link to post
Share on other sites
Meng Fan
Posted (edited)

e

 

Edited by Meng Fan
Typo
  • excuseme 1

Share this post


Link to post
Share on other sites
SKDrub

Pls Help

Share this post


Link to post
Share on other sites
RestractPrime
4 hours ago, SKDrub said:

Pls Help

you breach the size of bondary , the limit bondary is that sphere , make sure your object size is scaled down just fit inside that bondary.

Share this post


Link to post
Share on other sites
SKDrub
28 minutes ago, RestractPrime said:

you breach the size of bondary , the limit bondary is that sphere , make sure your object size is scaled down just fit inside that bondary.

I used your method but I keep passing them on :(, What I do is put them smaller in 3ds max or directly from sketchup?

Pd: your method worked... the cabbage doesn't bug but when I play I transfer them

Share this post


Link to post
Share on other sites
gold_fish
Posted (edited)
19 hours ago, SKDrub said:

Pls Help

use reset XForm in 3ds max before export

I also recommend exporting the collision via cst format (you will find this option in the GTA tools menu)  and importing it into the COL Editor

 

Edited by gold_fish
  • Like 2

Share this post


Link to post
Share on other sites
SKDrub
2 hours ago, gold_fish said:

use reset XForm in 3ds max before export

I also recommend exporting the collision via cst format (you will find this option in the GTA tools menu)  and importing it into the COL Editor

 

Thanks So Much!!!!!

17 hours ago, RestractPrime said:

you breach the size of bondary , the limit bondary is that sphere , make sure your object size is scaled down just fit inside that bondary.

And Thanks So Much x2

 

Share this post


Link to post
Share on other sites
Meng Fan
2 hours ago, gold_fish said:

use reset XForm in 3ds max before export

I also recommend exporting the collision via cst format (you will find this option in the GTA tools menu)  and importing it into the COL Editor

 

How to fix the BUG of GTA3 ghost town building explosion model?

Share this post


Link to post
Share on other sites
SKDrub

Someone knows how I can create a LOD.. and by the way if someone knows how to put the window lights on my 3d model Thank you

Share this post


Link to post
Share on other sites
Mr_White97

When pressing "show texture" it is not shown, I already added the path where the others are. the ones you see add them manually...

 

Spoiler

5jIOhSE.png

 

Also when I export a car with this tool it is exported but without any brightness

 

 

Edited by Mr_White97

Share this post


Link to post
Share on other sites
Tut98
7 hours ago, Mr_White97 said:

When pressing "show texture" it is not shown, I already added the path where the others are. the ones you see add them manually...

 

  Hide contents

5jIOhSE.png

 

Also when I export a car with this tool it is exported but without any brightness

 

 

I think that's a shading issue. On the upper left of your viewport where it says "Default shading" please set it to "Facet" or "Flat shading" and see if you get expected results.

 

The car brightness issue could be a material setting. Please show us your vehicle surface material and your DFF export settings.

Share this post


Link to post
Share on other sites
Zeneric

Reporting a possible bug:

I think UV Animation is broken because I wasn't able to get it working in game (crashes everytime) but I was able to with the original Kam's script.

 

Tried on both 3DS Max 2020 and 2021.

Edited by Zeneric
  • Like 1

Share this post


Link to post
Share on other sites
deltaCJ
9 hours ago, Zeneric said:

Reporting a possible bug:

I think UV Animation is broken because I wasn't able to get it working in game (crashes everytime) but I was able to with the original Kam's script.

 

Tried on both 3DS Max 2020 and 2021.

That's crazy, I just saw your tutorial in my recommended 😛

 

  • Like 1

Share this post


Link to post
Share on other sites
skatefilter5

i tired 3dmax 2021 but export to dff crashes my game, is anything for 3dmax 2021 cuz my 2011 version was expired and i cant nolong use it so , i try finding 2012 or 2016 version i end up getting 2021.

 

when can u do with 2021 if anyone haves?  

 

I look at videos ofr 3dmax  2021 with kam's script there's none of them. 😕

Edited by skatefilter5

Share this post


Link to post
Share on other sites
Einheit-101

Mesh fix doesnt work for skins it seems. We get this nice result:
 

I5dTY1V.png


This bug is annoying as f***

Share this post


Link to post
Share on other sites
deltaCJ
13 minutes ago, Einheit-101 said:

Mesh fix doesnt work for skins it seems. We get this nice result:
 

*pic*


This bug is annoying as f***

Hm, it's funny because I encountered that on newer versions of max but when I switched to Max 9 I haven't had a single problem with his updated scripts (the newer version, that was updated recently on Google Drive.)

 

Try:

 

  • Resetting XForm on the skin before export.
  • Vertex Welding at 0.001 
  • Export without UV Fix and Mesh Fix checked (I've noticed that using these options actually cause corruption if there was no corruption in the first place.) 
  • Try optimizing your mesh (ProOptimize works amazingly, just play with settings.) 

These solutions helped me with many errors I've encountered through modding. 

If none of these worked, you can always restart max, create a new project (because for some reasons when projects get corrupted, exports seem to corrupt as well.) and work from a new model. 

 

Let me know!

  • Like 1

Share this post


Link to post
Share on other sites
Einheit-101

In this case the problem was caused by welding the UVs... 

It gets quickly solved by exporting the character with RWIO (...) and re-importing the mesh. Rwio does not have such issue. It is very unfortunate that we cant weld UVs and we cant fix such a ruined mesh without using rwio. Not even exporting as obj or fbx solves it, only rwio can. 

 

Also, btw, the updated KAMS Scripts ruin rigging, it is not possible to export a working character in either Max 2010 or Max 2017 for me. I uninstalled the new KAMS and installed the 2009 original on my Max 2010 and suddenly i can export working characters again. 

Share this post


Link to post
Share on other sites
deltaCJ
8 hours ago, Einheit-101 said:

In this case the problem was caused by welding the UVs... 

It gets quickly solved by exporting the character with RWIO (...) and re-importing the mesh. Rwio does not have such issue. It is very unfortunate that we cant weld UVs and we cant fix such a ruined mesh without using rwio. Not even exporting as obj or fbx solves it, only rwio can. 

 

Also, btw, the updated KAMS Scripts ruin rigging, it is not possible to export a working character in either Max 2010 or Max 2017 for me. I uninstalled the new KAMS and installed the 2009 original on my Max 2010 and suddenly i can export working characters again. 

That's actually very unfortunate, just tried your theory of welding UVs and i was able to export a player model no problem. 

 

I went ahead and even tried making a new ped to see what could be the problem with rigging, and I once again encountered no problem...

This seems very weird and to me I feel like this may just be a problem with the certain scripts you have. I remember having countless problems with an old version of these scripts but this new version Gold_Fish and Shagg_E have informed me about, has given me not one single problem (Unless I do something incorrect leading to errors.)

 

If you don't mind, could you give me a rundown of what EXACTLY you do before making/rigging/exporting any mesh, maybe it is just a user caused problem that leads to these errors.

 

Merging UVs may be the cause of your problem for that exact mesh, but I still don't see how UVs and the mesh get jumbled in during export. I just welded the UVs for my UZI, and it came out great!

 

0XrsWem.png

 

Try smaller poly objects, maybe a very poor modelled house, or a simple object like a teapot, and see how they export after merging UVs.

(This was also with UV Fix and Mesh Fix UNCHECKED.)

 

 

EDIT: Also here's the link to the v0.37 KAM'S Gold_Fish Scripts

Edited by deltaCJ

Share this post


Link to post
Share on other sites
Einheit-101

It doesnt always happen when welding UVs, some models export just fine. But this one here certainly failed. The steps i did are simple, imported Torino.dff (Original skin), welded my droid skin UVs, merged my droid with Torino, export the file, get bug. Maybe its the orientation of the Vertices, but its not the count. I can export some larger models just fine.

Share this post


Link to post
Share on other sites
deltaCJ
2 minutes ago, Einheit-101 said:

It doesnt always happen when welding UVs, some models export just fine. But this one here certainly failed. The steps i did are simple, imported Torino.dff (Original skin), welded my droid skin UVs, merged my droid with Torino, export the file, get bug. Maybe its the orientation of the Vertices, but its not the count. I can export some larger models just fine.

Try Welding the UVs after rigging, see if that works? It most likely might be your rigging process. Also if you're rigging you should click Bone/Skin Export (Which Im guessing you already know, but I'm making sure.)

Share this post


Link to post
Share on other sites
gold_fish
10 hours ago, Einheit-101 said:

... welding UVs, ....

show me pls how you weld uv

why do you weld texture coordinates at all?

Select your skin in the DFF IO script window, press the chanell info button, then a small window will open and then press update, show me the information about the model channels, put a screen of this window

 

also show me pls the log after exporting the crooked skin (button f11)

Edited by gold_fish
  • Like 1

Share this post


Link to post
Share on other sites
Zeneric
10 hours ago, gold_fish said:

show me pls how you weld uv

 How do you weld uv? I'm probably doing it wrong too.

Edited by Zeneric

Share this post


Link to post
Share on other sites
gold_fish
12 hours ago, Zeneric said:

 How do you weld uv? I'm probably doing it wrong too.

UV is a scan of textures and it has its own vertices, UV does not need to weld, you only need to make a UV scan for your model, you can only weld the vertices of the model if you need it.

  • Like 1

Share this post


Link to post
Share on other sites
Zeneric
8 hours ago, gold_fish said:

UV is a scan of textures and it has its own vertices, UV does not need to weld, you only need to make a UV scan for your model, you can only weld the vertices of the model if you need it.

A lot of people suggested to weld UVs' vertices to reduce dff size. I saw little to no difference (dff size wise), and it sometimes messes up uv maps, so I thought I did something wrong.

Good to know. Thanks.

Share this post


Link to post
Share on other sites
gold_fish
5 hours ago, Zeneric said:

A lot of people suggested to weld UVs' vertices to reduce dff size. I saw little to no difference (dff size wise), and it sometimes messes up uv maps, so I thought I did something wrong.

Good to know. Thanks.

That's right, the size of the dff file is affected by the number of model vertices, triangles, UVs, prelights and materials.
On skins and cars, I would not recommend weld UV vertices at all. it greatly affects the structure of the model when exported due to which problems with geometry occur after export, unfortunately this script is not yet able to fully process all the nuances of the model's geometry and at some stages it can spoil the model. Just try to keep the model as simple as possible, use as few materials as possible, keep the mesh of the model even and correct, etc...


I also recommend to be very careful when using the break tool for vertexes, since after disconnecting the vertices, the UVs of the texture are also disconnected. And glueing it back can be problematic, I just recommend trying to perform fewer operations with the UVs and there will be fewer problems during export.

 

in the future I will add additional tools for fast compression of UVs and some more minor script updates, but all of them will not give 100% result for any model, you still have to work with each model individually and for each model its own settings and export methods

 

sorry for my English

Edited by gold_fish

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 2 Users Currently Viewing
    0 members, 1 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.