Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (92,207 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Assasinge

Model appears transparent or ghostlike in SA?

Recommended Posts

Assasinge

I recently rigged a model in Max for San Andreas and when I imported my rig into San Andreas it's appearing transparent, see through like.

 

This is in Max: 2018-03-11_10h11_18.png

 

This is it in SA: gta-sa_2018-03-11_10-13-08-41.jpg

 

Anyone ever encounter this before?

Share this post


Link to post
Share on other sites
guard3

What do the textures look like? Do they have some sort of transparency? If so, it could be a draw order issue

Share this post


Link to post
Share on other sites
Recommended

Check the textures' alpha settings, otherwise are you using an alpha texture? That seems to be what's causing that.

Share this post


Link to post
Share on other sites
Assasinge

Check the textures' alpha settings, otherwise are you using an alpha texture? That seems to be what's causing that.

 

Right, well I just opened up Magic TXD and looked at one of the textures and checked "Background" in the View tab and the texture indeed appears with a transparent background, a checkerboard to be more specific.

 

But when I open it in Photoshop the file looks fine.

 

It's a .dds file by the way.

Share this post


Link to post
Share on other sites
guard3

Photoshop has a dark background, that's why it looks fine. You may just need to add a black layer as background ;)

Share this post


Link to post
Share on other sites
Recommended

Yeah if it's showing a checkerboard effect for a texture in Magic TXD, that means it has an alpha applied to it. I'm not sure how you delete the alpha texture in Magic TXD, I still use TXD Workshop even to this day, and despite what others say, it's never caused me problems.

 

The only way I know that will work in Magic TXD is to delete the texture that has the alpha, and then re-add your texture into the TXD file with Magic TXD. That way it shouldn't apply an alpha to it.

Share this post


Link to post
Share on other sites
guard3

it's never caused me problems.

...yet :D

Share this post


Link to post
Share on other sites
Assasinge

I fixed it. Thanks for the help guys!

Share this post


Link to post
Share on other sites
Recommended

 

it's never caused me problems.

...yet :D

 

I've been using it for about 5 - 6 years now ;) It does have it's obvious issues but there are ways to get it to do what you need it to do.

 

Anyway, glad you've got it resolved! :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.