Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Diamond Casino Heist
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA 6

      1. St Andrews Cathedral
    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. Announcements

    2. Support

    3. Suggestions

Junior_Djjr

VehFuncs

Recommended Posts

007Ripper

My Speedometer cant reach 300 kmh, or is it in Mph ? And we do need digital rpm meter sir! :D

 

 

  • Like 1

Share this post


Link to post
Share on other sites
Mysterdogg

I wonder how could Vehfuncs implement a tachometer, or if the game even measures RPMs. How does Active Dashboard does it? I guess it could be emulated to give the illusion it works. Same thing for a temperature gauge, making it work based on speed and integrity of the vehicle perhaps. 

  • Like 1

Share this post


Link to post
Share on other sites
arminnas

I have problem!

when I tuning a car in transfender or somewhere else some parts of car missing. when I want to change the wheels my game will crash. without vehfuncs everything is fine. I had older version but everything was fine until install new version this happened.

59c2231342755787.jpg c6ea6c1342755794.jpg895d351342755801.jpg ee543d1342755810.jpg c01ef21342755822.jpg f9ff4c1342755829.jpg 

 

for example when I apply new front bumper from peugeot 206, rear bumber steering, wheel, huds and engine is gone or disappear 

Share this post


Link to post
Share on other sites
Junior_Djjr
On 5/3/2020 at 3:13 AM, Mysterdogg said:

I wonder how could Vehfuncs implement a tachometer, or if the game even measures RPMs. How does Active Dashboard does it? I guess it could be emulated to give the illusion it works. Same thing for a temperature gauge, making it work based on speed and integrity of the vehicle perhaps. 

I can do this using the engine sound progress, the problem is that I also need the total value to limit it, because different engine sounds have different lengths, so I also need the sound length. No, I don't want to make modders set the limit manually because who install the mod can add without replace, replace by another vehicle, set a different engine sound etc.

I need to try it yet.

 

On 5/4/2020 at 11:13 AM, arminnas said:

when I tuning a car in transfender or somewhere else some parts of car missing. when I want to change the wheels my game will crash. without vehfuncs everything is fine. I had older version but everything was fine until install new version this happened.

This problem actually happens in the old version, not the new one.

I even tested it again here with Uranus (the one in your image is original from the game, right?) and everything is fine.

 

On 4/18/2020 at 9:38 AM, Strs said:

i think its simple ignore Planes and helis in VehFuncs i dont see any of fly aircraft uses VehFuncs 

On 4/14/2020 at 10:31 AM, xXKenBlockXx said:

Zeneric's Shamal Remastered

...but this is because of the name "f_gear" that I didn't know that another mod also used this name.

Share this post


Link to post
Share on other sites
arminnas

I downloaded 1.8.3 beta and every things ok

Share this post


Link to post
Share on other sites
Priest14/88

Either vehfuncs or gsx causes mission vehicles to disappear, such as Sweet's Greenwood in Tagging up Turf. I managed to bypass this with the Never Despawn mod, but it didn't work in Catalyst with Ryder's Picador. Removing Vehfuncs and GSX fixed this issue, please, look into this.

Share this post


Link to post
Share on other sites
Junior_Djjr
20 hours ago, Priest14/88 said:

Either vehfuncs or gsx causes mission vehicles to disappear, such as Sweet's Greenwood in Tagging up Turf. I managed to bypass this with the Never Despawn mod, but it didn't work in Catalyst with Ryder's Picador. Removing Vehfuncs and GSX fixed this issue, please, look into this.

This is not a problem with this mod, it doesn't have any control over the existence of the vehicles, also, I tested it now and it didn't cause the bug.

 

Update v1.9 beta

  • Added "?d" class condition, followed by pedstat ID, to check driver pedstat (if it's cop, specific gang, old, young etc). Also "?nd" for negative. The number is from "pedstats.dat" (starting from 0, for example GANG2 (Families) is "?d5").
  • Added "?m" class condition to check if the vehicle is mission controlled. Only during missions. Also "?nm" for negative.
  • Recreated the way the nodes that matches classes are selected, now more optimized and, finally, a node can have more than 1 class. Also fixed a bug that classes with similar name are considered the same, so, it's recommended to re-check if your cars are using this bug.
  • Added .ini file for some settings. For now, multiply the default dirt level, set default steer angle, and disable .log generation (for a little performance improvement, specially for casual gameplay with a lot of adapted vehicles).
  • Fixed "_busrender" not working if the driver is created in the same frame as the bus.
  • Fixed a rare crash when setting the vehicle seed. Fixes crash that some people had in the Car Dealership and loading car saved from Tuning Mod.
  • Like 4
  • YEE 1

Share this post


Link to post
Share on other sites
Junior_Djjr

The download was wrong, it was a test version. Fixed now.

Share this post


Link to post
Share on other sites
Junior_Djjr
Posted (edited)

Update v2.0 beta

  • Re-implemented the damage for the parts "wing_lr" and "wing_rr" (rear fenders) removed from the final version of GTA SA. No original car in the game uses it, but mods can now use it, just like the front fenders. Based on the DK22Pac code that would go to the new version of IVF.
  • Added "_se=" (sound engine): Modders can now define the car's engine sound as a characteristic, without the need for a configuration file (compatible with the selection of extra parts etc., for example each engine or exhaust can use a different engine sound).
  • Added "f_dodometer" (digital odometer): Visualization of vehicle mileage. It is random based on some factors, such as the level of dirt and damage that the vehicle has appeared. Uses realistic speed calculation to count the distance. Mods can read and write the value (I have now updated the Car Dealership mod to use the same mileage shown in the menu). The mileage is saved with the car in the garage, of course.
  • Another tuning fix for cars that don't use the "chassis" part (which causes bugs, depending on the organization of the .dff hierarchy). VehFuncs will use the part "body", which modders usually use (this fixes the tuning of 70 cars in GTA Brasil).
  • Fixed tuning cars without "chassis" not working for "copcarla".
  • Fixed additional "vehicle.txd" not working for "copcarla".
  • On airplanes, "f_gear" was changed to "f_spin", as coincidentally another mod also uses this name (this fixes the wheels turning on some airplane mods).
  • Now all dashboard  functions will have LOD enabled by default (so as not to render if the camera is a far from the vehicle, improving game performance).
  • Configuration "LogNoTextureFound" added: Shows in "VehFuncs.log" the name of the textures not found. Disabled by default, useful for modders.
Edited by Junior_Djjr
  • Like 6
  • YEE 1

Share this post


Link to post
Share on other sites
_F_
Posted (edited)

Very happy to see the new _se feature! Something I´ve wanted for a long time. Did a quick test with it already and it works! 

Would be nice to have some tutorial or database about the IDs though

 

EDIT: Okay since it is pretty important information and there is no convenient database around, I went ahead and made one:

Spoiler
ID1	ID2	List of cars												
-1	-1	artict1	artict2	shamal	hydra	at400	petrotr	artict3	androm	rccam	utiltr1			
8	7	bravura	previon	solair	zr350	mesa	nebula	cadrona	primo	merit	uranus	elegy	euros	
11	10	baggage	tug											
12	-1	leviathn	hunter	cargobob	raindanc									
17	16	glendale	oceanic	bullet	tornado	glensh*t								
19	18	bmx	bike	mtbike										
22	21	predator	squalo	speeder	reefer	tropic	coastg	dinghy	marquis	jetmax	launch			
26	25	cabbie	fortune	willard	vincent	intruder	sunrise	yosemite	picador					
33	32	bus	coach	dft30										
35	34	hermes	remingtn	broadway										
36	118	rcbandit												
38	37	buffalo	infernus	hotring	hotrina	alpha								
41	40	copbike	wayfarer											
46	45	voodoo	stallion	sabre	buccanee	blade	clover	savanna						
48	47	sanchez	quad											
53	54	rustler	stunt											
58	57	forklift												
62	61	kart	mower											
64	63	caddy												
69	68	combine												
71	70	monster	bloodra	monstera	monsterb									
76	75	bfinject	hotknife	slamvan	hustler									
78	77	vortex												
79	141	mrwhoop												
81	80	trash	enforcer	barracks	flatbed	fbitruck	duneride	swatvan						
84	83	linerun	dumper	firetruk	rhino	packer	benson	petro	rdtrain	cement	firela			
85	-1	maverick	vcnmav	polmav										
87	86	sentinel	stretch	taxi	premier	admiral	elegant	sultan	stratum	stafford	emperor	copcarla	copcarsf	copcarvg
89	88	walton	dozer	tractor										
93	92	esperant	blistac	majestic	feltzer	jester	flash	tahoma	club					
95	94	peren	manana	moonbeam	washing	bobcat	romero	regina	virgo	greenwoo	sadler	tampa	sadlsh*t	
99	98	landstal	patriot	rancher	fbiranch	sandking	rnchlure	huntley	copcarru					
101	100	hotrinb	windsor	phoenix										
103	102	cheetah	banshee	turismo	comet	supergt								
104	-1	seaspar	sparrow											
107	106	rcbaron												
109	108	rcraider	rcgoblin											
113	112	rctiger												
115	114	fcr900	bandito											
119	118	pizzaboy	faggio											
120	54	skimmer	cropdust	dodo										
125	124	pcj600	nrg500	bf400										
127	126	sweeper												
130	129	bagboxa	bagboxb	tugstair	farmtr1									
132	131	freight	streak	freiflat	streakc	freibox								
132	133	tram												
134	135	beagle	nevada											
137	136	pony	mule	ambulan	securica	topfun	burrito	journey	towtruck	utility	newsvan	boxburg		
140	139	freeway												
142	141	rumpo	yankee	camper	boxville	hotdog								

 

 

Edited by _F_
  • Like 4

Share this post


Link to post
Share on other sites
Junior_Djjr

I use fastman92 limit adjuster configuration file to see the numbers, but your list looks way better to read.

I'll include it in the VehFuncs wiki.

Share this post


Link to post
Share on other sites
Leinad

I've enabled LogNoTextureFound = 1

It works, but this is kinda annoying, mostly related to painjtobs textures.

e.g.

Spoiler
VF v2.0
Handling: Vanilla handling pointer: 00C2B9DC 224 00C37D30 
Core: Started
Core: IVF installed
Can't find texture remapuranus92body256
Can't find texture remapuranus92body256
Can't find texture remapuranus92body256
Can't find texture remapuranus92body256
Can't find texture remapuranus92body256
Can't find texture remapuranus92body256
Can't find texture remapuranus92body256
Can't find texture remapuranus92body256
Can't find texture remapuranus92body256
Can't find texture remapuranus92body256
Can't find texture remapuranus92body256
Can't find texture remapuranus92body256
Can't find texture remapuranus92body256
Can't find texture remap4
Can't find texture remap4
Can't find texture remap4
Can't find texture remap4
Can't find texture remap4
Can't find texture remap4
Can't find texture remap4
Can't find texture remap4
Can't find texture remap4
Can't find texture remap4
Can't find texture remap4
Can't find texture remap4

 

 

Share this post


Link to post
Share on other sites
Junior_Djjr
On 5/25/2020 at 11:13 PM, Leinad said:

I've enabled LogNoTextureFound = 1

It works, but this is kinda annoying, mostly related to painjtobs textures.

Well, it is not wrong.

  • Like 1

Share this post


Link to post
Share on other sites
Junior_Djjr

Fixed some cars that use "body" keeping the body swinging (in fact I had only tested with the copcarla, and now I saw this happening in others).

  • Like 1

Share this post


Link to post
Share on other sites
_F_

Wouldn´t it be easier to turn off the body swinging feature, since you are now in the territory of using .ini

Share this post


Link to post
Share on other sites
fastman92
Posted (edited)

@Junior_Djjr, I would like to see the battleship in GTA San Andreas.

Would you be able to make it possible?

You can get the idea from rhino, 539 for this

 

BB61_USS_Iowa_BB61_broadside_USN.jpg

Edited by fastman92
  • Like 2

Share this post


Link to post
Share on other sites
Strs

Wouldn´t it be easier to turn off the body swinging feature, since you are now in the territory of using .ini

 

i have done it long time now with cleo no cars swing their bodies now :) 

Share this post


Link to post
Share on other sites
arminnas

digital speedometer didn't work with latest version!

52c52c1345603735.jpg 

  • Like 1

Share this post


Link to post
Share on other sites
Leinad
1 hour ago, arminnas said:

digital speedometer didn't work with latest version!

52c52c1345603735.jpg 

Check your vehfuncs.log, maybe is bad adapted, I have something like this in the log, I don't know why, the last version it worked fine the digital speedometer.

DigitalSpeedo: Found 'f_dspeedo'
DigitalSpeedo: Setup...
DigitalSpeedo: Error: Bad adapted
DigitalSpeedo: Speed multiplicator: 1

 

Share this post


Link to post
Share on other sites
arminnas
8 hours ago, Leinad said:

Check your vehfuncs.log, maybe is bad adapted, I have something like this in the log, I don't know why, the last version it worked fine the digital speedometer.

DigitalSpeedo: Found 'f_dspeedo'
DigitalSpeedo: Setup...
DigitalSpeedo: Error: Bad adapted
DigitalSpeedo: Speed multiplicator: 1

 

my log:

DigitalSpeedo: Found 'f_dspeedo' 
DigitalSpeedo: Setup...
DigitalSpeedo: Error: Bad adapted 
DigitalSpeedo: Speed multiplicator: 1

 

Share this post


Link to post
Share on other sites
Junior_Djjr
On 5/30/2020 at 6:00 AM, _F_ said:

Wouldn´t it be easier to turn off the body swinging feature, since you are now in the territory of using .ini

I agree.

 

Update v2.0.2 beta - 02/06/20 09:50

  • Fixed the digital speedometer not working.
  • Added the "_swc" characteristic for modders to disable or enable the car swinging chassis (useful mainly for SAMP, which does not load custom handling).
  • Taking advantage, you now have the option to enable "NoSwingingChassis" in VehFuncs.ini to disable the chassis swinging on all cars of the game.
  • Like 8
  • KEKW 1

Share this post


Link to post
Share on other sites
SomeGuy86

This is probably going to sound like one of those pointless questions, but can you please explain (give me a working example) on how to attach more than one wheel to a model? I've tried looking into one of the mods, but the more I analyze the hierarchy, the more confused I get.

 

I got two models (wheel1, wheel2), all linked to a "chassis". I realize this isn't the right way (normal method obviously requires the wheel to be linked with wheel_rf dummy) but I can't seem to get it working either way.

  • Like 1

Share this post


Link to post
Share on other sites
Leinad
23 minutes ago, SomeGuy86 said:

This is probably going to sound like one of those pointless questions, but can you please explain (give me a working example) on how to attach more than one wheel to a model? I've tried looking into one of the mods, but the more I analyze the hierarchy, the more confused I get.

 

I got two models (wheel1, wheel2), all linked to a "chassis". I realize this isn't the right way (normal method obviously requires the wheel to be linked with wheel_rf dummy) but I can't seem to get it working either way.

Well, I copied wheel_rf_dummy twice, and rename it f_wheel_1111 and the other one f_extras:1 this dummy should be inside of f_wheel_1111, inside of f_extras:1 you place your wheels. In this picture I have two wheels wheel_[norm] and wheel_[lowr], because I have 2 classes with those names, but if you aren't using classes you can name it like wheel_1, wheel_2 etc

https://i.imgur.com/HWfeYS8.png

Hope it helps!

  • Like 1

Share this post


Link to post
Share on other sites
SomeGuy86
Posted (edited)
13 hours ago, Leinad said:

Well, I copied wheel_rf_dummy twice, and rename it f_wheel_1111 and the other one f_extras:1 this dummy should be inside of f_wheel_1111, inside of f_extras:1 you place your wheels. In this picture I have two wheels wheel_[norm] and wheel_[lowr], because I have 2 classes with those names, but if you aren't using classes you can name it like wheel_1, wheel_2 etc

https://i.imgur.com/HWfeYS8.png

Hope it helps!

Thanks, I'm going to give it a try as soon as I get the chance 👍

 

I'm curious, would the same approach also work for adding additional "extras", other than 6 original "SA" ones?

 

Edit

Nevermind, I followed the template from another mod & eventually figured it out... Pretty complicated but (eventually) rewarding procedure.

Edited by SomeGuy86
  • Like 1

Share this post


Link to post
Share on other sites
Junior_Djjr
On 6/6/2020 at 8:25 AM, SomeGuy86 said:

I'm curious, would the same approach also work for adding additional "extras", other than 6 original "SA" ones?

Tutorials here:

https://github.com/JuniorDjjr/VehFuncs/wiki

Share this post


Link to post
Share on other sites
Leinad
Posted (edited)

There's a bug with Fire Ladder truck, (models misc_a, misc_b and misc_c) the ladder doesn't have animation with last version of vehfuncs 2.0.2

https://i.imgur.com/ax9w8zx.png

 

UPDATE

I think this is the problem is related to this option in the .ini file

NoSwingingChassis = 1

Changing the value to 0, the animation on ladder works.

Edited by Leinad
Found the reason

Share this post


Link to post
Share on other sites
QvH
Posted (edited)

I dont understand why in tutorial " :2 " but linked 3 parts or :1 but linked 2 parts
Or in tractor trailer example f_extra:1 but have 4 links under it... no extra:8 with 8 dummys but withextra:1 with 4 dummys

Edited by QvH

Share this post


Link to post
Share on other sites
QvH
Posted (edited)

and how work dirt? what if i have not standart dirt. it would work?

2dfx data would work linked to extras or would be work all time?(for making neon for example)

and interested question "what if car variation will be used for gang in cargrp its real to do variation for gang mambers(link to gang)?" 

Edited by QvH

Share this post


Link to post
Share on other sites
Jsk14

Hey @junior_djjr. Man don't forget that you said that you will add backfire in vehfuncs. And please adapt it with exhaust dummy system. As in Tuning MOD, when I change the exhaust dummy, The smoke comes out correctly from dummy place, but the backfire comes from original place of exhaust. Please fix it and adapt backfire to vehfuncs

Share this post


Link to post
Share on other sites
Junior_Djjr
19 hours ago, QvH said:

I dont understand why in tutorial " :2 " but linked 3 parts or :1 but linked 2 parts

The number you indicate in : is how many nodes you want to be selected.

i.e. using :1 I want to select just 1 part. Any doubt?

 

18 hours ago, QvH said:

and how work dirt? what if i have not standart dirt. it would work?

Here.

 

19 hours ago, QvH said:

2dfx data would work linked to extras or would be work all time?(for making neon for example)

I didn't test.

 

19 hours ago, QvH said:

and interested question "what if car variation will be used for gang in cargrp its real to do variation for gang mambers(link to gang)?" 

I didn't understand the question well, but in the list of conditions for class selection there is a way to check if such a driver is from such a gang.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 2 Users Currently Viewing
    0 members, 0 Anonymous, 2 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.