Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    2. News

    1. Red Dead Redemption 2

    1. GTA Online

      1. After Hours
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Recommended Posts

lsnoop

I fixed the jerky handling problem on original cars installing Improved SA Default Cars v0.7.2. It includes a handling which works fine and is way smoother than original.

 

I think a handling like this should be included in the mod so that people won't have to deal with original jerky car physics and spend time looking for a fix :santa:

 

Also what about turnlights (for AI cars too)? Does the mod have this feature? It would be great to add clicking sound too.

Share this post


Link to post
Share on other sites
Junior_Djjr
2 hours ago, lsnoop said:

Also what about turnlights (for AI cars too)? Does the mod have this feature? It would be great to add clicking sound too.

Already exist.

 

2 hours ago, lsnoop said:

I fixed the jerky handling problem on original cars installing Improved SA Default Cars v0.7.2. It includes a handling which works fine and is way smoother than original.

Wow, placebo is awesome.

Share this post


Link to post
Share on other sites
Junior_Djjr

f*cking nice.

 

I've been doing a cool new function (especially for those who like muscle cars). Wait.

Share this post


Link to post
Share on other sites
lsnoop
On 8/3/2018 at 5:05 AM, Junior_Djjr said:

Wow, placebo is awesome.

No idea what you mean.

 

The diff shows there were no changes in handling? :lol: That must be Silent Patch or something else then ...

Share this post


Link to post
Share on other sites
Junior_Djjr
Posted (edited)

Updated v0.5 beta

  • Added: f_shake — makes the part vibrate with the engine (useful for engines and exhausts). The vibration uses perlin noise for a natural effect and changes with accelerating. Also includes option for the part to tilt when accelerating, as it happens in some engines. Watch the video.
  • Added: f_gas — formerly known as "enh_scoop", but now supporting configurable XYZ rotation. It's a part that rotates with the gas pedal, being useful for several cases.
  • Characteristics and attributes (eg 'pj=' and 'mu=') are now required to be preceded by "_" for better compatibility. If you have adapted some car, check it.
  • Several performance improvements and some bug fixes.
  • Improved f_gear rotation when accelerating the car.

 

 

Edited by Junior_Djjr

Share this post


Link to post
Share on other sites
Avant_SA
Posted (edited)

Find a bug in new woobling feature. When there is part with f_shake inside hierarchy, only parts that's inside chassis visible throught windscreen. windscreen_dummy is in the bottom of chassis_dummy. Inside windscreen_dummy there is:

-windscreen_dummy

--windscreen_ok (rearview mirror)

---windscreen_ok (windshield glass)

 

2Kb9R.jpg

 

It's causing only when part with f_shake inside.

Edited by Avant_SA

Share this post


Link to post
Share on other sites
Junior_Djjr
11 hours ago, Avant_SA said:

When there is part with f_shake inside hierarchy

The most important: where? I need to reproduce the problem.

Share this post


Link to post
Share on other sites
AdusPL

Hey, Junior_Djjr I was curious whether it is possible to fix this retarded bike handlebars mechanic.

 



KppbrNd.jpg

Share this post


Link to post
Share on other sites
Avant_SA
Posted (edited)
3 hours ago, Junior_Djjr said:

The most important: where? I need to reproduce the problem.

Not actually plays role. I tried moving it inside chassis, chassis_dummy and even windscreen_dummy. Only one thing, that happened, it's reorganise materials and make from two windscreen's_ok only one, then works normal.

 

Tested on other model, that have only one windscreen_ok. Bug appears, when there is extra4 or extra3 on car. Mystic.

Edited by Avant_SA

Share this post


Link to post
Share on other sites
Junior_Djjr
9 hours ago, AdusPL said:

Hey, Junior_Djjr I was curious whether it is possible to fix this retarded bike handlebars mechanic.

 

 

  Reveal hidden contents

 

 


KppbrNd.jpg
 

 

 

Quadbike has handlebar animation.

How?

Simply the .ifp from quadbike has the arm moving and the bike does not...

If you edit the bike turn animation for the arm to move together, done, now just make the handlebar rotate (it's already separated in the model, doesn't need model adaptation).

 

8 hours ago, Avant_SA said:

Not actually plays role. I tried moving it inside chassis, chassis_dummy and even windscreen_dummy. Only one thing, that happened, it's reorganise materials and make from two windscreen's_ok only one, then works normal.

 

Tested on other model, that have only one windscreen_ok. Bug appears, when there is extra4 or extra3 on car. Mystic.

On my two test models this doesn't happen.

And it makes no sense to be a VehFuncs problem, the only thing VehFuncs does for a part to vibrate is to change its rotation. Changing the rotation of a part doesn't make sense to cause transparency bugs.

 

btw the game adds transparency fix on objects inside windscreen_dummy, I think it's limited (only childs and not grandchilds for example). On next update I'll add a way to apply transparency fix to any part, thus transparency problems are over (maybe). I did this in the next version of the Tuning Mod in an automatic way and works very nice.

 

Share this post


Link to post
Share on other sites
Avant_SA
Posted (edited)
5 hours ago, Junior_Djjr said:

Quadbike has handlebar animation.

How?

Simply the .ifp from quadbike has the arm moving and the bike does not...

If you edit the bike turn animation for the arm to move together, done, now just make the handlebar rotate (it's already separated in the model, doesn't need model adaptation).

 

On my two test models this doesn't happen.

And it makes no sense to be a VehFuncs problem, the only thing VehFuncs does for a part to vibrate is to change its rotation. Changing the rotation of a part doesn't make sense to cause transparency bugs.

 

btw the game adds transparency fix on objects inside windscreen_dummy, I think it's limited (only childs and not grandchilds for example). On next update I'll add a way to apply transparency fix to any part, thus transparency problems are over (maybe). I did this in the next version of the Tuning Mod in an automatic way and works very nice.

 

Anyway, it works good only with one f_shake. I attcahed 3 details to one f_shake. Here, how it works with two f_shakes:

2Kd32.jpg

 

My hieratchy is:

-chassis_dummy

--chassis

---parts

---parts

---f_shake

---f_shake_mu=0.3

---parts

---extra1-3

---rearglass

---extra4

 

My other convert, first one model, about i written. There was also that bug with extras, but it was only with extra2, that was in boot_dummy only for IVF version. I moved two f_shake from chassis_dummy to model dummy and putted it higher, and now it works good with that extra. :sarcasm: These function have a lot of bugs, before they won't be fixed it can't be normal usable.

 

New bugs with that. That extras, with which was windscreen glass, now bug with rear glass. Just facepalm. Playing in hierarchy with both details don't give anything. Rear glass is separate detail.
2Kd6y.jpg

Edited by Avant_SA

Share this post


Link to post
Share on other sites
_F_
12 hours ago, Junior_Djjr said:

Quadbike has handlebar animation.

How?

Simply the .ifp from quadbike has the arm moving and the bike does not...

If you edit the bike turn animation for the arm to move together, done, now just make the handlebar rotate (it's already separated in the model, doesn't need model adaptation).

 

On my two test models this doesn't happen.

And it makes no sense to be a VehFuncs problem, the only thing VehFuncs does for a part to vibrate is to change its rotation. Changing the rotation of a part doesn't make sense to cause transparency bugs.

But wouldn´t it be possible to somehow stretch the player´s hands? Because there is dummy actually where the grip should be (I don´t remember the name, but it´s not used by the game engine), and also in 3ds Max the whole fork with handle bar rotates, while in game the handle bar doesn´t move, only the fork. Therefore maybe it´s possible to somehow make it that the player´s hand bone is always attached to the grip dummy, no matter what, and when it turns, it just stretches the arm instead of letting go. (Though of course I don´t know how that might look in game :D, might be sh*t ) :D

Share this post


Link to post
Share on other sites
Davve95

Where can I download finished vehicles with VehFuncs? I Google'd but I could only find one.

Share this post


Link to post
Share on other sites
Junior_Djjr
8 hours ago, _F_ said:

But wouldn´t it be possible to somehow stretch the player´s hands? Because there is dummy actually where the grip should be (I don´t remember the name, but it´s not used by the game engine), and also in 3ds Max the whole fork with handle bar rotates, while in game the handle bar doesn´t move, only the fork. Therefore maybe it´s possible to somehow make it that the player´s hand bone is always attached to the grip dummy, no matter what, and when it turns, it just stretches the arm instead of letting go. (Though of course I don´t know how that might look in game :D, might be sh*t ) :D

That is, the same happens with the peds?

I would cite this, I plan to apply this to CJ, including in cars, so it will be easier to make CJ's hand on steering wheel. But honestly I think the animation of the arm turning a handlebar (or the steering wheel) will spoil everything. I do not have much hope.

 

4 hours ago, Davve95 said:

Where can I download finished vehicles with VehFuncs? I Google'd but I could only find one.

VF is new yet.

In the future I hope they will use it. A project created by some friends and members of my forum (where I helped a little), GTA Brasil, will use this in abundance.

I'm also making it fully compatible with my Tuning Mod, so people do not have to wait for adapted cars, they can install parts themselves in any car, fully in-game (just install any part and change the part name to make it work). On Tuning Mod v2.2 will be possible to install any pre-adapted part (just install it and done; I will release that supercharger from the video above pre-adapted too).

 

@Avant_SA, I think you'd better send me the car to test (it can be just the .dff).

Share this post


Link to post
Share on other sites
Junior_Djjr
On 8/7/2018 at 11:00 PM, Junior_Djjr said:

 

@Avant_SA, I think you'd better send me the car to test (it can be just the .dff).

Isn't exactly a VehFuncs bug. It's a original game bug, but IVF fixes that, and VehFuncs "unfixes".

 

Here, without IVF and VF:

1.jpg

If you use VehFuncs' extra system this will not happen, but I understand that this is a problem that needs to be fixed.

 

....oh, nice, now I reenabled IVF and VF and it's working:

1.jpg

I don't know what happened.

Share this post


Link to post
Share on other sites
Avant_SA
46 minutes ago, Junior_Djjr said:

Isn't exactly a VehFuncs bug. It's a original game bug, but IVF fixes that, and VehFuncs "unfixes".

 

Here, without IVF and VF:

1.jpg

If you use VehFuncs' extra system this will not happen, but I understand that this is a problem that needs to be fixed.

 

....oh, nice, now I reenabled IVF and VF and it's working:

1.jpg

I don't know what happened.

Anyway, that's really need to be fixed. I thought about making shaking parts in IVF+AD and HQLM versions too, because without vehfuncs the parts on right places. Hope, you will fix that. I think, on second screen other extra, because there is two extras with that border.

Share this post


Link to post
Share on other sites
Junior_Djjr
Posted (edited)
On 8/9/2018 at 9:00 PM, Avant_SA said:

I think, on second screen other extra, because there is two extras with that border.

Well remembered, and now I've seen better, confirmed, the problem happens even without VehFuncs, it has nothing to do with mod bugs, and only happens in extra2.

We can fix using this:

On 8/7/2018 at 1:30 AM, Junior_Djjr said:

btw the game adds transparency fix on objects inside windscreen_dummy

Look:

1.jpg

Again, I'll put something to apply this transparency fix to any node, so you will not need to place the part on the windscreen_dummy, but if you do in this way, I think will work pretty fine, looking quickly I didn't notice problems.

Edited by Junior_Djjr

Share this post


Link to post
Share on other sites
Avant_SA
3 hours ago, Junior_Djjr said:

Well remembered, and now I've seen better, confirmed, the problem happens even without VehFuncs, it has nothing to do with mod bugs, and only happens in extra2.

We can fix using this:

Look:

1.jpg

Again, I'll put something to apply this transparency fix to any node, so you will not need to place the part on the windscreen_dummy, but if you do in this way, I think will work pretty fine, looking quickly I didn't notice problems.

Yes, it's worked. Moved rearglass and extra4 inside windscreen_dummy, now it works, thanks. And one more thing, it's start bugging only if there is materials with 253 alpha channel inside the model. My newest convert works perfect with two vibrating parts. But it have no extras with alpha channel. 253 alpha channel fixes some extra bugs, when corners of transparent texture is shining through other parts. That's only one way to fix it. Thanks for the answer, only that way it's really worked.

Share this post


Link to post
Share on other sites
Junior_Djjr
Posted (edited)
On 8/11/2018 at 1:29 AM, Avant_SA said:

Yes, it's worked. Moved rearglass and extra4 inside windscreen_dummy, now it works, thanks. And one more thing, it's start bugging only if there is materials with 253 alpha channel inside the model. My newest convert works perfect with two vibrating parts. But it have no extras with alpha channel. 253 alpha channel fixes some extra bugs, when corners of transparent texture is shining through other parts. That's only one way to fix it. Thanks for the answer, only that way it's really worked.

I tried to add an alpha fix on VehFuncs...

gta-sa-vehfuncs-alpha-mask-fix.jpg

It worked also in an automatically way, but some old modded cars gets bugged.

So, I added manually in some parts, the fix was the same of <>255 alpha channel was you said... but not exactly, when you use an alpha channel different than 255, the result is better, smooth.

1.jpg

There is no "more correct" way than your solution.

 

Also, I think the solution of moving the part to the windscreen hierarchy had no relation to the alpha render fix, but to the order in the hierarchy. The alpha fix actually works by the name of the node i.e. if you use the name "windscreen" the fix will be applied, as well as using <>255 alpha on material.

 

So, yeah, the better way to fix alpha issues is using <>255 alpha and a good hierarchy placement order.

Edited by Junior_Djjr

Share this post


Link to post
Share on other sites
Junior_Djjr
Posted (edited)

Something that is worth saying: VehFuncs does not need and will not need parent dummy, different from IVF and Active Dashboard/Steering.

This is much more convenient for modelers and is compatible with Tuning Mod parts (which can rotate, scale, distort etc).

i.e. you don't need "steer_dummy | steer", can be just "steer".

Edited by Junior_Djjr

Share this post


Link to post
Share on other sites
TerRaBite92

How to fix support with IVF on movable parts? Spoilers works on chassis dummy with class, not inside on boot_dummy. Without IVF working normally. Main and hierarchy screen. And i'm send to you model in PM

Share this post


Link to post
Share on other sites
AdusPL

Suggestions:

 

 

1. Working clocks (not digital):

 

 


O0KIqXd.jpg
 

 

 

  a. speedometer: there'a a pointer and it rotates depending on the speed, the values would just be a normal texture same for every vehicle I guess

  b. tachometer: maybe depending on the acceleration sound? (when the sound loops it would rotate back to 0 angle)

  c. temperature: just a random rotation probably would do

 

2. Rear footpegs for motorcycles(activated when there's a passenger on a motorcycle):

 



k7skhO6.png
 

 

3. Kickstand (when parked):

 



K9NUfSz.png
 

 
 


s-l1600.jpg
 
 
Edited by AdusPL
wow the new editor is f* terrible

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.