Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. Los Santos Summer Special
      2. The Diamond Casino Heist
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA VI

      1. St. Andrews Cathedral
    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. Announcements

    2. Support

    3. Suggestions

The Hero

Debug menu

Recommended Posts

The Hero

Updated both menu and debug plugin.

 

The debugmenu has the keyboard controls fixed now. Also there are changes to make it compatible with VCSPC that are only relevant for developers.

 

The debug plugin has some things changed, I don't remember. Most importantly I changed the hotkey for the debug cam to Ctrl-B.

 

have fun!

  • Like 6

Share this post


Link to post
Share on other sites
GuruGuru
Quote

Most importantly I changed the hotkey for the debug cam to Ctrl-B.

 

Can we nominate this plugin for mod of the year?

  • Like 2

Share this post


Link to post
Share on other sites
The Hero

New release 2.1 of debugmenu:

1.1 and steam exes supported for III and VC. by Fire_Head

 

the debug plugin is NOT updated. I do not want 1.1 and steam support in there because then i feel obliged to keep it when i make changes, which only means more work for me.

Edited by The Hero

Share this post


Link to post
Share on other sites
Shred N Slash

Sorry for the bump

 

So is there a way to make the debug camera work on cutscenes in III, or...? Since LMB has to be pressed for the camera to move and since LMB skips cutscenes and cannot be unbound it's kinda screwed. Help please?

Share this post


Link to post
Share on other sites
RegistaG
22 minutes ago, HotlineVice19603 said:

Sorry for the bump

 

So is there a way to make the debug camera work on cutscenes in III, or...? Since LMB has to be pressed for the camera to move and since LMB skips cutscenes and cannot be unbound it's kinda screwed. Help please?

Press and hold left mouse button before going into the marker

  • Like 1

Share this post


Link to post
Share on other sites
Wolff

I can't get the VC version to work sadly. I have 1.0 US. I put debugmenu.dll and vc_debug.dll (tried renaming to .asi too) in my root folder but nothing happens when i press CTRL+M (I also tried right ctrl)

Share this post


Link to post
Share on other sites
SHIFAAU9 / SHIFAAH9

@The Hero why can't I see skyGFX or silent patch or anything other than "Debug" area/section in GTA 3 debug menu?

as for GTA VC debug menu itself is not accessible.

Edited by SHIFAAU9 / SHIFAAH9

Share this post


Link to post
Share on other sites
The Hero

Maybe wrong directories or something? i dunno.

Share this post


Link to post
Share on other sites
SHIFAAU9 / SHIFAAH9

nah that can't be it since i tried:

-scripts folder

-modloader folder

-game directory

even the  "Mss" folder!

 

the result is the same in both games (as for SA works perfectly, no problems with that game)

Share this post


Link to post
Share on other sites
Vindsole

Is there a way to preserve PostFX settings? I'd like to save my radiosity U and V correction setting.

Share this post


Link to post
Share on other sites
Akiri

put both files in VC root folder,press ctrl+m, nothing shows

Share this post


Link to post
Share on other sites
The Hero

You probably haven't loaded gtadebug correctly. it has to be loaded the same way as other mods like skygfx. just don't touch debugmenu.dll, that one has to be in root under that exact name.

Share this post


Link to post
Share on other sites
zendex

how do i open it nothing shows its in the directory of san andreas (sa_debug.dll)

Share this post


Link to post
Share on other sites
GTAVlookscool

Wtf, the download only has debugmenu.dll and the instructions say "Include debugmenu_public.h in your plugin, define 'DebugMenuAPI gDebugMenuAPI'
globally somewhere and load the debugmenu.dll by calling 'bool DebugMenuLoad(void)'," how the f*ck do I just get it working?
Another comment says "Make sure it's named 'debugmenu.dll' and lies in your gta root directory.", am I meant to rename the file? Why isn't it already named the right thing??
I'm wanting to get this working for GTA III.

Share this post


Link to post
Share on other sites
Shred N Slash
3 minutes ago, GTAVlookscool said:

Wtf, the download only has debugmenu.dll and the instructions say "Include debugmenu_public.h in your plugin, define 'DebugMenuAPI gDebugMenuAPI'
globally somewhere and load the debugmenu.dll by calling 'bool DebugMenuLoad(void)'," how the f*ck do I just get it working?
Another comment says "Make sure it's named 'debugmenu.dll' and lies in your gta root directory.", am I meant to rename the file? Why isn't it already named the right thing??
I'm wanting to get this working for GTA III.

The .h and API files don't matter unless you're a developer. Place the .dll in your game directory and that's it.

Share this post


Link to post
Share on other sites
GTAVlookscool
On 1/2/2018 at 7:08 PM, Claude_Lib said:

Make sure that you have both debugmenu.dll and iii/vc/sa_debug.dll/asi where the game can find them.

Use DLL/ASI Loader for SA, it doesn't have one inbuilt.

Use the right Ctrl, not left one.

Where do I get that? (iii/vc/sa_debug.dll/asi)

  

1 hour ago, Shred N Slash said:

The .h and API files don't matter unless you're a developer. Place the .dll in your game directory and that's it.

Thanks bro, I'll try with a fresh install I guess.
I chucked the debugmenu.dll in the root directory, load the game and press control m (tried both control keys) and nothing happens.

https://i.imgur.com/FprJTUq.jpg


EDIT: okay I found the solution. I downloaded iii_debug.asi from https://www.mixmods.com.br/2017/09/iii-vc-sa-debug-menu.html and placed it in my scripts folder.
EDIT 2: Nevermind it's a much sh*ttier debug menu with essentially no options compared to the Youtube video I saw.

Edited by GTAVlookscool

Share this post


Link to post
Share on other sites
The Hero

boohoo

  • Like 5

Share this post


Link to post
Share on other sites
NiteOwl94

I don't wanna waste your time, but I can't figure out how to get the mouse to move the debug camera in VC.
I've held the LMB while dragging the mouse, but it doesn't work.
 

Share this post


Link to post
Share on other sites
Shred N Slash
17 hours ago, NiteOwl94 said:

I don't wanna waste your time, but I can't figure out how to get the mouse to move the debug camera in VC.
I've held the LMB while dragging the mouse, but it doesn't work.
 

Are you sure you've got 'Camera' movement selected rather than 'Player' in the menu?

Share this post


Link to post
Share on other sites
NiteOwl94
4 hours ago, Shred N Slash said:

Are you sure you've got 'Camera' movement selected rather than 'Player' in the menu?

Yes. I've toggled it both ways, and I still can't move the camera at all.

Share this post


Link to post
Share on other sites
The Hero

Did you even activate the camera? it should be ctrl-b and it used to be ctrl-d i think (i dunno how up to date the files are).

  • Like 1

Share this post


Link to post
Share on other sites
NiteOwl94

ctrl-b doesn't do anything. ctrl-d activates the camera, but the mouse doesn't move it.
I open the debug menu to make sure it's toggled to camera and not player.

Not trying to be dense, sorry. I've read all three pages here, and went over the readme's several times.

Edited by NiteOwl94

Share this post


Link to post
Share on other sites
AshGamer007
20 hours ago, NiteOwl94 said:

ctrl-b doesn't do anything. ctrl-d activates the camera, but the mouse doesn't move it.
I open the debug menu to make sure it's toggled to camera and not player.

Not trying to be dense, sorry. I've read all three pages here, and went over the readme's several times.

You have to click and hold left mouse and the camera will move

Share this post


Link to post
Share on other sites
NiteOwl94
11 hours ago, AshGamer007 said:

You have to click and hold left mouse and the camera will move

That is what I have been doing. And it is not working.
Maybe this will help showcase what I've been doing wrong(?) apparently:

 

Share this post


Link to post
Share on other sites
Ho Diver

SilentPatch shows up in the menu in GTA 3 but not in VC. Is it supposed to be like this or am I doing something wrong?

Share this post


Link to post
Share on other sites
AshGamer007

Police Car and Rhino while spawned with debug plugin spawns locked in III/VC (Not sure about SA)

Share this post


Link to post
Share on other sites
Akiri
Posted (edited)

I press ctrl+m and only features from other mods show up,I can‘t use debugmenu‘s function,I already put two .dll files into game directory。https://imgur.com/ejZ8wQg

 

Edited by Akiri

Share this post


Link to post
Share on other sites
Akiri

for vc

I change vc_debug.dll to vc_debug.asi,then put vc_debug.asi into "scripts" folder then it is loaded succesfully

Share this post


Link to post
Share on other sites
CleytonGames
gts.
18 minutes ago, Brookin said:

Sup,

could you recreate this debug menu too?

As if it were that easy.

Spoiler

zF4M1kc.png

 

  • Like 1
  • KEKW 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.