Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Diamond Casino Heist
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

      1. Events
    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA 6

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. Announcements

    2. Support

    3. Suggestions

The Hero

Debug menu

Recommended Posts

The Hero

Made a new release for gtadebug, mostly changes to VC

 

- change car colours of spawned vehicles in III and VC

- fixed bike spawning in VC (thanks Crspy!)

- change area in VC

- change player model in VC

  • Like 5

Share this post


Link to post
Share on other sites
B_Smiles

Excellent, now I can do away with that car spawner!

Thanks

 

could I make some suggestions?

- edit colour of zone names

- change colour of the big mission arrow (III / VC / SA) [since this is only doable via the executable, I think]

 

 

snap_1509269063.png

 

Edited by B_Smiles

Share this post


Link to post
Share on other sites
MightyMax

Made a new release for gtadebug, mostly changes to VC

 

- change car colours of spawned vehicles in III and VC

- fixed bike spawning in VC (thanks Crspy!)

- change area in VC

- change player model in VC

please add more features to debugmenu please for gta vice city,gta san andreas, gta 3

Share this post


Link to post
Share on other sites
The Hero

You probably didn't install it correctly. Make sure it's named 'debugmenu.dll' and lies in your gta root directory.

Share this post


Link to post
Share on other sites
ThirteenAG

Make sure it's named 'debugmenu.dll' and lies in your gta root directory.

What is this, 2005?
  • Like 3

Share this post


Link to post
Share on other sites
The Hero

What does the filename or file location have to do with the current year?

Edited by The Hero
  • Like 2

Share this post


Link to post
Share on other sites
ThirteenAG

Maybe you should acknowledge the things like modloader and the fact that it doesn't load dll?

Or do a better job with your releases, so there's no way people would be able to install them "incorectly"?

  • Like 1

Share this post


Link to post
Share on other sites
The Hero

So there's *no way*? Dude, how can I do that? please enlighten me. I explained in the readme:

"Put debugmenu.dll for your game into the game's root directory."

If people don't follow the installation instruction (not even plural, it's a single instruction) there's nothing I can do.

And why doesn't this work with modloader? Why does it prevent plugins from loading modules? That would sound more like a bug in modloader.

Edited by The Hero
  • Like 2

Share this post


Link to post
Share on other sites
ThirteenAG

It might as well be in the folder with the module(s) that utilize it. Yet you don't mention that, only root folder.

And instead of instructions like "unpack content of archive to modloader directory" we have this nonsense like "put this to root, rename this to asi if this and that, simple loader, dll, etc".

  • Like 4

Share this post


Link to post
Share on other sites
The Hero

Whatever, the instructions are clear. If you follow them, it works.

  • Like 2

Share this post


Link to post
Share on other sites
The Hero

New versions of both.

- debugmenu has fixed mouse y handling (it could be inverted by the menu setting)

- you can now load and save camera positions with the debug cam, oh and it also pans with the arrow keys

  • Like 5

Share this post


Link to post
Share on other sites
GuruGuru

I would love to have configurable key combos.Most of the time I trigger by accident the debug camera

  • Like 2

Share this post


Link to post
Share on other sites
BlackScout

I would love to have configurable key combos.Most of the time I trigger by accident the debug camera

Such as when riding a BMX and jumping at the same time. Ctrl + D =p
  • Like 1

Share this post


Link to post
Share on other sites
emrc01

does not work press ctrl+m and nothing shows

  • Like 1

Share this post


Link to post
Share on other sites
Claude_Lib

Make sure that you have both debugmenu.dll and iii/vc/sa_debug.dll/asi where the game can find them.

Use DLL/ASI Loader for SA, it doesn't have one inbuilt.

Use the right Ctrl, not left one.

  • Like 1

Share this post


Link to post
Share on other sites
Gu1k

cant access degub camera?, damn was excited to explore the cutscenes. i press ctrl+ D and nothing happens

Edited by Gu1k

Share this post


Link to post
Share on other sites
RegistaG

Had to reinstall VC again and now I only have these optionsE26FWCo.png

  • Like 1

Share this post


Link to post
Share on other sites
The Hero

And I assume you want the vc_debug entries too? Looks like you didn't install vc_debug properly.

Share this post


Link to post
Share on other sites
RegistaG

does it have to be a dll or can it be an asi, because in my installation it's an asi

Share this post


Link to post
Share on other sites
B_Smiles

When will we be able to use the special characters in gta3 / vc?

Share this post


Link to post
Share on other sites
The Hero

Both asi and dll should work.

 

B_Smiles: hm?

Share this post


Link to post
Share on other sites
B_Smiles

hm?

There's options on III & vc to change player models (including pedestrians) thing is, it also lists special01 to special 09? And when you click them, nothing happens. Will this be implemented? Would be cool to go around as curtly or catalina

Share this post


Link to post
Share on other sites
The Hero

No, I just put the whole ped ID range in there. I haven't thought about implementing CS actors in III yet, perhaps later.

Share this post


Link to post
Share on other sites
Sam Lake

arent "CS actors" in III technically just heads?

Share this post


Link to post
Share on other sites
_RJSingh_

hi,i have some problem with debugcam

"-Dragging the mouse or moving the left stick rotates the camera"

It isn't working,Can you check?

Share this post


Link to post
Share on other sites
The Hero

Have you clicked the left mouse button? Could be I worded that badly....

Share this post


Link to post
Share on other sites
_RJSingh_

So..Holding the left mouse button and moving around mouse works :) ,I think you should update instructions asap. ;)

Share this post


Link to post
Share on other sites
ChengizVlad09

So, how do I save configuration inside debug/debug menu? I've changed radiosity filter passes and color multiplier parameters, but upon starting a new game (starting sa.exe) they revert themselves back to default values. For example, I've changed radiosity filter passes to 2 - even inside the skygfx ini - but debugmenu is always showing value 1. 

 

Edited by ChengizVlad09

Share this post


Link to post
Share on other sites
The Hero

That's not possible, sorry :( And skygfx also resets some values under some circumstances...the multiple ini architecture didn't work too well with the debug menu.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.