Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    2. News

    1. Red Dead Redemption 2

      1. News
      2. Red Dead Online
    1. GTA Online

      1. After Hours
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Nick99

First person mod won't work on 1070

Recommended Posts

Nick99

Hi.

This is my first post, so I don't know if this is the right place to post this. If it's not, please let me know.

 

So, I downgraded GTA 4 from patch 8 to patch 7 and I proceed to install mods. Here's a list:

First person mod

Native trainer (version 6.5 I think.)

Safehouse mod

Subway driver mod

Abandoned railroad mod

Taxi side missions mod

icehancer 3.0

 

I have been unable to get the first person mod to work. I have

xlive.dll

scripthook.dll and

scripthookdotnet.asi

 

I'm including the log files

 

// -- GTA IV ASI LOADER LOG -- //
//-- © Alexander Blade 2008 -- //
C:\WINDOWS\system32\dsound.dll is loaded, address 0x592B0000
Hooking dsound proc named "DirectSoundCreate"
"DirectSoundCreate" hooked, address 0x592F66E0
Hooking dsound proc named "DirectSoundEnumerateA"
"DirectSoundEnumerateA" hooked, address 0x5930F0A0
Hooking dsound proc named "DirectSoundEnumerateW"
"DirectSoundEnumerateW" hooked, address 0x5930F0C0
Hooking dsound proc named "DllCanUnloadNow"
"DllCanUnloadNow" hooked, address 0x592F73D0
Hooking dsound proc named "DllGetClassObject"
"DllGetClassObject" hooked, address 0x592F0730
Hooking dsound proc named "DirectSoundCaptureCreate"
"DirectSoundCaptureCreate" hooked, address 0x5930EFA0
Hooking dsound proc named "DirectSoundCaptureEnumerateA"
"DirectSoundCaptureEnumerateA" hooked, address 0x5930F060
Hooking dsound proc named "DirectSoundCaptureEnumerateW"
"DirectSoundCaptureEnumerateW" hooked, address 0x5930F080
Hooking dsound proc named "GetDeviceID"
"GetDeviceID" hooked, address 0x5930F3B0
Hooking dsound proc named "DirectSoundFullDuplexCreate"
"DirectSoundFullDuplexCreate" hooked, address 0x5930F0E0
Hooking dsound proc named "DirectSoundCreate8"
"DirectSoundCreate8" hooked, address 0x592FC270
Hooking dsound proc named "DirectSoundCaptureCreate8"
"DirectSoundCaptureCreate8" hooked, address 0x5930EED0
Loading ASI C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\FirstPerson.asi
ASI loaded : C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\FirstPerson.asi, Address 0x514D0000
Loading ASI C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\ScriptHookDotNet.asi
ASI loaded : C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\ScriptHookDotNet.asi, Address 0x510C0000
2017-05-25 18:47:08 - Initializing ScriptHookDotNet v1.7.1.7 BETA (on GTA IV version 1.0.7.0 with C++ Hook version 0.5.1)
Log start: Thu May 25 18:47:07 2017
The first person mod log is below.
-----------------------------------------------
[iNFO] GTA IV Script Hook 0.3.0c - Initialized
[iNFO] Process base address: 0x13c0000
[iNFO] Using game version 3.0.1
[iNFO] Awaiting game thread creation
Log start: Thu May 25 18:47:08 2017
-----------------------------------------------
[iNFO] GTA IV Script Hook 0.5.1 - © 2009, Aru - Initialized
[iNFO] Process base address: 0x13c0000
[iNFO] Auto detecting game version
[iNFO] Using game version 1.0.7
I hope all of this information will be useful.

 

Share this post


Link to post
Share on other sites
Rocky0910

I've never had issues with the mods. Try replacing the scripthook files from simple native trainer's .zip file. that might work.

Share this post


Link to post
Share on other sites
Jxcob

You need AdvancedHook.dll, also xlive messes up alotta mods heres the files I use if u want em.. If it doesnt work use ur own dsound.dll (cant have dsound and xlive at same time)

 

https://www.mediafire.com/?sz00p6vd78s7z3o

Share this post


Link to post
Share on other sites
Nick99

You need AdvancedHook.dll, also xlive messes up alotta mods heres the files I use if u want em.. If it doesnt work use ur own dsound.dll (cant have dsound and xlive at same time)

 

https://www.mediafire.com/?sz00p6vd78s7z3o

No luck. The native trainer works fine. I have xlive_d.dll and xlive.dll and no dsound.dll. So there's no conflict between the two files. How do I know if my asi loader is up to date? Maybe that's the problem. FirstPerson.asi might not be loading. Here are the logs.

Log start: Tue Jun 06 16:03:32 2017
-----------------------------------------------
[iNFO] GTA IV Script Hook 0.3.0c - Initialized
[iNFO] Process base address: 0xe70000
[iNFO] Using game version 3.0.1
[iNFO] Awaiting game thread creation
[iNFO] Script Hook - Shutdown
For some reason the script hook shutsdown. What causes that? Maybe that's the root cause. I also don't know why it says my game version is 3.0.1 when I'm running 1.0.7.0
// -- GTA IV ASI LOADER LOG -- //
//-- © Alexander Blade 2008 -- //
C:\WINDOWS\system32\dsound.dll is loaded, address 0x58730000
Hooking dsound proc named "DirectSoundCreate"
"DirectSoundCreate" hooked, address 0x587766E0
Hooking dsound proc named "DirectSoundEnumerateA"
"DirectSoundEnumerateA" hooked, address 0x5878F0A0
Hooking dsound proc named "DirectSoundEnumerateW"
"DirectSoundEnumerateW" hooked, address 0x5878F0C0
Hooking dsound proc named "DllCanUnloadNow"
"DllCanUnloadNow" hooked, address 0x587773D0
Hooking dsound proc named "DllGetClassObject"
"DllGetClassObject" hooked, address 0x58770730
Hooking dsound proc named "DirectSoundCaptureCreate"
"DirectSoundCaptureCreate" hooked, address 0x5878EFA0
Hooking dsound proc named "DirectSoundCaptureEnumerateA"
"DirectSoundCaptureEnumerateA" hooked, address 0x5878F060
Hooking dsound proc named "DirectSoundCaptureEnumerateW"
"DirectSoundCaptureEnumerateW" hooked, address 0x5878F080
Hooking dsound proc named "GetDeviceID"
"GetDeviceID" hooked, address 0x5878F3B0
Hooking dsound proc named "DirectSoundFullDuplexCreate"
"DirectSoundFullDuplexCreate" hooked, address 0x5878F0E0
Hooking dsound proc named "DirectSoundCreate8"
"DirectSoundCreate8" hooked, address 0x5877C270
Hooking dsound proc named "DirectSoundCaptureCreate8"
"DirectSoundCaptureCreate8" hooked, address 0x5878EED0
Loading ASI C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\FirstPerson.asi
ASI loaded : C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\FirstPerson.asi, Address 0x60FF0000
Loading ASI C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\ScriptHookDotNet.asi
ASI loaded : C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\ScriptHookDotNet.asi, Address 0x57050000
Loading ASI C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\Trainer.asi
ASI loaded : C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\Trainer.asi, Address 0x54C70000
Loading ASI C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\Trainertbogt.asi
ASI loaded : C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\Trainertbogt.asi, Address 0x04D60000
Loading ASI C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\Trainertlad.asi
ASI loaded : C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\Trainertlad.asi, Address 0x77C00000
Scratch that. I think my asi loader is up to date due to the fact this log was produced.
ScriptHookDotNet log:
2017-06-06 16:03:33 - Initializing ScriptHookDotNet v1.7.1.7 BETA (on GTA IV version 1.0.7.0 with C++ Hook version 0.5.1)
2017-06-06 16:04:53 - Direct3D device created!
2017-06-06 16:04:54 - SEARCHING FOR SCRIPTS...
2017-06-06 16:04:54 - DONE! No DotNet script found!
2017-06-06 16:04:54 - INFO: Phone number checks are not available!
2017-06-06 16:06:26 - Direct3D device lost!
First person log:
Log start: Tue Jun 06 16:03:32 2017
-----------------------------------------------
[iNFO] GTA IV Script Hook 0.3.0c - Initialized
[iNFO] Process base address: 0xe70000
[iNFO] Using game version 3.0.1
[iNFO] Awaiting game thread creation
[iNFO] Script Hook - Shutdown
I feel that a premature and or uncommanded shutdown is taking place somehow. Am I right?
Script hook log:
Log start: Tue Jun 06 16:03:32 2017
-----------------------------------------------
[iNFO] GTA IV Script Hook 0.5.1 - © 2009, Aru - Initialized
[iNFO] Process base address: 0xe70000
[iNFO] Auto detecting game version
[iNFO] Using game version 1.0.7
[iNFO] [simpleTrainer] Thread started
[iNFO] [simpleTrainer_TBOGT] Thread started
[iNFO] [simpleTrainer_TLAD] Thread started
[iNFO] [scriptHookDotNet] Thread started
[iNFO] Car model available... spawning it!
[iNFO] Car model available... spawning it!
[iNFO] Car model available... spawning it!
[iNFO] [scriptHookDotNet] Thread killed
[iNFO] [simpleTrainer_TLAD] Thread killed
[iNFO] [simpleTrainer_TBOGT] Thread killed
[iNFO] [simpleTrainer] Thread killed
[iNFO] Script Hook - Shutdown
I don't know what this log is for, but I'll include it anyways.
full path: C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\
redirecting CreateDevice
redirecting CreateDevice
initialising shader environment
unable to create depthStencilSurface (hr=-2005530516)
redirecting device->Reset
initialising shader environment
unable to create depthStencilSurface (hr=-2005530516)
I hope I'm not breaking any rules that might consider this spam or something with all of this information. Let me know If I am.
Thanks.

I've never had issues with the mods. Try replacing the scripthook files from simple native trainer's .zip file. that might work.

If your'e telling me to replace the scripthook files in my game directory with the one in the .zip file, that dosen't seem to have had any impact. I hope I understood your idea.

Share this post


Link to post
Share on other sites
~Tiger~

Hi.

This is my first post, so I don't know if this is the right place to post this. If it's not, please let me know.

 

I'm moving your topic to our dedicated Modding Forum buddy :^:

Share this post


Link to post
Share on other sites
Nick99

 

Hi.

This is my first post, so I don't know if this is the right place to post this. If it's not, please let me know.

 

I'm moving your topic to our dedicated Modding Forum buddy :^:

 

Thanks.

Share this post


Link to post
Share on other sites
Jxcob

Try using dsound instead of xlive.. also try looking up all the files on google, AdvancedHook.dll, ScriptHookDotNet.asi, ScriptHook.dll,

Share this post


Link to post
Share on other sites
Nick99

Try using dsound instead of xlive.. also try looking up all the files on google, AdvancedHook.dll, ScriptHookDotNet.asi, ScriptHook.dll,

I'm almost positive I have all the files from a Google search. Out of curiosity, what's the difference between xlive.dll and dsound.dll?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.