Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (91,862 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

  • 0
Sign in to follow this  
kaetsyth

Unhandled Exception @ 004bb164

Question

kaetsyth

Hi,

 

I have been playing VC since a couple of weeks and modded it a bit after I finish it 100%. I have both Steam and retail version but I did start on Steam to continue on retail due to better cleo and mod support.

 

Yesterday, my game crashed while playing the slow-motion crap for a stunt, it was on a previously completed UJ spot. I didn't pay attention as I do have from time to time some random crashes, but today I encountered the same bug. So I guessed it wasn't right and that there was something wrong with UJ spots and my game. Not everytime but after at best 4 or 5 stunts where UJ are, I get an Unhandled Exception c0000005 at address 004bb164.

 

So far, I tried :

 

- playing 1.0 retail, bloodpatch, 1.1, Steam = same crash

- turning off cleo

- playing w/o SilentPatch

- playing w/o the ddraw patch

- playing w/o Ginput

- reinstalling retail, both w/ or w/o the radios

- beginning a new game, doing 4 or 5 UJs, going again through them = no crash

- after beginning this new game, loading my savegame and going through them = crash after one or two

- deleting the .set file

- adding the game to DEP

- running the game as admin, 98/Millenium compatibility, etc.

 

I play with the frame limiter turned on and with widescreen off.

 

With everything I tried, I'm almost sure that it's the savegame itself that's corrupted. I never saved at Cherry Poppers. I do sometimes have some other crashes i.e. when picking a car from the SA garages, but it barely happens, like twice or three times in 150 hours playtime, while you can get this exception while going through some already completed UJ.

 

I barely mod my game, I've been playing with cleo for a mod or 2 at max, with SilentPatch, GInput and ddraw, and it's been like this for a very long time. I didn't modify my savegame or w/e before I encounter this bug.

 

I uploaded the savegame on GTASnP if it can be of any interest for anyone. Does anyone know how I could fix this bug or if the savegame is permanently broken ?

 

Link : http://gtasnp.com/OXkfUB

 

Thanks

Edited by kaetsyth

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
kaetsyth

Funny, just started the game, loaded the savegame, jumped on the PCJ in the Links View garage where I saved and I had this Unhandled Exception while Tommy getting on the bike. I always do stunts on PCJ, didn't try to go through the UJ with another vehicle, I'll give it a try, maybe it's the PCJ that's screwed up :(

 

Update: Crash at first UJ south of Malibu Club with the Comet stolen from Leaf Links.

 

Guess something is really wrong with my savegame...

 

Another update: was casually biking over Downtown and got the crash with that same address 15 minutes after starting playing. Even if the UJ seems to force to trigger the exception, it also happens randomly. :(

 

I have a Mac at home, gonna try on the Mac version of the game.

​Update: my savegame doesn't work even after a SnP conversion with my Steam version of the game for OSX, doesn't matter anyway since on a new game I don't encounter this exception, that means my savefile is probably corrupted.

 

Update 4 : game instant crashes with that savegame when I turn frame limiter off, with that same address

 

Update 5 : did all the jumps from the mission G-Spotlight and a couple of them on Mainland, the ones who seem to make the game crash are located around Washington Beach (south of Malibu Club, next to the VCPD HQ and Bunch of Tools, plus the ones from PCJ Playground).

Edited by kaetsyth

Share this post


Link to post
Share on other sites
  • 0
spaceeinstein

I'm guessing you have broken CLEO scripts. Can you list all the ones you have installed and where you had downloaded them?

Edited by spaceeinstein

Share this post


Link to post
Share on other sites
  • 0
kaetsyth

I got all my mods from here, I played with the Complete Mission Loader to replay a couple of missions (Sir, yes Sir, Gun Runner, Mall Shootout and Cap the Collector), and with the Cleo scripts given with the friendly updated SCM (spawns some vehicles).

Thing is since the second time it crashed I completely turned off cleo and yet I still encounter that exception.

Update: even tried to switch back to the original SCM but no more luck. My game is currently unmodded.

 

Update: installed the retail game on a computer where it had never been installed before, stock game w/o addons, and yet the same exception occurs. I guess the savegame is corrupted but I don't know how to fix it. :/

 

Update: I'm starting to think this may be due to the global timer. I know there are some glitch that appens around 37 and 74 hours. The fact that the game instantly crashes if I turn frame limiter off, considered that my savegame has 151:47 of playing time and mainly during UJ slow-mo camera make me think it could be tied to the global timer. I tried to use SnP's beta timer reset but the savegame doesn't load if I use it. I also save on two differents file each time, that means I can rollback to a previous save if needed. My previous save has a playing time stat of 151:13 and encounters the bug too. The glitch seems to occur at 4474 minutes. 4474 x 2 = 8948 = 149.1 hours, which is less than my current playing time, even though I can't really tell when this glitch occured since I don't often go through UJ spots.

 

Update 4: Read the thread about the III/VC glitches and the timer part. My game also freezes a couple of real-time seconds after I take an adrenaline.

 

I think resetting the timers would do the trick - but I don't find any tool or way to do it without having to hex edit the savegame.

Edited by kaetsyth

Share this post


Link to post
Share on other sites
  • 0
spaceeinstein

If a broken CLEO script damaged your save, it doesn't matter if you turn off CLEO. You would still be loading a damaged save. When you say "same crash", does that happen at the same exact address to all EXE versions that you've tried?

Share this post


Link to post
Share on other sites
  • 0
kaetsyth

Yes. It's the same address each time. Played a bit this morning and the game seems to run normally apart when the game has to turn on slow-motion - adrenaline pills or while performing a UJ. And it still instant freezes with that very same exception address when I turn frame limiter off.

Edited by kaetsyth

Share this post


Link to post
Share on other sites
  • 0
kaetsyth

Save file fixed by OrionSR (see III/VC save games glitch thread). Thanks to anyone who helped!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.