Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
      4. Frontier Pursuits
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. DLC
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
      7. The Diamond Casino Heist
    2. Grand Theft Auto Series

    3. GTA 6

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA IV Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA SA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA VC Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA III Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

Claude_Lib

GTA IV Patch 1.0.8.0/EfLC Patch 1.1.3.0

Recommended Posts

Official General

Apparently, someone did fix scripthook completely, but nobody knew about it. A friend got the link from FiveM devs, he then gave it to me to test it, and it spawned all cars and player models without any issues whatsoever. GET IT HERE.

 

Edit: EFLC seems to refuse to start for me with the fixed scripthook and snt at the same time.

Edit 2: Yeah, this only appears to work for IV, but not EFLC.

 

Thanks, will give it a try real soon. Its a shame it don't work for EFLC though !

Share this post


Link to post
Share on other sites
gunziness

That's weird. Did you use the old scripthookhook that had a file called !ehook.asi? Try deleting that file, as well as the nativelist and nativeignore text files. Also, did you extract the scripthook itself from the archive (since it seems different from the original one)?

 

I used the scriphook it came within the .zip you linked. There were two files, scripthook, and scripthookhook, and I used both. There wasnt any !ehook.asi or nativelist/ignore text files neither.

 

 

 

Share this post


Link to post
Share on other sites
B Dawg

That's strange. Then I have no idea.

Share this post


Link to post
Share on other sites
cryptorelic

I was really surprised about this patch. I thought it couldn't get any worse after 1.0.7.0 (refused to use it at all), but now after testing 1.0.8.0 they seemed to have fixed a variety of huge performance/graphic problems.

 

I'm around 55% into the story now (going for 100%) and everything went just fine so far. Smooth 60+ FPS gameplay, only very little glitches every now and then.

They also seemed to have fixed the shadow sharpness and optimised the game a lot more for newer graphic cards, which really helps in gathering FPS + getting 1080p HD detailed graphics.

 

Before this patch got released I was using 1.0.4.0 and CitizenIV:MP for multiplayer.

Share this post


Link to post
Share on other sites
TWIST_OF_HATE

^

Yes, patch 8 did fix some stuff here and there, but they can do so much more.

Hope for new patch soon.

  • Like 1

Share this post


Link to post
Share on other sites
Wol321

Sadly I can say the same thing, 1.0.7.0 and 1.0.8.0 gives me practically the exact same performance. For running fine this game I can play it on Max setting (also draw distance) with a 30fps cap or with all on high and draw distance set to 20 at an almost constant 60fps. I've always found GTA IV's performance pretty random, I hear guys who runi it at 60+ fps at maximum settings and people who barely can play the game... Some years ago I had a GTX 650 (with 1 GB VRAM) that could run this game even better than my GTX 970. I'm hoping for a 1.0.9.0 patch for 10th anniversary, maybe this time we'll get rid of GFWL

  • Like 1

Share this post


Link to post
Share on other sites
iiCriminnaaL 49

Whenever I try to install the patch it just tells me that I got to make sure that GTA IV is installed correctly. Does anybody know why? Noting that my game has nothing wrong with its files.

Share this post


Link to post
Share on other sites
zanesix

I take it you don't have the steam version?

Share this post


Link to post
Share on other sites
iiCriminnaaL 49

I take it you don't have the steam version?

No, not the steam version.

Share this post


Link to post
Share on other sites
Nco06

Not sure why, but -availablevidmem in commandline doesn't work with EFLC 1.1.3.0 update (only -windowed part). Does anyone know about it? I have non-Steam version.

Share this post


Link to post
Share on other sites
Nco06

Kinda spamming but can I use Simple Native Trainer without downgrading 1.1.2.0 in EFLC? (non-Steam) I need an answer.

Share this post


Link to post
Share on other sites
zanesix

Kinda spamming but can I use Simple Native Trainer without downgrading 1.1.2.0 in EFLC? (non-Steam) I need an answer.

Not for EFLC directly, but if you must you can use this GTA IV only scripthook for patch 8 and then make them launch as DLCs using this. Then you should be able to use the trainer.

Share this post


Link to post
Share on other sites
Nco06

 

Kinda spamming but can I use Simple Native Trainer without downgrading 1.1.2.0 in EFLC? (non-Steam) I need an answer.

Not for EFLC directly, but if you must you can use this GTA IV only scripthook for patch 8 and then make them launch as DLCs using this. Then you should be able to use the trainer.

 

Seems like using asi mods became harder because of that. I hope it can be fixed anytime soon.

Share this post


Link to post
Share on other sites
Matt_STS

Does anyone knows if there's a way to make the Recoil Fix (shootstuff.asi) work with the latest GTA IV version? I have Xliveless 0.999b7 installed.

Share this post


Link to post
Share on other sites
cp1dell

Does anyone knows if there's a way to make the Recoil Fix (shootstuff.asi) work with the latest GTA IV version? I have Xliveless 0.999b7 installed.

I've had multiple people contact me about this, and the source of jenksta's script being gone because his website is gone. I don't have the source, but this is him explaining how the script works. Someone with IV scripting knowledge would probably be able to rewrite it.

 

"Basically in iv's CWeapon::Fire function there's a call to a CWeapon::CalculateShotTargetAccuracy which calculates the target offset for the weapon shot (based on the peds weapon accuracy multiplier, current anim, e.t.c.), in this function there's a check for player peds (only applies if you they don't have a target entity (auto aim)) which checks a flag in the games control pad structure (set if theres any buttons pressed on the controller), if not using the controller the inaccuracy multiplier used is 0.1, however when using a controller the multiplier is set to 0.6."

 

With that said, all his script did was force the multilplier for the player to 0.6. That way it didn't matter if you were using a controller or not. The player's accuracy multiplier would always be 0.6 - as it should be.

Edited by cp1dell
  • Like 1

Share this post


Link to post
Share on other sites
B Dawg

The links for manual down/upgrading are no longer working, so here are some new ones (older patches don't have installers included for lower size)

1070 - 1080

1120 - 1130

Edited by B Dawg
  • Like 4

Share this post


Link to post
Share on other sites
fiekert123

thanks for uploading those downgrade packs b dawg! you saved my ass in hours of trying fix it running in the first place.

Share this post


Link to post
Share on other sites
ViceBoy69

Just built a computer running xp  i have no updates installed on either game i prefer to play the games this way.

Share this post


Link to post
Share on other sites
hal210
On 4/27/2017 at 10:35 AM, Claude_Lib said:

Well, I thing I've got a problem. When I install some vehicle mods for police and police 2, taxi bug appear. It would be reasonable, if it wasn't because I installed vanilla non els mods... any clue?

" If you're using IV 1.0.8.0 or EfLC 1.1.3.0, use ThirteenAG's fork. "

 

Hi ,just wondering what  'RIL.Budgeted.asi'  is for ,haven't seen it before.

Is it specifically for the Taxi Bug error ?

Edited by hal210

Share this post


Link to post
Share on other sites
Claude_Lib

Yup, that's exactly it.

  • Like 1

Share this post


Link to post
Share on other sites
hal210

Thanks Claude_Lib !

Edited by hal210
name correction

Share this post


Link to post
Share on other sites
hal210
On 11/26/2018 at 6:52 PM, B Dawg said:

The links for manual down/upgrading are no longer working, so here are some new ones (older patches don't have installers included for lower size)

1070 - 1080

1120 - 1130

Anyone have 1040 ? It seems to be the only one missing if you want to go to a 1.4 game version.

 

Not a big deal but i'd like to setup a v1.0.4.0 game copy for testing a load of old mods i have stored ,quiet a few of them require game v.1.0.4.0 .

Edited by hal210

Share this post


Link to post
Share on other sites
Wol321
51 minutes ago, hal210 said:

Anyone have 1040 ? It seems to be the only one missing if you want to go to a 1.4 game version.

 

Not a big deal but i'd like to setup a v1.0.4.0 game copy for testing a load of old mods i have stored ,quiet a few of them require game v.1.0.4.0 .

In theory you should just download and install the .exe of 1.0.4.0 patch and then copy the old game's fonts (that have been changed in the 1.0.5.0 patch). Oh, and you'll may need xLiveLess too!

Follow this guide on Steam Community, in the .zip file there are all the files you need for downgrading the game. Of course downgrading to 1.0.4.0 patch won't downgrade the soundtrack too.

  • Like 1

Share this post


Link to post
Share on other sites
hal210

Oh  , doesn't sound too difficult and that link seems to have just what what i need ,cheers !

Edited by hal210

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 3 Users Currently Viewing
    0 members, 0 Anonymous, 3 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.