Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
      4. Frontier Pursuits
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Diamond Casino & Resort
      2. DLC
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA 6

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA IV Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA SA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA VC Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA III Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

Furry_Monkey

Crew Colour Editor

Recommended Posts

АВС

Right ho, thank you for the swift response and I'll see to installing Google Chrome. Given my history with computers it's far more likely to be something I've buggered up myself than a problem with the tool.

 

Update; I appear to be having less success with Chrome, for nothing at all happens when I attempt to follow the link, I've ensured that the 'javascript:' prefix is present, yet I'm not so much as redirected to a blank page upon attempting to open the bookmark, the menu simply disappears and I'm left on the Social Club page. If I manually enter it in the address bar and hit the enter key, the previous address reappears.

 

Another update; I've finally manged to make it work, God only knows how, but the colour editing window has appeared at long last!

 

Nailed it! Now I can finally transform my beloved Lampadati Pigalle into a replica of Leonid Breznev's Citroen SM! Marvellous tool, thank you for the help.

Edited by АВС

Share this post


Link to post
Share on other sites
Furry_Monkey

Right ho, thank you for the swift response and I'll see to installing Google Chrome. Given my history with computers it's far more likely to be something I've buggered up myself than a problem with the tool.

 

Update; I appear to be having less success with Chrome, for nothing at all happens when I attempt to follow the link, I've ensured that the 'javascript:' prefix is present, yet I'm not so much as redirected to a blank page upon attempting to open the bookmark, the menu simply disappears and I'm left on the Social Club page. If I manually enter it in the address bar and hit the enter key, the previous address reappears.

 

Another update; I've finally manged to make it work, God only knows how, but the colour editing window has appeared at long last!

 

Nailed it! Now I can finally transform my beloved Lampadati Pigalle into a replica of Leonid Breznev's Citroen SM! Marvellous tool, thank you for the help.

 

Very happy you got it working. Kudos for sticking at it and figuring it out :)

Share this post


Link to post
Share on other sites
xFaK10

Hey @Furry_Monkey, my image doesn't load.

Link of the image https://vignette2.wikia.nocookie.net/gtawiki/images/3/35/Tempesta-GTAO-front.png/revision/latest?cb=20161213203018

Social Club website https://socialclub.rockstargames.com/crew/xfakers/manage/edit

Programs I use Razer Cortex, Steam. Malware Bytes, Overwolf, Razer Synapse and Steelseries Engine 3.

I also changed some things in my hosts file [To bypass Spotify ads [i can't acess their website in my browser, only the program so idk if that changes the script too]

http://imgur.com/a/2fm6c

 

Thanks in advance

Edited by xFaK10

Share this post


Link to post
Share on other sites
rendub

Yeah, dead for me as well. Nothing loads when I click on the bookmark.

Share this post


Link to post
Share on other sites
Furry_Monkey

 

 

Hey @Furry_Monkey, my image doesn't load.

Link of the image https://vignette2.wikia.nocookie.net/gtawiki/images/3/35/Tempesta-GTAO-front.png/revision/latest?cb=20161213203018

Social Club website https://socialclub.rockstargames.com/crew/xfakers/manage/edit

Programs I use Razer Cortex, Steam. Malware Bytes, Overwolf, Razer Synapse and Steelseries Engine 3.

I also changed some things in my hosts file [To bypass Spotify ads [i can't acess their website in my browser, only the program so idk if that changes the script too]

http://imgur.com/a/2fm6c

 

Thanks in advance

 

It does work if you change the protocol from Http to Https - there may be something wrong with their SSL certificate.

 

Try this instead: http://vignette2.wikia.nocookie.net/gtawiki/images/3/35/Tempesta-GTAO-front.png

 

 

 

 

Yeah, dead for me as well. Nothing loads when I click on the bookmark.

 

My hosting company upgraded my server over the weekend so it was offline for a couple of hours today while everything was repointed. It's all up and running now :)

Edited by Furry_Monkey

Share this post


Link to post
Share on other sites
Riprock

Anone been successful having a car with two different crew colours (primary & secondary). Wanting to have a Dominator with pure white primary with pure black secondary. When I switch crews and change either colour, it changes for whole car.

Share this post


Link to post
Share on other sites
N. Man

Alright, so where exactly do I paste the code? I have no idea how to use this thing. I've got java and chrome both efficiently working.

 

Edit: Alright, so I've pasted the code as a bookmark, but nothing happens when I click on said bookmark.

Edited by NaijaMango

Share this post


Link to post
Share on other sites
Furry_Monkey

Alright, so where exactly do I paste the code? I have no idea how to use this thing. I've got java and chrome both efficiently working.

 

Edit: Alright, so I've pasted the code as a bookmark, but nothing happens when I click on said bookmark.

 

Sorry - long time no see!

 

Are you clicking the bookmark when you're on the social club, on the "edit crew" page where you select the colour? If you're clicking it anywhere else then it won't do anything.

 

Also, note for anyone interested, I've just upped the number of "recently used colours" from 10 to 24. You may need to clear your browser cache to see the update but I'm guessing it'll be okay for most people without that.

Share this post


Link to post
Share on other sites
Dark_Razar

For some reason it actually doesn't save anymore: It keeps giving the same error indefinitely.

Share this post


Link to post
Share on other sites
Furry_Monkey

For some reason it actually doesn't save anymore: It keeps giving the same error indefinitely.

 

Can you give me the hex value of the colour you're trying to save?

Share this post


Link to post
Share on other sites
jason_stanfield

I'm currently using Chrome Version 63.0.3239.84 (Official Build) (64-bit), OS X 10.13.1 High Sierra, and the customizer doesn't appear to be working for me, whereas it did a few months ago when I last used it.

 

I checked the top post in this topic and saw there was a November update, so just to make sure I had everything up to date:

 

- I highlighted the entire text starting with "javascript," and pressed CTRL C

 

- went to my bookmark, entitled Crew Color Customizer

 

- option-click, chose Edit

 

- highlighted text in URL field, CTRL V, then pressed Save;

 

When it worked before, I would go to my crew edit page, click on my Customizer link, and a box appeared per the design - I could open up images, or simply dial in a desired hex code, and eventually get the proper code.

 

Now, clicking on my Customizer link does nothing. If I left- or right-click on the Crew Color box, the page's normal color chooser appears.

 

I'm not a code guy, so I have no idea what all the hieroglyphics mean, but I'm pretty good at following instructions. I know how to use Chrome's Inspect feature, and remember enough "suffixes" to get the color saved, but I do miss being able to open images directly.

 

Am I doing something wrong?

Share this post


Link to post
Share on other sites
Terrazi Terrajin

It was working last night, but now it isn't. I open the edit page as normal and click the bookmark but nothing happens at all. Did anything change?

Share this post


Link to post
Share on other sites
Furry_Monkey

It was working last night, but now it isn't. I open the edit page as normal and click the bookmark but nothing happens at all. Did anything change?

Yes, the internet changed :p

 

There was a pretty large issue with the UK internet infrastructure. It's coming back up now so should be working soon enough.

Share this post


Link to post
Share on other sites
Terrazi Terrajin

 

It was working last night, but now it isn't. I open the edit page as normal and click the bookmark but nothing happens at all. Did anything change?

Yes, the internet changed :p

 

There was a pretty large issue with the UK internet infrastructure. It's coming back up now so should be working soon enough.

 

Damn really? Anyway thanks for the snappy response! One last question, when you pick a color from an image using it, how much do you have to alter the brightness to get it to be correct? Someone posted somewhere (can't find it now) that it comes out too bright, and advised others to lower it by a certain amount.

Share this post


Link to post
Share on other sites
Furry_Monkey

 

 

It was working last night, but now it isn't. I open the edit page as normal and click the bookmark but nothing happens at all. Did anything change?

Yes, the internet changed :p

 

There was a pretty large issue with the UK internet infrastructure. It's coming back up now so should be working soon enough.

 

Damn really? Anyway thanks for the snappy response! One last question, when you pick a color from an image using it, how much do you have to alter the brightness to get it to be correct? Someone posted somewhere (can't find it now) that it comes out too bright, and advised others to lower it by a certain amount.

 

 

It varies. Just play about with it to find what you prefer. If it was something that you could calculate then I'd put an option on there to automatically do it, but truth is we don't know exactly what happens to the colour you pick, other than "it changes a bit".

Share this post


Link to post
Share on other sites
ImTheWalrus

It's not working for me anymore for some reason. I'm doing what i've always done and the additional window doesn't pop up anymore when i open the bookmark.

Other times i get what looks like a bug that looks like it does open but it's down in the left corner of the page.

 

 

Edited by ImTheWalrus

Share this post


Link to post
Share on other sites
Furry_Monkey
1 hour ago, ImTheWalrus said:

It's not working for me anymore for some reason. I'm doing what i've always done and the additional window doesn't pop up anymore when i open the bookmark.

Other times i get what looks like a bug that looks like it does open but it's down in the left corner of the page.

 

  Reveal hidden contents

 

Thanks for letting me know.  There is a problem with the SSL certificate on my site - it's expired but should automatically renew.  I've contacted the hosting company but don't expect to get it fixed for a few days.

 

However, if you allow your browser access to the site with the expired certificate then you should be able to use the bookmarklet again.

 

Just go to https://www.furrymonkey.co.uk and (click "advanced" if you have to) and then "proceed to site" (or something along those lines - it differs from browser to browser).  Once you've done that and you've access my site then the bookmarklet should start to work for you again.

Share this post


Link to post
Share on other sites
ImTheWalrus
22 hours ago, Furry_Monkey said:

Thanks for letting me know.  There is a problem with the SSL certificate on my site - it's expired but should automatically renew.  I've contacted the hosting company but don't expect to get it fixed for a few days.

 

However, if you allow your browser access to the site with the expired certificate then you should be able to use the bookmarklet again.

 

Just go to https://www.furrymonkey.co.uk and (click "advanced" if you have to) and then "proceed to site" (or something along those lines - it differs from browser to browser).  Once you've done that and you've access my site then the bookmarklet should start to work for you again.

Thank you for getting back to me so quickly! I'm gonna try again following these instruction and i'll let you know what happens.

Also you're awesome for creating this tool and keeping it running for so long, just letting you know :cool:

_____

 

Update: using the method provided above it works like a charm once again, for anyone wondering.

Cheers Monkey!

Edited by ImTheWalrus

Share this post


Link to post
Share on other sites
ZKSchismo
On ‎7‎/‎7‎/‎2018 at 9:18 PM, ImTheWalrus said:

Thank you for getting back to me so quickly! I'm gonna try again following these instruction and i'll let you know what happens.

Also you're awesome for creating this tool and keeping it running for so long, just letting you know :cool:

_____

 

Update: using the method provided above it works like a charm once again, for anyone wondering.

Cheers Monkey!

Yup, was wondering what was going on. But the above method by Furry Monkey has worked for me as well. Thanks alot

Share this post


Link to post
Share on other sites
Furry_Monkey

Thanks guys, for confirming you were able to get it working again.

 

I've jumped through the relevant hoops and I'm now just waiting for my new certificate to be issued and then we'll be back to business as usual.

Share this post


Link to post
Share on other sites
Furry_Monkey

Finally!

 

I'll be with a new host by the time it needs doing again because those guys were beyond inept.

 

Back to secure & normal again, so colour away!

Share this post


Link to post
Share on other sites
Baddtraxx

Beat me if I dig this out but I thought this may work instead of the old methods, but instead I get this error now
19b38a43dd.png

apparently Cuccstar wont let us have fancy colors anymore.
For example, I tried to get a true white there (ingame default whites are washed out). #FFFFFF, #FEFEFE or #F9F9F9 all dont work.
Strangely the Halloween Red (#FF1003AA) worked. Odd.

I hope I can get some assistance here.

Edited by Baddtraxx

Share this post


Link to post
Share on other sites
Furry_Monkey
On 10/5/2018 at 1:13 PM, Baddtraxx said:

Beat me if I dig this out but I thought this may work instead of the old methods, but instead I get this error now
19b38a43dd.png

apparently Cuccstar wont let us have fancy colors anymore.
For example, I tried to get a true white there (ingame default whites are washed out). #FFFFFF, #FEFEFE or #F9F9F9 all dont work.
Strangely the Halloween Red (#FF1003AA) worked. Odd.

I hope I can get some assistance here.

 

Did you keep trying to save it?  If you've not got up to 32 then it's not tried all potential combinations.

 

Edit: I just tried it and it saved #FFFFFF on attempt 7.  Dude, RTFM :p

Edited by Furry_Monkey

Share this post


Link to post
Share on other sites
Baddtraxx
On 10/7/2018 at 5:16 PM, Furry_Monkey said:

 

Did you keep trying to save it?  If you've not got up to 32 then it's not tried all potential combinations.

 

Edit: I just tried it and it saved #FFFFFF on attempt 7.  Dude, RTFM :p

aaight thx my dude, will try out later. will update if it worked. I mean with how R* made the new site and all it could've been they did anti-edit like they did with logos. luckily mine's still there.

Share this post


Link to post
Share on other sites
senniee
On 2/18/2016 at 6:59 PM, Furry_Monkey said:

If you used this prior to October 12th 2016 then you need to update your existing bookmark.

 

I've written a little application to help you edit your crew colour. You can either enter a hex value, use the colour picker, or load an image from a URL and pick a colour directly from it. Rather than have some massive piece of code in a bookmark I've simplified the whole thing into one line. Simply copy and paste the following code...

javascript:(function(){var script=document.createElement('script');script.src="//www.furrymonkey.co.uk/_external/gta/edit-crew-colour.js";document.getElementsByTagName('head')[0].appendChild(script);})()

Then create a new bookmark in your browser and call it something like "Edit crew colour", and paste the code you just copied as the address or URL.

 

When you go to your crew page and you're in the edit tab (where the crew colour can be set), just click the bookmark when you want to edit the colour and it will pop up the dialog as shown here...

 

custom-crew-colour-editor-1.png

 

 

Use that dialog to set your crew colour to anything you like, and then click "ok" to set it. You must also save your changes with the save button at the bottom of the page, as before. If it tells you that it couldn't save for some reason then it will tell you it was attempt 1 of 32 (currently - that may change). Click save again and it will try a different combination that may save your colour. It's rare that you'll have to do this more than a few times and unlikely you'll ever find a colour that won't save with any of the 32 tries.

 

If you want to change the colour again you can either click the bookmark or just click the colour button on the page. Once the script is loaded it will stay available until you leave the page.

 

To use an image to choose a colour, either type or paste the image URL into the text box in the dialog and press enter to load the image...

 

custom-crew-colour-editor-2.png

 

 

You can then click anywhere in the image to select the colour under the mouse. This is helpful for when you have photos of vehicles and you're trying to match the colour. It will never be exact as the colours in the game are slightly different from what you see in real life, but you can get close enough and then make minor adjustments from there, should you need to.

 

 

If you have any requests for help with finding the right colour then please don't ask for them here. There's already a very good thread where there are lots of people helping out with that...

 

http://gtaforums.com/topic/782581-kustom-crew-color-request-rare-share/

 

 

If you have any problems with this utility then just let me know.

 

 

 

Update notes

 

28th November, 2017

Upped the number of "recently used colours" to 24, like it should have been from the start! Many thanks to @Randoom. for the heads-up about that.

 

15th June, 2016

Added a "recently used colours" box where any colours you recently saved are shown, up to a maximum of 10. (It only shows colours saved from now on.)

 

9th June, 2016

Fixed issue where the colour picker was picking the wrong colour if the browser page had been scrolled at all.

 

8th June, 2016

Updated website to use https protocol, in order to work with the recently updated Social Club.

Where do I put the code and how do I do this? Is there a tutorial somewhere?

Share this post


Link to post
Share on other sites
badfish5051

hey, was wondering if there's any recent issues with the crew color tool, I used it fine yesterday but this morning I can't get it to work on different browsers and computers

Share this post


Link to post
Share on other sites
Frenchtone83
Posted (edited)

^ Same here, it's still working on a page I had opened this morning but tried to open a new one now and it's not working...

Edited by Frenchtone83

Share this post


Link to post
Share on other sites
Furry_Monkey
1 hour ago, badfish5051 said:

hey, was wondering if there's any recent issues with the crew color tool, I used it fine yesterday but this morning I can't get it to work on different browsers and computers

 

1 hour ago, Frenchtone83 said:

^ Same here, it's still working on a page I had opened this morning but tried to open a new one now and it's not working...

 

Sorry guys, but the SSL certificate on my site has expired and I don't actually plan on renewing it, so the script can't be loaded on the Social Club any more.  I've kept it going purely for this for nearly 3 years, but it's time to say goodbye.

 

However, I can modify it so the bookmark includes the whole script, rather than injecting it from my site.  That will fix the issue with the script being "insecure".  So give me a little while and I'll get the 1st post updated with instructions on how to use that instead.

Share this post


Link to post
Share on other sites
Frenchtone83
13 hours ago, Furry_Monkey said:

 

 

Sorry guys, but the SSL certificate on my site has expired and I don't actually plan on renewing it, so the script can't be loaded on the Social Club any more.  I've kept it going purely for this for nearly 3 years, but it's time to say goodbye.

 

However, I can modify it so the bookmark includes the whole script, rather than injecting it from my site.  That will fix the issue with the script being "insecure".  So give me a little while and I'll get the 1st post updated with instructions on how to use that instead.

Well it's understandable, you've kept this going for so long, thank you ever so much for creating the script, "hosting" it and allowing so many of us to easily change crew colours, it has been much appreciated and I think many of us took it for granted.

If you ever need a hand in game, I for one would be happy to help.

 

 

 

 

Share this post


Link to post
Share on other sites
badfish5051
On 7/23/2019 at 1:11 PM, Furry_Monkey said:

 

 

Sorry guys, but the SSL certificate on my site has expired and I don't actually plan on renewing it, so the script can't be loaded on the Social Club any more.  I've kept it going purely for this for nearly 3 years, but it's time to say goodbye.

 

However, I can modify it so the bookmark includes the whole script, rather than injecting it from my site.  That will fix the issue with the script being "insecure".  So give me a little while and I'll get the 1st post updated with instructions on how to use that instead.

custom colors are literally the only reason I play this game, it makes collecting cars that much more satisfying, and your tool is the only way I've ever gotten them to work. never had any luck with the inspect element method, or any other bookmark tool out there. I hope it gets online soon and isn't too much harder to use. thanks for your service for all these years. you are literally one of the only things that made this game playable for me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 2 Users Currently Viewing
    0 members, 0 Anonymous, 2 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.