Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (91,318 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

pep legal

San Andreas Ambient Sounds - SAAS

Recommended Posts

Eevee™ 🎲

EDIT: No more crashes :) So yeah, this is one of the best CLEO sound mods Ive downloaded!

Edited by SolidEevee

Share this post


Link to post
Share on other sites
TomBomb

Works fine for me. Got no Error, everything is perfect. I combine it with Insanity Audio, GS Insanity, and Lots of CLEO Mods, didn't get any Error a Single time. Perfect! Here's some cookies :cookie::cookie::cookie::cookie::cookie::cookie::cookie:

Share this post


Link to post
Share on other sites
Junior_Djjr

A guy sent to me.

 

http://pastebin.com/7VtzP19F

 

He said that's a crash when add a new car using fastman92 limit adjuster.

Occurs when enter in the game.

Edited by Junior_Djjr

Share this post


Link to post
Share on other sites
Jitterdoomer

Is there any way to test out Black Project's siren because the siren is different from PS2 version on the PC port.

Share this post


Link to post
Share on other sites
pep legal

A guy sent to me.

 

http://pastebin.com/7VtzP19F

 

He said that's a crash when add a new car using fastman92 limit adjuster.

Occurs when enter in the game.

 

 

Strictly speaking...SAAS is not the culprit ! :monocle:

 

That guy is probably using some broken / old Cleo release (opcode 0AC7 is not doing what it should)...or he got a severe memory corruption at the very begining of the game (during INI file loading).

 

Maybe he is using TWO limit adjusters (like Open Limit Adjuster)...and OLA is not properly set for that new car.

 

...or it's just a broken model / texture file.

 

Ask him to try out this pre-release of SAAS (still Beta) == > https://mega.nz/#!9dgAFLBC!AE-HaHMV9Qk2BDZZGUvTxh4ds4Mn6XzhFsx1aoQcqr4

 

I've also included my cleo.asi version (just to compare dates - don't use it - better download latest version).

 

.

Edited by pep legal

Share this post


Link to post
Share on other sites
Michael_Townley

Does this mod conflicts with the other sound mod?

 

For example, I use this mod together with GTA V wasted music mod? Will it cause any incompatibility?

Share this post


Link to post
Share on other sites
Junior_Djjr

 

A guy sent to me.

 

http://pastebin.com/7VtzP19F

 

He said that's a crash when add a new car using fastman92 limit adjuster.

Occurs when enter in the game.

 

Strictly speaking...SAAS is not the culprit ! :monocle:

 

That guy is probably using some broken / old Cleo release (opcode 0AC7 is not doing what it should)...or he got a severe memory corruption at the very begining of the game (during INI file loading).

 

Maybe he is using TWO limit adjusters (like Open Limit Adjuster)...and OLA is not properly set for that new car.

 

...or it's just a broken model / texture file.

 

Ask him to try out this pre-release of SAAS (still Beta) == > https://mega.nz/#!9dgAFLBC!AE-HaHMV9Qk2BDZZGUvTxh4ds4Mn6XzhFsx1aoQcqr4

 

I've also included my cleo.asi version (just to compare dates - don't use it - better download latest version).

 

.

 

He deleted his comments, without explanation :blink:

 

If he deleted because he realized was wrong about this crash, it really is a shame to see people doing it instead of giving better information......

 

edit:

 

Cleisson Rodrigues 13/12/15 23:06

Não é mais necessário, não sei como mais o crash parou

acho que era problema no save...

mas vlw ae pela atenção!

Edited by Junior_Djjr

Share this post


Link to post
Share on other sites
Fireman

Does this mod conflicts with the other sound mod?

 

For example, I use this mod together with GTA V wasted music mod? Will it cause any incompatibility?

No, it only adds sounds, doesn't replace anything.

 

I use the bug-free sound overhaul mod with this (replaces almost all sounds) and it works fine with this.

Share this post


Link to post
Share on other sites
Savidge

EDIT: nvm

Edited by Savidge

Share this post


Link to post
Share on other sites
camilo_97

Grand Theft Auto ifruit (Android) have sound files in .Ogg

Share this post


Link to post
Share on other sites
ParanoiNigga

Hey Can somebody add the sound of a car accelarating far away as that in gta 5.It would be awesome.

Share this post


Link to post
Share on other sites
daniels3

 

I've cleared the CLEO folder already for just SAAS, but I also have .asi plugins in my main folder and I used a bug-free sound overhaul.

 

Better to try it on a fresh install.

 

 

 

I haven't given up on you yet....try this one --> https://mega.nz/#!IRBX0IJQ!cGsViAvFhtxDiOfRg71Yj_B2axmfzm8qkYdO1Xx7AgI

.

 

I think I've a similar issue, I've installed the mod on an absolutely fresh GTA RIP Version, i've tried nearly everything to make it running yet i'm crashing after the loading screen is over or joining a server on SA:MP, the link you've posted is broken though, I'd be thankful if you could re-upload it, I crash once the loading screen on the single mod or SA:MP is over (I get opcodes errors on samp though, and i've changed it milion of times to newer, older etc.)

Share this post


Link to post
Share on other sites
pep legal

I think I've a similar issue, I've installed the mod on an absolutely fresh GTA RIP Version, i've tried nearly everything to make it running yet i'm crashing after the loading screen is over or joining a server on SA:MP, the link you've posted is broken though, I'd be thankful if you could re-upload it, I crash once the loading screen on the single mod or SA:MP is over (I get opcodes errors on samp though, and i've changed it milion of times to newer, older etc.)

 

Are you sure of be using 1.0 US EXE version ?

 

 

(obs.: that link is intentionally off...first page has the latest releases [december] / the january release is still being cooked)

.

Edited by pep legal

Share this post


Link to post
Share on other sites
daniels3

 

I think I've a similar issue, I've installed the mod on an absolutely fresh GTA RIP Version, i've tried nearly everything to make it running yet i'm crashing after the loading screen is over or joining a server on SA:MP, the link you've posted is broken though, I'd be thankful if you could re-upload it, I crash once the loading screen on the single mod or SA:MP is over (I get opcodes errors on samp though, and i've changed it milion of times to newer, older etc.)

 

Are you sure of be using 1.0 US EXE version ?

 

 

(obs.: that link is intentionally off...first page has the latest releases [december] / the january release is still being cooked)

.

 

Yeah and i've tried others' too.

How come I have that problem, i've installed it on a fresh copy of GTA as well.

Edited by daniels3

Share this post


Link to post
Share on other sites
pep legal

Yeah and i've tried others' too.

How come I have that problem, i've installed it on a fresh copy of GTA as well.

You have installed NewOpcodes by DK...right ? (It's mandatory...read the first page)

 

(I will not ask you about latest Cleo...it's pretty obvious).

 

Silent Patch, Mix Sets (by Junior), and some Limit Extender (like OLA) are strongly recommendable as well (not mandatory for SAAS, though)

 

For the last: Modloader and LOD-Lights complete the minimum set that every gta player should use.

 

.

Edited by pep legal

Share this post


Link to post
Share on other sites
shangalisto

This beautiful mod is working on SAMP, the sounds are often too low even with global volume to 1.0, I "cheat" with the volume in game settings but it's not practical

 

A failure on ambience sounds to hospital AS : There are european sirens, cool in Los Santos !! ( :D )

 

EDIT: File .ini has not effect in game (with SAMP, not tested with solo) and the volume sound is catastrophic, it's loooooow. So bugged on SAMP !

Edited by shangalisto

Share this post


Link to post
Share on other sites
Kushy300

This beautiful mod don't work on my SAMP.. Does anyone know how to fix it? It work on the singleplayer

Share this post


Link to post
Share on other sites
malengs

Why is it i'm having error loading plugin/newopcodes.cleo everytime i run it? i downloaded everything in the first page but still no luck.

Share this post


Link to post
Share on other sites
Ruvix

So any news ?

Share this post


Link to post
Share on other sites
daniels3

Got it worked, but I hardly can hear them, they're like very very low, I tried to edit the audio in the config yet barley hear it, I more hear the original gtasa waves and the car

Share this post


Link to post
Share on other sites
daniels3

figured what is it, it's the "Radio" which depends on the sound, no way to edit it somehow to be not based on the gtasa original audio?

 

Such a wonderful mod thought, this deserves way more replies, damn hard work, good job adds alot to the game.

Edited by daniels3

Share this post


Link to post
Share on other sites
Deadstroke

Pep Legal, how did you take the ini files like this to the mod in cleo script? Can you show me how to do this too?

heightWind		: -2400	-1600	 300	 300	 000	 -70	-980		;Mont Chilliad (Windy)heightQuiet		: -2400	-1600	 300	 300	 000	 -70	-980		;Mont Chilliad (reduces interference)heightWind		:  1	  1   2950	2950	 010	 -80	-500		;global wind (proportional to height)heightQuiet		:  1	  1   2950	2950	 003	 -150  -1500		;global quietness (proportional to height)carPlay0		:  2150	 1650	 400	 700	 072	  20	   6		;Crazy Party cars in LV (during the night)

Share this post


Link to post
Share on other sites
ERICK_GTAVC

Excellent, i've tested another ambient sounds for sa like ''seagulls on the beaches'' or other ambient sounds, but this mod have future because it have a particular sound on a specific zone at different times, Good Job :^:

Edited by ERICK_GTAVC

Share this post


Link to post
Share on other sites
pep legal

Pep Legal, how did you take the ini files like this to the mod in cleo script? Can you show me how to do this too?

 

 

 

const   ...a lot of var labels   .   .   .   _bufferIndex_   = [email protected]   _Buffer_        = [email protected](_bufferIndex_,1v)endvar   ...a lot of vars   .   .   .   [email protected]  : int = 0   [email protected]  : array 30 of longstring  //any array will doend//======================================================================//Prepare Buffer0AC7: _temp_1I_ = var [email protected] offset // get the pointer to the last usable variable0AC6: _temp_2I_ = label @Buffer offset // get the pointer to the thread area to store the new variables data0A8F: _temp_3I_ = _temp_2I_ - _temp_1I_ // get the offset from variable [email protected] to the memory_bufferIndex_ = _temp_3I_0016: _bufferIndex_ /= 16 // this index is a long-string index, so 16 bytes0B14: _remainder_ = _temp_3I_ mod 16//======================================================================//Read Ini File//Read Coordinates and Sounds name0A9A: _fileHandle_ = openfile "cleo\saas.ini" mode "rt"0AC6: _List_Index_ = label @List offset_TotalSounds_ = 0:readINI_loopif   0AD7: read_string_from_file _fileHandle_ to _Buffer_ size 128 // read a line of text from INI filethen   0AC6: _temp_2I_ = label @Buffer offset // pointer to Buffer (which has the read text line)   _temp_2I_ -= _remainder_ // compensate address offset bettween _Buffer_ and Buffer   _temp_4I_ = _temp_2I_ // preserve beggining address of buffer   for _temp_1I_ = 0 to 15 // scan Buffer looking for ":" in the text line      0A8D: _temp_3I_ = read_memory _temp_2I_ size 1 virtual_protect 0      if or         _temp_3I_ == 0x3A // ":"         _temp_3I_ == 0x00 // end of text      then         Break      end      _temp_2I_ += 1   end   if _temp_3I_ == 0x3A // ":" found   jf @readINI_loop   0A8C: write_memory _temp_2I_ size 1 value 0 virtual_protect 0 //put a zero at the end of filename segment...so buffer will behave like a null terminated string   0AD4: _temp_1I_ = scan_string _temp_4I_ format '%s' store_num_results_to _fileName_ _temp_2I_ //read file name   if and   _temp_1I_ == 1 //one string read (file name)   0AAB: does_file_exist _startHour_ //...and that file exist.   then       _temp_2I_ += 1 //advance one byte (prepare to read the rest of the buffer)      0AD4: _temp_1I_ = scan_string _temp_2I_ format '%d%d%d%d%d%d%d' store_num_results_to _PosX_ _PosY_ _RadX_ _RadY_ _fading_ _startHour_ _stopHour_      if         _temp_1I_ == 7      then         //store resolved sound paramenters from INI line to List line         0093: _PosX_ = int_to_float _PosX_ // convert to float.         0093: _PosY_ = int_to_float _PosY_         0093: _RadX_ = int_to_float _RadX_         0093: _RadY_ = int_to_float _RadY_         0AC7: _temp_2I_ = var _fileName_ offset // address of the first parameter (filename)         0D27: copy_memory_from _temp_2I_ to _List_Index_ size LIST_LINE_SIZE // copy all List parameters to an entry in the List         _List_Index_ += LIST_LINE_SIZE // point to next entry in the list         _TotalSounds_ += 1      end   end   jump @readINI_loopend:endINI0A9B: close_file _fileHandle_if   _TotalSounds_ == 0then   0AD1: show_formatted_text_highpriority "MP3 Files MISSING" time 3000   wait 3000   0A93: terminate_this_custom_scriptend  ==================================  //  at the end of the file :  :Bufferhex00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00end 

 

 

Edited by pep legal

Share this post


Link to post
Share on other sites
Deadstroke

There are a lot of things on it!

Thanks Pep!

Share this post


Link to post
Share on other sites
Deadstroke

 

Pep Legal, how did you take the ini files like this to the mod in cleo script? Can you show me how to do this too?

 

 

 

const   ...a lot of var labels   .   .   .   _bufferIndex_   = [email protected]   _Buffer_        = [email protected](_bufferIndex_,1v)endvar   ...a lot of vars   .   .   .   [email protected]  : int = 0   [email protected]  : array 30 of longstring  //any array will doend//======================================================================//Prepare Buffer0AC7: _temp_1I_ = var [email protected] offset // get the pointer to the last usable variable0AC6: _temp_2I_ = label @Buffer offset // get the pointer to the thread area to store the new variables data0A8F: _temp_3I_ = _temp_2I_ - _temp_1I_ // get the offset from variable [email protected] to the memory_bufferIndex_ = _temp_3I_0016: _bufferIndex_ /= 16 // this index is a long-string index, so 16 bytes0B14: _remainder_ = _temp_3I_ mod 16//======================================================================//Read Ini File//Read Coordinates and Sounds name0A9A: _fileHandle_ = openfile "cleo\saas.ini" mode "rt"0AC6: _List_Index_ = label @List offset_TotalSounds_ = 0:readINI_loopif   0AD7: read_string_from_file _fileHandle_ to _Buffer_ size 128 // read a line of text from INI filethen   0AC6: _temp_2I_ = label @Buffer offset // pointer to Buffer (which has the read text line)   _temp_2I_ -= _remainder_ // compensate address offset bettween _Buffer_ and Buffer   _temp_4I_ = _temp_2I_ // preserve beggining address of buffer   for _temp_1I_ = 0 to 15 // scan Buffer looking for ":" in the text line      0A8D: _temp_3I_ = read_memory _temp_2I_ size 1 virtual_protect 0      if or         _temp_3I_ == 0x3A // ":"         _temp_3I_ == 0x00 // end of text      then         Break      end      _temp_2I_ += 1   end   if _temp_3I_ == 0x3A // ":" found   jf @readINI_loop   0A8C: write_memory _temp_2I_ size 1 value 0 virtual_protect 0 //put a zero at the end of filename segment...so buffer will behave like a null terminated string   0AD4: _temp_1I_ = scan_string _temp_4I_ format '%s' store_num_results_to _fileName_ _temp_2I_ //read file name   if and   _temp_1I_ == 1 //one string read (file name)   0AAB: does_file_exist _startHour_ //...and that file exist.   then       _temp_2I_ += 1 //advance one byte (prepare to read the rest of the buffer)      0AD4: _temp_1I_ = scan_string _temp_2I_ format '%d%d%d%d%d%d%d' store_num_results_to _PosX_ _PosY_ _RadX_ _RadY_ _fading_ _startHour_ _stopHour_      if         _temp_1I_ == 7      then         //store resolved sound paramenters from INI line to List line         0093: _PosX_ = int_to_float _PosX_ // convert to float.         0093: _PosY_ = int_to_float _PosY_         0093: _RadX_ = int_to_float _RadX_         0093: _RadY_ = int_to_float _RadY_         0AC7: _temp_2I_ = var _fileName_ offset // address of the first parameter (filename)         0D27: copy_memory_from _temp_2I_ to _List_Index_ size LIST_LINE_SIZE // copy all List parameters to an entry in the List         _List_Index_ += LIST_LINE_SIZE // point to next entry in the list         _TotalSounds_ += 1      end   end   jump @readINI_loopend:endINI0A9B: close_file _fileHandle_if   _TotalSounds_ == 0then   0AD1: show_formatted_text_highpriority "MP3 Files MISSING" time 3000   wait 3000   0A93: terminate_this_custom_scriptend  ==================================  //  at the end of the file :  :Bufferhex00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00end 

 

 

I'm having some problems with it:

- The 'Prepare Buffer', I use it once in mod, all right?

- The var _Buffer_ doesn't mean nothing in script and is crashing the game in opcode 0AD7;

- The label @List is anyone thread memory that I could use to use in script, right?

- In "0AAB: does_file_exist _startHour_ //...and that file exist.", does it make sense? I didn't use in script that I tried to load.

 

Edit.: I got to use this script! Thanks so much!

You'll have credits in mod that I'm creating....

Edited by Deadstroke

Share this post


Link to post
Share on other sites
pep legal

.

 

A long overdue Update (jul-16) :santa:

 

- Several sounds were replaced, fixed, tweaked, removed, changed, etc.

 

- Few new sounds added (rail tunnel, SF tower clock, Airports, Military bases, car sellers).

 

- New option in INI file.

 

- Some minor bugs in script are now fixed.

 

 

Summarizing: No big change, but a lot of small changes.

 

.

Edited by pep legal

Share this post


Link to post
Share on other sites
kkjj

Can you please upload the updated files separatly pep legal.

Share this post


Link to post
Share on other sites
kkjj

@Pep legal again I am requesting please upload the updated files for me because I have a very slow internet. Please upload the files.

Share this post


Link to post
Share on other sites
pep legal

.

Ok...there it goes...

 

A small update having only changed files:

 

 

- Not mandatory (but recommendable) for those people already using the new " jul-16 " version.

 

- Totally necessary for those still using " nov-15 " version.

 

 

 

.

Edited by pep legal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 2 Users Currently Viewing
    0 members, 0 Anonymous, 2 Guests

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.