Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Cayo Perico Heist
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA VI

      1. St. Andrews Cathedral
    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. Announcements

    2. Support

    3. Suggestions


The Hero

Recommended Posts

Script isn't in the right folder probably. I put that .asi in the scripts folder and it loads properly (though I am using an edited variant with motion blur but still based on this script).

  • Like 1
Link to post
Share on other sites

Yeah. The order in which the game loads the scripts matters (at least for III and VC; it may just be the ASI loader) if you have a bunch of them installed. The ones in the scripts folder are first if I'm not mistaken.

Link to post
Share on other sites

@Kristian Thanks!!!! Now it works anyway The Hero didn't say that the asi need to be in script folder...

>not having root of you games clean

but also aint there some ini file in scripts folder that has settings for loading asi outside the scripts folder from root?

yes. in global.ini set LoadFromScriptsOnly=1 to 0 and it should work :)

Link to post
Share on other sites

That's turned off by default as far as I remember. Putting all scripts in the scripts folder doesn't work if you have a sh*t-ton of them and the order in which they are loaded matters.

e.g.

 

Iis2gqW.png

 

Link to post
Share on other sites
Blackbird88

Just FYI. If you have SilentPatchIII/VC in scripts folder then you don't need the DDraw component.

Edited by Blackbird88
  • Like 2
Link to post
Share on other sites
  • 3 months later...

So do I need both vctrails.asi and sharptrails.asi? I added sharptrails to scripts folder and removed vctrails, but now the trails option no longer shows up.

Edited by SF117
Link to post
Share on other sites
spaceeinstein

You need sharptrails.asi and not vctrails.asi. You also need to have the Ultimate ASI Loader (which is included in the Widescreen Fixes Pack).

 

sharptrails_pause_th.jpg

sharptrails_th.jpg

Edited by spaceeinstein
Link to post
Share on other sites
  • 5 weeks later...
spaceeinstein

I found a minor bug. It is possible that when starting up the game the trails option remains off even if you had turned it on in the previous game session. The issue is dependent on the user's controls configuration. In the LoadSetFile() function, a fixed value is used to read the gta_vc.set file. But due to R*'s quirky usage of a function to write the file it's possible that the incorrect location in the file will be read. For example, using the default standard controls, "Turret + Lean Down" is mapped to NUM6. Backspace to clear it and map it to something else, e.g. NUM1. Switch trails on, quit and restart the game. The trails option will be displayed as off instead of on. The location of the data that stored the switch is now at 0x5B7 instead of 0x5B8 in the settings file. The quirk is also probably why Silent's trails reads a different location at 0x5BA.

Edited by spaceeinstein
  • Like 2
Link to post
Share on other sites
Silent

lol yeah they open the file as if it was text file and not binary - would be easily fixable but would also break existing SET files so could be risky to just make it open as binary :(

Link to post
Share on other sites
  • 2 weeks later...
spaceeinstein

I think LoadSetFile() is not needed at all. I think this would work:

 

Patch(0x4902D2, pTrailsOptionEnabled); // SaveSettingsPatch(0x48FF97, pTrailsOptionEnabled); // LoadSettings
The game will initially have trails enabled since the location is occupied by 's' but changing the option will change that to 0 or 1. The game should be able to save and load the setting fine.
Link to post
Share on other sites
  • 2 months later...
Marsi4eg

I've noticed that in this version the heat haze effect in VC is not present. It has to take effect on exhaust of vehicles for example. Silent's vctrails which just adds an option and enables it - has heat haze.

In this version it's disabled in both modes (dx9 and dx8 - named as 'sharptrails' or 'trails'). If this cannot be done in dx9 mode - it have to be fixed at least for native dx8

Edited by Marsi4eg
  • Like 1
Link to post
Share on other sites
ThirteenAG

I've noticed that in this version the heat haze effect in VC is not present.

If you mean these annoying twitching blur things, then yeah, they were disabled on purpose. You're welcome :)
  • Like 2
Link to post
Share on other sites
gts.

I've noticed that in this version the heat haze effect in VC is not present. It has to take effect on exhaust of vehicles for example.

Is this effect present on PS2? I can't remember.

 

Thanks!

I was using latest version too, and I want everything in VC just like how it is on PS2.

  • Like 1
Link to post
Share on other sites
  • 1 month later...
spaceeinstein

What other mods are you using? What happens when you disable them?

Edited by spaceeinstein
Link to post
Share on other sites
Marsi4eg

Those boxes appear where the heat effect (or 'twitching blur thing' as 13AG described :) ) has to be.

I've experienced this once when I tried to find another graphics bug caused by old version of cleo plugin.

 

And I remember that I was experimenting with d38to9 wrapper when I got these boxes. Then they disappeared and blur worked correctly. So make sure you have correct dlls installed (asi loader, d3d8to9 wrapper, etc.)

Also don't place sharptrails.asi in mss folder, put it to scripts

Edited by Marsi4eg
Link to post
Share on other sites
  • 2 months later...

I've noticed that in this version the heat haze effect in VC is not present. It has to take effect on exhaust of vehicles for example. Silent's vctrails which just adds an option and enables it - has heat haze. In this version it's disabled in both modes (dx9 and dx8 - named as 'sharptrails' or 'trails'). If this cannot be done in dx9 mode - it have to be fixed at least for native dx8.

Someone can do this (again?) but with the new version please?

  • Like 2
Link to post
Share on other sites
  • 1 month later...
Claude_Lib

Weird thing, it doesn't work if I rename the file. I mean, if I change the extension to asi, it works, but if I touch the name, it stops. Even if I just change the case of a letter (SharpTrails), it no longer works.

Link to post
Share on other sites
The Hero

Haha yes. That's something TAG did once: the plugin only patches in the new code if the file name contains "sharp". The idea was that you could just rename it to trails.asi and it would only enable trails. I don't know...should this be kept or not?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.