Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (85,248 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Gforce

Adding Cars with DLC Pack (Working Template)

Recommended Posts

GTAGeek123

I trying to add a vehicle that was made to replace the Issi vehicle. However, I'm noticing that the Issi vehicle doesn't have certain entries in the vehiclelayouts.meta. For example it doesn't have any VehicleCoverBoundOffsetInfos, VehicleEntryPointAnimInfos, or VehicleLayoutInfos. Does anyone know how do find out what values the Issi uses so I can copy them? Do I even need to have the information, and if not, should I just put in the only information I found for the Issi in the vehiclelayouts.meta file (which is the <FirstPersonDriveByLookAroundData> info) in the vehiclelayouts.meta in the dlc I'm trying to make and then just apply it to the vehicle I'm trying to add?

Edited by GTAGeek123

Share this post


Link to post
Share on other sites
SonofUgly

@GTAGeek123 - vehiclelayouts.meta is used by vehicles.meta, so check the issi in vehicles.meta to see what it uses in vehiclelayouts.meta.

For instance, the issi doesn't have its own VehicleCoverBoundOffsetInfos, instead it uses the Intruder's coverboundoffset: INTRUDER_COVER_OFFSET_INFO.

 

If the vehicle mod you're using doesn't change anything in vehiclelayouts.meta, then you don't need to change that info in vehicles.meta and don't even need a vehiclelayouts.meta in your dlc.

 

 

Got the dreaded E63's tuning parts working,

What did you do to get it working? Edited by SonofUgly

Share this post


Link to post
Share on other sites
GTAGeek123

Thanks SonofUgly. Really appreciate it. One more question are there any limitations on what numbers can be used for ids in the carcols.meta file?

Share this post


Link to post
Share on other sites
TheAdmiester

 

What did you do to get it working?

 

 

I know for a fact that I did nothing different in the carcols.meta file, so I think it's just down to the fact that the car's .yfts and .ytds are all in the DLC file along with the _mods.rpf files. I think they have to be in the same DLC file otherwise it won't load them, but of course until you posted the gameconfig.xml fix, having the car in the DLC would crash it.

Share this post


Link to post
Share on other sites
GTAGeek123

I'm having an issue where I get an invalid model error when I try to load any custom vehicle via the simple trainer. I even tried installing SonofUgly's car dlc (the one with 16 new cars), but got the same issue. I am using the mods folder option on openiv so I can make changes to files with actually changing the original files. Do anyone one know if that may be the issue?

 

EDIT: I fixed the issue by changing the original files. Does anyone have any idea why it won't work when using the mods folder?

 

EDIT2: IMPORTANT: This edit not a bug report. I have found that there some additional changes needed to the gameconfig.xml file in order for the crashing issue where the game crashes at [email protected] to be turely fixed. I found this out as I added a seventeenth car to SonofUgly's car dlc (with the aircraft dlc enabled as well) and the clip_anim issue returned and would not go away (even with vehicle_spawn set to 10000). I then increased the below entries to the values show below and it went away again.

 

 

<MaxVehicleModelInfos value="500"/>
<MaxExtraVehicleModelInfos value="200"/>

Edited by GTAGeek123

Share this post


Link to post
Share on other sites
Gforce

Hi guys, good to see the topic is being used for helping each other.

 

sorry I haven't been around to participate, but I have a lot going on in my real life atm that's keeping me from playing GTA let alone do any modding, I should hopefully be able to get back to doing some more modding in the next week.

good to see a few finding this useful, also really good to see you helping each other out with problems :^:

Share this post


Link to post
Share on other sites
Apocalypsing

I can't seem to get self-created DLCs to work. If I add a DLC I put together, the game will crash on startup. If I download a pre-made DLC pack and add it to the game, it will work fine though.

 

Currently I'm trying to create a police vehicle DLC pack, starting with this 1999 CVPI model.

 

Here are the DLC files I'm trying to get to work.

Share this post


Link to post
Share on other sites
TheAdmiester

 

Here are the DLC files I'm trying to get to work.

This worked fine for me.

 

That might actually be some very telling info. If the files provided work perfectly fine, then the issue is likely in the file that they didn't provide - dlclist.xml.

 

@Apocalypsing, can you spoiler-post the contents of your update.rpf\common\data\dlclist.xml? If you use a modded update.rpf then post whichever one you're working with.

Share this post


Link to post
Share on other sites
lpgunit

This + Virtual File System on update.rpf = golden.

 

Yeah since copying RPF files to the mods folder wholesale is a bit unwieldy even despite that you're not poking into the original archives.

Share this post


Link to post
Share on other sites
UHDFreddyEST

Hello, why i dont get dlc car tuning parts working, ? :S

Share this post


Link to post
Share on other sites
TheAdmiester

Nothing really important but just a bit of info for those who were curious.

 

After the free mode update, I managed to install a few more vehicles than normal before the game crashed, which is confirmation that Rockstar is indeed increasing gameconfig.xml values with new DLCs. I managed to add the F35 mod and Gallardo LP570 before it started crashing on @clip_anim again. I just increased the values mentioned in this thread and it works perfectly again.

Share this post


Link to post
Share on other sites
Mr.Arrow

how did rockstar increase gameconfig.xml

 

I thought the game had limits like gta iv

Share this post


Link to post
Share on other sites
Claude_Lib

The game has much less hardcoded limits than IV, if any at all. This time it's all about DLCs so the engine has to be as flexible as possible.

Share this post


Link to post
Share on other sites
TheAdmiester

The game has much less hardcoded limits than IV, if any at all. This time it's all about DLCs so the engine has to be as flexible as possible.

Which is perfect for us, because if Rockstar can add content, so can we. Hence why we're adding cars instead of replacing.

Share this post


Link to post
Share on other sites
NexusAU

What do I need to edit to move the character forward in a seat. Currently the character is sitting too far back in the car and I need to move them forward a bit.

Which of the meta files do I need to edit?

Share this post


Link to post
Share on other sites
_CP_

Move seat_dside_f dummy in car model.

Share this post


Link to post
Share on other sites
NexusAU

Move seat_dside_f dummy in car model.

 

Cheers

Edited by Nexus AU

Share this post


Link to post
Share on other sites
_CP_

I tried adding GTA IV cars to the game, and encountered a few issues.

1. Some cars crash. (probably due to a typeo somewhere)

2. Most cars have no audio. (No tire sounds, no engine sounds, no door sounds) Some cars do have audio though.

3. No radio in the added cars.

I think I know the reason of void sound, vehicle must be exported with the same name as in the rest of files (you can't add vehicle exported in Zmodeler as "a", when in other files is called "b").

Share this post


Link to post
Share on other sites
nkjellman

 

I tried adding GTA IV cars to the game, and encountered a few issues.

1. Some cars crash. (probably due to a typeo somewhere)

2. Most cars have no audio. (No tire sounds, no engine sounds, no door sounds) Some cars do have audio though.

3. No radio in the added cars.

I think I know the reason of void sound, vehicle must be exported with the same name as in the rest of files (you can't add vehicle exported in Zmodeler as "a", when in other files is called "b").

 

The Tug does have sound.

 

But if that is the reason, the sound issue won't get fixed because I'm not paying for Zmodeler.

Share this post


Link to post
Share on other sites
_CP_

That's my theory. When I wanted to add Presidente as a DLC car, it didn't have any sound.

Edited by _CP_

Share this post


Link to post
Share on other sites
fastman92

No need to edit american.gxt, when adding new vehicles anymore.

 

http://gtaforums.com/topic/733982-fastman92-limit-adjuster/

 

Just install that plugin and configure the .ini

 

[ADDONS]

Enable FXT loader = 1

 

Then create .fxt files in FXT\ directory like this example of FXT for GTA SA:

 

AT400 Boeing 737 LOTELEGY BMW M3HOTKNIF Talbot Lago T26CPCJ600 Aprilia RSV4NRG500 Suzuki GSX-R600WAYFARE HexerSANCHEZ Yamaha YZ250FHAYABUS Suzuki HayabusaBUSX3GL Designx-X3 busBAGX3GL Designx-X3 trailerBMX Ferrari ColnagoBRAVURA Renault MeganeSULTAN Aston Martin DB9LANDSTK AMG Hummer H2MESA UAZ 469 HUNTER
GXT label of vehicle is defined by <gameName>...</gameName> Edited by fastman92

Share this post


Link to post
Share on other sites
Claude_Lib

I almost said "You picked the wrong thread, fool!" © Big Smoke, but then I looked through your topic, and you actually made the FXT loader for RAGE era games! This is awesome!

Share this post


Link to post
Share on other sites
TheAdmiester

That's my theory. When I wanted to add Presidente as a DLC car, it didn't have any sound.

Did you give it an <audioNameHash> value?

Share this post


Link to post
Share on other sites
ExtraFluffyYo

Hi, so when I am adding a vehicle mod that has tuning parts. For example, I am using the Mitsubishi Evo X mod, it comes with tuning parts that replaces the ones for kuruma. So I followed every step provided and was able to get everything in the game. However, when I try to add parts like Skirts or Wings, the positioning is off. Like the front bumper part is just floating on the left. The Wing is too close to back window. Just wondering what I did wrong. Thanks

Edited by ExtraFluffyYo

Share this post


Link to post
Share on other sites
TheAdmiester

Hi, so when I am adding a vehicle mod that has tuning parts. For example, I am using the Mitsubishi Evo X mod, it comes with tuning parts that replaces the ones for kuruma. So I followed every step provided and was able to get everything in the game. However, when I try to add parts like Skirts or Wings, the positioning is off. Like the front bumper part is just floating on the left. The Wing is too close to back window. Just wondering what I did wrong. Thanks

It's a bit tricky. The easiest way is to open the car in OpenIV and look at the "bone" (basically just parts) names. Then in carcols.meta, each tuning part should be linked to something relevant. For example, a spoiler for a car would have:

 

<bone>boot</bone>

 

To attach it to the boot. I think side skirts should be linked to the chassis bone, so try that and see what happens.

Share this post


Link to post
Share on other sites
ExtraFluffyYo

 

Hi, so when I am adding a vehicle mod that has tuning parts. For example, I am using the Mitsubishi Evo X mod, it comes with tuning parts that replaces the ones for kuruma. So I followed every step provided and was able to get everything in the game. However, when I try to add parts like Skirts or Wings, the positioning is off. Like the front bumper part is just floating on the left. The Wing is too close to back window. Just wondering what I did wrong. Thanks

It's a bit tricky. The easiest way is to open the car in OpenIV and look at the "bone" (basically just parts) names. Then in carcols.meta, each tuning part should be linked to something relevant. For example, a spoiler for a car would have:

 

<bone>boot</bone>

 

To attach it to the boot. I think side skirts should be linked to the chassis bone, so try that and see what happens.

 

Thanks man. Yeah that is way too tricky for me. I thought it would be a lot easier. I'll just wait for a more completed tutorial or for the car mod creator to make it as addon.

Share this post


Link to post
Share on other sites
_CP_

@TheAdmiester

 

Oh, my bad, thanks.

Share this post


Link to post
Share on other sites
TheAdmiester

 

 

Hi, so when I am adding a vehicle mod that has tuning parts. For example, I am using the Mitsubishi Evo X mod, it comes with tuning parts that replaces the ones for kuruma. So I followed every step provided and was able to get everything in the game. However, when I try to add parts like Skirts or Wings, the positioning is off. Like the front bumper part is just floating on the left. The Wing is too close to back window. Just wondering what I did wrong. Thanks

It's a bit tricky. The easiest way is to open the car in OpenIV and look at the "bone" (basically just parts) names. Then in carcols.meta, each tuning part should be linked to something relevant. For example, a spoiler for a car would have:

 

<bone>boot</bone>

 

To attach it to the boot. I think side skirts should be linked to the chassis bone, so try that and see what happens.

 

Thanks man. Yeah that is way too tricky for me. I thought it would be a lot easier. I'll just wait for a more completed tutorial or for the car mod creator to make it as addon.

 

At least try it with one part first. Take a segment of carcols.meta that you've already set up, change the bone and see how it affects it. I had to do it this way when installing my first non-replacing-but-tunable car mod, it's quite easy once you actually get the hang of it.

Share this post


Link to post
Share on other sites
ExtraFluffyYo

 

 

 

Hi, so when I am adding a vehicle mod that has tuning parts. For example, I am using the Mitsubishi Evo X mod, it comes with tuning parts that replaces the ones for kuruma. So I followed every step provided and was able to get everything in the game. However, when I try to add parts like Skirts or Wings, the positioning is off. Like the front bumper part is just floating on the left. The Wing is too close to back window. Just wondering what I did wrong. Thanks

It's a bit tricky. The easiest way is to open the car in OpenIV and look at the "bone" (basically just parts) names. Then in carcols.meta, each tuning part should be linked to something relevant. For example, a spoiler for a car would have:

 

<bone>boot</bone>

 

To attach it to the boot. I think side skirts should be linked to the chassis bone, so try that and see what happens.

 

Thanks man. Yeah that is way too tricky for me. I thought it would be a lot easier. I'll just wait for a more completed tutorial or for the car mod creator to make it as addon.

 

At least try it with one part first. Take a segment of carcols.meta that you've already set up, change the bone and see how it affects it. I had to do it this way when installing my first non-replacing-but-tunable car mod, it's quite easy once you actually get the hang of it.

 

So I checked the carcols.meta and everything is there. I pretty much copied the kuruma part in the original carcols.meta from the dlcpack mpheist. Now when I load the car, I don't see any tuning mods or parts.

I linked my dlc.rpf if you don't mind checking it out. If not, no worries.

https://www.dropbox.com/s/m698idgg7oblzjl/dlc.rpf?dl=0

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.