Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
PlatinumSerb

SAxVCxLC - VC and LC in San Andreas

Recommended Posts

eagle152

I checked the last fixes (those were supposed to fix water beneath VC/LC) and unfortunately I dont see any changes these. As for SA I haven't looked at it.

Share this post


Link to post
Share on other sites
chaosbginwenrealityend
On 10/20/2018 at 10:11 AM, goodidea82 said:

I have read the readme of your waterfix. There you write:

"6- entire water plane raised +1 meter"

The original water.dat that comes with SAxVCxLC had that problem. The extra water in SA (like in the NRG500 challenge basin) cause an entire raising of the water plane +1 meter (the Z axis). This 'high tide' effect happens when another water plane is put above another within 10m z axis of each other. This is also why water was on the roadway in Blueberry and clear water can be seen poking through the mud water creek near Helena's place; even though all the water quads in water.dat were set correctly at 0.0 z axis.

 

No adjustments to the z axis were made because once the extra water quads were removed, the entire water plane went back to it's original state naturally. The change log in the readme included with the new water.dat shows what all has been fixed. The water plane is now at its correct plane of 0.0 z axis. I apologize if I wasn't clear. Many times I write these things when it's late at night.

 

To be clear, the photos show the original problems and the change log shows the fixes. From readme:

 

A new water.dat is being provided that fixes ALL of the known water bugs:  
1- water in NRG500 challenge basin
2- water on roadway near Blueberry
3- No mud water in creek over by Helenas place
4- several gaps or holes in ocean  
5- improper transition around original SA map bounds
6- entire water plane raised +1 meter
7- water under VC and LC (thank you Eagle152 for raising my attention to this matter recently)

 

Edited by chaosbginwenrealityend

Share this post


Link to post
Share on other sites
chaosbginwenrealityend
On 10/21/2018 at 5:24 AM, eagle152 said:

I checked the last fixes (those were supposed to fix water beneath VC/LC) and unfortunately I dont see any changes these. As for SA I haven't looked at it.

 

Did you get the last one that I revised date 9 October? Don't use the one included with several other fixes. I submitted a revised one several days later based on your comments about water under the VC/LC islands. Either that or there is a misunderstanding of what 'water under VC/LC' means. Is it possible to provide a photo of what you mean?

Share this post


Link to post
Share on other sites
Brunophillips101

There's the world trade center towers by ms1991 on this map?

Share this post


Link to post
Share on other sites
santosvagos

Could you add specific peds for each city ??

Edited by santosvagos

Share this post


Link to post
Share on other sites
PlatinumSerb
On 10/3/2018 at 7:07 AM, goodidea82 said:

Micro$oft just destroyed compatibility here.

@PlatinumSerb: Try the following alternative script. Let's call it testXcopyExclude2.bat:

Other people should also try it out and let me know the output and the windows version. If this works, I can fix the installation script.

Sorry for such a late reply. Here is the output that I am seeing:
 

D:\GTA_Related\GitHub_SAX\SAx VCxLC>testXcopyExclude2.bat

D:\GTA_Related\GitHub_SAX\SAx VCxLC>setlocal enabledelayedexpansion

D:\GTA_Related\GitHub_SAX\SAx VCxLC>CALL :shortname "D:\GTA_Related\GitHub_SAX\SAx VCxLC\toolsForInstallation\xcopy_exclude.txt"

D:\GTA_Related\GitHub_SAX\SAx VCxLC>set exclude=D:\GTA_Related\GitHub_SAX\SAx VCxLC\toolsForInstallation\xcopy_exclude.txt

D:\GTA_Related\GitHub_SAX\SAx VCxLC>echo Echo1 D:\GTA_Related\GitHub_SAX\SAx VCxLC\toolsForInstallation\xcopy_exclude.txt
Echo1 D:\GTA_Related\GitHub_SAX\SAx VCxLC\toolsForInstallation\xcopy_exclude.txt

D:\GTA_Related\GitHub_SAX\SAx VCxLC>exit /b

D:\GTA_Related\GitHub_SAX\SAx VCxLC>echo Echo2 D:\GTA_Related\GitHub_SAX\SAx VCxLC\toolsForInstallation\xcopy_exclude.txt
Echo2 D:\GTA_Related\GitHub_SAX\SAx VCxLC\toolsForInstallation\xcopy_exclude.txt

D:\GTA_Related\GitHub_SAX\SAx VCxLC>exit /b

D:\GTA_Related\GitHub_SAX\SAx VCxLC>

 

On 10/28/2018 at 8:49 PM, Brunophillips101 said:

There's the world trade center towers by ms1991 on this map?

Should be easy to make it compatible, its just a map mod it seems. I would recommend asking ms1991 if hes still active to release a SAxVCxLC compatible version.

 

On 11/7/2018 at 9:23 PM, santosvagos said:

Could you add specific peds for each city ??

Eventually that will be the case, but I do not think anyone is actively working on that part just yet.

Share this post


Link to post
Share on other sites
Morningstar666

chaosbginwenrealityend Did you correct the problems of the missions?

Share this post


Link to post
Share on other sites
goodidea82

@PlatinumSerb: Thanks for the test. The result tells me that unlike Windows 7, Windows 10 does not have full support for windows batch files.

 

Someone can still test the installation on W10 where the path to install.bat contains spaces, and tell me the result. Otherwise, the recommendation is, when using W10 then make sure that the path where install.bat is located does not contain spaces.

 

@chaosbginwenrealityend thanks for the details. Currently I'm inactive so haven't added the updates myself, but it should be added.

 

Btw, once in a while I check for pull requests. Just informing that they will be seen at some point, however, make sure that a pull-request does not break the game or cause other problems.

Share this post


Link to post
Share on other sites
chaosbginwenrealityend
On 11/16/2018 at 7:46 AM, Morningstar666 said:

 Did you correct the problems of the missions?

Greetings Morningstar. I run a stripped main.scm in my configuration so I don't know of any problematic missions except what I read here. I have found though through extensive testing that most of the added cars to SAxVCxLC caused random crashes. My recommendation for you or anyone with mission problems is to restore the original cargrp.dat, carmods.dat, carcols.dat, handling.cfg and vehicles.ide. You will also need to either remove the added car entries in the cleo scripts and recompile or remove the cleo scripts which spawn these added cars too and then try the missions. You will more than likely have to start a new game.

 

If this is done already try disabling most of the error reporting features in the FLA ini like just leave: Model does not have collision loaded = 1 enabled. My own tests revealed when all of these were enabled the game crashed at the end of the loading bar.

 

In my own game with the aforementioned already done long ago I can literally play in the original SA part of the map for real time days with no crashes; however, playing in VC or LC is still plagued with random crashes after 2-2 and half hours game play. I'm still on the hunt for those crashes although I am led to believe these are island number related and I know that limit (if there is one) has never been hacked. I have tried changing the value of this in main.scm: change_integer_stat 181 to 4 to 8, 12, 16 with changing the corresponding VC LC zones islands to 5,6, 7, 8 etc got mixed results and crashes. I suspect this because I watch what is being loaded at runtime in real time during game play what models are being loaded where ever CJ is at any given time - and this don't include reused or generic models. For example, CJ is on island 1 in VC those models being loaded while models from island 1 in SA I see some being loaded too at the same time. This could be nothing - and may be unrelated to missions - still testing.

 

By my own testing; cols, ipls and ides get loaded at game boot but no models and objects from VC or LC (except what is listed on object.dat) gets loaded (unless one changed the player initial spawn point to VC or LC). After game is done loading and you see your CJ standing there then only the surrounding objects and models will 'stream' within a radius of like 0-1800 but no objects and models from VC and LC will stream till CJ gets near those islands and the added cars is the only change to the original SA configuration at runtime that occurs on the fly during game play while in SA (game reads cargrp.dat and spawns cars according the zone CJ is in) so try restoring those data files. Another possibility of crashes occurring during missions is if one has changed any of the enexes (the yellow teleport markers at the entries) while using a save game.

 

The only other remote possibility of crashes related to missions would be paths. Paths for missions are scripted in main.scm and does refer to external paths but I've never really looked at any of the nodes.dat to see if any mission paths are there. I think the mission paths are separate files though. Fastman92 limit adjuster hacks or manipulates certain memory addresses for paths like trains, cars, boats, peds and flight so it is possible there may be a conflict with missions there. I have insufficient windows programming knowledge to form an opinion there. It's too bad I never got Swoorups path importer for Blender to work in Linux. It would have been nice to see a 'visual' of all paths and could look to see if any scripted paths are there.

 

The size of the map doesn’t seem to affect main.scm weather a stripped or original. I've tested both ways but only played a few of the beginning missions with the original. On my stripped main after I first installed this conversion I put all the weapon, car (except the added ones), zones, planes, boats etc,  written in cleo and placed them all in scm starting with $11500 and have had no problems; so this tells me scm has no boundaries. I also long ago wrote nine girlfriend scripts where CJ can free roam with any or all six girlfriends at the same time; a script where CJ can pick up any girl anywhere anytime; free roam with Catalina; Kendle or all at the same time; can do all same type of dating as Rockstarz brand except teleport through markers; All work flawlessly no matter where on the map so this tells me there no boundaries with cleo scripts.

 

Hope this helps

 

Goodidea82: I am fairly picky and rigorously and thoroughly test everything I release or post here. When I write scripts I place my own generic debugging code within so I know exactly how the script is performing and most importantly that what is created is destroyed/released when the script ends then remove the debug code when satisfied coding is stable before release. Data files and also scripts; I can attach X64dbg and it will tell me of invalid perimeters and of course  good 'ol game play for hours IE; water.dat I spent probably 30 hours total in game flying around the map looking for bugs and a Maverick or Seasparrow flying around the islands looking for missing water quads; walking the parameters; and making corrections in 3dsmax as I found them. All mostly hand edited as there are no tools to automate this process. Labor of love type thing.

 

I know from experience from my early days of GTA modding what it's like to download mods from the net only to find they created problems or game crashes. As time rolled on with new knowledge of the game mechanics one finds either poorly written scripts or models to heavy in polys and/or col size for the game engine; bad parameters and very rarely any change log, etc. I hope that I have proven my sole intent here is to help remedy problems not create them. This is also why I provide an explicit change log and/or detailed install instructions.

 

And finally for those who would to see certain peds in certain areas you can edit info.zon but it will only change what 'group' from pedgrp.dat. In other words, you can bring the SA beach peds to VC like this:

 

SMB1, 0, 8708.53, -8924.02, 0.0, 9158.53, -8817.02, 100.0, 1, BEACH1
SMB2, 0, 8834.79, -8815.37, 0.0, 9234.79, -8708.37, 100.0, 1, BEACH1

 

Info.zon explaination

 

SMB1 = ped group from pedgrp.dat

0 = interior in this case 'outside world' any defined number above is interior like a safe house, diner, bar or strip club. SA doesn't have interior zones so always zero (0)

next 6 parameters = area coords of defined zone

1 = unknown always 1

BEACH1 = text displayed on screen of zone name like in this case Ocean Beach

 

The above will bring beach peds to Ocean Beach in VC. It will also bring the Family. You'll have to play with these yourself. Search the forums I think Spaceeinstein did some really nice maps of the VC and LC zones to use as reference where they are. I just used CJ and Sanny builder coords to find what I wanted to change. It is the first parameter that dictates what ped group is spawned i.e, SMB1. Leave the rest at default. There is also zone maps for SA. There is no other way I know of to assign peds to certain areas other than through zones. Just be sure to use the correct zone names like SMB1, SMB2, VERO1 etc for use here. Main.scm alters the behaviour of zones so if you have not done so already open main.scm in SB and you can see what zones are altered:

 

0767: set_zone 'SMB1' popcycle_group_for_peds_and_cars_to 8  
0767: set_zone 'SMB2' popcycle_group_for_peds_and_cars_to 8  
076C: set_zone 'SMB1' gang 1 density_to 10  
076C: set_zone 'SMB2' gang 1 density_to 10

 

Use SB help files it will tell what gang ids are like gang 0 is Ballas and 1 is the Families etc. or if you want to use certain zone names for certain peds but don't want any gang members there then you'll have to either find another zone that has the desired effect without gangs or edit main.scm.

 

Hope this helps

Edited by chaosbginwenrealityend

Share this post


Link to post
Share on other sites
Morningstar666

Greetings  @chaosbginwenrealityend  could you make a uploud of those files that you changed so that I could add in my gta and do a little test with the missions?
if this works we can have a perfect gta because
for me cities work normal

Share this post


Link to post
Share on other sites
chaosbginwenrealityend
On 11/27/2018 at 5:52 AM, Morningstar666 said:

could you make a uploud of those files that you changed so that I could add in my gta and do a little test with the missions?

Any report and/or file from me that fixed a bug or removed a potential game crash I submitted already in this thread on the last two or three pages. I put them here with the hopes people will use them and confirm the problems were fixed.

 

Also, I did a study of mission paths. I never had a reason to ever look at these so I thought this was a good opportunity to do so.

 

The mission paths that main.scm refers to are located in data/paths/carrec.img. I opened both the original and the one from SAxLCxVC and compared them side by side and could not find any differences other than the one from SAxLCxVC has eight additional paths which were appended to the end. Goodidea82 put on his Github site the missions crashing so I further noted every scripted path used in all those missions and compared line by line each one but there no differences; and are still in the same correct order in the hierarchy as the original,  so this tells me it should not be a path related problem. The nodes.dat I think are all car and ped paths probably not mission related. On mine for testing seeing the SAxLCxVC carrec was still under the limit of 475 I commented out this in the FLA.ini:

 

; RRR (475)
#FILE_TYPE_RRR = 500

 

I did notice an increase of train traffic after I done this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 Members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.