Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums! (92,348 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

mlgthatsme

Single Player Garage

Recommended Posts

ikt

SinglePlayerApartments has an acceptable alternative to this, and it's being updated. Sadly you just can't share the garage between your characters.

 

SPA currently has less conflicts with other mods that utilize the MP maps.

Share this post


Link to post
Share on other sites
F2F2

SinglePlayerApartments has an acceptable alternative to this, and it's being updated. Sadly you just can't share the garage between your characters.

 

SPA currently has less conflicts with other mods that utilize the MP maps.

It'd be great.. if I could move my cars from this mod over :/

Share this post


Link to post
Share on other sites
Cyron43

It no longer seems to work with the latest update of GTA V. I read previously that the mod was no longer being worked on, does this mean its the end or did the maker find someone to continue on it or something. Perhaps someone found a way to keep it working?

I offered him to continue this project but he hasn't replied yet.

 

 

 

SinglePlayerApartments has an acceptable alternative to this, and it's being updated. Sadly you just can't share the garage between your characters.

 

SPA currently has less conflicts with other mods that utilize the MP maps.

It'd be great.. if I could move my cars from this mod over :/

 

Does SPG crash right at the start in your game? I'm asking because it usually crashes at the attempt to enter a garage. You don't need to do that in order to access a vehicle. Just press F5 and choose one from the list. Then drive it to your desired SPA garage. Edited by Cyron43

Share this post


Link to post
Share on other sites
ikt

SPG works fine here, I can get my cars delivered normally with the F5 method.

Share this post


Link to post
Share on other sites
wootwoots

why would ppl still use that mod ?

 

no more support

very bad resources eating

 

I mean ?

Share this post


Link to post
Share on other sites
kkj_9690

Just hoping for the best.... I want to get the mod working again..

Share this post


Link to post
Share on other sites
drklng

well I can't get SPG working anymore, and I can't drive a car into SPA so I now have none of my saved cars at all.

Share this post


Link to post
Share on other sites
F2F2

 

It no longer seems to work with the latest update of GTA V. I read previously that the mod was no longer being worked on, does this mean its the end or did the maker find someone to continue on it or something. Perhaps someone found a way to keep it working?

I offered him to continue this project but he hasn't replied yet.

 

 

SinglePlayerApartments has an acceptable alternative to this, and it's being updated. Sadly you just can't share the garage between your characters.

 

SPA currently has less conflicts with other mods that utilize the MP maps.

It'd be great.. if I could move my cars from this mod over :/

 

Does SPG crash right at the start in your game? I'm asking because it usually crashes at the attempt to enter a garage. You don't need to do that in order to access a vehicle. Just press F5 and choose one from the list. Then drive it to your desired SPA garage.

 

SPG crashes right at the start, at loading screen, can't get the game to work anymore since latest patch.

 

 

SPG works fine here, I can get my cars delivered normally with the F5 method.

Not for me, you got legit copy with latest patch? Cause so far I've only heard cracks and people with previous patch that got it to work.

Edited by F2F2

Share this post


Link to post
Share on other sites
ikt

Nope build 617 from Steam works normally.

Share this post


Link to post
Share on other sites
F2F2

Nope build 617 from Steam works normally.

I don't use steam...

Share this post


Link to post
Share on other sites
Cyron43

why would ppl still use that mod ?

 

no more support

very bad resources eating

 

I mean ?

Well if someone with good programming skills inherits this project, there will be support again and he can probably do something about the resource management. I'd need to get my hands on the code before I can tell for sure.

So your arguments are invalid because you complain about the current state. We on the other hand talk about the future of this mod. A new and shiny version which runs like a charm. Still not interested? Well... who cares. I want it and if I get the code, I will make it happen and I will enjoy the result. I would publish the new version of course but I would give an excrement if anyone else likes it. I have written way more mods than just VAutodrive but I enjoy them all by myself. The less people care, the less I face the annoyance of people who are too lazy to read the manual. :p

Edited by Cyron43

Share this post


Link to post
Share on other sites
ikt

You can run the dll through a .NET decompiler and resurrect the mod. Nothing's stopping you. (Well, aside from the fact you'd be stealing the code...)

 

cx1j1OT.png

 

It's nice and tidy and easy to look at.

Edited by ikt

Share this post


Link to post
Share on other sites
kkj_9690

So definitely no more updates?

Share this post


Link to post
Share on other sites
FCCC

I've been using this mod for sometime now and it works ok for me. I'm currently running it on the Steam version of GTAV Build 1.0.617.1 Online 1.32.

 

If anyone interested in getting it to work let me know.

Share this post


Link to post
Share on other sites
F2F2

I've been using this mod for sometime now and it works ok for me. I'm currently running it on the Steam version of GTAV Build 1.0.617.1 Online 1.32.

 

If anyone interested in getting it to work let me know.

Haven't been able to get it to work for non-steam version... so....

Share this post


Link to post
Share on other sites
FCCC

I haven't try it on the Rockstar version of the game yet, but it shouldn't make any difference I would think.

 

First install the mod as normal and load the game let crash, close Rockstar window.

 

What the problem is this mod calls a server which is shut down or no longer used, so what you need to do is look for a file (SPG.ini) in the Grand Theft Auto V folder.

 

Open it with Nopepad or Notepad++,

 

<Key>use_net_notifications</Key>

<Value>True</Value> ***Change this value to False***

 

then save the file and the game should load and the mod will work.

I'm shock that no one else hasn't notice this, the SPG.log file tell you that's the issue.

Edited by FCCC

Share this post


Link to post
Share on other sites
F2F2

I haven't try it on the Rockstar version of the game yet, but it shouldn't make any difference I would think.

 

First install the mod as normal and load the game let crash, close Rockstar window.

 

What the problem is this mod calls a server which is shut down or no longer used, so what you need to do is look for a file (SPG.ini) in the Grand Theft Auto V folder.

 

Open it with Nopepad or Notepad++,

 

<Key>use_net_notifications</Key>

<Value>True</Value> ***Change this value to False***

 

then save the file and the game should load and the mod will work.

I'm shock that no one else hasn't notice this, the SPG.log file tell you that's the issue.

Thanks i'll try this and let you know how it went :)

Share this post


Link to post
Share on other sites
qiangqiang101

 

It no longer seems to work with the latest update of GTA V. I read previously that the mod was no longer being worked on, does this mean its the end or did the maker find someone to continue on it or something. Perhaps someone found a way to keep it working?

I offered him to continue this project but he hasn't replied yet.

 

 

SinglePlayerApartments has an acceptable alternative to this, and it's being updated. Sadly you just can't share the garage between your characters.

 

SPA currently has less conflicts with other mods that utilize the MP maps.

It'd be great.. if I could move my cars from this mod over :/

 

Does SPG crash right at the start in your game? I'm asking because it usually crashes at the attempt to enter a garage. You don't need to do that in order to access a vehicle. Just press F5 and choose one from the list. Then drive it to your desired SPA garage.

 

If I'm going to continue this project, I need to study Mlgthatsme's coding because we all have our own coding pattern, and I'm coding in VB not C# so there is no way I can continue his project, maybe if you ask somebody familiar with C# like jedijosh920 or Guadmaz.

Share this post


Link to post
Share on other sites
mlgthatsme

Long time no see.

 

Update has been posted on GTA5 Mods

Share this post


Link to post
Share on other sites
Johnny362000

I can't be bothered to read through 24 pages to see if this has been brought up yet but I have a minor problem

The vehicles I put into my garages don't have 2 things saved - liveries (on things like the Slamvan Custom or Sultan RS) and extra options like the stock spoiler on the Elegy, roof of Coquette etc

I don't know how easy these 2 things are to fix but could you please fix them? Other than that the mod is everything I've been looking for and more and is pretty much perfect

Edited by Johnny362000

Share this post


Link to post
Share on other sites
Chiz-Wiz

Hi guys, well i'm just new here... but i've been modding GTA5 for about a year now and SPG is one of the top must install mods in the game hahaha. Thanks mlgthatme

 

Just wanted to report a bug i'm experiencing so far.

 

So I installed SPG (No-persistence mods since conflict), then another mod called Vstanced.

 

*(Vstanced just lowers your vehicle in game)

https://www.gta5-mods.com/scripts/vstanced

 

Now with the car lowered, I can still save car but each time I enter the garage it also exits right away which spawns me on the entry point. Another problem I have is when I enter on foot on the bugged garages, my character is sent into the abyss and spawns on the middle of the street and another assortment of bugs appear like peds and vehicles disappear when near you.

 

One fix i made is to enter the garage with the suspension raised up to max (normal suspension) using vstanced. It works for the garages with interiors like on the pillbox building and the 2 car interior etc.

 

But on a building with the white interior i.e. eclipse towers (sorry i don't know what the interiors are called) even if the suspension is raised the bug remains the same.

 

I hope that someone would somehow look into this because vstanced can really make a tall sh*tty car into something (with wheel mods and stuff) hahahahaha

 

Thanks again, hope to hear form you guys...

Edited by Chiz-Wiz

Share this post


Link to post
Share on other sites
ironhair

Faced an error in game..

 

https://cdn.discordapp.com/attachments/335524938851287040/376928387215785985/unknown.png

 

The SPG.log file:

 

----- Begin Exception -----
Time: 06-11-2017 08:24:43
Message: Method not found: 'Boolean GTA.Blip.op_Inequality(GTA.Blip, GTA.Blip)'.
Extra Message:
Exception Dump:

System.MissingMethodException: Method not found: 'Boolean GTA.Blip.op_Inequality(GTA.Blip, GTA.Blip)'.
at mlgthatsme.GarageMod.GarageBuilding.CreateGarageBlips()
at mlgthatsme.GarageMod.GarageBuilding.SaveBuilding()
at mlgthatsme.GarageMod.SinglePlayerGarageScript.SaveAllBuildings()
at mlgthatsme.GarageMod.Garage.Load(String garageDir, GarageLayout garageLayout, GarageOutsideLayout garageOutside)
at mlgthatsme.GarageMod.GarageBuilding.Load(String s)
at mlgthatsme.GarageMod.SinglePlayerGarageScript.Init()
at mlgthatsme.GarageMod.SinglePlayerGarageScript.OnTick(Object sender, EventArgs e)
------ End Exception ------

 

Any help will be appreciated

 

-----------

Did a google search and I have updated my scripthook and .net scripthook and all my mod files. Didn't help.

Edited by ironhair

Share this post


Link to post
Share on other sites
ironhair

Help, anyone?

Share this post


Link to post
Share on other sites
Dude1357

First time trying out the mod, I got it alongside a Dealership mod for MP vehicles and Benny's Shop. This mod worked alright at first, but when I tried to enter with a vehicle (I had a Slamvan) it loaded, showed the garage for a split second, and kicked me out again. Now the Slamvan did save into the garage, but it also kicked me out still in the Slamvan. I tried a couple times to enter still in the Slamvan and the same thing. I tried entering on foot then, and when the garage loaded, there was no garage and I fell through the world. Not sure if I did something wrong or if there's some bug here. I followed the install instructions perfectly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.