Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (91,610 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

sjaak327

Simple Trainer for GTAV

Recommended Posts

raburs

I don't know if this has been reported or not, but in the latest version, whenever I spawn a model, there is a slight delay between click and spawning. This was working fine in the last versions. What I mean is, it feels like the new version takes a little time to spawn model unlike previous versions. Like whenever I spawn a model, the menu just disappears for a sec then reappears when the model is spawned. This never happened in previous versions. It was really fast and smooth in previous version.

Share this post


Link to post
Share on other sites
ikt

I don't know if this has been reported or not, but in the latest version, whenever I spawn a model, there is a slight delay between click and spawning. This was working fine in the last versions. What I mean is, it feels like the new version takes a little time to spawn model unlike previous versions. Like whenever I spawn a model, the menu just disappears for a sec then reappears when the model is spawned. This never happened in previous versions. It was really fast and smooth in previous version.

Have you experienced this with other trainers? I've been getting the same but the game has been having resource loading issues for a while, so it's probably the game. I don't know how sjaak coded it, but generally spawning is just this:

 

 

STREAMING::REQUEST_MODEL(hash);while (!STREAMING::HAS_MODEL_LOADED(hash)) WAIT(0);VEHICLE::CREATE_VEHICLE(hash, pos.x, pos.y, pos.z, heading, 0, 1);

Share this post


Link to post
Share on other sites
zanesix

I don't know if this has been reported or not, but in the latest version, whenever I spawn a model, there is a slight delay between click and spawning. This was working fine in the last versions. What I mean is, it feels like the new version takes a little time to spawn model unlike previous versions. Like whenever I spawn a model, the menu just disappears for a sec then reappears when the model is spawned. This never happened in previous versions. It was really fast and smooth in previous version.

Changes from 5.7

-fixed an issue where when changing characters, the no helmet option would not work.

-added a 2 second wait to fix the above issue...

-added some missing weapons to the drive by bodyguards weapons. Be aware, the attachments for the new weapons have not been updated, this also applies to the

normal weapons section, I cannot be bothered atm, they work, and that's all that counts...

Share this post


Link to post
Share on other sites
ZZCOOL

can you add an option to access all timecycle modifiers i'd like to access all the timecycles that activates when you go inside a spot

Share this post


Link to post
Share on other sites
_CP_

@zzcool
It's already there.

Share this post


Link to post
Share on other sites
nkjellman

@zzcool

It's already there.

I see what he is asking for though.

 

You can add timecyc modifiers. It would be sweet if they showed up in the trainer.

Share this post


Link to post
Share on other sites
davedumas0

i am a developer for a fiveM script is there a way to see the source for this trainer? i am curious how the bunker stuff gets loaded

Share this post


Link to post
Share on other sites
nkjellman

i am a developer for a fiveM script is there a way to see the source for this trainer? i am curious how the bunker stuff gets loaded

Since Open Interiors seems to be dead, I would like to make my own script that is supposed to run along side Open Interiors, which handle the Gun Running and Import/Export interiors so I'd like to know that as well.

Share this post


Link to post
Share on other sites
sjaak327

I don't know if this has been reported or not, but in the latest version, whenever I spawn a model, there is a slight delay between click and spawning. This was working fine in the last versions. What I mean is, it feels like the new version takes a little time to spawn model unlike previous versions. Like whenever I spawn a model, the menu just disappears for a sec then reappears when the model is spawned. This never happened in previous versions. It was really fast and smooth in previous version.

I had to add a two seconds delay, otherwise the no helmet "persistance" would lead to game crash.

 

Hardly a problem, in my view.

Share this post


Link to post
Share on other sites
sjaak327

i am a developer for a fiveM script is there a way to see the source for this trainer? i am curious how the bunker stuff gets loaded

 INTERIOR::_ENABLE_INTERIOR_PROP(interior1, Set07[set7a].prop);    INTERIOR::_ENABLE_INTERIOR_PROP(interior1, Set08[set8a].prop);    INTERIOR::_ENABLE_INTERIOR_PROP(interior1, Set09[set9a].prop);    if (gr1 == true) { INTERIOR::_ENABLE_INTERIOR_PROP(interior1, "office_blocker_set"); }    if (gr2 == true) { INTERIOR::_ENABLE_INTERIOR_PROP(interior1, "office_upgrade_set"); }    if (gr3 == true) { INTERIOR::_ENABLE_INTERIOR_PROP(interior1, "gun_range_blocker_set"); }    if (gr4 == true) { INTERIOR::_ENABLE_INTERIOR_PROP(interior1, "gun_wall_blocker"); }    if (gr5 == true) { INTERIOR::_ENABLE_INTERIOR_PROP(interior1, "gun_range_lights"); }    if (gr6 == true) { INTERIOR::_ENABLE_INTERIOR_PROP(interior1, "gun_locker_upgrade"); }    if (gr7 == true) { INTERIOR::_ENABLE_INTERIOR_PROP(interior1, "gun_schematic_set"); }        INTERIOR::REFRESH_INTERIOR(interior1); 

and set07 choices:

 

{"Style A","bunker_style_a"},

{"Style B","bunker_style_b" },

{"Style C","bunker_style_c" },

 

set08:

 

{ "Standard Bunker Set","standard_bunker_set" },

{ "Upgrade Bunker Set","upgrade_bunker_set" },

 

and set09:

 

{ "Standard Security","standard_security_set" },

{ "Upgraded Security","security_upgrade" },

Edited by sjaak327

Share this post


Link to post
Share on other sites
Quinn_flower

Question....

 

Can I use this online to unlock the Halloween shirts? Been looking forever to unlock them.

Share this post


Link to post
Share on other sites
SilverRST

Question....

 

Can I use this online to unlock the Halloween shirts? Been looking forever to unlock them.

No, you can't use Simple Trainer in online.

Edited by SilverRST

Share this post


Link to post
Share on other sites
Daines001

Sjaak sorry to ask ... but my MP_freemode doesn't save my face changes only clothes, hair etc... but not facial options I made and saved.

Share this post


Link to post
Share on other sites
Marcin6

Could you add option to freeze mission timer ? Also is there a posiility to increase characters stats like lung driving, shooting, stamina etc... ?

Share this post


Link to post
Share on other sites
raburs

"SCRIPT HOOK V ERROR - CORE: An exception occurred while executing 'TrainerV.asi' (0x00007FFAD97DCDB0), id 36" - This happened when I spawn models sometimes. It doesn't happen always, but almost every session, I get this after spawning one or two models. Or after playing for a few minutes (1-2).

 

I don't know if this has been reported but many people have reported this even on 5mods.

 

This issue has been occurring since the last few updates.

Edited by raburs

Share this post


Link to post
Share on other sites
MightyMax

@sjaak327 "SCRIPT HOOK V ERROR - CORE: An exception occurred while executing 'TrainerV.asi' (0x00007FFAD97DCDB0), id 36" - This happened when I spawn models sometimes. It doesn't happen always, but almost every session, I get this after spawning one or two models. Or after playing for a few minutes (1-2).

Edited by MightyMax

Share this post


Link to post
Share on other sites
wootwoots

@sjaak327

 

Little "request" : would it be possible to have a little option to be able to have the keys "MenuKeyQF/QB" used to change the various options instead of the "MenuKeyScrollUp/down" keys ?

I now use way more thoses column left - right keys than the page change ones, i would be far more handy that way :)

 

thanks !

Share this post


Link to post
Share on other sites
65536

"SCRIPT HOOK V ERROR - CORE: An exception occurred while executing 'TrainerV.asi' (0x00007FFAD97DCDB0), id 36" - This happened when I spawn models sometimes. It doesn't happen always, but almost every session, I get this after spawning one or two models. Or after playing for a few minutes (1-2).

 

I don't know if this has been reported but many people have reported this even on 5mods.

 

This issue has been occurring since the last few updates.

Seems other peoples seems to get same issue too, including me. I got this same crash in SimpleNativeTrainer's Skin Selector screen twice!

 

@sjaak327, can you fix this issue? :panic: Aside of this bug, you'll need also do now update your trainer for latest Online DLC - "Smuggler's Run" released today by R*, and for the new GTA V's patch which is now 1.0.1180.2. :panic:

Edited by 65536

Share this post


Link to post
Share on other sites
nkjellman

@sjaak327

Have you considered making your vehicle list update dynamically like Menyoo? It would be less for you to deal with when updating the trainer. You would just need a file which relates all of the vehicle names to the model names. If you did this, you could even remove the add on cars menu.

 

Also regarding radio emitters, there are some things that I wanted to point out.

-The update could have fixed it, so it might not be a problem.

-The SP safehouse emitter (Michael's house) messes up when it isn't even active in the trainer, and plays the same default music. Without mods, it is fine.

-In Gun Running, Rockstar did add a radio emitter in the Mobile Operations Center, (and added one in the Hangar in Smugglers Run). This may have been what screwed up your code.

 

I sure hope that it can be fixed. It adds a lot of immersion to the interiors. I even modified the source code to Single Player Apartment when you added it to remove the on foot radio workaround.

Edited by nkjellman

Share this post


Link to post
Share on other sites
sjaak327

^ We will have to wait and see what will happen to the radio, the fact that R added some radios would not mess up my code.

 

In any case, when the hook is out, I have already added most of the new stuff.

 

Changes from 5.8
-removed 2 second wait when changing characters, the no helmet option now needs to be re-enabled if it was enabled. This should fix the crashes people were reporting.
-added 19 new Vehicles.
-added one ped (u_m_y_smugmech_01).
-added 2 cutscenes.

 

I will add the overlays once I have a working hook, also there seems to be a new interior, again when the hook is out, I can play with it.

Edited by sjaak327

Share this post


Link to post
Share on other sites
nkjellman

^ We will have to wait and see what will happen to the radio, the fact that R added some radios would not mess up my code.

 

In any case, when the hook is out, I have already added most of the new stuff.

 

Changes from 5.8

-removed 2 second wait when changing characters, the no helmet option now needs to be re-enabled if it was enabled. This should fix the crashes people were reporting.

-added 19 new Vehicles.

-added one ped (u_m_y_smugmech_01).

-added 2 cutscenes.

 

I will add the overlays once I have a working hook, also there seems to be a new interior, again when the hook is out, I can play with it.

Yeah you wouldn't think that would be the case. For all you know, it could be a limit. If they added more emitters, and your adding more emitters, it could have caused some sort of memory problem. It is a habit I have when things like this occur to blame the gameconfig.xml. lol.

 

Also, Rockstar added 1 additional interior in this update, which would be the hangar. That one can be customized.

 

Another request, would it be possible to save the interior prop settings to the ini? Heck, maybe even let us set it up so the whole interior loads on start up (regardless of whether your trainer has the MP maps on or off since I have another script handling that). That would be helpful so I can use SP Garage to get them 60 car garages and hangars functional without having to manually load the interior and set it up every time.

 

Finally, I am curious, how does the No Helmet option work? It may be info worth sharing to Unknown Modder, who may be able to do some more work on Character Swap so your character will use the right helmets or parachutes.

Share this post


Link to post
Share on other sites
sjaak327

^ :

 

PED::SET_PED_HELMET(playerPed, 0);
PED::REMOVE_PED_HELMET(playerPed, true);

 

It still boggles the mind why this would lead to a crash when swapping models, as I don't even run this in tick. I added a two second wait, but apparently it still crashes the game.

Share this post


Link to post
Share on other sites
nkjellman

^ :

 

PED::SET_PED_HELMET(playerPed, 0);

PED::REMOVE_PED_HELMET(playerPed, true);

 

It still boggles the mind why this would lead to a crash when swapping models, as I don't even run this in tick. I added a two second wait, but apparently it still crashes the game.

Different peds have different helmet components. For example, the MP characters have a lot more components due to all of the DLC. This component variation between peds is probably why.

 

I recommend undoing what it does when swapping models, then reapply when the switch is complete.

Share this post


Link to post
Share on other sites
Alex106
Wanted to report 2 bugs

The teleport for the Maze Bank West (Power Broker Ice) office doesn't load the interior

The freeze weather function doesn't work with the xmas weather. Instead it freezes to another one (Extra Sunny or Clear)

Here's how it is after trying to freeze it

Rp6iPg7.jpg

Share this post


Link to post
Share on other sites
sjaak327

 

Wanted to report 2 bugs
The teleport for the Maze Bank West (Power Broker Ice) office doesn't load the interior
The freeze weather function doesn't work with the xmas weather. Instead it freezes to another one (Extra Sunny or Clear)
Here's how it is after trying to freeze it
Rp6iPg7.jpg

 

​The first problem is solved, the second one is not, the code is 100% correct, I actually freeze the wheater to XMAS, but the game does not execute it for some reason, I have no idea why.

 

edit: I employed a work-around which seems to be working. I first set the weather explicitely then force. So also fixed, alltough in my view no bug in my code :D

Edited by sjaak327

Share this post


Link to post
Share on other sites
teisco

Off topic but just have to know, does GTA 5 support VR?

Share this post


Link to post
Share on other sites
BrownieBear

Not officially

Share this post


Link to post
Share on other sites
teisco

Thanks but will it work and how to make it work?

Share this post


Link to post
Share on other sites
BrownieBear

For that you really have to either do research yourself or create a new thread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 3 Users Currently Viewing
    0 members, 0 Anonymous, 3 Guests

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.