Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Criminal Enterprises
      2. Updates
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Blood Money
      2. Frontier Pursuits
      3. Find Lobbies & Outlaws
      4. Help & Support
    3. Crews

    1. Grand Theft Auto Series

      1. Bugs*
      2. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Classic GTA SA
      2. Guides & Strategies
      3. Help & Support
    6. GTA Vice City

      1. Classic GTA VC
      2. Guides & Strategies
      3. Help & Support
    7. GTA III

      1. Classic GTA III
      2. Guides & Strategies
      3. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

    2. Support

    3. Suggestions

Please,help me!


maoffense01
 Share

Recommended Posts

maoffense01

Damn this problem! :devil: I'm feeling mad oh damn! Look at this stupid bug. It's just natural,right? But I saw the problem "Incorrect number of conditions. 8 max." . I don't know how to fix it. Really need a quick reply,please!

My cleo mission's ready,but this problemm, ahhhhhhhhhhhhhh! I think I wanna punch a wall! Please,reply please!

 

Here's the code:

:GROVE_STREET_MISSION1 wait 0 ms0247: load_model #TAHOMA 0247: load_model #MAJESTIC 0247: load_model #GREENWOO 0247: load_model #SAVANNA 0247: load_model #CHROMEGUN0247: load_model #SHOTGSPA 0247: load_model #AK47 0247: load_model #MINIGUN 0247: load_model #MICRO_UZI 0247: load_model #MP5LNG 0247: load_model #TEC9 0247: load_model #AK47 0247: load_model #M40247: load_model #FAM1 0247: load_model #FAM2 0247: load_model #FAM3 0247: load_model #BALLAS1 0247: load_model #BALLAS2 0247: load_model #BALLAS304ED: load_animation  "TEC"04ED: load_animation  "PED"if or8248:   not model #TAHOMA available8248:   not model #MAJESTIC available8248:   not model #GREENWOO available8248:   not model #SAVANNA available8248:   not model #CHROMEGUN available8248:   not model #SHOTGSPA available8248:   not model #AK47 available8248:   not model #MINIGUN available8248:   not model #MICRO_UZI available8248:   not model #MP5LNG available8248:   not model #TEC9 available8248:   not model #AK47 available8248:   not model #M4 available8248:   not model #FAM1 available8248:   not model #FAM2 available8248:   not model #FAM3 available8248:   not model #BALLAS1 available8248:   not model #BALLAS2 available8248:   not model #BALLAS3 available84EE:   not animation "TEC" loaded84EE:   not animation "PED" loadedjf @GROVE_STREET_MISSION2  wait 0 msjump @GROVE_STREET_MISSION1   :GROVE_STREET_MISSION2

Hope you answer quickly!

Edited by maoffense01
Link to comment
Share on other sites

Damn this problem! :devil: I'm feeling mad oh damn! Look at this stupid bug. It's just natural,right? But I saw the problem "Incorrect number of conditions. 8 max." . I don't know how to fix it. Really need a quick reply,please!

My cleo mission's ready,but this problemm, ahhhhhhhhhhhhhh! I think I wanna punch a wall! Please,reply please!

 

Here's the code:

:GROVE_STREET_MISSION1 wait 0 ms0247: load_model #TAHOMA 0247: load_model #MAJESTIC 0247: load_model #GREENWOO 0247: load_model #SAVANNA 0247: load_model #CHROMEGUN0247: load_model #SHOTGSPA 0247: load_model #AK47 0247: load_model #MINIGUN 0247: load_model #MICRO_UZI 0247: load_model #MP5LNG 0247: load_model #TEC9 0247: load_model #AK47 0247: load_model #M40247: load_model #FAM1 0247: load_model #FAM2 0247: load_model #FAM3 0247: load_model #BALLAS1 0247: load_model #BALLAS2 0247: load_model #BALLAS304ED: load_animation  "TEC"04ED: load_animation  "PED"if or8248:   not model #TAHOMA available8248:   not model #MAJESTIC available8248:   not model #GREENWOO available8248:   not model #SAVANNA available8248:   not model #CHROMEGUN available8248:   not model #SHOTGSPA available8248:   not model #AK47 available8248:   not model #MINIGUN available8248:   not model #MICRO_UZI available8248:   not model #MP5LNG available8248:   not model #TEC9 available8248:   not model #AK47 available8248:   not model #M4 available8248:   not model #FAM1 available8248:   not model #FAM2 available8248:   not model #FAM3 available8248:   not model #BALLAS1 available8248:   not model #BALLAS2 available8248:   not model #BALLAS3 available84EE:   not animation "TEC" loaded84EE:   not animation "PED" loadedjf @GROVE_STREET_MISSION2  wait 0 msjump @GROVE_STREET_MISSION1   :GROVE_STREET_MISSION2

Hope you answer quickly!

Split the condition loops up into something like this:

 

 

if or

8248: not model #TAHOMA available

8248: not model #MAJESTIC available

8248: not model #MP5LNG available

8248: not model #TEC9 available

8248: not model #AK47 available

8248: not model #M4 available

8248: not model #FAM1 available

8248: not model #FAM2 available

8248: not model #FAM3 available

8248: not model #BALLAS1 available

8248: not model #BALLAS2 available

8248: not model #BALLAS3 available

84EE: not animation "TEC" loaded

84EE: not animation "PED" loaded

jf @GROVE_MISSION3

 

:GROVE_MISSION3

wait 0

if and

8248: not model #GREENWOO available

8248: not model #SAVANNA available

8248: not model #CHROMEGUN available

8248: not model #SHOTGSPA available

8248: not model #AK47 available

8248: not model #MINIGUN available

8248: not model #MICRO_UZI available

jf @GROVE_MISSION1

 

 

It's a small example, hopefully this will help. It's basicly a loop, with multiple outputs.

If 1 condition is not met, the engine jumps to the next loop. And after it went through all loops, it'll go back to the beginning.

Link to comment
Share on other sites

DON'T load PED anims! They're loaded all the time.

 

 

It's a small example, hopefully this will help. It's basicly a loop, with multiple outputs.

If 1 condition is not met, the engine jumps to the next loop. And after it went through all loops, it'll go back to the beginning.

And it's incorrect.

 

 

Best way would be to use high level constructs, because then you don't end up with sh*tty looking and easy to ocnfuse labels. Your code actually looks like R*'s loading check loop, which in fact looked somewhat like:

 

 

 

0247: load_model #TAHOMA0247: load_model #MAJESTIC0247: load_model #GREENWOO0247: load_model #SAVANNA0247: load_model #CHROMEGUN0247: load_model #SHOTGSPA0247: load_model #AK470247: load_model #MINIGUN0247: load_model #MICRO_UZI0247: load_model #MP5LNG0247: load_model #TEC90247: load_model #AK470247: load_model #M40247: load_model #FAM10247: load_model #FAM20247: load_model #FAM30247: load_model #BALLAS10247: load_model #BALLAS20247: load_model #BALLAS304ED: load_animation "TEC"while true    if or        8248:   not model #TAHOMA available        8248:   not model #MAJESTIC available        8248:   not model #GREENWOO available        8248:   not model #SAVANNA available        8248:   not model #CHROMEGUN available        8248:   not model #SHOTGSPA available        8248:   not model #AK47 available        8248:   not model #MINIGUN available    jf break    wait 0endwhile true    if or        8248:   not model #MICRO_UZI available        8248:   not model #MP5LNG available        8248:   not model #TEC9 available        8248:   not model #AK47 available        8248:   not model #M4 available        8248:   not model #FAM1 available        8248:   not model #FAM2 available        8248:   not model #FAM3 available    jf break    wait 0endwhile true    if or        8248:   not model #BALLAS1 available        8248:   not model #BALLAS2 available        8248:   not model #BALLAS3 available        84EE:   not animation "TEC" loaded    jf break    wait 0end
(do onte this has no labels as they are useless)

 

 

Better yet... is this loading done during a fadeout? If it is, just remove all those checks and place LOAD_ALL_MODELS_NOW. You'll save yourself some hassle and also allow the mission to progress asap.

Link to comment
Share on other sites

maoffense01

I need a help. The .cm file is okay now. I've compiled it. I maked a .cs file(to teleport where the mission will start) and .fxt file(to show texts). And I place the three(.cs, .cm and .fxt files) into Cleo folder. I placed the fxt file into cleo text. The mission is okay now.

 

But when I go to sphere where the mission is there to stars,my GTA SA crashes. It crashes in the very beginning of the mission. As the mission name show,the mission crashes. Really need help please!

 

Code :

{$CLEO .cm}thread 'GSM'increment_mission_attempts   $ONMISSION = 101F0: set_max_wanted_level_to 000BA: show_text_styled GXT "MNAME" time 2000 style 2  // The Fight Against Balla's01B4: set_player $PLAYER_CHAR can_move 0:GROVE_STREET_MISSION10247: load_model #TAHOMA 0247: load_model #MAJESTIC 0247: load_model #GREENWOO 0247: load_model #SAVANNA 0247: load_model #CHROMEGUN0247: load_model #SHOTGSPA 0247: load_model #AK47 0247: load_model #MINIGUN 0247: load_model #MICRO_UZI 0247: load_model #MP5LNG 0247: load_model #TEC9  0247: load_model #M40247: load_model #FAM1 0247: load_model #FAM2 0247: load_model #FAM3 0247: load_model #BALLAS1 0247: load_model #BALLAS2 0247: load_model #BALLAS304ED: load_animation  "TEC"038B: load_requested_models:CHCKMODLS1if or8248:   not model #TAHOMA available8248:   not model #MAJESTIC available8248:   not model #GREENWOO available8248:   not model #SAVANNA available8248:   not model #CHROMEGUN available8248:   not model #SHOTGSPA available8248:   not model #AK47 available8248:   not model #MINIGUN availablejf @CHCKMODLS2  wait 0jump @CHCKMODLS1 :CHCKMODLS2while trueif or8248:   not model #MICRO_UZI available8248:   not model #MP5LNG available8248:   not model #TEC9 available8248:   not model #AK47 available8248:   not model #M4 available8248:   not model #FAM1 available8248:   not model #FAM2 available8248:   not model #FAM3 availablejf @CHCKMODLS3  wait 0jump @CHCKMODLS2 :CHCKMODLS3while trueif or8248:   not model #BALLAS1 available8248:   not model #BALLAS2 available8248:   not model #BALLAS3 available84EE:   not animation "TEC" loadedjf @GROVE_STREET_MISSION2  wait 0jump @CHCKMODLS3   :GROVE_STREET_MISSION2

Hope you answer

Link to comment
Share on other sites

I need a help. The .cm file is okay now. I've compiled it. I maked a .cs file(to teleport where the mission will start) and .fxt file(to show texts). And I place the three(.cs, .cm and .fxt files) into Cleo folder. I placed the fxt file into cleo text. The mission is okay now.

 

But when I go to sphere where the mission is there to stars,my GTA SA crashes. It crashes in the very beginning of the mission. As the mission name show,the mission crashes. Really need help please!

 

Code :

{$CLEO .cm}thread 'GSM'increment_mission_attempts   $ONMISSION = 101F0: set_max_wanted_level_to 000BA: show_text_styled GXT "MNAME" time 2000 style 2  // The Fight Against Balla's01B4: set_player $PLAYER_CHAR can_move 0:GROVE_STREET_MISSION10247: load_model #TAHOMA 0247: load_model #MAJESTIC 0247: load_model #GREENWOO 0247: load_model #SAVANNA 0247: load_model #CHROMEGUN0247: load_model #SHOTGSPA 0247: load_model #AK47 0247: load_model #MINIGUN 0247: load_model #MICRO_UZI 0247: load_model #MP5LNG 0247: load_model #TEC9  0247: load_model #M40247: load_model #FAM1 0247: load_model #FAM2 0247: load_model #FAM3 0247: load_model #BALLAS1 0247: load_model #BALLAS2 0247: load_model #BALLAS304ED: load_animation  "TEC"038B: load_requested_models:CHCKMODLS1if or8248:   not model #TAHOMA available8248:   not model #MAJESTIC available8248:   not model #GREENWOO available8248:   not model #SAVANNA available8248:   not model #CHROMEGUN available8248:   not model #SHOTGSPA available8248:   not model #AK47 available8248:   not model #MINIGUN availablejf @CHCKMODLS2  wait 0jump @CHCKMODLS1 :CHCKMODLS2while trueif or8248:   not model #MICRO_UZI available8248:   not model #MP5LNG available8248:   not model #TEC9 available8248:   not model #AK47 available8248:   not model #M4 available8248:   not model #FAM1 available8248:   not model #FAM2 available8248:   not model #FAM3 availablejf @CHCKMODLS3  wait 0jump @CHCKMODLS2 :CHCKMODLS3while trueif or8248:   not model #BALLAS1 available8248:   not model #BALLAS2 available8248:   not model #BALLAS3 available84EE:   not animation "TEC" loadedjf @GROVE_STREET_MISSION2  wait 0jump @CHCKMODLS3   :GROVE_STREET_MISSION2

Hope you answer

 

Firstly, forgive me for being blind, I don't see a sphere ever being created in the script?

 

Secondly, I'd end the thread after:

:GROVE_STREET_MISSION2

Just to be safe whilst coding the start of the mission.

 

Oh and there aren't any fades either.

Link to comment
Share on other sites

maoffense01

Oh,ED-E! That's just okay! It's nice to meet you.I'm sorry too! By the way, this problem is fixed now. The mission crashes because of cutscenes. I don't really know ho to use cutscenes. So,instead of cutscenes,I'll only use texts and not cutscenes.

Thank you for the reply,and I'll bring it too when I become a pro cleo modder! Nice to meet you! :)


Alright! Yes! My very first cleo mission without the help of each other(I only used help only in what opcodes. Thanks to them). I did this whole code myself. Yesssssssssss Hahahahahha! I'm real cleo modder now oh yeahhhhhhhhhhhhhhhhhh!!!!

Link to comment
Share on other sites

DON'T load PED anims! They're loaded all the time.

 

 

It's a small example, hopefully this will help. It's basicly a loop, with multiple outputs.

If 1 condition is not met, the engine jumps to the next loop. And after it went through all loops, it'll go back to the beginning.

And it's incorrect.

 

 

Best way would be to use high level constructs, because then you don't end up with sh*tty looking and easy to ocnfuse labels. Your code actually looks like R*'s loading check loop, which in fact looked somewhat like:

 

 

 

0247: load_model #TAHOMA0247: load_model #MAJESTIC0247: load_model #GREENWOO0247: load_model #SAVANNA0247: load_model #CHROMEGUN0247: load_model #SHOTGSPA0247: load_model #AK470247: load_model #MINIGUN0247: load_model #MICRO_UZI0247: load_model #MP5LNG0247: load_model #TEC90247: load_model #AK470247: load_model #M40247: load_model #FAM10247: load_model #FAM20247: load_model #FAM30247: load_model #BALLAS10247: load_model #BALLAS20247: load_model #BALLAS304ED: load_animation "TEC"while true    if or        8248:   not model #TAHOMA available        8248:   not model #MAJESTIC available        8248:   not model #GREENWOO available        8248:   not model #SAVANNA available        8248:   not model #CHROMEGUN available        8248:   not model #SHOTGSPA available        8248:   not model #AK47 available        8248:   not model #MINIGUN available    jf break    wait 0endwhile true    if or        8248:   not model #MICRO_UZI available        8248:   not model #MP5LNG available        8248:   not model #TEC9 available        8248:   not model #AK47 available        8248:   not model #M4 available        8248:   not model #FAM1 available        8248:   not model #FAM2 available        8248:   not model #FAM3 available    jf break    wait 0endwhile true    if or        8248:   not model #BALLAS1 available        8248:   not model #BALLAS2 available        8248:   not model #BALLAS3 available        84EE:   not animation "TEC" loaded    jf break    wait 0end
(do onte this has no labels as they are useless)

 

 

Better yet... is this loading done during a fadeout? If it is, just remove all those checks and place LOAD_ALL_MODELS_NOW. You'll save yourself some hassle and also allow the mission to progress asap.

 

Alright. I guess that works too.

Edited by dkluin
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.