Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Cayo Perico Heist
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

      1. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. Announcements

    2. Support

      1. Court House
    3. Suggestions

Enhanced Native Trainer


arewenotmen

Recommended Posts

14 hours ago, _cOdy_ said:

Yes, I do!

edit:

I turned this option off and it works fine now!!! I didn't think this causes this problem!!! Thanks 4 your work n help! Bests!

Yeah, i know what the problem is. I'll fix it so you can use 'fuel consumption' even on missions. Just wait for the update.

Link to post
Share on other sites

Which key triggers the respawn when you have "Manual Respawn" feature on?

I think I clicked every key on my keyboard and I just can't do it.

Link to post
Share on other sites
On 1/12/2020 at 7:34 AM, grindersky said:

Which key triggers the respawn when you have "Manual Respawn" feature on?

I think I clicked every key on my keyboard and I just can't do it.

I suppose 'space' will do the trick.

Link to post
Share on other sites

@Slash_Alex Thank you! Please, do not forget the mentioned Locations / 'Teleport to Mission marker' and 'Teleport to maker' problems, either!

Edited by _cOdy_
Link to post
Share on other sites

there are strange things happen when I use the 'Teleport to Mission marker' in the

1) first mission 'Prologue' because the mission becomes failed when I drive the car and I have to go to the point;

2) Tonya mission 'Pulling Favors' because when I have to go to the tow-truck with a vehicle and I use this option then the vehicle starts to fly into the air flips around in the sky, but when I connect the tow-truck to the car what i have to pull away then everything is fine!

I think there are problems with the 'Teleport to Mission marker'.

Link to post
Share on other sites
16 hours ago, _cOdy_ said:

there are strange things happen when I use the 'Teleport to Mission marker' in the

1) first mission 'Prologue' because the mission becomes failed when I drive the car and I have to go to the point;

2) Tonya mission 'Pulling Favors' because when I have to go to the tow-truck with a vehicle and I use this option then the vehicle starts to fly into the air flips around in the sky, but when I connect the tow-truck to the car what i have to pull away then everything is fine!

I think there are problems with the 'Teleport to Mission marker'.

 

Yeah, the 'Teleport to Mission marker' option is pretty bugged. It works fine on some missions, but it fails many missions.

Edited by Slash_Alex
Link to post
Share on other sites
  • 3 weeks later...

I tried and I wanted to edit the hotkeys but the whole program freezes and gives this error:

https://mega.nz/#!V801wQQS!1gJEVDwxsZslYkivAJO9_7g_8lCszQP_skx3o-Bqn_k

I edited the ent-config.xml file with the following:

    <key function="hotkey_1" value="VK_DIVIDE" modCtrl="false" modAlt="false" modShift="false"/>
    <key function="hotkey_2" value="VK_MULTIPLY" modCtrl="false" modAlt="false" modShift="false"/>
    <key function="hotkey_3" value="VK_NUMPAD9" modCtrl="false" modAlt="false" modShift="false"/>
    <key function="hotkey_4" value="VK_SUBTRACT" modCtrl="false" modAlt="false" modShift="false"/>
    <key function="hotkey_5" value="VK_DECIMAL" modCtrl="false" modAlt="false" modShift="false"/>
    <key function="hotkey_6" value="VK_ADD" modCtrl="false" modAlt="false" modShift="false"/>
    <key function="hotkey_7" value="VK_NUMPAD7" modCtrl="false" modAlt="false" modShift="false"/>
    <key function="hotkey_8" value="VK_NUMPAD1" modCtrl="false" modAlt="false" modShift="false"/>
    <key function="hotkey_9" value="VK_NUMPAD3" modCtrl="false" modAlt="false" modShift="false"/>

 

The same 'Script Hook V Error' happens with the original 'ent-config.xml" file, too.

 

 

Edited by _cOdy_
ERROR
Link to post
Share on other sites
18 hours ago, _cOdy_ said:

THX! Where can I download the edited version?

No, no, sorry, but i don't know what the problem is. You say the game crashes even with the default config? Try to delete the 'ent-config.xml' file completely, then try to launch the game.
@Zemanez must know smth.

Edited by Slash_Alex
Link to post
Share on other sites
5 hours ago, _cOdy_ said:

Ok, I did but the same thing happens. The error line is different 0x00007FFDC4FA93E0.

Did you have any problems with previous ENT versions? Do you have crashes with ENT 42 bugfix 2 only?

Link to post
Share on other sites

I haven't got any error like this in the previous versions! Yes, it happens with ENT Update 42 - bugfix update 2, only!

EDIT:

I found strange - in the ENT Update 42 - bugfix update 2 - that if I press the numlock del key the mini map starts to zoom out!

Edited by _cOdy_
Link to post
Share on other sites
14 hours ago, _cOdy_ said:

I haven't got any error like this in the previous versions! Yes, it happens with ENT Update 42 - bugfix update 2, only!

EDIT:

I found strange - in the ENT Update 42 - bugfix update 2 - that if I press the numlock del key the mini map starts to zoom out!

Try to launch the game with ENT only. It means you'll have to move your 'scripts' and 'mods' folders somewhere temporarily.

Are you using a controller? Try to launch the game without it.

Are you using ENB? Delete it.

Link to post
Share on other sites

I use only the ENT. I do no use controller!

I put back the older ENT and it remembered the hotkey setting. I copy back the new ENT and it works, now! I do not know what happened!!!

Link to post
Share on other sites
7 hours ago, _cOdy_ said:

I use only the ENT. I do no use controller!

I put back the older ENT and it remembered the hotkey setting. I copy back the new ENT and it works, now! I do not know what happened!!!

Only other thing I could suggest is you verify your game files in case a mod (or ENT) has corrupted something. 

 

Really odd that this happening as there isn't any natives involved regarding the config, and enabled options are stored in the DB. Since you've either deleted or moved both - it can't really be anything obvious (i.e a mod conflict or enabled option).

Link to post
Share on other sites

Is there any file what contains ENT config data?

Because I set the hotkeys in the older version.

I deleted the old version (all 3 files) and copy the new one into the GTA folder but the new ENT crashed the whole program when I wanted to edit the hotkeys because they were not worked.

I deleted the new ENT (all 3 files) and put back the old 1.

Rewrote the old version 'ent-config.xml' to active the hotkeys in the ENT.

When I started the old ENT the program contained the hotkey data so I haven't set the hotkeys in the ENT again because the settings were there! This is what confused me!

I deleted the old ENT except the 'ent-config.xml' what I renamed.

I copy the new ENT again and copy/paste the hotkey lines into the 'ent-config.xml' of the new ENT version. And it works now.

So, again is there any file what contains ENT config data? Because if there is another file what contains data about the setting that caused the crash!!!

Link to post
Share on other sites
11 hours ago, _cOdy_ said:

Is there any file what contains ENT config data?

Because I set the hotkeys in the older version.

I deleted the old version (all 3 files) and copy the new one into the GTA folder but the new ENT crashed the whole program when I wanted to edit the hotkeys because they were not worked.

I deleted the new ENT (all 3 files) and put back the old 1.

Rewrote the old version 'ent-config.xml' to active the hotkeys in the ENT.

When I started the old ENT the program contained the hotkey data so I haven't set the hotkeys in the ENT again because the settings were there! This is what confused me!

I deleted the old ENT except the 'ent-config.xml' what I renamed.

I copy the new ENT again and copy/paste the hotkey lines into the 'ent-config.xml' of the new ENT version. And it works now.

So, again is there any file what contains ENT config data? Because if there is another file what contains data about the setting that caused the crash!!!

The 'ent-config.xml' file is compatible with previous versions, so you don't need to rewrite it every time you update ENT.

All ENT settings are stored here: press Windows key + R -> Type: %appdata% -> 'GTAV Enhanced Native Trainer' folder.
If you have any problems try to delete this folder. It will reset all settings, though it will also remove all your saved vehicles.

Link to post
Share on other sites
  • 4 weeks later...

@Zemanez Hi, I'm sorry for the bad English right away.

I came across your version of Enhanced Native Trainer, there was a desire to try to translate it into Russian, of course, indicating all the authors. and without any benefit to yourself.

is there any where to download the source code?

Link to post
Share on other sites
20 hours ago, berkut116 said:

@Zemanez Hi, I'm sorry for the bad English right away.

I came across your version of Enhanced Native Trainer, there was a desire to try to translate it into Russian, of course, indicating all the authors. and without any benefit to yourself.

is there any where to download the source code?

No need to apologise. Your english is fine!

 

Currently there isn't a way to download the source no (as online modders have abused it in the past).

 

I did try and add support for translations a while ago, but for some reason ENT would crash the scripthook before it opened. It has support for unicode/wide chars but for some reason crashes with anything apart from ascii text which limits what can be done (so it's pretty much stuck with English).

 

The same bug affects users who have non-ascii characters in their Windows usernames (ENT will crash during the loading screen because it can't find the Appdata folder even though it properly handles WChars in the code and had extracted almost half of the packed vehicle previews before it decides to crash).

Edited by Flying Scotsman
Link to post
Share on other sites
  • 3 weeks later...
On 4/1/2020 at 5:05 AM, _cOdy_ said:

Does this work on the online version, too?

You can't play online with it. Actually it would be illegal.

Link to post
Share on other sites
On 4/2/2020 at 9:28 AM, Slash_Alex said:

You can't play online with it. Actually it would be illegal.

OK! THX! The R* launcher detects it!

Link to post
Share on other sites
  • 2 weeks later...

I had turned on the slow down time while aiming option I believe on your March 23rd build.  I installed your April 5th build, and couldn't find the option in the menu (wasn't sure if I was just forgetting where it was or you had removed it)

 

For the mission "Three's company", when using that feature-When Franklin aims from the other building, the game gets stuck after you eliminate all the targets- You are unable to back out of the mission.

If you removed that feature in your latest build, how do I disable it?  If you didn't remove it, where is it again?

Link to post
Share on other sites

I recently purchased the game and am LOVING it with the trainer, so thank you.

 

I typically use both my controller and joystick when playing, through x360ce, but neither of them seem to work with ENT enabled (even with controller disabled in ENT settings). I saw that the same issue was brought up on Page 86, concluding that it was due to both x360ce and ENT emulating a controller, but there was a fix being considered.

 

Was that fix ever implemented? Or is there any way at all I can use multiple controllers with this trainer?

 

Thanks!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.