Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. Gameplay
      2. Missions
      3. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Arena War
      2. After Hours
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA Next

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

arewenotmen

Enhanced Native Trainer

Recommended Posts

MightyMax

@Zemanez and @Slash_Alex ask to @MAFINS for add collisions objects spawn freeze :) thanks. When i spawn objects the cars or me be passes the object. Menyoo non have this problem when i spawn objects with spooner objects

Edited by MightyMax

Share this post


Link to post
Share on other sites
vemundoo

Amazing trainer, but I have a problem. When I install the trainer and launch GTA I get massive lag and stuttering, and when I remove it, it stops... Is there any fix to this? I have reset the entire trainer and removed saved files etc. inside it.

Share this post


Link to post
Share on other sites
Slash_Alex

Amazing trainer, but I have a problem. When I install the trainer and launch GTA I get massive lag and stuttering, and when I remove it, it stops... Is there any fix to this? I have reset the entire trainer and removed saved files etc. inside it.

 

Do you have any GTA V mod manager installed? Is your Windows Defender activated? If you have a controller plugged in (XBox, PS4) try to disable it.
The cause of this problem is not quite known yet, and it seems to be different for everyone. It's definitely due to the player's setup more than anything.
Edited by Slash_Alex

Share this post


Link to post
Share on other sites
Zemanez

Amazing trainer, but I have a problem. When I install the trainer and launch GTA I get massive lag and stuttering, and when I remove it, it stops... Is there any fix to this? I have reset the entire trainer and removed saved files etc. inside it.

 

 

 

Amazing trainer, but I have a problem. When I install the trainer and launch GTA I get massive lag and stuttering, and when I remove it, it stops... Is there any fix to this? I have reset the entire trainer and removed saved files etc. inside it.

 

Do you have any GTA V mod manager installed? Is your Windows Defender activated? If you have a controller plugged in (XBox, PS4) try to disable it.
The cause of this problem is not quite known yet, and it seems to be different for everyone. It's definitely due to the player's setup more than anything.

 

 

As Slash_Alex mentioned, it's been an issue for a while now but we've tried recreating it but it hasn't happened to us (I personally tested ENT across 3 different machines and none of them had the issue).

 

It's definitely a weird one as some have fixed it by temporarily disabling Windows Defender/Anti-Virus while others reinstalled their game completely and it worked again (possible mod conflict?) but at the moment there's no "fix for everyone" I'm afraid. Each case has been sorted differently (or randomly went away by itself).

Edited by Zemanez

Share this post


Link to post
Share on other sites
Aebian

Hi,

 

Something I really would love to see:

 

Possibility to create a weapon set and be able to apply it.

But also: Be able to tick an option to disable the pickup of items and weapons.

 

I currently have to manually every time pick my 4 weapons.

 

Other than that, good work.

sutC3jt.png

 

btw your e-mail is down.

 

 

@Zemanez:

 

Any Clue why you did not include the Pistol holster for Steve Haines?

 

https://i.imgur.com/Z5oZO89.png (CS for Cutscene) And only two drawables for both (0 for no belt and 1 for belt) https://i.imgur.com/SsIRnx0.png seems that they did it different in the end mission.

 

End-mission screen: http://c-7npsfqifvt34x24wjhofuufx2ex78jljbx2eopdppljfx2eofu.g00.wikia.com/g00/3_c-7hub.x78jljb.dpn_/c-7NPSFQIFVT34x24iuuqtx3ax2fx2fwjhofuuf.x78jljb.opdppljf.ofux2fhubx78jljx2fjnbhftx2f8x2f83x2fUifXsbqVq-HUBW-BoesfbtTbodifax2538tEfbui.qohx2fsfwjtjpox2fmbuftux3fdcx3d31262312296119_$/$/$/$/$/$/$/$?i10c.ua=1

Edited by Aebian

Share this post


Link to post
Share on other sites
Zemanez

Hi,

 

Something I really would love to see:

 

Possibility to create a weapon set and be able to apply it.

But also: Be able to tick an option to disable the pickup of items and weapons.

 

I currently have to manually every time pick my 4 weapons.

 

Other than that, good work.

sutC3jt.png

 

btw your e-mail is down.

 

 

@Zemanez:

 

Any Clue why you did not include the Pistol holster for Steve Haines?

 

https://i.imgur.com/Z5oZO89.png (CS for Cutscene) And only two drawables for both (0 for no belt and 1 for belt) https://i.imgur.com/SsIRnx0.png seems that they did it different in the end mission.

 

End-mission screen: http://c-7npsfqifvt34x24wjhofuufx2ex78jljbx2eopdppljfx2eofu.g00.wikia.com/g00/3_c-7hub.x78jljb.dpn_/c-7NPSFQIFVT34x24iuuqtx3ax2fx2fwjhofuuf.x78jljb.opdppljf.ofux2fhubx78jljx2fjnbhftx2f8x2f83x2fUifXsbqVq-HUBW-BoesfbtTbodifax2538tEfbui.qohx2fsfwjtjpox2fmbuftux3fdcx3d31262312296119_$/$/$/$/$/$/$/$?i10c.ua=1

The weapon loadout thing- added it to the list, but it won't be in an update soon since we'd have to figure out how to save things to the DB properly (which we haven't done yet) and I've got some other features I want to implement at the moment (in the middle of development of ~2 new (pretty big) features).

 

The missing Pistol Holder is because that's a clothes component. You should be able to toggle it under the character customisation submenu (can't remember which slot it's in, but if you scroll you should be able to find it).

 

Yeah, the email being down is known. If you (or anyone else) wants access to add a new feature or fix something in ENT, just add me on Discord if you have it (Flying Scotsman#8234) and I'll add you/them to the repo.

Edited by Zemanez

Share this post


Link to post
Share on other sites
Aebian

@Zemanez:

 

Thanks for your reply. Are you sure its there?

 

I checked this out: 7Qnvz9d.png

 

But there is only an option for the big belt, not for the holster only (like seen in the mission).

 

Regards,

 

Alex

Share this post


Link to post
Share on other sites
janimal

Hello,

yesterday I was using v33 with my current setup with no problems, this morning I checked for an update & installed v37 update 1. Stupidly this is the one time I deleted my older zip versions (I had multiple old versions back to the old v28) When loading GTA now I get the following error

 

[07:08:44] CORE: Launching main() for 'EnhancedNativeTrainer.asi' (0x000007FEDC5B49E0), id 35
[07:08:44] CORE: An exception occurred while executing 'EnhancedNativeTrainer.asi' (0x000007FEDC5B49E0), id 35

 

The game & scripthook are up to date.

 

I have tried starting with no controller plugged in & with the controller. I'm going to have to do some checking for conlicts etc...now, but what would have been very useful would be somewhere to download some previous versions. As I really just wanted to play GTA for a couple of hours while the other half is asleep.

 

Anyway thanks for your hard work & time.

 

EDIT: Actually it was my ent-config.xml was malformed.

Edited by janimal

Share this post


Link to post
Share on other sites
Zemanez

Hello,

yesterday I was using v33 with my current setup with no problems, this morning I checked for an update & installed v37 update 1. Stupidly this is the one time I deleted my older zip versions (I had multiple old versions back to the old v28) When loading GTA now I get the following error

 

[07:08:44] CORE: Launching main() for 'EnhancedNativeTrainer.asi' (0x000007FEDC5B49E0), id 35

[07:08:44] CORE: An exception occurred while executing 'EnhancedNativeTrainer.asi' (0x000007FEDC5B49E0), id 35

 

The game & scripthook are up to date.

 

I have tried starting with no controller plugged in & with the controller. I'm going to have to do some checking for conlicts etc...now, but what would have been very useful would be somewhere to download some previous versions. As I really just wanted to play GTA for a couple of hours while the other half is asleep.

 

Anyway thanks for your hard work & time.

 

EDIT: Actually it was my ent-config.xml was malformed.

Glad you got it working again.

 

I've "unhidden" the previous ENT updates as far back as Update 35 - QoL update 2 if you need to get backup zips of the previous updates. They're on the GTA5Mods page under the downloads.

Share this post


Link to post
Share on other sites
CesaRodriguez

Hi, everyone. When i want to spawn a car with the mentioned trainer, it blocks the game and gives me a fatal error message. Can someone help me fix it, pls?

Edited by CesaRodriguez

Share this post


Link to post
Share on other sites
Zemanez

Hi, everyone. When i want to spawn a car with the mentioned trainer, it blocks the game and gives me a fatal error message. Can someone help me fix it, pls?

By spawn are you talking about spawning a previously saved vehicle or just using the spawner?

 

If it's spawning a previously saved vehicle - that normally happens if you're either missing the Benny's DLC or it's corrupted and you need to re-verify the files (the error is related to setting the dashboard colours - and if you don't have the Benny's DLC installed or working, it'll crash because it's missing).

Share this post


Link to post
Share on other sites
CesaRodriguez

 

Hi, everyone. When i want to spawn a car with the mentioned trainer, it blocks the game and gives me a fatal error message. Can someone help me fix it, pls?

By spawn are you talking about spawning a previously saved vehicle or just using the spawner?

 

If it's spawning a previously saved vehicle - that normally happens if you're either missing the Benny's DLC or it's corrupted and you need to re-verify the files (the error is related to setting the dashboard colours - and if you don't have the Benny's DLC installed or working, it'll crash because it's missing).

 

No, I was talking about the Vehicule Spawner, I was trying to spawn any kind of car, when I hit Num Pad 5, nothing happens, after a few tries the game crash and show me the "Fatal error" message, and says something about the ENT. I will try installing the Benny's DLC and see if its works. Thanks.

 

EDIT: I was using the last ENT version. The only one I could use is the update 28, I can't use any other.

 

This is the error message I get

 

SfxKDY.png

Thank you for your help and your time.

 

EDIT x2: Now the game never opens, I go to my task manager and the Gta.exe and the launcher are there, but after a few seconds, they disappears and nothing happens.

Edited by CesaRodriguez

Share this post


Link to post
Share on other sites
Zemanez

 

 

Hi, everyone. When i want to spawn a car with the mentioned trainer, it blocks the game and gives me a fatal error message. Can someone help me fix it, pls?

By spawn are you talking about spawning a previously saved vehicle or just using the spawner?

 

If it's spawning a previously saved vehicle - that normally happens if you're either missing the Benny's DLC or it's corrupted and you need to re-verify the files (the error is related to setting the dashboard colours - and if you don't have the Benny's DLC installed or working, it'll crash because it's missing).

 

No, I was talking about the Vehicule Spawner, I was trying to spawn any kind of car, when I hit Num Pad 5, nothing happens, after a few tries the game crash and show me the "Fatal error" message, and says something about the ENT. I will try installing the Benny's DLC and see if its works. Thanks.

 

EDIT: I was using the last ENT version. The only one I could use is the update 28, I can't use any other.

 

This is the error message I get

 

SfxKDY.png

Thank you for your help and your time.

 

EDIT x2: Now the game never opens, I go to my task manager and the Gta.exe and the launcher are there, but after a few seconds, they disappears and nothing happens.

 

The native which you're crashing on is "_SET_VEHICLE_DASHBOARD_COLOUR" which is normally an issue if your Benny's DLC is corrupt somehow (via a broken mod install or a mod overwrote something within it). Have you tried verifying the files to make sure nothing has been corrupted?

 

Have you also tried just running ENT and no other mod to see if it's a conflict or not?

 

The "GTA is already running" is an issue with the scripthook (it's happened to me). When it crashes, it doesn't always close properly so you have to Task Manager the game instead.

Share this post


Link to post
Share on other sites
CesaRodriguez

 

 

 

Hi, everyone. When i want to spawn a car with the mentioned trainer, it blocks the game and gives me a fatal error message. Can someone help me fix it, pls?

By spawn are you talking about spawning a previously saved vehicle or just using the spawner?

 

If it's spawning a previously saved vehicle - that normally happens if you're either missing the Benny's DLC or it's corrupted and you need to re-verify the files (the error is related to setting the dashboard colours - and if you don't have the Benny's DLC installed or working, it'll crash because it's missing).

 

No, I was talking about the Vehicule Spawner, I was trying to spawn any kind of car, when I hit Num Pad 5, nothing happens, after a few tries the game crash and show me the "Fatal error" message, and says something about the ENT. I will try installing the Benny's DLC and see if its works. Thanks.

 

EDIT: I was using the last ENT version. The only one I could use is the update 28, I can't use any other.

 

This is the error message I get

 

SfxKDY.png

Thank you for your help and your time.

 

EDIT x2: Now the game never opens, I go to my task manager and the Gta.exe and the launcher are there, but after a few seconds, they disappears and nothing happens.

 

The native which you're crashing on is "_SET_VEHICLE_DASHBOARD_COLOUR" which is normally an issue if your Benny's DLC is corrupt somehow (via a broken mod install or a mod overwrote something within it). Have you tried verifying the files to make sure nothing has been corrupted?

 

Have you also tried just running ENT and no other mod to see if it's a conflict or not?

 

The "GTA is already running" is an issue with the scripthook (it's happened to me). When it crashes, it doesn't always close properly so you have to Task Manager the game instead.

 

I'm gonna do something even better.. Im gonna redownload the whole game and install all over again, I will come back if anything comes out.. Thanks Zemanes..

Share this post


Link to post
Share on other sites
daniel_kukiela

Hi guys.

 

I have some issue when trying to use x360ce and ENT at the same time. Whenever ENT loads in, breaks x360ce.

i tried to enable "Turn Off All Controller Input In Trainer" without any change.

Do you think you could try to fix that or maybe i could help with that?

It's important for us to have both ENT and x360ce working at the same time, as we want to add controller support to our project.

 

Regards,

Daniel

Share this post


Link to post
Share on other sites
Zemanez
17 hours ago, daniel_kukiela said:

Hi guys.

 

I have some issue when trying to use x360ce and ENT at the same time. Whenever ENT loads in, breaks x360ce.

i tried to enable "Turn Off All Controller Input In Trainer" without any change.

Do you think you could try to fix that or maybe i could help with that?

It's important for us to have both ENT and x360ce working at the same time, as we want to add controller support to our project.

 

Regards,

Daniel

That issue is related to ENT's use of Xinput to handle controller related things (so you're effectively emulating a 360 pad, which ENT is also trying to do - Emulating an emulated input). I've been meaning to actually replace it with GTA's default controller input instead (which will also fix issues like GTA hanging during load if you have a controller plugged in - also an issue related to Xinput) but I haven't had the time to actually sit down to bash it out. 

 

I'll see if I can do something soonish about it when I've got some spare time. 

Share this post


Link to post
Share on other sites
daniel_kukiela
On 9/26/2018 at 11:11 PM, Zemanez said:

That issue is related to ENT's use of Xinput to handle controller related things (so you're effectively emulating a 360 pad, which ENT is also trying to do - Emulating an emulated input). I've been meaning to actually replace it with GTA's default controller input instead (which will also fix issues like GTA hanging during load if you have a controller plugged in - also an issue related to Xinput) but I haven't had the time to actually sit down to bash it out. 

 

I'll see if I can do something soonish about it when I've got some spare time. 

I missed your response (i was sure i'll receive notification via email, i've set that now).

Anyway, thank you for your explanation. Ok, we'll wait patiently for those changes. Thank you for your interest in this topic.

 

 

Regards,

Daniel

Share this post


Link to post
Share on other sites
Aebian

Anyone knows how to use the "Jump to Coordinates" thingy? Idk what coordinates the textbox accepts because everytime I try something my Scripthook crashes the Trainer. 

 

I only have these coords atm: 161.7827000, -745.89030000, 69.65520000, (X Y Z) I would like to goto.

 

Over and Out,

 

Aebian

Edited by Aebian

Share this post


Link to post
Share on other sites
Slash_Alex
On 10/15/2018 at 2:22 AM, Aebian said:

Anyone knows how to use the "Jump to Coordinates" thingy? Idk what coordinates the textbox accepts because everytime I try something my Scripthook crashes the Trainer. 

 

I only have these coords atm: 161.7827000, -745.89030000, 69.65520000, (X Y Z) I would like to goto.

 

Over and Out,

 

Aebian

 

Remove commas. You have to separate coords with spaces like 161.7827000  -745.89030000 69.65520000

 

p.s. there is a also a bug in this feature we'll try to fix. Z coord is cut sometimes.

Edited by Slash_Alex

Share this post


Link to post
Share on other sites
Slash_Alex

@Aebian

 

I've fixed all the bugs (i hope) so you'll be able to use both commas and spaces to separate coords in the next version.

Share this post


Link to post
Share on other sites
Aebian

@Slash_Alex Thanks, without the commas worked fine for me, no worries. 

Share this post


Link to post
Share on other sites
MightyMax
11 hours ago, Slash_Alex said:

@Aebian

 

I've fixed all the bugs (i hope) so you'll be able to use both commas and spaces to separate coords in the next version.

thanks for do best trainer ENHANCER NATIVE TRAINER with best features :)

Share this post


Link to post
Share on other sites
YourBakedSkoda

Is the 'MP vehicles in SP' mod required to spawn in Online cars with this?

Share this post


Link to post
Share on other sites
Zemanez
20 hours ago, YourBakedSkoda said:

Is the 'MP vehicles in SP' mod required to spawn in Online cars with this?

Nope, ENT has a bypass for that built in (via an automatic pointer and an option under Misc to find the pointer if ENT hasn't already found it).

Share this post


Link to post
Share on other sites
MrEnigma

Is it possible/will there be an update to allow spawning of MP cars *without* breaking the in-game shops???  That would make this the perfect trainer then

 

(I know there are 1-2 other trainers out there that allow the spawning of these rides - I’ve used ENT for so long, saved so many outfits and modded rides though, I really don’t want to switch)

 

 

If not, does anyone know if that despawn option will interfere with the progress of the story (for those scripted times you have to step into a clothing shop or ammunation etc) ???

Share this post


Link to post
Share on other sites
Zemanez
On 12/19/2018 at 8:52 PM, MrEnigma said:

Is it possible/will there be an update to allow spawning of MP cars *without* breaking the in-game shops???  That would make this the perfect trainer then

 

(I know there are 1-2 other trainers out there that allow the spawning of these rides - I’ve used ENT for so long, saved so many outfits and modded rides though, I really don’t want to switch)

 

 

If not, does anyone know if that despawn option will interfere with the progress of the story (for those scripted times you have to step into a clothing shop or ammunation etc) ???

ENT already auto-applies the anti-despawn pointer so you don't need to kill the script responsible (which breaks shops). 

 

The option to kill the script is there in case your game is modified and the Scripthook game version check can't figure out which pointer to apply (which can happen with franken-updates which involves a pirated and/or outdated exe but official non cracked update installed on top for example). 

Edited by Zemanez

Share this post


Link to post
Share on other sites
MrEnigma
3 hours ago, Zemanez said:

ENT already auto-applies the anti-despawn pointer so you don't need to kill the script responsible (which breaks shops). 

 

The option to kill the script is there in case your game is modified and the Scripthook game version check can't figure out which pointer to apply (which can happen with franken-updates which involves a pirated and/or outdated exe but official non cracked update installed on top for example). 

 

Ahh.  Initially right after the game updated and then after I downloaded the latest Scripthook version, I saw the MP to SP script was broken, removed it and then when I tried spawning cars (like the Impaler for example), they disappeared within a few seconds (unless I had that anti-despawn option checked).

 

I downloaded the latest version of Menyoo though and was able to spawn em and play with no problem.  Then I read this, went back and tried again with ENT and it worked - don't know what the disconnect might've been or if there's some cross functionality going on then.

 

Thanks for the explanation though!

Share this post


Link to post
Share on other sites
Mark91

Why is it possible to change the color for some MK2 weapons while for others MK2 not?

Share this post


Link to post
Share on other sites
Slash_Alex
Posted (edited)
On 3/6/2019 at 2:56 AM, Mark91 said:

Why is it possible to change the color for some MK2 weapons while for others MK2 not?

I guess it depends on the MK2 weapon. They should all be there apart from the Marksman rifle mk 2 as that kept being removed from the moddable list for some reason. Simply saying this is a pain in the arse. It's hard to get that to work with ENT's current weapon mod system 'cause R* keeps changing weapon mods with every update and it's hard to update it all the time without breaking all the weapons.

Edited by Slash_Alex

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.