Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. Gameplay
      2. Missions
      3. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Arena War
      2. After Hours
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA Next

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

alexslx

Vehicle Controller (Lights, Engine, Doors, Cruise, etc)

Recommended Posts

INF3RN040
LOADER: Loading *.asi plugins

ASI: Loading "C:\Program Files\Rockstar Games\Grand Theft Auto V\VehicleController.asi"

"VehicleController.asi" failed to load

LOADER: Finished loading *.asi plugins



not working :(

Edited by INF3RN040

Share this post


Link to post
Share on other sites
CJDoesGames

Yeah, Alex, everyone is getting the .ASI failed to load... Please fix this? Also, people are already getting scripthookv online, make it easier and allow this online as well. The online bypasses are everywhere and I'd love to use this online.

Share this post


Link to post
Share on other sites
ashtreylil

cant wait for the gamepad version of this.

Share this post


Link to post
Share on other sites
ILS_Supernova

Guys Alex is aware most of us are unable to load this mod. We need the people who can load this and the ones that can't to help each other find a possible solution. There has to be something preventing us from loading it thats different to people who can I guess somewhere?

Share this post


Link to post
Share on other sites
Shadowspk

Guys Alex is aware most of us are unable to load this mod. We need the people who can load this and the ones that can't to help each other find a possible solution. There has to be something preventing us from loading it thats different to people who can I guess somewhere?

 

I think i know how to fix this, just registered to check if it'll work for you guys too. Search google for these two files "msvcp120.dll" and "msvcr120.dll" and copy both of them in your main GTA V folder. Make sure to download 32bit or 64 bit versions according to your system. Before i did this, asi file was not registering at all, now it works perfectly. Try and let me know if it worked for you.

Share this post


Link to post
Share on other sites
ILS_Supernova

 

 

Guys Alex is aware most of us are unable to load this mod. We need the people who can load this and the ones that can't to help each other find a possible solution. There has to be something preventing us from loading it thats different to people who can I guess somewhere?

I think i know how to fix this, just registered to check if it'll work for you guys too. Search google for these two files "msvcp120.dll" and "msvcr120.dll" and copy both of them in your main GTA V folder. Make sure to download 32bit or 64 bit versions according to your system. Before i did this, asi file was not registering at all, now it works perfectly. Try and let me know if it worked for you.

What are these files?

Share this post


Link to post
Share on other sites
Shadowspk

 

 

Guys Alex is aware most of us are unable to load this mod. We need the people who can load this and the ones that can't to help each other find a possible solution. There has to be something preventing us from loading it thats different to people who can I guess somewhere?

I think i know how to fix this, just registered to check if it'll work for you guys too. Search google for these two files "msvcp120.dll" and "msvcr120.dll" and copy both of them in your main GTA V folder. Make sure to download 32bit or 64 bit versions according to your system. Before i did this, asi file was not registering at all, now it works perfectly. Try and let me know if it worked for you.

What are these files?

 

These are the files necessary for this mod to work. If you open the asi file with any viewer you can see it references these two files. That's the difference between other working asi files and this. Same thing applies to "turn signals" mod as well, tho it only requires msvcr120.dll to work.

Share this post


Link to post
Share on other sites
ILS_Supernova

Hopefully someone can confirm this does indeed work, away from my computer till later so can't check.

Edited by ILS_Supernova

Share this post


Link to post
Share on other sites
tall70

Not working for me either, i have no line with VehicleController.asi in log and tried both dlls in correct bit version with it. SNT is working fine. Great script idea btw, hopefuly it can be fixed.

Share this post


Link to post
Share on other sites
Shadowspk

Not working for me either, i have no line with VehicleController.asi in log and tried both dlls in correct bit version with it. SNT is working fine. Great script idea btw, hopefuly it can be fixed.

Could you try copying those files in your system directories as well? Windows/System32 for 32 bit, Syswow64 for 64 bit.

Share this post


Link to post
Share on other sites
NexusAU

I'm having the "Failed to Load" issue a lot of other people are having although earlier versions of the mod worked for me.
I'll dump my asiloader.log incase you need it.

// GTA V ASI LOADER (build Apr 22 2015)//     © Alexander Blade 2015LIB: "C:\Windows\system32\dsound.dll" => 00007FFFBA820000API: "DirectSoundCreate" => 00007FFFBA848050API: "DirectSoundEnumerateA" => 00007FFFBA848150API: "DirectSoundEnumerateW" => 00007FFFBA825620API: "DllCanUnloadNow" => 00007FFFBA852780API: "DllGetClassObject" => 00007FFFBA826DF0API: "DirectSoundCaptureCreate" => 00007FFFBA847F30API: "DirectSoundCaptureEnumerateA" => 00007FFFBA848030API: "DirectSoundCaptureEnumerateW" => 00007FFFBA832770API: "GetDeviceID" => 00007FFFBA829920API: "DirectSoundFullDuplexCreate" => 00007FFFBA848170API: "DirectSoundCreate8" => 00007FFFBA82C7C0API: "DirectSoundCaptureCreate8" => 00007FFFBA830B50LOADER: Loading *.asi pluginsASI: Loading "D:\Games\steamapps\common\Grand Theft Auto V\LUA.asi"     "LUA.asi" => 00007FFFAF730000ASI: Loading "D:\Games\steamapps\common\Grand Theft Auto V\NativeTrainer.asi"     "NativeTrainer.asi" => 00007FFFB90B0000ASI: Loading "D:\Games\steamapps\common\Grand Theft Auto V\VehicleController.asi"     "VehicleController.asi" failed to loadLOADER: Finished loading *.asi plugins

Good Luck :)

Share this post


Link to post
Share on other sites
ILS_Supernova

 

 

Not working for me either, i have no line with VehicleController.asi in log and tried both dlls in correct bit version with it. SNT is working fine. Great script idea btw, hopefuly it can be fixed.

Could you try copying those files in your system directories as well? Windows/System32 for 32 bit, Syswow64 for 64 bit.

Hang on sorry for being paranoid but why would we need to put them in there? These files better be safe!

Share this post


Link to post
Share on other sites
Shadowspk

 

 

Not working for me either, i have no line with VehicleController.asi in log and tried both dlls in correct bit version with it. SNT is working fine. Great script idea btw, hopefuly it can be fixed.

Could you try copying those files in your system directories as well? Windows/System32 for 32 bit, Syswow64 for 64 bit.

Hang on sorry for being paranoid but why would we need to put them in there? These files better be safe!

 

They are Microsoft runtime library files necessary for running some applications, perfectly safe. You can search for it. Problem solved after i put both 32 bit and 64 bit versions in main Gta V folder and system folders.

Edited by Shadowspk

Share this post


Link to post
Share on other sites
BeVerwyQuiet

Hello All,

 

Here is the official link for the Microsoft Visual C++ Redistributable 2013:

 

Please, who have issues try to install this and see if it fixes the problem.

 

Regards,

 

Still not working. :( Still getting this:

 

ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\VehicleController.asi"
"VehicleController.asi" failed to load
Tried what someone else up above said about the 2 .dll files, put them into GTA 5 main directory were .exe is, didn't work. Then put it into Windows/System32 and also didn't work. Starting to lose hope :(. It's such a great mod but this problem is soooo aggravating! It was working just fine on an older version yesterday :(.

Share this post


Link to post
Share on other sites
alexslx

 

Hello All,

 

Here is the official link for the Microsoft Visual C++ Redistributable 2013:

 

Please, who have issues try to install this and see if it fixes the problem.

 

Regards,

 

Still not working. :( Still getting this:

 

ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\VehicleController.asi"
"VehicleController.asi" failed to load
Tried what someone else up above said about the 2 .dll files, put them into GTA 5 main directory were .exe is, didn't work. Then put it into Windows/System32 and also didn't work. Starting to lose hope :(. It's such a great mod but this problem is soooo aggravating! It was working just fine on an older version yesterday :(.

 

 

Have you tried to install both versions from microsoft website? x64 and x86? Have you tried to reboot after install?

 

We're frustrated as much as you are. Nobody want to put a lot of effort into something for nothing, but we need patience (remember that ScriptHook doesn't have a debug console yet, and probably have less error checking than before to help discover errors). I'm trying to find the error, but I'm not able to reproduce the error yet.

Share this post


Link to post
Share on other sites
Shadowspk

For the record, my game version is 1.0.335.2 and those files fixed "script registration" problem for me. Not "failed to load" error.

Share this post


Link to post
Share on other sites
kenryk

Thanks a lot for this brilliant mod, alexslx! Working great so far for me.

 

I was wondering if you could implement the new control scheme from the Turn Signals mod (if l is on and you activate r, l switches off and r turns on, so you can activate both only by using the hazard lights key), the source code is available, so I hope it's not too much to ask. In my opinion, it improves the usability of the turn signals. (Sadly, it doesn't support key combinations)

Share this post


Link to post
Share on other sites
jackmap

Hey Alex, just wanted to say thanks for the reply. :) I also have an idea about how to aim the spotlight. Would it be possible to aim it based on the direction the player is looking? Thanks again and keep up the good work! :)

Share this post


Link to post
Share on other sites
Sonik-hedgehog

 

Hello All,

 

Here is the official link for the Microsoft Visual C++ Redistributable 2013:

 

Please, who have issues try to install this and see if it fixes the problem.

 

Regards,

Now its working !! Thank you

 

Not working for me - I tried to install these files:

vcredist_x86.exe
vcredist_x64.exe
Windows 8.1 x64, latest divers, steam updates and latest updates for GTA V.
// GTA V ASI LOADER (build Apr 22 2015)//     © Alexander Blade 2015LIB: "C:\WINDOWS\system32\dsound.dll" => 00007FFC1AD60000API: "DirectSoundCreate" => 00007FFC1AD88050API: "DirectSoundEnumerateA" => 00007FFC1AD88150API: "DirectSoundEnumerateW" => 00007FFC1AD65620API: "DllCanUnloadNow" => 00007FFC1AD92780API: "DllGetClassObject" => 00007FFC1AD66DF0API: "DirectSoundCaptureCreate" => 00007FFC1AD87F30API: "DirectSoundCaptureEnumerateA" => 00007FFC1AD88030API: "DirectSoundCaptureEnumerateW" => 00007FFC1AD72770API: "GetDeviceID" => 00007FFC1AD69920API: "DirectSoundFullDuplexCreate" => 00007FFC1AD88170API: "DirectSoundCreate8" => 00007FFC1AD6C7C0API: "DirectSoundCaptureCreate8" => 00007FFC1AD70B50LOADER: Loading *.asi pluginsASI: Loading "F:\Gamedistribs\Steam\steamapps\common\Grand Theft Auto V\VehicleController.asi"     "VehicleController.asi" failed to loadLOADER: Finished loading *.asi plugins
Edited by Sonik-hedgehog

Share this post


Link to post
Share on other sites
arewenotmen

Apologies if someone has already asked, but are you planning on releasing the source?

 

I'd like to incorporate this into the Native Trainer further down the line, and it'd be a shame to redo all your work.

Share this post


Link to post
Share on other sites
Hurrikane

Try turning off virus protection for 15 minutes then download file an place asi file in GTA V folder. For some reason it was removing my file when scanned through Norton.

 

Also I had turn signal mod combined with this mod and it seemed to not work. Try delete the turn signal mod

Edited by Hurrikane

Share this post


Link to post
Share on other sites
alexslx

Apologies if someone has already asked, but are you planning on releasing the source?

 

I'd like to incorporate this into the Native Trainer further down the line, and it'd be a shame to redo all your work.

 

Yes, I'll release the source code soon.

 

If someone who can't run lastest version can try this version (not v0.5 officially yet):

https://mega.co.nz/#!48FGERRb!0EDOU2jADIW5Lt4jL7mooE86a94emMHSCI7HUabtLc4

 

I'll release the v0.5 version soon with some important modifications like automatic car crash detection when using the cruise control...

 

Regards,

Edited by alexslx

Share this post


Link to post
Share on other sites
klova91

 

Apologies if someone has already asked, but are you planning on releasing the source?

 

I'd like to incorporate this into the Native Trainer further down the line, and it'd be a shame to redo all your work.

 

Yes, I'll release the source code soon.

 

If someone who can't run lastest version can try this version (not v0.5 officially yet):

https://mega.co.nz/#!48FGERRb!0EDOU2jADIW5Lt4jL7mooE86a94emMHSCI7HUabtLc4

 

I'll release the v0.5 version soon with some important modifications like automatic car crash detection when using the cruise control...

 

Regards,

 

 

Thanks! I can confirm I was also getting the "ASI: Loading "F:\Gamedistribs\Steam\steamapps\common\Grand Theft Auto V\VehicleController.asi"

"VehicleController.asi" failed to load" and after removing the v0.4 files and replacing them with the v0.5 ones it works now. The car I tested it with however did not have the back right turn signal working but everything else worked as far as I can tell. Also just fyi I had not downloaded and installed the 2 files Shadowspk posted or installed the 2013 microsoft Visual C++ software, I only installed the v0.5 fromt eh v0.4

 

Edit: Works with every other car I've tried so far, seems to be just the casco that has that issue with the right rear signal. Not sure why.

Edited by klova91

Share this post


Link to post
Share on other sites
Slinkyy

Something small and simple but it adds a lot more detail in to the game, I would of never thought about doing something like this. Great release! :)

Share this post


Link to post
Share on other sites
Tiryll

 

If someone who can't run lastest version can try this version (not v0.5 officially yet):

https://mega.co.nz/#!48FGERRb!0EDOU2jADIW5Lt4jL7mooE86a94emMHSCI7HUabtLc4

 

 

Now working for me. It's great.

 

One request: If the speed is set to zero, then upon pressing t for cruise control, allow us to set a default speed to travel at? or some default increments? I really hate the way moving forward always sounds like I'm maxing the engine and burning rubber when I'm just trying to move from the traffic lights :p

Edited by Tiryll

Share this post


Link to post
Share on other sites
qwerasdzxc

 

Apologies if someone has already asked, but are you planning on releasing the source?

 

I'd like to incorporate this into the Native Trainer further down the line, and it'd be a shame to redo all your work.

Yes, I'll release the source code soon.

 

If someone who can't run lastest version can try this version (not v0.5 officially yet):

https://mega.co.nz/#!48FGERRb!0EDOU2jADIW5Lt4jL7mooE86a94emMHSCI7HUabtLc4

 

I'll release the v0.5 version soon with some important modifications like automatic car crash detection when using the cruise control...

 

Regards,

This new version of the mod fixed the issue for me and now it works like a charm.

Thanks!

Edited by qwerasdzxc

Share this post


Link to post
Share on other sites
ReemICS

 

Apologies if someone has already asked, but are you planning on releasing the source?

 

I'd like to incorporate this into the Native Trainer further down the line, and it'd be a shame to redo all your work.

 

Yes, I'll release the source code soon.

 

If someone who can't run lastest version can try this version (not v0.5 officially yet):

https://mega.co.nz/#!48FGERRb!0EDOU2jADIW5Lt4jL7mooE86a94emMHSCI7HUabtLc4

 

I'll release the v0.5 version soon with some important modifications like automatic car crash detection when using the cruise control...

 

Regards,

 

 

Work great ! Thank you, amazing mod !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.