Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. Gameplay
      2. Missions
      3. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Arena War
      2. After Hours
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA Next

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

Alexander Blade

Script Hook V

Recommended Posts

markswe
Posted (edited)

Not? :O wierd

 

 

Coz i get fatal error even when i got the newest update

Edited by markswe

Share this post


Link to post
Share on other sites
markswe
Posted (edited)

Coz i get fatal error even when i got the newest update then it need to be updated the version..... How do i verify gtav files then?

Edited by markswe

Share this post


Link to post
Share on other sites
NovaRuk
35 minutes ago, markswe said:

Coz i get fatal error even when i got the newest update then it need to be updated the version..... How do i verify gtav files then?

Which version of GTA V you got? Is it Steam?

Share this post


Link to post
Share on other sites
markswe

// GTA V SCRIPT HOOK (build Feb 10 2019, v1.0.1604.1)
//     (C) Alexander Blade 2015-2019
[14:59:57] INIT: Started
[14:59:57] INIT: Success, game version is VER_1_0_1604_1_NOSTEAM
[14:59:57] INIT: Registering script 'ScriptHookVDotNet.asi' (0x00007FFDD4F11390)
[14:59:57] INIT: Registering script 'TrainerV.asi' (0x00007FFD9D2143A0)
[15:00:03] INIT: Pool 1 extended
[15:00:03] INIT: Pool 2 extended
[15:00:03] INIT: Pool 3 extended
[15:00:03] INIT: Pool 4 extended
[15:00:09] INIT: GtaThread collection size 189
[15:00:09] INIT: wnd proc 0x00000000FFFF2BFF
[15:00:09] INIT: IDXGISwapChain 0x00007FFDD907EC80 (0x00007FFDD9015070)
[15:00:09] INIT: IDXGISwapChain set
[15:00:09] INIT: DX init started
[15:00:09] INIT: DX feature level B000
[15:00:09] INIT: DX init succeeded
[15:01:11] CORE: Requesting thread creation
[15:01:11] CORE: Creating threads
[15:01:14] CORE: Started control thread, id 42 active 1
[15:01:14] CORE: Started thread 'ScriptHookVDotNet.asi' (0x00007FFDD4F11390), id 43 active 1
[15:01:14] CORE: Started thread 'TrainerV.asi' (0x00007FFD9D2143A0), id 44 active 1
[15:01:14] CORE: Launching main() for 'ScriptHookVDotNet.asi' (0x00007FFDD4F11390), id 43
[15:01:14] CORE: Launching main() for 'TrainerV.asi' (0x00007FFD9D2143A0), id 44
[15:08:41] CORE: Cleaning threads
[15:08:41] CORE: Creating threads
[15:08:42] CORE: Started control thread, id 144 active 1
[15:08:42] CORE: Started thread 'ScriptHookVDotNet.asi' (0x00007FFDD4F11390), id 145 active 1
[15:08:42] CORE: Started thread 'TrainerV.asi' (0x00007FFD9D2143A0), id 146 active 1
[15:08:42] CORE: Launching main() for 'ScriptHookVDotNet.asi' (0x00007FFDD4F11390), id 145
[15:08:42] CORE: Launching main() for 'TrainerV.asi' (0x00007FFD9D2143A0), id 146
[15:09:25] UNINIT: Unregistering script 'TrainerV.asi'
[15:09:25] UNINIT: Unregistering script 'ScriptHookVDotNet.asi'

 

Now it works 😛

Share this post


Link to post
Share on other sites
LeeC2202

If you have problems in the future, it will help if you don't tell people you have the latest version of ScriptHookV, when you're actually running an older version of ScriptHookV.

 

Always check the version numbers in the logs, always check the version numbers on the website. If your log version number is older, update ScriptHookV.

Share this post


Link to post
Share on other sites
Joshua Markwood

I'm a steam user and I paid for the game.

 

My error is:

A black screen with yellow text saying ''not signed in'' and, underneath that white text saying ''You must be signed into Social Club to play Grand Theft Auto V''.

I just pressed play and this is what shows up, hope you can solve it :) 

 

Windows 10

 

Game version: 1.0.1604.1

 

ScriptHook Log:

// GTA V SCRIPT HOOK (build Feb 10 2019, v1.0.1604.1)
//     (C) Alexander Blade 2015-2019
[01:10:04] INIT: Started
[01:10:04] INIT: Success, game version is VER_1_0_1604_1_STEAM
[01:10:04] INIT: Registering script 'NativeTrainer.asi' (0x00007FFAEB5CA3C0)
[01:10:11] INIT: Pool 1 extended
[01:10:11] INIT: Pool 2 extended
[01:10:11] INIT: Pool 3 extended
[01:10:11] INIT: Pool 4 extended
[01:10:17] INIT: GtaThread collection size 189
[01:10:17] INIT: wnd proc 0x00000000FFFF0A51
[01:10:17] INIT: IDXGISwapChain 0x00007FFB0193EC80 (0x00007FFB018D5070)
[01:10:17] INIT: IDXGISwapChain set
[01:10:17] INIT: DX init started
[01:10:17] INIT: DX feature level B000
[01:10:17] INIT: DX init succeeded

Asiloader Log:

// GTA V ASI LOADER (build May  2 2015)
//     (C) Alexander Blade 2015
LIB: "C:\WINDOWS\system32\dinput8.dll" => 00007FFAEB600000
API: "DirectInput8Create" => 00007FFAEB609D40
API: "DllCanUnloadNow" => 00007FFAEB619BD0
API: "DllGetClassObject" => 00007FFAEB619CA0
API: "DllRegisterServer" => 00007FFAEB623990
API: "DllUnregisterServer" => 00007FFAEB623C00
LOADER: Loading *.asi plugins
ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\NativeTrainer.asi"
     "NativeTrainer.asi" => 00007FFAEB5C0000
LOADER: Finished loading *.asi plugins

Share this post


Link to post
Share on other sites
LeeC2202
Posted (edited)

Your question needs more information, like:

1) Did you log in with your Social Club account when you run the game?

2) Do you actually have a Social Club account?

3) What happens when you use a perfectly clean version of the game, i.e. no modded files of any kind in the game folders?

4) Have you checked for any Firewall rules that might be stopping the game connecting to the Rockstar servers?

 

Edited by LeeC2202

Share this post


Link to post
Share on other sites
Blejd

About Joshua Markwood post, i have same problem 😜 but i bought gta v on social club.

And about LeeC2202 post i done everything and still not working

Share this post


Link to post
Share on other sites
LeeC2202

Well if you've done number 3), which is a clean version of the game and it still doesn't work, then it has nothing to do with ScriptHookV and should really be a question in this section https://gtaforums.com/forum/292-help-support/

 

In fact, if it is happening on a clean version of the game, then Rockstar Support are probably your best bet. It could be a Social Club account issue and nobody besides Rockstar can help with that. You will have to provide game logs to show you're not using mods and if you mention mods, they will refuse to help you... so don't send them the ScriptHookV log whatever you do.

 

Might also be worth reading this thread first, just in case it has something useful in it. https://gtaforums.com/topic/785007-bug-list-with-solutions-pc/

 

Share this post


Link to post
Share on other sites
sauce_boy3
On 3/22/2019 at 8:29 PM, LeeC2202 said:

To be honest, you're probably better off switching to a different trainer, if you're using the one that came with ScriptHookV. As far as I know, the one included with ScriptHookV was more of a sample mod, to show other modders how the API and Functions worked.

 

I would personally recommend Simple Trainer V but there's also Enhanced Native Trainer and Menyoo to try. All of those are regularly updated and are more likely to be compatible with your keyboard. If they don't work, then you can probably find the authors of them on the forums here at some point and they might be able to help you further.

thx

Share this post


Link to post
Share on other sites
shadow17340

Is the latest version of scripthook outdated with the latest steam version of GTA? I have the latest version of both and it doesn't work. Im new to this sorry.

 

f252125a0fbbb1dd04a942b9892127d4.png 

Share this post


Link to post
Share on other sites
LeeC2202
Posted (edited)
7 hours ago, shadow17340 said:

Is the latest version of scripthook outdated with the latest steam version of GTA? I have the latest version of both and it doesn't work. Im new to this sorry.

 

f252125a0fbbb1dd04a942b9892127d4.png 

1604.0 isn't the latest version, you're missing a ScriptHookV update.

Edited by LeeC2202

Share this post


Link to post
Share on other sites
Joshua Markwood
On 4/2/2019 at 2:15 AM, LeeC2202 said:

Your question needs more information, like:

1) Did you log in with your Social Club account when you run the game?

2) Do you actually have a Social Club account?

3) What happens when you use a perfectly clean version of the game, i.e. no modded files of any kind in the game folders?

4) Have you checked for any Firewall rules that might be stopping the game connecting to the Rockstar servers?

 

1- When I launch the game, Social club automatically logs me in.

2- I do have a Social club account.

3- The game runs fine when using a clean version.

4- I already tried with the Firewall turn off but the error message still appears.

Share this post


Link to post
Share on other sites
LeeC2202
7 hours ago, Joshua Markwood said:

1- When I launch the game, Social club automatically logs me in.

2- I do have a Social club account.

3- The game runs fine when using a clean version.

4- I already tried with the Firewall turn off but the error message still appears.

Is your game set to launch straight into online mode? I'm just wondering if it's being caused by the code in ScriptHookV that won't let you go online with mods installed.

 

It runs fine with a clean version... what happens if the only mod files you have installed are ScriptHookV.dll and dinput8.dll? So no OpenIV.asi, no NativeTrainer.asi, no mods folder, no scripts folder, just the 2 files that come with ScriptHookV? Do you still get the same screen?

 

It would be useful if you could post a screenshot of that screen as well, just in case there are any error codes in a corner or something that you haven't noticed.

Share this post


Link to post
Share on other sites
markswe
Posted (edited)

Same here when i try to run it again :( EDIT: Now it works :D 

Edited by markswe

Share this post


Link to post
Share on other sites
iamnothingelse
On ‎4‎/‎14‎/‎2019 at 6:51 PM, LeeC2202 said:

Is your game set to launch straight into online mode? I'm just wondering if it's being caused by the code in ScriptHookV that won't let you go online with mods installed.

 

It runs fine with a clean version... what happens if the only mod files you have installed are ScriptHookV.dll and dinput8.dll? So no OpenIV.asi, no NativeTrainer.asi, no mods folder, no scripts folder, just the 2 files that come with ScriptHookV? Do you still get the same screen?

 

It would be useful if you could post a screenshot of that screen as well, just in case there are any error codes in a corner or something that you haven't noticed.

I done all this, still don't work

Share this post


Link to post
Share on other sites
muroko

The same thing started to happen to me too. I have a legit, non-steam copy of GTA V up-to-date.

Logged in to Social Club.
The only things i use is for single player, and they are dinput8.dll, ScriptHookV.dll (version 1.0.1604.1) and EnhancedNativeTrainer.asi
If i run the game with these, it automatically starts story mode for some reason, even though it's set up to go to the main lobby screen.

Once i get rid of EnhancedNativeTrainer.asi the game starts properly, so i assume the issue is with that. I just don't know what, it was working a few days ago and i don't see any files that could be damaged, i even re-downloaded it to be sure.

 

TLDR : game runs fine with dinput8.dll and ScriptHookV.dll only

Share this post


Link to post
Share on other sites
muroko
6 minutes ago, muroko said:

The same thing started to happen to me too. I have a legit, non-steam copy of GTA V up-to-date.

Logged in to Social Club.
The only things i use is for single player, and they are dinput8.dll, ScriptHookV.dll (version 1.0.1604.1) and EnhancedNativeTrainer.asi
If i run the game with these, it automatically starts story mode for some reason, even though it's set up to go to the main lobby screen.

Once i get rid of EnhancedNativeTrainer.asi the game starts properly, so i assume the issue is with that. I just don't know what, it was working a few days ago and i don't see any files that could be damaged, i even re-downloaded it to be sure.

 

TLDR : game runs fine with dinput8.dll and ScriptHookV.dll only

 

Okay here is what happened to me. Windows 10 Ransomware Protection.
 

Solution: Go to Start > Settings > Update & Security > Windows Security > Virus & threat protection > if Ransomware Protection is turned on, go to Manage Ransomware Protection > Allow an app through Controlled folder access > Add an allowed app and browse your GTAV.exe

 

This was the issue in my case. Windows 10 version 1809 build 17763.437

 

hope it helps at least someone. cheers

Share this post


Link to post
Share on other sites
iamnothingelse
On ‎4‎/‎16‎/‎2019 at 11:21 AM, muroko said:

 

Okay here is what happened to me. Windows 10 Ransomware Protection.
 

Solution: Go to Start > Settings > Update & Security > Windows Security > Virus & threat protection > if Ransomware Protection is turned on, go to Manage Ransomware Protection > Allow an app through Controlled folder access > Add an allowed app and browse your GTAV.exe

 

This was the issue in my case. Windows 10 version 1809 build 17763.437

 

hope it helps at least someone. cheers

It works! Thanks man

Share this post


Link to post
Share on other sites
Son of Dutch

I’m having this weird issue right now.. whenever I try to activate mod menu in the game. It simply does not work at all. Nothing pops up. Any help will be appreciated 

Share this post


Link to post
Share on other sites
AlphaRishi

I get a fatal error (native not found) whenever I try to do a soul switch or use a soul switch gun on anyone

Share this post


Link to post
Share on other sites
LeeC2202
10 minutes ago, AlphaRishi said:

I get a fatal error (native not found) whenever I try to do a soul switch or use a soul switch gun on anyone

Perhaps you have a version of the game that native doesn't exist in. Unless you tell us which version of everything you are using (Game and ScriptHookV), nobody can tell.

Share this post


Link to post
Share on other sites
Quakex64

is there an update? people are saying their scripthook isnt working

Share this post


Link to post
Share on other sites
LeeC2202

Scripthook is working just fine.

Share this post


Link to post
Share on other sites
GTA BELGIUM
Posted (edited)

My game started crashing today while using scripthook, on the loading screens... If I delete ScriptHookV.dll everything works.

 

EDIT: Seems to be a Menyoo problem, when I put back ScriptHookV.dll and delete Menyoo, it works as well...

Edited by GTA BELGIUM

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.