Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. Gameplay
      2. Missions
      3. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Arena War
      2. After Hours
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA Next

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

Alexander Blade

Script Hook V

Recommended Posts

Claude_Lib

Damn, but why would they remove a native?

Share this post


Link to post
Share on other sites
Unknown_Modder

I don't know but this

_0xF7B79A50B905A30D(-8192.0f, 8192.0f, -8192.0f, 8192.0f);

is basically the same so maybe someone at R* decided to removed it because no scripts need an extra native for that ¯\_(ツ)_/¯

Share this post


Link to post
Share on other sites
slejzy

 

 

My game crashes with the new scripthookv and dinput.

Same here

f1Jnhml.jpg

Share this post


Link to post
Share on other sites
ChARCOOL

Edited by ChARCOOL

Share this post


Link to post
Share on other sites
Slash_Alex

 

 

 

My game crashes with the new scripthookv and dinput.

Same here

 

 

 

You also have to update your 'gameconfig.xml' file.

Edited by Slash_Alex

Share this post


Link to post
Share on other sites
Cyron43

 

Hi Alexander, whenever is start the autopilot of my VAutodrive mods the game crashes with "Can't find native 0x80E4A6EDDB0BE8D9".

That is because 0x80E4A6EDDB0BE8D9 (LOAD_ALL_PATH_NODES) has been removed in b1180.

 

Thank you. :)

I removed the call to this function and taddaa the autopilot works as well. *shrugs*

Edited by Cyron43

Share this post


Link to post
Share on other sites
N. Man

 

 

 

 

My game crashes with the new scripthookv and dinput.

Same here

 

 

 

You also have to update your 'gameconfig.xml' file.

 

When you say update our config, do you mean have a modded config that can support more content like so,https://www.gta5-mods.com/misc/gta-5-gameconfig-300-cars, or just the new config added with the new update? Otherwise, me included, I don't think most of us know how to manually modify the gameconfig.xml file.

Share this post


Link to post
Share on other sites
ChARCOOL

Can anyone help me with SET_BLIP_COLOUR, I can't get it working!

Share this post


Link to post
Share on other sites
Slash_Alex

 

 

 

 

 

My game crashes with the new scripthookv and dinput.

Same here

 

 

 

You also have to update your 'gameconfig.xml' file.

 

When you say update our config, do you mean have a modded config that can support more content like so,https://www.gta5-mods.com/misc/gta-5-gameconfig-300-cars, or just the new config added with the new update? Otherwise, me included, I don't think most of us know how to manually modify the gameconfig.xml file.

 

 

Yes, that's what i meant exactly. If you follow the link you will find in the comments how to edit the 'gameconfig.xml' manually, or wait until it will be updated by the author.

Edited by Slash_Alex

Share this post


Link to post
Share on other sites
_MK_

Just did that manual gameconfig update,the game crashes.

Share this post


Link to post
Share on other sites
Slash_Alex

Just did that manual gameconfig update,the game crashes.

 

There must be some other reason then, 'cause manual update worked fine for me.

Share this post


Link to post
Share on other sites
Disappear

Well,anyone help me? I want to know why Native Trainer stop adding the new vehicle in car spwan menu in recent update, I can see the Native Trainer version still in Mar.17,2017 and always in page Num.49.

Native Trainer usually update with script hook but the last two times without any updates so I'm confused about it. It Alex no longer updated the vehicle list? Or can I update the new vehicle to the original version of Native Trainer by myself?

Edited by Disappear

Share this post


Link to post
Share on other sites
_CP_

@Disappear
Alex don't give a damn about this trainer, it's just a sample to check if ScriptHook is working.

Share this post


Link to post
Share on other sites
Disappear

@Disappear

Alex don't give a damn about this trainer, it's just a sample to check if ScriptHook is working.

Oh no,I'm used to it and now it never update....Can I add the new vehicle by myself?

Share this post


Link to post
Share on other sites
_CP_

@Disappear
If you have a source code and know how to do this then why not? Personally, there are much better trainers.

Share this post


Link to post
Share on other sites
ChARCOOL

What is going on with nativedb it's still not updated

why alexander blade left us alone :(

Share this post


Link to post
Share on other sites
MrBellicLC

I can't use any scriptmods.

asiloader.log

 

LIB: "C:\WINDOWS\system32\dinput8.dll" => 00007FFC94CF0000
API: "DirectInput8Create" => 00007FFC94CFA050
API: "DllCanUnloadNow" => 00007FFC94D093C0
API: "DllGetClassObject" => 00007FFC94D09490
API: "DllRegisterServer" => 00007FFC94D12AF0
API: "DllUnregisterServer" => 00007FFC94D12D70
LOADER: Loading *.asi plugins
ASI: Loading "C:\Program Files\Rockstar Games\Grand Theft Auto V\Menyoo.asi"
"Menyoo.asi" failed to load
ASI: Loading "C:\Program Files\Rockstar Games\Grand Theft Auto V\mpsmuggler.asi"
"mpsmuggler.asi" failed to load
ASI: Loading "C:\Program Files\Rockstar Games\Grand Theft Auto V\OpenIV.asi"
"OpenIV.asi" => 00007FFC79E40000
ASI: Loading "C:\Program Files\Rockstar Games\Grand Theft Auto V\ScriptHookVDotNet.asi"
"ScriptHookVDotNet.asi" failed to load
LOADER: Finished loading *.asi plugins

 

Share this post


Link to post
Share on other sites
Claude_Lib

Shouldn't the ASI Loader log also mention the Hook itself? Because I don't see it in yours. Are you sure that you have it installed?

Share this post


Link to post
Share on other sites
MrBellicLC

Shouldn't the ASI Loader log also mention the Hook itself? Because I don't see it in yours. Are you sure that you have it installed?

Yes I have it.

Share this post


Link to post
Share on other sites
Crunchy83

Hey guys, I can't activate the Native Trainer while in Single Player. I tried every keys of my keyboard and nothing... Also, I can't connect to GT-MP, it loads the SP and it stays in the SP. Any idea if that's related ? Thanks !

Share this post


Link to post
Share on other sites
unknown modder

Shouldn't the ASI Loader log also mention the Hook itself? Because I don't see it in yours. Are you sure that you have it installed?

The ASI loader doesn't load ScriptHookV directly so it wont appear inside its log file.

 

I can't use any scriptmods.

asiloader.log

 

LIB: "C:\WINDOWS\system32\dinput8.dll" => 00007FFC94CF0000

API: "DirectInput8Create" => 00007FFC94CFA050

API: "DllCanUnloadNow" => 00007FFC94D093C0

API: "DllGetClassObject" => 00007FFC94D09490

API: "DllRegisterServer" => 00007FFC94D12AF0

API: "DllUnregisterServer" => 00007FFC94D12D70

LOADER: Loading *.asi plugins

ASI: Loading "C:\Program Files\Rockstar Games\Grand Theft Auto V\Menyoo.asi"

"Menyoo.asi" failed to load

ASI: Loading "C:\Program Files\Rockstar Games\Grand Theft Auto V\mpsmuggler.asi"

"mpsmuggler.asi" failed to load

ASI: Loading "C:\Program Files\Rockstar Games\Grand Theft Auto V\OpenIV.asi"

"OpenIV.asi" => 00007FFC79E40000

ASI: Loading "C:\Program Files\Rockstar Games\Grand Theft Auto V\ScriptHookVDotNet.asi"

"ScriptHookVDotNet.asi" failed to load

LOADER: Finished loading *.asi plugins

 

 

Well the 3 asi files all have a dependancy of ScriptHookV.dll, chances are that isnt found inside your GTA V directory. Make sure it exists in there then they should all load

Share this post


Link to post
Share on other sites
Disappear

@Disappear

If you have a source code and know how to do this then why not? Personally, there are much better trainers.

Oh yes you are right...I found a better trainer just need more time to get used to it.. :lol:

Share this post


Link to post
Share on other sites
Fasta

Why my ped can't kick me out from vehicle when i try "/sit -1"?

[Command("buddy")]        public void buddy(Client player)        {            Vector3 pos = player.position;            pos.X += 0.5f;            p = API.createPed(API.pedNameToModel("AfriAmer01AMM"), pos, 0);			API.sleep(2000);			API.sendChatMessageToPlayer(player, "Sleep ended");			API.sendNativeToPlayer(player, Hash.FREEZE_ENTITY_POSITION, p.handle, false);			API.sendNativeToPlayer(player, Hash.SET_ENTITY_INVINCIBLE, p.handle, false);			API.sendNativeToPlayer(player, Hash.SET_PED_CAN_RAGDOLL, p.handle, true);			        }                [Command("sit")]        public void sitIntoCar(Client player, int seat)        {            API.sendNativeToPlayer(player, 0xC20E50AA46D09CA8, p, myVehicle, -1, seat, 2.0, 1, 0);        }

Share this post


Link to post
Share on other sites
ChiroVette

Hey folks, I know this is Dumb Question-101 I am asking here, but here goes anyway. I downloaded the new Scripthoook V. Now I have other mods installed as well, including ones that use Open IV, ScripthookDoTNet, ScripthookVDotNet, my mod manager, and some other map stuff. So my question is do I have to do anything else to run the updated game aside from copying over the file ScripthookV.dll into my main game directory?

 

I assume all the other mods should be fine as long as I update ScripthookV?

 

Oh and do I also need to re-copy dinput8.dll over as well updated as well? Because the file date on that one seems to indicate it should be the same as when I first copied it over from Blade's original folder.

 

Thanks!

Share this post


Link to post
Share on other sites
rollschuh2282

Hey folks, I know this is Dumb Question-101 I am asking here, but here goes anyway. I downloaded the new Scripthoook V. Now I have other mods installed as well, including ones that use Open IV, ScripthookDoTNet, ScripthookVDotNet, my mod manager, and some other map stuff. So my question is do I have to do anything else to run the updated game aside from copying over the file ScripthookV.dll into my main game directory?

 

I assume all the other mods should be fine as long as I update ScripthookV?

 

Oh and do I also need to re-copy dinput8.dll over as well updated as well? Because the file date on that one seems to indicate it should be the same as when I first copied it over from Blade's original folder.

 

Thanks!

when you use the Mods Folder and have Mods in the update.rpf, then you need to copy the new update.rpf to the Mods Folder and install the update.rpf Mods again

Share this post


Link to post
Share on other sites
ChiroVette

 

Hey folks, I know this is Dumb Question-101 I am asking here, but here goes anyway. I downloaded the new Scripthoook V. Now I have other mods installed as well, including ones that use Open IV, ScripthookDoTNet, ScripthookVDotNet, my mod manager, and some other map stuff. So my question is do I have to do anything else to run the updated game aside from copying over the file ScripthookV.dll into my main game directory?

 

I assume all the other mods should be fine as long as I update ScripthookV?

 

Oh and do I also need to re-copy dinput8.dll over as well updated as well? Because the file date on that one seems to indicate it should be the same as when I first copied it over from Blade's original folder.

 

Thanks!

when you use the Mods Folder and have Mods in the update.rpf, then you need to copy the new update.rpf to the Mods Folder and install the update.rpf Mods again

 

 

Okay, this is what's weird! My GTA V directory is a mess. Because clearly I set up my game that way, with a Mods folder/directory in the main game directory. In that folder, I have the Update folder as well, with update.rpf in there. (I also have mod folders like LeFix Speedo and a scripts folder as well, with things like No Restricted Areas and Single Player Apartments.

 

Now what is also very weird is I ALSO have some mod files in my MAIN game directory. In the main game directory I have:

 

-dinput8.dll (which I copied over from the Scripthook V folder I downloaded, way back in June)

-ScripthookV

-gtamp-reveal-full-map_v1_1

-LeFixSpeedo.asi

-Native Trainer

-NoRestrictedAreas

-Open Interiors

Plate

ScripthookVDotNet

 

Now I have to be honest and say I have NO IDEA how this happened. I haven't run my game in a few weeks, so those mod files should have disappeared from my game upon me not running it, right?

 

I am trying to remember if I maybe tanked the idea of keeping mod files out of my main game directory because I was having trouble getting them to run after a previous update OR if maybe since I never go online at all to play, I am wondering if I just shrugged my shoulders and stopped giving a crap if I installed mods into my main game directory, again, after a previous update. Truth is, I honestly don't remember.

 

Does it sound like I messed something up?

Edited by ChiroVette

Share this post


Link to post
Share on other sites
rollschuh2282

 

 

Hey folks, I know this is Dumb Question-101 I am asking here, but here goes anyway. I downloaded the new Scripthoook V. Now I have other mods installed as well, including ones that use Open IV, ScripthookDoTNet, ScripthookVDotNet, my mod manager, and some other map stuff. So my question is do I have to do anything else to run the updated game aside from copying over the file ScripthookV.dll into my main game directory?

 

I assume all the other mods should be fine as long as I update ScripthookV?

 

Oh and do I also need to re-copy dinput8.dll over as well updated as well? Because the file date on that one seems to indicate it should be the same as when I first copied it over from Blade's original folder.

 

Thanks!

when you use the Mods Folder and have Mods in the update.rpf, then you need to copy the new update.rpf to the Mods Folder and install the update.rpf Mods again

 

Okay, this is what's weird! My GTA V directory is a mess. Because clearly I set up my game that way, with a Mods folder/directory in the main game directory. In that folder, I have the Update folder as well, with update.rpf in there. (I also have mod folders like LeFix Speedo and a scripts folder as well, with things like No Restricted Areas and Single Player Apartments.

 

Now what is also very weird is I ALSO have some mod files in my MAIN game directory. In the main game directory I have:

 

-dinput8.dll (which I copied over from the Scripthook V folder I downloaded, way back in June)

-ScripthookV

-gtamp-reveal-full-map_v1_1

-LeFixSpeedo.asi

-Native Trainer

-NoRestrictedAreas

-Open Interiors

Plate

ScripthookVDotNet

 

Now I have to be honest and say I have NO IDEA how this happened. I haven't run my game in a few weeks, so those mod files should have disappeared from my game upon me not running it, right?

 

I am trying to remember if I maybe tanked the idea of keeping mod files out of my main game directory because I was having trouble getting them to run after a previous update OR if maybe since I never go online at all to play, I am wondering if I just shrugged my shoulders and stopped giving a crap if I installed mods into my main game directory, again, after a previous update. Truth is, I honestly don't remember.

 

Does it sound like I messed something up?

no, the Mods Folder is only for .rpf Mods (like car Mods) so you don't mess up the main files, and need to reinstall the game again when you break something.

so .asi for example needs to be at the main Folder, but the Mods Folder for the .rpf Mods.

oh, and for the mods Folder you need the openiv.asi to load the files inside of the Mods folder

Edited by rollschuh2282

Share this post


Link to post
Share on other sites
ChiroVette

 

no, the Mods Folder is only for .rpf Mods (like car Mods) so you don't mess up the main files, and need to reinstall the game again when you break something.

so .asi for example needs to be at the main Folder, but the Mods Folder for the .rpf Mods.

oh, and for the mods Folder you need the openiv.asi to load the files inside of the Mods folder

 

 

 

I wasn't aware that I needed the openiv.asi file in my mod file directory. I assume this is true if I am using a Mod Manager, too?

 

Also, if I am not going online, does it hurt me at all that all those mod files are in my main game directory?

 

I am honestly not sure where to even start to clean up all this mess with having a mod folder, mod manager, AND all those mod files in my main game directory.

Share this post


Link to post
Share on other sites
rollschuh2282

 

no, the Mods Folder is only for .rpf Mods (like car Mods) so you don't mess up the main files, and need to reinstall the game again when you break something.

so .asi for example needs to be at the main Folder, but the Mods Folder for the .rpf Mods.

oh, and for the mods Folder you need the openiv.asi to load the files inside of the Mods folder

 

 

I wasn't aware that I needed the openiv.asi file in my mod file directory. I assume this is true if I am using a Mod Manager, too?

 

Also, if I am not going online, does it hurt me at all that all those mod files are in my main game directory?

 

I am honestly not sure where to even start to clean up all this mess with having a mod folder, mod manager, AND all those mod files in my main game directory.

openiv.asi is needed to load modified .rpf files, because openiv doesn't encrypt them not correctly, and the game then gives a error about corrupted files.

and when you don't know what you can delete or remove from you're Game Folder, Post a screenshot and I will try to help

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 6 Users Currently Viewing
    0 members, 0 Anonymous, 6 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.