Jump to content
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Criminal Enterprises
      2. Updates
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Blood Money
      2. Frontier Pursuits
      3. Find Lobbies & Outlaws
      4. Help & Support
    3. Crews

    1. Grand Theft Auto Series

      1. Bugs*
      2. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Classic GTA SA
      2. Guides & Strategies
      3. Help & Support
    6. GTA Vice City

      1. Classic GTA VC
      2. Guides & Strategies
      3. Help & Support
    7. GTA III

      1. Classic GTA III
      2. Guides & Strategies
      3. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

    2. Support

    3. Suggestions

Lag when driving


nkjellman
 Share

Recommended Posts

Am I the only one having this issue? The game lags when driving. It will have good frames, but it will have a quick drop like every 3 seconds. Very irritating. Any solutions?

 

I have:

-i7 4790k

-GTX 970 4GB

-16 GB of RAM

-Game installed on a 4TB external

 

I hope there is a solution to this, and it isn't that the game is another GTA IV.

Link to comment
Share on other sites

oCrapaCreeper

Toning down the traffic density or traffic variation might help a bit. The density on PC is remarkably insane, so there's a lot of stuff going on when you're driving.

Link to comment
Share on other sites

Or I guess installing the game on SSD + FAST RAM

Don't listen to idiots saying ddr3 1333 is enough

Link to comment
Share on other sites

Toning down the traffic density or traffic variation might help a bit. The density on PC is remarkably insane, so there's a lot of stuff going on when you're driving.

I did graphics limbo and turned everything all the way down. It still did the lag. I think that it needs a patch.

Link to comment
Share on other sites

This seems to be caused by streaming data, maybe the external drive is not fast enough or the data doesn't move fast enough between disc~ram, is it usb ? i don't know about the current state of external drives, but last i knew it wasn't recommended to install a game that frequently streams a lot of data and assets like gta in one of them. I'd advise you to install on a normal fast sata hdd, or even a ssd if you have one.

Link to comment
Share on other sites

Or I guess installing the game on SSD + FAST RAM

Don't listen to idiots saying ddr3 1333 is enough

 

The difference between 1333Mhz and 1600/1866/2166Mhz is negligible.

 

I dare say YOUR the idiot for suggesting people pay a 50-100% premium for something that will provide little/no benefit

Link to comment
Share on other sites

Toning down the traffic density or traffic variation might help a bit. The density on PC is remarkably insane, so there's a lot of stuff going on when you're driving.

I did graphics limbo and turned everything all the way down. It still did the lag. I think that it needs a patch.

 

The drive is a USB 3.0.

Edited by nkjellman
Link to comment
Share on other sites

RisingRedWolf

Try installing on something that isn't an external drive. I have mine installed on a SSD and absolutely no issue with performance while driving.

Link to comment
Share on other sites

What's the Max Read speed of the device? Actual rather than stated...

That's probably causing the issues.

Link to comment
Share on other sites

 

Or I guess installing the game on SSD + FAST RAM

Don't listen to idiots saying ddr3 1333 is enough

 

The difference between 1333Mhz and 1600/1866/2166Mhz is negligible.

 

I dare say YOUR the idiot for suggesting people pay a 50-100% premium for something that will provide little/no benefit

 

You're the idiot who fails to realize that faster RAM speeds have significant gains in the minimum FPS you get in games which could be the difference between 24 and 30 FPS in some case. (Battlefield 4 is a good example)

Seriously, this misinformation of "faster RAM has miniscule benefits" is getting boring. Especially when the price difference between 1600Mhz and 2133 RAM is $10 at most.

Link to comment
Share on other sites

i got i7 4770 and 760 sli... and its butter smooth at high speed.

 

might be your hdd. i'm running off a near empty ssd

Link to comment
Share on other sites

JUST A REMINDER :

 

GUYS, PLEASE REPORT YOUR PROBLEMS AT ROCKSTAR SUPPORT....

 

IF YOU DON'T THEN IT WONT BE FIXED.

 

I DON'T HAVE THE GAME RIGHT NOW....SO I CAN'T..

 

BUT IF YOU ARE FACING GLITCHES, BUGS OR ISSUES....PLEASE REPORT THEM ALL AT ROCKSTAR SUPPORT FORUM...

 

RIGHT NOW.

Edited by raburs
  • Like 2
Link to comment
Share on other sites

Some tips:

 

Install on an internal drive

 

Install the latest drivers

 

Disable AA and Tessellation.

  • Like 1
Link to comment
Share on other sites

Try installing on something that isn't an external drive. I have mine installed on a SSD and absolutely no issue with performance while driving.

 

Mine's install on a 3TB internal hard drive and it was lagging during the Lamar/Franklin mission when we had to steal the 2 cars.. It wasnt doing it during the Prologue mission, it was perfect... idk its weird

Link to comment
Share on other sites

GTA V = similar port-game than it´s previous IV

 

4770.GTX-750TI ,new WHQL NVIDIA dr.

TEX normal

Shadow normal

 

rest 1080p,HIGH - VERY HIGH...

 

18-20FPS avg.

 

also several lags in 1st missing lamar - franklin

Link to comment
Share on other sites

GTA V = similar port-game than it´s previous IV

 

4770.GTX-750TI ,new WHQL NVIDIA dr.

TEX normal

Shadow normal

 

rest 1080p,HIGH - VERY HIGH...

 

18-20FPS avg.

 

also several lags in 1st missing lamar - franklin

Why u even try very high on that gpu

  • Like 3
Link to comment
Share on other sites

 

GTA V = similar port-game than it´s previous IV

 

4770.GTX-750TI ,new WHQL NVIDIA dr.

TEX normal

Shadow normal

 

rest 1080p,HIGH - VERY HIGH...

 

18-20FPS avg.

 

also several lags in 1st missing lamar - franklin

Why u even try very high on that gpu

 

i wanna to see how optim.with that graphic card :) under that settings

Link to comment
Share on other sites

Geeteeaifive

 

 

Or I guess installing the game on SSD + FAST RAM

Don't listen to idiots saying ddr3 1333 is enough

 

The difference between 1333Mhz and 1600/1866/2166Mhz is negligible.

 

I dare say YOUR the idiot for suggesting people pay a 50-100% premium for something that will provide little/no benefit

 

You're the idiot who fails to realize that faster RAM speeds have significant gains in the minimum FPS you get in games which could be the difference between 24 and 30 FPS in some case. (Battlefield 4 is a good example)

Seriously, this misinformation of "faster RAM has miniscule benefits" is getting boring. Especially when the price difference between 1600Mhz and 2133 RAM is $10 at most.

 

Battlefield is the only example. Frankly anything over 1600 or good 1333 is a waste of money. Most games gain 1-2 fps at max. That is simply not worth extra 100 lol. now 10-20fps is worth it. 970 isnt supposed to run gta v maxed. 980 is. Also 970 has that vram issue.

Link to comment
Share on other sites

GTA V = similar port-game than it´s previous IV

 

4770.GTX-750TI ,new WHQL NVIDIA dr.

TEX normal

Shadow normal

 

rest 1080p,HIGH - VERY HIGH...

 

18-20FPS avg.

 

also several lags in 1st missing lamar - franklin

 

What kind of a f*cking idiot runs GTA V on a 750 Ti at Very High settings?

Link to comment
Share on other sites

 

GTA V = similar port-game than it´s previous IV

 

4770.GTX-750TI ,new WHQL NVIDIA dr.

TEX normal

Shadow normal

 

rest 1080p,HIGH - VERY HIGH...

 

18-20FPS avg.

 

also several lags in 1st missing lamar - franklin

 

What kind of a f*cking idiot runs GTA V on a 750 Ti at Very High settings?

 

 

he's right. you can't run on very high with that card. to get anything close to 60 fps you gonna have to drop everything to medium, turn off msaa and tess

Link to comment
Share on other sites

I might mention that I get this weird lag on foot too. It just isn't nearly as bad.

Link to comment
Share on other sites

RedIndianRobin

GTA V = similar port-game than it´s previous IV

 

4770.GTX-750TI ,new WHQL NVIDIA dr.

TEX normal

Shadow normal

 

rest 1080p,HIGH - VERY HIGH...

 

18-20FPS avg.

 

also several lags in 1st missing lamar - franklin

Do you have any idea? You're running on Very high settings on a 750? You serious?

Link to comment
Share on other sites

Unfortunately Steam is giving me trouble in moving the game files over. Dumb Steam is trying to re download the files when I move the install directory, delete local content, and try to install the game.

 

I sure hope Rockstar fixes this issue. It bugs me that no one else except me is having this problem.

Link to comment
Share on other sites

Unfortunately Steam is giving me trouble in moving the game files over. Dumb Steam is trying to re download the files when I move the install directory, delete local content, and try to install the game.

 

I sure hope Rockstar fixes this issue. It bugs me that no one else except me is having this problem.

i have the same problem

 

i5 2500k @ 3.3, 8gb ram (2133 but i guess it's not that relevant), gtx 760, installed on a 1TB caviar black

 

i would've guessed that my problem is the cpu (that has me worried since the official specs came out)

i turned down all the graphic details with no improvement on the heavy drops while driving, i highly doubt my problem is the hard disk

 

yet if you have the same problem maybe it's not the cpu either

Edited by tuccio
Link to comment
Share on other sites

I too am having this same problem and is making the game very hard to play, especially with friends.

 

The game seems fine at first glance but as soon as you get up to about half speed (or in other instances when the game speed increases) I get choppy lag and the FPS can appear to drop as low as 5 or 6.

 

I am running a RADEON 295x2 and the game is installed on a SSD so I shouldn't be getting any lag what so ever.

 

What I have tried;

 

Updating drivers: Made no difference.

Re installing game: Made no difference.

Lowering settings from 2560x1440 High to 1920x1080 Medium: Made no Difference

 

Specs:

i7 4770K OC at 4.4
16GB Ram

R295x2

SSD 840 256gb Pro

 

Need to get to the bottom of this, spent so much money on card and game and I cant even play properly :(

Link to comment
Share on other sites

I guess it has a lot to do with the what are you looking at when driving.

I don't have lagging issue in Prologue mission or non-city area, only in the downtown area.

 

What's interesting is the GPU usage is actually lowering when driving in the city area, it was only 40%, CPU usage was not high neither.

But the GPU usage will ramp up to 80%-90% when I look down at the road instead of look ahead.

Meanwhile, the GPU usage is constantly 70% when playing Far Cry 4.

 

I think we should try to find out what is slowing things down, GPU? CPU? Hard drive?

I will try different setting today and come back edit this post.

 

AMD FX-8230, AMD R9 280, 16GB, 3TB.

 

Update:

Based on this post by Aikor, I first tried unpark my CPU then tried the Catalyst 15.4 beta driver. I am totally agree that the driver REALLY works!

However, don't know how much does unparking CPU helps because if I open the Resource Monitor CPU tab, will see my CPU cores got unparked automatically when driving downtown in the game.

(I have two monitors, so I can see different monitoring while in the game)

I was seeing the GPU usage was 40% when driving in the city. After install the latest driver, the number jump to 60% ~ 70%. Definitely better GPU utilization now. (Don't know whether it will be even better if installed on a SSD)

 

Now I can play the game with 1920*1080, no MSAA, low shadow, max population, very high texture on a decent FPS.

(MSAA gives me some display glitch at the bottom right corner of the screen)

 

PS: I had some trouble installing Catalyst. It gives me some "Install Source Package Not Found" error. Use custom install and uncheck some video transcoding thing helped.

Edited by gtamorio
Link to comment
Share on other sites

Huskerboy42

Is it weird that I can get a steady 60 fps with little to no stutters on high-very high settings with 4x msaa with an R9 270 and a Pentium G3258, I think this game is optimized very well.

Link to comment
Share on other sites

Is it weird that I can get a steady 60 fps with little to no stutters on high-very high settings with 4x msaa with an R9 270 and a Pentium G3258, I think this game is optimized very well.

 

Da f*ck?

 

No way... *grabs popcorn*

I have a FX6300 with R9 270x...I think i've got this covered.. ;)

  • Like 1
Link to comment
Share on other sites

ClaudeSteed

Installing a demanding game like this on the drive with the lowest throughput, yeah nice work there, hehehehe.....

 

Seriously, why install it on an external drive!?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.