Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Cayo Perico Heist
      2. The Diamond Casino Heist
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA VI

      1. St. Andrews Cathedral
    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. Announcements

    2. Support

    3. Suggestions

nonamenoname

SAMP Addon

Recommended Posts

Malekithh
On 8/1/2018 at 5:07 AM, _keegan_ said:

Black screen after alt +tab,  any fix ?

If you using Windows 10 try it.

 

 

Share this post


Link to post
Share on other sites
_keegan_

On one server after alt + tab everything works and on the other server I have a black screen.... }  BIG WTF 

Btw. I still have the sound after alt +tab

Edited by _keegan_

Share this post


Link to post
Share on other sites
publicenemy12

SA-MP 0.3DL
Exception At Address: 0x00553526
Exception: 0xC0000005 - Access violation writing location 0x78244658

Registers:
EAX: 0x00000000    EBX: 0x00000001    ECX: 0x429FCB0D    EDX: 0x005534B9
ESI: 0x12FDAC00    EDI: 0x125274F0    EBP: 0xFFFDFFFF    ESP: 0x0028F4B8
EFLAGS: 0x00010246

Backtrace:
0x00553526 in gta_sa.exe
0x005549D8 in gta_sa.exe
0x0072D10B in gta_sa.exe
0x00555563 in gta_sa.exe
0x0028F650 in unknown
0x8B4C0DD8 in unknown
0x05D80085 startPlugin2+0x511DE5 in audio.dll+0x580085
0x00858B48 in gta_sa.exe
0xF0249CD9 in unknown
0x3BA3D70A in unknown

ASI plugins:
2dfx.asi
2dfx_min.asi
audio.asi
bullethole.asi
CLEO.asi
flickr.asi
GFXHack.asi
GInputSA.asi
GTASA.WidescreenFix.asi
IDE_DD_Tweaker.asi
ImVehFt.asi
modloader.asi
mousefix.asi
normalmap.asi
NormalMapFix.asi
outfit.asi
OutFitFix.asi
ped_spec.asi
radarrect.asi
samp.asi
SAMPGraphicRestore.asi
samp_grass.asi
sa_draw_distance_changer.asi
Searchlights.asi
ShellFix.asi
skygrad.asi
StreamMemFix.asi
wshps.asi
yacl.asi

d3d9.dll: Sobeit

Address code: 89 34 85 58 46
Before address code: A1 44 68 B7 00

Stack:
+0000: 0x12FDAC00   0x005549D8   0x12FDAC00   0x429FCB0D
+0010: 0x00000001   0x000000B6   0x0028F558   0x00000003
+0020: 0x43480000   0x00000005   0x429FCB0D   0x0072D10B
+0030: 0xFFFFFFDA   0x00C8E0C8   0xC31B5480   0xC34F1B57
+0040: 0x015DC1A8   0x000000C8   0x000000B6   0xBFD65749
+0050: 0x3E0FEA22   0x433654A5   0x00000005   0x43486717
+0060: 0x00000052   0x00000003   0x00000001   0x00000059
+0070: 0x000000B6   0x4068E468   0x43470A2C   0x42929AE7

Game work: 0 sec

Pos: 1505.067017 -892.109680 59.658157

Game Version: US 1.0

Memory: 581 MB
Stream memory: 333/1024 MB

Windows 7 64 bit
 

//

Thanks for sharing a really good program.

 

When I check it, IDE_DD_Tweaker.asi generates an error.

I used an older version and replaced it with the latest version. This did not happen in older versions.

Edited by publicenemy12

Share this post


Link to post
Share on other sites
𝓦𝓸𝓵𝓯

good job 👍

Share this post


Link to post
Share on other sites
nebojsa1994

best patch ^_^ and fixer ever ! 

 

 

2 year lather i instal have <3 thanks for :D that bro

Share this post


Link to post
Share on other sites
yusa

Hello,

 

first of all realy nice Job! 👍

 

Now, i have a issue, that i cant fix and hope for some Help:

 

I did implement Vice City and Liberty City to my Map.

All seems to be Okey.

After that i installed the Addon and run it.

I spawned in Los Santos drived to San Fierro but after the second tunnel to San Fierro near to the Airport, my Game freeze.

That is exact the same when i go to Vice City near the bridge on top.

 

So my Game freezes and just exit.

After that im back on Desktop.

 

I Hope You, or Someone else, can help me with that.


 

EDIT!-:

 

+ some streets and other objects dont have collisions now since i took the Samp.asi out of the folder but i can get in the Zone where i get the Freeze/Crash. The Problem is, that i get many FPS Drops and Laggs. + no collisions in some areas

 

Pls help! @nonamenoname

 

:(

 

Sry for my english. 😅

Edited by yusa

Share this post


Link to post
Share on other sites
PatricD

Hello!

 I installed a modpack that has a older version of SAMP Add-on, and I don't know how to put the last version. Anything I do I keep getting this error: https://imgur.com/a/2G8YZfj. I tried to uninstall the SAMP Add-on from the control panel. I tried to install over this modpack. Help pls.

Share this post


Link to post
Share on other sites
publicenemy12

There is one question.

With this program, loading speed is significantly faster. Normally, if the progress bar takes 5 seconds, the program skips those tasks and displays the San Andreas screen in 2 seconds.

What memory addresses need to be modified?

Edited by publicenemy12

Share this post


Link to post
Share on other sites
Jelemark1341
20 hours ago, PatricD said:

Hello!

 I installed a modpack that has a older version of SAMP Add-on, and I don't know how to put the last version. Anything I do I keep getting this error: https://imgur.com/a/2G8YZfj. I tried to uninstall the SAMP Add-on from the control panel. I tried to install over this modpack. Help pls.

You need to delete sampfuncs

Share this post


Link to post
Share on other sites
KatOnDrugs

Hi! I got a problem after install this. When I try to get into the server that I play, it says "Connection as 0.3.7" and later the "Retrieving information" thing appears and I can't connect to the server

Share this post


Link to post
Share on other sites
PatricD
On 8/8/2018 at 2:44 PM, Jelemark1341 said:

You need to delete sampfuncs

But I have mods that need SAMPFUNCS :(

Share this post


Link to post
Share on other sites
Jeleu

Hi guys, this addon was recommended to me because of some random crashes on cleo mods. The problem I have is that the anti pause mod is very very annoying especially when you're in a hydra/car and need to be AFK. I know It can be disabled from the .exe version, but If I try a command from a cleo mod I automatically get crashed, this happens only if I uncheck that option of disable anti-pause game. So i need a way to manually disable it, so my cleo mods can work.

 

 

On 8/7/2018 at 6:27 PM, PatricD said:

Hello!

 I installed a modpack that has a older version of SAMP Add-on, and I don't know how to put the last version. Anything I do I keep getting this error: https://imgur.com/a/2G8YZfj. I tried to uninstall the SAMP Add-on from the control panel. I tried to install over this modpack. Help pls.

Search on google for samp R1 and install it (B-Zone). 

Edited by Jeleu

Share this post


Link to post
Share on other sites
yarakjo

I'm having problem with this. I play the game without mods, file names are normal. How can I fix this problem?

Desktop_Screenshot_2018.08.13_-_01.05.27

Share this post


Link to post
Share on other sites
Malekithh
1 hour ago, yarakjo said:

I'm having problem with this. I play the game without mods, file names are normal. How can I fix this problem?

Desktop_Screenshot_2018.08.13_-_01.05.27

@yarakjo dostum sanırım oyunu kurarken o ekranda gözüken karakterler var ondan dolayı hata veriyor olabilir.

Share this post


Link to post
Share on other sites
Edvincik

@nonamenoname "Bugs of textures in the interior after the minimize of the game" can you explain how did you fix that?

Share this post


Link to post
Share on other sites
Swirly D

Has a fix/solution been discovered for users who have mouse issues on multi monitor setups? Quick mouse movements on dual monitor setups cause the mouse to appear in game. It's quite annoying to have to press T to get rid of the mouse frequently in game. Even then, it almost immediately will pop back in.

 

Edit: After further using this mod and testing what makes it occur, it seems to occur the easiest write after you press T and type something, then exit the chat. After doing this, even short movements make it occur. But it seems that if you don't press T/Type in the chat, it is significantly harder to get mouse to appear. Only other way is to make extremely rapid/unrealistic mouse movements across your mouse pad. I used this mod several months ago, it was much worse then, causing me not to use it. But now it is a lot more manageable than it use to be. A fix for it however would be greatly appreciated.

Edited by Swirly D
  • Like 1

Share this post


Link to post
Share on other sites
deshawnw
On 8/20/2018 at 5:38 AM, Swirly D said:

Has a fix/solution been discovered for users who have mouse issues on multi monitor setups? Quick mouse movements on dual monitor setups cause the mouse to appear in game. It's quite annoying to have to press T to get rid of the mouse frequently in game. Even then, it almost immediately will pop back in.

 

Edit: After further using this mod and testing what makes it occur, it seems to occur the easiest write after you press T and type something, then exit the chat. After doing this, even short movements make it occur. But it seems that if you don't press T/Type in the chat, it is significantly harder to get mouse to appear. Only other way is to make extremely rapid/unrealistic mouse movements across your mouse pad. I used this mod several months ago, it was much worse then, causing me not to use it. But now it is a lot more manageable than it use to be. A fix for it however would be greatly appreciated. 

There are 2 solutions that I know of:

1. Either press  your LMB when in the game several times and then try to see if it occurs again.

2. Use what I use, because the first solution isn't very practical, a program called DisplayFusion. I will never go back to any other program, DisplayFusion allows you to set a hotkey, so that the mouse will be locked on a program, and also a hotkey or any other trigger you can think of to make the game not minimize, without any "Borderless mods" or what ever. The program has a HUGE list of features and I recommend it. It will certainly help you.

  • Like 1

Share this post


Link to post
Share on other sites
Waleed.18

Hello again bro ,i have only 2 problems left , first one is easy one , its i really dont like anti afk , so if i disable it , all my cleo mods will not work , i hope u can fix that ,
and the second problem and its really annoying me , is when i use wallhack (Nametag) i see each player nick name 2 times ,one time normal infront of me , and another one time fake behind me and it moves when ever i move too , me and 3 of my friends having the same problem , we are admins and wee need a clear wallhack sometimes , so i hope you can fix that also and upload it here again . Thank you alot i respect your free help for everyone and that much waste of time .  
Best regards

Share this post


Link to post
Share on other sites
Hayron

It shows bad enb version, I can't launch SAMP with ENB, but I know that ENB is fine without SAMP ADDON

Edited by Hayron

Share this post


Link to post
Share on other sites
LOST100293

 

What is responsible for flickering objects on the screen without samp addon? It's about such graphic artifacts popping up on the egret with stretched various objects.

Share this post


Link to post
Share on other sites
Hayron
4 hours ago, LOST100293 said:

 

What is responsible for flickering objects on the screen without samp addon? It's about such graphic artifacts popping up on the egret with stretched various objects.

Without SAMP Addon for flickering objects responsible are Stream memory, You need to download Stream Memory Fix

Share this post


Link to post
Share on other sites
Autorojo

Hi!

 

I've been using SAMP Addon for a year. I updated it to the latest version, but I had to uninstall it after getting the following error.

 

fjj7guJ.png

 

I'm trying to connect a 0.3.7 server.

 

Any fix? Can you enable some cfg function to connect a 0.3.7 server without reconnect?

 

Thanks you!

Share this post


Link to post
Share on other sites
nonamenoname

2.3 R13

 

FPS
✔Standart SAMP FPS limit increased to 120, but no more, there are many high FPS bugs exist
✔Fixed SAMP bug when FPS drops in some interiors
✔Fixed bug there were many particle effects from Vortex on water on high FPS, it's also fix FPS drop

VortexEffect.jpg


✔Additional optimization of coronas, corona's reflections and physics engine

 

FPS 0.3.7/0.3DL:
✔Optimization of dialogs, killchat, 3DTextLabels, objects algoritms
✔Vehicle models no more unloaded from memory after disconnect
✔Fixed SAMP bug caused low FPS in some places due to RemoveBuildingForPlayer
✔Additional optimisation of player's nicks

 

FPS 0.3DL:
✔FPS Optimization of GetPlayerCameraTarget

 

FPS setting if you have slow system
✔Other's player shadows disabled on 3'd level effects setting
✔Vehicle distance increasing to 100 work only on 4'd effects setting (I didn't write about this distance change before)
✔Vehicle distance decreased to 50 on 1'st level effects setting
✔Increased quality mirrors disabled on 1'st level effects setting
✔Increased water wave distance disabled and set to more low on 1'st level effects setting (I didn't write about this water wave distance change before)
✔Anisotropic filtration force disabled on 1'st level effects setting (I didn't write about this anisotropic filtration on 2'nd level effects change before)

 

Fixed graphic bugs:
✔Fixed game bug when checkpoints doesn't render on the edge of the screen
✔Objects are rendered in right order, it fixes some of alpha bugs

AlphaBug1.jpg

AlphaBug2.jpg


✔Grass are rendered in right order, it fixes some of alpha bugs

GrassAlpha.jpg

 

Graphic:
✔Increased checkpoint draw distance

CheckPointDistance.jpg


✔Better render player's arrow in Esc - Map - Legend, but you need mipmaps in hud.txd

 

Fixed crashes:
✔Fixed SAMP bug caused gliches and crash on 0x0156AA19
✔0x004F1B70 if sound disabled on system
✔0x00728365 without textures with some mods
✔0x006EB628 & 0x006EB670 without water textures waterclear256 и waterwake
✔0x004C8F24 when many vehicles in stream - in theory if you place different 128 vehicle models in 1 place - your game will crash and it will be exploit on server

 

Fixed bugs on high FPS:
✔You can jump high on bike on high FPS
✔When player head move fast if head move enabled in SAMP on high FPS
✔Slow camera move in vehicle on high FPS
✔Flash sun effect speed on high FPS


SAMP:
✔Deleted SAMP icons from Esc - Map - Map legend
✔Option - Esc - Display Setup - Subtitles - deleted in SAMP
✔Fixed bug when fist doesn't work outside on map
✔Fixed samp bug when some interiors lost objects
✔Additional fix to mouse right click on map
✔Fixed sun effect works through SAMP objects
✔Fixed icons in Esc - Map start draw after several seconds

 

0.3.7/0.3DL
✔F10 disabled textdraws and nicks
✔Nicks, 3DTextLabels, killchat, chat and interface draws in right order

InterfaceOrder1.jpg

InterfaceOrder2.jpg


✔Additional Fixes to wrong width space tabs in dialogs

DialogTabs.jpg


✔Fixed dialog size bug when you change fontsize if dialog are opened
✔Fixed 3DTextLabel draws on nick

3DLabelNick.jpg


✔Fixed drawing order of 3DTextLabels

3DLabelOrder.jpg


✔Fixed 3DTextLabels draw in spectator

 

0.3DL:
✔Fixed keyboard OnPlayerKeyState lag and improved syncronization in many players stream
✔Fixed /save in spectator
✔Fixed samp bug when object move on low distance doesn't work on high FPS

 

0.3.7:

✔Fixed sit animation synchronization moved to 0.3.7

 

Other mod bugs:
✔Setting IMFX bUseSAMP enables auto, there is no auto check for samp in IMFX
✔map.asi renames if you have not 0.3.7R1, bcz this mods crashes on other samp ver

 

Changes:
✔If radio disabled, text [Radio off] will not display when you enter to vehicle
✔Additional enhanced cursor approximation map in Esc

MapCursor.jpg


✔Deleted delay after Z on map
✔Deleted particle4.txd, water and tire tracks texture now read from particle.txd, so you need mipmaps in particle.txd
✔Deep water land and clouds texture uses mipmap, you need mipmaps in particle.txd!
✔Camera state V Key are saved, setting controller setup to default will reset camera V state
✔Option - Esc - Display setup - Restore default - reset monitor resolution
✔Option - Esc - Display Setup - Advanced - Mip mapping - deleted, it doens't work
✔Mouse will not move after dialog close during several seconds, it was changes in Addon
✔Texture anisotopy and mirrow quality changes immediately after effects quality change
✔Quality cursors fronten_pc.txd crosshair and fronten1.txd arrow

Cursor1.jpg

Cursor2.jpg

 

Fixed several addon bugs

 

Also
Thx to Silent for this!
✔Keyboard input latency decreased by one frame
✔FILE_FLAG_NO_BUFFERING flag has been removed from IMG reading functions - speeding up streaming
✔Fixed an issue which would cause games to freeze if III/VC/SA were running at the same time

 

Download installer

Download Rar

Edited by nonamenoname
  • Like 1

Share this post


Link to post
Share on other sites
Big_Daddy3400

Look at this crash report, help me please

SA-MP 0.3DL
Exception At Address: 0x00000000 in unknown
Exception: 0xC0000005 - Access violation reading location 0x00000000

Registers:
EAX: 0x99C68800	EBX: 0x00000000	ECX: 0x000001F4	EDX: 0x000001F4
ESI: 0x06FBE688	EDI: 0x0387652F	EBP: 0x7621F9B0	ESP: 0x0028FD48
EFLAGS: 0x00010202

Backtrace:
0x00000000 in unknown
0x037642DB in samp.dll+0x742DB
0x007F99C7 in gta_sa.exe
0x007FB1C3 in gta_sa.exe
0x007EE388 in gta_sa.exe
0x0074526A in gta_sa.exe
0x05418066 in audio.dll+0x68066

ASI plugins:
audio.asi
NormalMapFix.asi
OutFitFix.asi
R2 Compatibility by MISTER_GONWIK.asi
samp.asi
SAMPGraphicRestore.asi
ShellFix.asi
StreamMemFix.asi
weaponlimit.asi

Address code: 8B C6 5E C2 04
Before address code: E8 15 94 02 00

Crash module: samp.dll
Size: 1466368
CRC32: 53C8C7F8

Stack:
+0000: 0x037642DB   0x007F99B0   0x007F99C7   0x03F80BD8
+0010: 0x007FB1C3   0x06FBE688   0x002E028E   0x00000000
+0020: 0x0000001A   0x06FBB65C   0x007EE388   0x06FBE688
+0030: 0x002E028E   0x00000000   0x00000001   0x0074526A
+0040: 0x06FBB65C   0x002E028E   0x00000000   0x05418066
+0050: 0x06FBB65C   0x06FBB65C   0x44000000   0x43C00000
+0060: 0x0053ECC2   0x00000001   0x00619B71   0x0000001A
+0070: 0x00000001   0x00000001   0x0000000A   0x00748DA0

Game work: 21 sec

Pos: -2632.250488 1367.649170 9.588125

Game Version: US 1.0

Memory: 305 MB
Stream memory: 74/1024 MB

Windows 7 64 bit

 

Share this post


Link to post
Share on other sites
nonamenoname

Big_Daddy3400

from crashlog I see you have other mods, try to find reason

Share this post


Link to post
Share on other sites
LOST100293
On 2.09.2018 at 19:54, Hayron said:

Bez dodatku SAMP do migotania obiektów, które są odpowiedzialne za pamięć Stream, musisz pobrać Stream Memory Fix

Nope, not work. 

It is not that the objects do not load and are all shaking, but only additional graphic artefacts appear.

5 hours ago, nonamenoname said:

Big_Daddy3400

z crashlog Widzę, że masz inne mody, spróbuj znaleźć powód

 

What should I do to ensure that after installing this module I have not changed the version of the sampler to 0.3.7DL? I do not want this version, my server works on 0.3.7, and 0.3.7DL is unfinished and eg the sound sometimes disappears / bugs. Will you make options for the unofficial version 0.3.7.dl to support 0.3.7, which is official? 

 

I have a problem with the sensitivity of mice in gta, and I do not have any mods. This one sometimes stutters on the screen and I can hardly move it. Just like something in the game wants to write in the chat, sometimes it's like it lasts longer because the letters appear in the chat with a delay. There is no addon without samp.

Share this post


Link to post
Share on other sites
nonamenoname

LOST100293

it's a magic

try to find other mods thats creates your bugs

 

also it's better to play with 0.3DL on 7 ver serv

no reason for to play with old 7

 

but you can just install 7 after addon install, why not?

Share this post


Link to post
Share on other sites
LOST100293
2 hours ago, nonamenoname said:

LOST100293

to magia

spróbuj znaleźć inne mody, które tworzy twoje błędy

 

również lepiej grać z 0.3DL na 7 ver serv

nie ma powodu, aby grać ze starym 7

 

ale po instalacji dodatku możesz zainstalować 7, dlaczego nie?

 

I do not have any module other than SAMP Addon. In addition, when I return to the game from the taskbar, the window is visible for a moment, which disappears after a while. Why?

on samp 0.3.7DL I have a problem with sound, sometimes the sound of the motor, for example, disappears, I still do not have any other module. ;) and on 0.3.7 r2 there is no problem, only on 0.3.7DL

Share this post


Link to post
Share on other sites
nonamenoname

I don't have your problems

Share this post


Link to post
Share on other sites
Big_Daddy3400

Hi,

It works in a training server, but when i join servers like IUF or RPG server it crashs

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 9 Users Currently Viewing
    0 members, 0 Anonymous, 9 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.