Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (86,018 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

nonamenoname

[REL|SA] SAMP Addon

Recommended Posts

nonamenoname

You didn't install addon

Share this post


Link to post
Share on other sites
Mozza_

Is this mod crashing with the new GTA IV HUD?

Share this post


Link to post
Share on other sites
Jelemark1341

https://imgur.com/a/XvXGQ

 

I have problem with lights of vehicle. Problem is displaying lights, lights is displaying under vehicle. This is happening when I have SAMP Addon installed and when I haven't SAMP Addon installed. It's interesting because this problem is ONLY on Duneride (another vehicles is ok). I uninstalled GTA SA, installed only SAMP Addon ( without other mods installed ) and problem is returned. Can you tell me why this happening?

Share this post


Link to post
Share on other sites
RifleExpert
Posted (edited)

Ah, installation full version fixed it for me thank you @nonamenoname.

 

However. Adding the new files .txd files such as the hud2.txd and others in modloader crash game? Should I put these into correct place or leave them out. Also is there way to save FPS? I lose 20-30 FPS with full verion of SAMP Addon, I try disabledrawdistance but not sure what else is able to be used.

Edited by RifleExpert

Share this post


Link to post
Share on other sites
AeroDynamic.

@nonamenoname

 

Could you please add an option to disable the transparent menu and return to the normal one?

Maybe some people like it that way, after all, some more customization can never hurt.

Share this post


Link to post
Share on other sites
nonamenoname
Posted (edited)

Jelemark1341

As I know it's game bug, I checked it without addon and it's same

 

 

RifleExpert

hud2.txd must be in models, why do you change file folder? I didn't tested it on modloader bcz, bcz I don't care about it and it's not for modloader

 

What your original FPS? can you post example where I can do benchmarks?

 

 

AeroDynamic.

In online game you need invincible pause cheat, I created transparent variant special for this forum, but I don't understand why you need this, only for cheat...

Edited by nonamenoname

Share this post


Link to post
Share on other sites
AeroDynamic.

Jelemark1341

As I know it's game bug, I checked it without addon and it's same

 

 

RifleExpert

hud2.txd must be in models, why do you change file folder? I didn't tested it on modloader bcz, bcz I don't care about it and it's not for modloader

 

What your original FPS? can you post example where I can do benchmarks?

 

 

AeroDynamic.

In online game you need invincible pause cheat, I created transparent variant special for this forum, but I don't understand why you need this, only for cheat...

Honestly, I just like it more with the stock menu. Also, everyone who doesn't use samp addon with the transparent menu is cheating? :/

Share this post


Link to post
Share on other sites
nonamenoname

with pause - yes, that game become unfair, you invincible

Share this post


Link to post
Share on other sites
AeroDynamic.
Posted (edited)

with pause - yes, that game become unfair, you invincible

Well, samp servers (at least the rpg server I play on) have this issue addressed in the server script. If you are paused and someone kills you, when you come back you will be dead. For example if you have wanted and a cop kills you, you will be sent to jail no matter if you are paused or not.

I wouldn't consider it cheating.

 

Edit: it would also be useful to know when someone is AFK or not.

Edited by AeroDynamic.

Share this post


Link to post
Share on other sites
nonamenoname

with antipause it's not possible to detect is game is afk in samp, there is no functions for this in samp

 

I will not return black screen in esc, it's not singleplayer

Share this post


Link to post
Share on other sites
AeroDynamic.
Posted (edited)

with antipause it's not possible to detect is game is afk in samp, there is no functions for this in samp

 

I will not return black screen in esc, it's not singleplayer

Okay, thanks for answering.

 

One more question, is it possible to disable the transparency of radar icons and also to remove the gray highlight of dialog options and return to the normal, red one?

Edited by AeroDynamic.

Share this post


Link to post
Share on other sites
ProDead

Where is Samp Addon 2.2 on 2.3 when i minimaze samp and i enter in game before i will have black screen

Share this post


Link to post
Share on other sites
LiverLande
(in regards to weapons through windows)

is it a real problem? like cheat lol?!!!!

 

Yes, on the server I play (LS-RP) you can be banned for it because it gives an unfair advantage with seeing weapons through windows for those that don't have it installed, same as SilentPatch. A .txt disabler would be great.

Share this post


Link to post
Share on other sites
RifleExpert
Posted (edited)

@nonamenoname

My FPS is 80-70, but with the Audio.asi my FPS goes down to 61-72 FPS when driving vehicle and in some area like near Pizza Place in Ganton it is lower than before in 70 FPS when he was 80 FPS. This depend of the server yes? This server I play I get good FPS but now with the Audio.asi it goes lower. Perhaps the EXE is problem? Your exe maybe not have 4gb Patch applied, i cannot apply patch or SAMP Addon wont run. I will try to do more test to see if it is the cause, disabling draw distance helped a little for me it is more stable.

 

 

Does it add new vehicle shadow? I notice some shadow not displayed properly, maybe I can disable new vehicle shadow if added. The audio.asi also turned my seabd32 texture to come out as white in game.

 

After test.. Audio.asi was culprit to making low FPS. I went to a bridge with only a car and nothing around, FPS was at 81, I remove audio.asi my FPS was 97. Is there something I can disable to bring back good FPS? I know it seem like nothing because I was in empy area, but in areas with a lot of cars my FPS goes down because of audio.asi, something like 42-47 when it should be around 60 FPS.

Edited by RifleExpert

Share this post


Link to post
Share on other sites
nonamenoname
Posted (edited)

LiverLande

for this you need to disable this:

Weapons are now visible when viewed through a vehicle window

Holding a weapon will not cause some objects to be incorrectly light anymore

Muzzle flash will now show up when firing the last bullet from the clip

vehicle window is render bug, not function

now it work as it must work

admin LS-RP must delete weapon from player in vehicle for this or not to ban players for this, did you try to PM him about this?

 

RifleExpert

no problems with seabd32 texture texture

you did something wrong

where examples with screenshots or video? try in singleplayer 1'st

 

ProDead

delete bad incompatible mods

 

AeroDynamic.

why do you need to disable icon transparent?

Edited by nonamenoname

Share this post


Link to post
Share on other sites
AeroDynamic.

LiverLande

for this you need to disable this:

Weapons are now visible when viewed through a vehicle window

Holding a weapon will not cause some objects to be incorrectly light anymore

Muzzle flash will now show up when firing the last bullet from the clip

vehicle window is render bug, not function

now it work as it must work

admin LS-RP must delete weapon from player in vehicle for this or not to ban players for this, did you try to PM him about this?

 

RifleExpert

no problems with seabd32 texture texture

you did something wrong

where examples with screenshots or video? try in singleplayer 1'st

 

ProDead

delete bad incompatible mods

 

AeroDynamic.

why do you need to disable icon transparent?

Again, it's preference, I would like it a lot better without the transparency of the icons and also I find the gray highlight pretty ugly and, sometimes, difficult to spot if using without the disableautodialog.txt option.

Share this post


Link to post
Share on other sites
RifleExpert

@nonamenoname

 

ok I will try find issue with seabed texture, but what about fps issue with the audio.asi? is there way to minimize fps loss?

Share this post


Link to post
Share on other sites
LiverLande

LiverLande

for this you need to disable this:

Weapons are now visible when viewed through a vehicle window

Holding a weapon will not cause some objects to be incorrectly light anymore

Muzzle flash will now show up when firing the last bullet from the clip

vehicle window is render bug, not function

now it work as it must work

admin LS-RP must delete weapon from player in vehicle for this or not to ban players for this, did you try to PM him about this?

LS-RP is a large server within the English roleplay community, getting 400+ players regularly. I doubt they will do this (or want to) just so mods don't create unfair advantages that can simply not be installed. I'm fine with disabling the other weapon related things it fixes, as it means I won't be (even if not maliciously or intent fully) getting any advantages over others.

Share this post


Link to post
Share on other sites
AeroDynamic.

The light coronas (from cars, lampposts) disappear after playing for a while, only happens with samp addon installed.

This is how it looks like: https://imgur.com/a/SoDkk(you can see that the lights from the front of the car and from the lampposts have disappeared)

This is how it should look like: https://imgur.com/a/mtTDR(the coronas are there on the lampposts and also at the front / rear of the car)

Share this post


Link to post
Share on other sites
RifleExpert

@AeroDynamic.

 

I believe this is bug with something like SALodLights and Limit Adjuster. With or without Limit Adjuster I not remember.

Share this post


Link to post
Share on other sites
RAZR.

Is there a way to disable these light coronas though? They annoy me a little bit since in the normal game they appear only when there is a storm and I wanna keep it that way.

 

Also, the blue arrow object: https://dev.prineside.com/en/gtasa_samp_model_id/model/19131-ArrowType2/

has its two texture indexes swapped, can it be fixed? It looks bad in maps when they are retextured.

Share this post


Link to post
Share on other sites
nonamenoname
RAZR.

what do you mean about retexture? there is new arrow dff and txd

can you post examples?

 

 

RifleExpert

can you post fps examples with screenshots or video or benchmarks? try in singleplayer 1'st

Share this post


Link to post
Share on other sites
Jelemark1341

How I can remove shadows in chat ( I mean the shadows of the text )? Is it possible?

Share this post


Link to post
Share on other sites
nonamenoname

Light type chat in F7 removed and can be enabled in sa-mp.cfg - chattype=1

 

Share this post


Link to post
Share on other sites
RifleExpert

@nonamenoname

 

I will try get screenshot examples. I dont understand why try in single player because this is with SAMP not singleplayer?

Share this post


Link to post
Share on other sites
Dwight

Please help me, im using windows 10 everything runs good v 2.1 addon, but when i add sampfuncs in game directory it loads singleplayer instead of mp and im unable to add mods because of that.

Share this post


Link to post
Share on other sites
RAZR.

I'll post images of the object later, but I encountered crashing issues when dealing with dialogs. In the new SAMP version, in certain occasions SAMP Addon crashes the client when the dialogs come up.

Cannot paste crash report cause I pressed enter on them too fast.

But can try and post it if needed.

Share this post


Link to post
Share on other sites
nonamenoname

yes, I need crashlog

Share this post


Link to post
Share on other sites
RAZR.

yes, I need crashlog

Sent in PM.

Share this post


Link to post
Share on other sites
RAZR.
Posted (edited)

So my issue with the arrow object is here.

As you can see from the first image, the arrow object was used in my map to indicate the direction of travel at an apartment block's gates.

To make this sign, I used the arrow object: https://dev.prineside.com/en/gtasa_samp_model_id/model/19131-ArrowType2/

... and retextured one of its texture indexes to invisible and the other to the correct street sign.

 

But with SAMP Addon this object is changed to a HD version, that wouldn't be an issue at all, but these texture indexes are swapped on the new model.

So the previously used index 0 became the index 1 and the previously used index 1 became index 0. Making the sign in my map look like it isn't even there.

 

Images:

Normal object, without SAMP Addon: https://i.imgur.com/8t81Ehf.png

With SAMP Addon: https://i.imgur.com/V5ddAYx.png

 

As you can see, there would be a texture displayed, but on the wrong index ID. The side and the face of the object are swapped.

 

 

And please don't tell me to swap the textures manually in the map, because that would solve the issue only for people who use the Addon and not for those who play without it.

Edited by RAZR.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.