Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Cayo Perico Heist
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA VI

      1. St. Andrews Cathedral
    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. Announcements

    2. Support

    3. Suggestions

SkyGfx: PS2, Xbox and Mobile graphics for PC


The Hero
  • Replies 9.8k
  • Created
  • Last Reply

Top Posters In This Topic

  • The Hero

    1516

  • Inadequate

    577

  • Sneed

    413

Top Posters In This Topic

Popular Posts

SkyGfx (Sky is name of Renderware for the PS2, any semblance to the actual sky is purely accidental) brings accurate PS2 and Xbox graphics to the PC version of San Andreas, Vice City and III  

Xbox-like code is implemented and seems to be working perfectly finally!!

Version 3.1 turned out to be bigger than I had thought. See OP for the link to the release. The first two inis are PS2 and PC like config as before. The third ini has some custom settings like the ne

Recommended Posts

@inadequate

 

Turn off Exclude surface from culling flag in IDE from this:

9101, luxorlight_nt, pyramid, 150, 128, 22, 5
to this:

 

9101, luxorlight_nt, pyramid, 150, 0, 22, 5

I did this to ALL .ide files a while back, since this flag is also responsible for the shadows not displaying on some surfaces (as well as collision boxes), basically this flag doesn't exist in my game anymore. Do you know if doing this can cause any problems?

 

EDIT:

 

I don't know, I always keep the dual pass on for vehicles since benefits are better than just the rotor bug. But it's still there.

 

Vehicle dual pass on:

NNB1mGU.png

Off:

5C29U0r.png

These are with completely fixed models and textures, you can see the rotor model cuts through the blur when it's supposed to be invisible.

Hmm so it wasn't fixed after all?

 

And I agree vehicle dual-pass fixes some alpha issues so it's better to use it.

Edited by Reyks
Link to post
Share on other sites

When dual pass is on the rotors still flicker and look ugly because the silhouette of the model shows up through the blur, so it's really not much better than what regular PC SA rotors look like. If you just play with SilentPatch or turn off dual pass for vehicles, then it looks good again. But turning off dual pass for vehicles will screw up other things, like making cracked windows transparent, and so on.

Edited by Snowshoe
  • Like 1
Link to post
Share on other sites
Inadequate

@inadequate

 

Turn off Exclude surface from culling flag in IDE from this:

9101, luxorlight_nt, pyramid, 150, 128, 22, 5
to this:

 

9101, luxorlight_nt, pyramid, 150, 0, 22, 5

Now works and they flash but I think is like that how to should be.

alQjIQe.png

  • Like 3
Link to post
Share on other sites
SilverRST

When dual pass is on the rotors still flicker and look ugly because the silhouette of the model shows up through the blur, so it's really not much better than what regular PC SA rotors look like. If you just play with SilentPatch or turn off dual pass for vehicles, then it looks good again. But turning off dual pass for vehicles will screw up other things, like making cracked windows transparent, and so on.

So it is not just me. The odd thing, the Rustler has it good. Wether dualpass is on or off, its rotors works great.

 

inadequate, which IDE to fix the luxorlight?

Edited by SilverRST
Link to post
Share on other sites
Inadequate

 

When dual pass is on the rotors still flicker and look ugly because the silhouette of the model shows up through the blur, so it's really not much better than what regular PC SA rotors look like. If you just play with SilentPatch or turn off dual pass for vehicles, then it looks good again. But turning off dual pass for vehicles will screw up other things, like making cracked windows transparent, and so on.

So it is not just me. The odd thing, the Rustler has it good. Wether dualpass is on or off, its rotors works great.

 

inadequate, which IDE to fix the luxorlight?

 

vegase.ide

 

And about vehicle dual pass, when is turned ON the rotors has the same behaviour as PS2? I mean looks just like in PS2 with 2P for vehicles or we've an issue there?

Link to post
Share on other sites

I still get it with Rustler. It's very apparent

jLDoQkV.png

 

I don't know if this happens on PS2 also. I think it has to do with the dual pass implementation rather.

Edited by Snowshoe
Link to post
Share on other sites

The Hero said few times that his converted PS2 vehicles doesn't have this bug! But The Hero could try to add something like ugly wheel hack for rotors too

Link to post
Share on other sites
SilverRST

 

 

When dual pass is on the rotors still flicker and look ugly because the silhouette of the model shows up through the blur, so it's really not much better than what regular PC SA rotors look like. If you just play with SilentPatch or turn off dual pass for vehicles, then it looks good again. But turning off dual pass for vehicles will screw up other things, like making cracked windows transparent, and so on.

So it is not just me. The odd thing, the Rustler has it good. Wether dualpass is on or off, its rotors works great.

 

inadequate, which IDE to fix the luxorlight?

 

vegase.ide

 

And about vehicle dual pass, when is turned ON the rotors has the same behaviour as PS2? I mean looks just like in PS2 with 2P for vehicles or we've an issue there?

 

What kind of bug does that luxorbuilding have? Corona's disappearing? PS2 has a crappy draw distance ya know :p

 

I checked the luxor crap and the corona's disappear indeed.

Edited by SilverRST
Link to post
Share on other sites

The Hero said few times that his converted PS2 vehicles doesn't have this bug! But The Hero could try to add something like ugly wheel hack for rotors too

What exactly causes this compared to the PS2 vehicles? It would be interesting to know why PC vehicles have this.

 

I tried his rustler.dff and it went away. But yeah, maybe another "wheel hack" is in order. Especially since PS2 vehicles also have their own bugs (things that aztecas fixed).

Edited by Snowshoe
Link to post
Share on other sites

What exactly causes this compared to the PS2 vehicles? It would be interesting to know why PC vehicles have this.

Dunno. A bit of R* vision maybe

Link to post
Share on other sites
Inadequate

What kind of bug does that luxorbuilding have? Corona's disappearing? PS2 has a crappy draw distance ya know :p

I checked the luxor crap and the corona's disappear indeed.

Corona's disappear. They only appear like a second or less. Ninja'd.

Edited by inadequate
  • Like 2
Link to post
Share on other sites
The Hero

Color modulation is the thing that makes the game bright and ugly.

Oh, the ignorance....

 

I don't know what's up with the rotors, it seems many people have problems with them but I've never seen them. I guess I'll have to take a look some time but I'm still busy with infrared vision. I fixed the color modulation provisorily...I'm getting closer...

  • Like 4
Link to post
Share on other sites

 

What kind of bug does that luxorbuilding have? Corona's disappearing? PS2 has a crappy draw distance ya know :p

I checked the luxor crap and the corona's disappear indeed.

Corona's disappear. They only appear like a second or less. Ninja'd.

 

What about PS2? I recall having issues with some custom coronas disappearing even though their settings were fine and I wasn't reaching the corona limit.

Edited by TJGM
Link to post
Share on other sites
Inadequate

 

 

What kind of bug does that luxorbuilding have? Corona's disappearing? PS2 has a crappy draw distance ya know :p

I checked the luxor crap and the corona's disappear indeed.

Corona's disappear. They only appear like a second or less. Ninja'd.

What about PS2? I recall having issues with some custom coronas disappearing even though their settings were fine and I wasn't reaching the corona limit.

PS2 has the same bug iirc.

 

I don't know what's up with the rotors, it seems many people have problems with them but I've never seen them. I guess I'll have to take a look some time but I'm still busy with infrared vision. I fixed the color modulation provisorily...I'm getting closer...

Probably a UglyRotorHack option.

 

PS2>PS3 rotors.

https://www.youtube.com/watch?v=ZMIBPjnZcn8

  • Like 4
Link to post
Share on other sites

 

I don't know what's up with the rotors, it seems many people have problems with them but I've never seen them. I guess I'll have to take a look some time but I'm still busy with infrared vision. I fixed the color modulation provisorily...I'm getting closer...

Probably a UglyRotorHack option.

 

PS2>PS3 rotors.

 

 

The Hero, if you can get the code of how the rotors are rendered in PS2 and implement it in a ini option like UglyRotorHack would be awesome for all of us. :D

Link to post
Share on other sites

Well, then is most recommendable and better (in my opinion) use the PS2 vehicles in PC, like Hero said PC vehicles has specular problems and now... the rotors.

Link to post
Share on other sites

Well, then is most recommendable and better (in my opinion) use the PS2 vehicles in PC, like Hero said PC vehicles has specular problems and now... the rotors.

But Aztecas_5's fixed vehicles mate... PS2 vehicles still have all the bugs that he fixed.

  • Like 1
Link to post
Share on other sites

Ok, this is a disaster. Everybody wants the rotors fixed in PC vehicles but they don't want use the PS2 vehicles even with them the rotor will be get fixed. Then I guess, this is not problem from skygfx and The Hero, skygfx is fine. This is a work for Az, probably he is missing some PS2 material in the rotors, I don't know. Or him can fix the PS2 vehicles like with the PC vehicles and everybody happy?

Edited by gts.
Link to post
Share on other sites

Or him can fix the PS2 vehicles like with the PC vehicles and everybody happy?

This would take a serious amount of time to do, plus it's not his fault, at the time nobody knew the PS2 models were different from the the PC ones, heck not even SkyGfx existed back then, also 99% of the vehicle mods out there use the PC .dff file structure as a base.

 

Like others have said, having an UglyRotorHack option (off by default) would be the best thing to do if possible.

Link to post
Share on other sites

Ok, you got a point there. Then a UglyRotorHack option will be welcomed and everybody happy. Now The Hero probably can implement the PS2 render rotor code into that ini option and we will be ok.

  • Like 1
Link to post
Share on other sites

Wait a sec...

 

HOLY SH*T I FINALLY GOT A PIX FRAME OF THIS CURSED BUG!!!!!!!!!

 

 

No idea how I managed to do it, it started happening in my game even with LESS than 256mb of streaming memory (probably because I was modding a sh*tload of .ide and .col files).

 

Anyways please someone take a look at it, it's about time this bug gets fixed:

 

https://www.sendspace.com/file/n845ly

  • Like 5
Link to post
Share on other sites

Regarding the streaming problem, that mesh doesn't look good: http://aap.papnet.eu/gta/f*cked_mesh.csv

Well yeah I guess that should be expected, I mean it IS a massive polygon shaped artifact after all :p

 

Listen I want to do everything I can to help you fix this issue, seriously this thing is the ultimate cancer of SA modding, if you need more PIX frames or anything at all please let me know, I'm really tired of this f*cking bug.

 

Here's a few things I noticed about it that may prove useful to you:

 

- The artifacts come from peds and vehicles, doesnt happen with objects AFAIK.

- If you keep playing the game with these artifacts sometimes peds will literally lose their lower parts (basically floating people with no legs).

- The game may or may not crash if you keep playing.

- They seems to react to heavy modding, if you keep modifying certain game files they will come back at some point.

- Lowering the streaming memory usage helps up to a certain point, but depending on how heavily modded the game is they will show up no matter how low the streaming memory is.

 

And here's exactly what happened these last few weeks since I started modding .IDE/.COL/.IPL files:

 

- Installed Windows 10 and San Andreas.

- Using 256mb of streaming memory everything is working fine no bugs.

- Activated Nvidia DSR, started using it in San Andreas to play at 1440p in 1080p monitor.

- Removed the flag 128 (Exclude surface from culling) from ALL models in ALL .IDE files in the "objs" section, in a attempt to make player/ped/vehicle shadows show up in more places.

- Started using the Unofficial Patch's collision files.

- Started modifying collisions trying to fix places with no grass and also wrong properties (dirt sound like concrete etc...)

- Added a few more objects to the map (already had a few before, see San Andreas Remapped, about 700+ new objects in LS with the non-public version).

- Started a new game in SA and did a few missions, saved the game.

- Next day loaded the save game and started exploring the map and stuff.

- After a while artifacts started showing up like crazy, checked the streaming memory usage, it was at 256 (maximum).

- Spend about an entire day trying to figure out what the heck was going on, after lots of digging I deactivated DSR and used the native resolution (1080p), the artifacts were gone.

- Resumed modifying collisions.

- Learned how to make new collision models using blender and replaced some sh*tty ones in SA.

- About two weeks passed and no sign of artifacts.

- Today I realized that I forgot to remove the flag 128 from the "tobjs" section in the .IDE files after _CP_'s post.

- Removed ALL the remaing flags that needed to be removed.

- Went in the game to see how nice the Luxor Casino looked.

- When I arrived there the artifacts came back from the dead.

- Got pissed off, grabbed PIX went in-game and FINALLY got a frame of this abomination.

 

Not sure if this will help, but like I said, I'm willing to do anything I possibly can to help get this bug fixed.

 

EDIT:

 

And the actual picture I got from the PIX frame (you have this already but whatever)

 

aPBWjVl.png

 

Scary stuff.

Edited by Reyks
  • Like 2
Link to post
Share on other sites

Is strange, i'm very very sure something is broken in your side (some mod or something even your savegame), just like with the 'bug' of the ped paths I noticed yesterday. On my game if I remember correctly, they come after some deads (six or seven peds) and/or exploded vehicles (one or two cars), anyway I will test this on my game later for confirm (I'm not in PC with SA installed right now).

 

P.S. All of that is written about crystal clear game with Silent Patch ONLY.

 

Anyway that lazy Urban services dont seem interesting to The Hero or anyone else. Lets just drop it then.

Edited by uncaged
Link to post
Share on other sites

Wait a sec...

 

HOLY SH*T I FINALLY GOT A PIX FRAME OF THIS CURSED BUG!!!!!!!!!

 

 

No idea how I managed to do it, it started happening in my game even with LESS than 256mb of streaming memory (probably because I was modding a sh*tload of .ide and .col files).

 

Anyways please someone take a look at it, it's about time this bug gets fixed:

 

https://www.sendspace.com/file/n845ly

oh, yesterday had the same bug first time ever, just closed the game and forgot

Link to post
Share on other sites

The Hero you are right with the Night vertex color! All i have to do to fix damn circles was swap texture with it's alpha. It's not like that on PS2 but it need to be done on PC at least for now

Edit: But the light from converted DFF is a f*cked up so the circles can't be seen behind 'em + few lights are completely white :/R* added some other lights with different texture. and the PS2 were with circles completely removed -_-

Edited by Tomasak
  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 4 Users Currently Viewing
    0 members, 0 Anonymous, 4 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.