Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    2. News

    1. Red Dead Redemption 2

      1. Gameplay
      2. Missions
      3. Help & Support
    2. Red Dead Online

      1. Gameplay
    1. GTA Online

      1. After Hours
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Sign in to follow this  
stef538

Cannot load .net.dll anymore

Recommended Posts

stef538

Hi guys, so i'm about to release my new back to the future mod, but when i test it on my main PC everything is fine, no errors. But if I try it on my Laptop (Which is powerfull enough) I get this message :

2014-11-24 16:44:10 - SEARCHING FOR SCRIPTS...
2014-11-24 16:44:10 - Unable to load Assembly 'scripts\BT-LC TimeTravel.net.dll':
System.BadImageFormatException: Could not load file or assembly '6978915 bytes loaded from ScriptHookDotNet, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. Poging om een programma te laden met een onjuiste indeling.
File name: '6978915 bytes loaded from ScriptHookDotNet, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' ---> System.BadImageFormatException: Bad IL format.
at System.Reflection.RuntimeAssembly.nLoadImage(Byte[] rawAssembly, Byte[] rawSymbolStore, Evidence evidence, StackCrawlMark& stackMark, Boolean fIntrospection, SecurityContextSource securityContextSource)
at System.Reflection.Assembly.Load(Byte[] rawAssembly)
at GTA.RemoteScriptDomain.LoadAssembly(String Filename)
2014-11-24 16:44:10 - -> InnerException:
System.BadImageFormatException: Bad IL format.
2014-11-24 16:44:10 - DONE! No DotNet script found!
Also this problem has occured on other pc's.

Share this post


Link to post
Share on other sites
byteMe420

both pc's have current .net framework? also are you compiling with obfuscation? make sure you compile with .net 4.0 (i use client profile which is all you need) and x86 settings

Edited by byteMe420

Share this post


Link to post
Share on other sites
stef538

I am not compiling with obfuscation, and yeah they have .net FrameWork 4.5

Share this post


Link to post
Share on other sites
byteMe420

did you check if you are compiling with x86 and .net 4.0?

Share this post


Link to post
Share on other sites
stef538

well Definitly X86, but how do I check if i'm compiling with .net 4 ?

Share this post


Link to post
Share on other sites
Jitnaught

well Definitly X86, but how do I check if i'm compiling with .net 4 ?

Project -> *project name* Properties... -> Target framework

 

I don't think compiling with .NET Framework 4.5 would be the problem though, as I compile my mods with 4.5 and they work for me and everyone on GTA4-Mods.com.

Edited by LetsPlayOrDy

Share this post


Link to post
Share on other sites
stef538

Alright, well I listed .NET Framework 4.0 Client as Active, but whenever I do that it gives me errors in scripthook.dll. So i'm trying some other frameworks.

Share this post


Link to post
Share on other sites
byteMe420

only suggestion is to try and recompile, if not reinstall .net

 

http://stackoverflow.com/questions/13416240/what-does-bad-il-range-exception-mean


Alright, well I listed .NET Framework 4.0 Client as Active, but whenever I do that it gives me errors in scripthook.dll. So i'm trying some other frameworks.

 

do you mean scripthookdotnet.dll? that was compiled with 4.0 so it should not, probably Visual Studio settings are wrong somewhere

Share this post


Link to post
Share on other sites
stef538

yeah I meant ScriptHookDotNet.dll, So i'll be reinstalling windows soon. just a clean install and then I try again :) thanks guy.

Share this post


Link to post
Share on other sites
stef538

Didn't work :(

Share this post


Link to post
Share on other sites
Rugz007

So that's kinda strange... Can you give me the file... I will test on my com?

Share this post


Link to post
Share on other sites
stef538

nah, it doesn't work on other pc's then my own. tested it on several pc's.

Share this post


Link to post
Share on other sites
byteMe420

nah, it doesn't work on other pc's then my own. tested it on several pc's.

try compiling the source code on another pc

Share this post


Link to post
Share on other sites
stef538

Doesn't work either..

Share this post


Link to post
Share on other sites
byteMe420

what references are you using by the way?

 

are you using, for 1.0.7 or eflc, 0.5.1 (1.0.4 uses 0.4.0) scripthook and 1.7.1.7 beta scripthookdotnet?

 

if you don't mind you can pm me your source code and i will try to compile it... im also curious what is in your code that your compiler can't generate IL properly if it is even code related.

Edited by byteMe420

Share this post


Link to post
Share on other sites
stef538

just 1.0.7.0 and 1.7.1.7B scripthookdotnet, But I already threw away the project and started over..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • 1 User Currently Viewing
    0 Members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.