Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (92,869 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

nWo51289

[REL|SA] SA_LODless

Recommended Posts

nWo51289

Thanks, now I know what was causing the crash. Copy and replace below to the [sALIMITS] in you limit_adjuster_gta3vcsa.ini

 

[sALIMITS]PtrNodeSingle = 140000PtrNodeDouble = 18400EntryInfoNode = 500Peds = 140Vehicles = 110Buildings = 30000Objects = 7000Dummys = 19000ColModel = 19999Task = 500Event = 200PointRoute = 64PatrolRoute = 32NodeRoute = 64TaskAllocator = 16PedIntelligence = 140PedAttractors = 64MatrixList = 90000OutsideWorldWaterBlocks = 500AlphaEntityList = 1250InVisibleEntityPtrs = 5000VisibleEntityPtrs = 5000StreamingObjectInstancesList = 7500TimeModels = 1500

Share this post


Link to post
Share on other sites
uokka

 

@Download the errordump.asi from here and post the error log.

Whenever I go to that link I get this jumbled up text:

 

(...) ;(;a;w;░;╘;⌡<╢<м<Ф<Ъ<=.=D=Z=p=├= =Ё=и=ъ=У=>!>?>E>L>у>Р>$?+?6?p?ё?©?О?0t0F0T0\0x0┴0≥0╜0╩0ц0ъ0К0П061I1x1└1░1°1х1л1п1т1ь1э1Ю1x2|2─2└2┬2▄2P6Ё6д6Х6Т6<7B7H7N7T7Z7`7&949ё;Ю;X>И>K?R?t?{[email protected]╓00╚0╤3Б3Х34>4D4S4Ь40555?5s5▀5⌠5°5у5 666*6╣6я6И6<7i78B8w8╦8З8L99║9у9%:G:j:÷:б:┘;▄;≤;й;у;<T<┬<√<!=*=y=┘=║=╖=╢=╩=ю=ь=Ц=И=Р=В=>">+>4>A>O>p>ъ>Й>%?]?▒?°?PD0$0D0J0Q0g0m0t0┌0┬0╣1╪1≤2═2╣2ю2e45&5L5╛5╩5ж5К8А9u;╦;Д;<И=`хA0E0I0M0Q0U0Y0]0l3│3a4k4x4П4Ж4555 [email protected]}5┐5Д5К5616d6{6m7s7y77┘7▀7▓7≥7═7╖7╝7╣7╪7д7л7т7Ю7И7Н7Т7Ч7888#83888>8D8Z8a8■9≥9╤9╪9н9:@:J:b:╡:Д:;О<[email protected]=▐=Ъ=o>u>▐>·>╚>╥>г>н>щ>И>Ж>?X?f?┐?█?Ё?Ж?px00>0|0▒0╝0B12$2<2W2╝2^3p3у5,7R7X7┌7г7н7Ц7*848_8w8∙8╧8И8Ш8)9L9R9Ь9:=:c: <3<R<q<л<≥=╩=ф=Э=>6>G>T>[>k>}>┌>5?A?─ьL0202S2w2°3п[email protected] (...)

 

 

Right-Click -> Save As...

Share this post


Link to post
Share on other sites
Savidge

Thanks, now I know what was causing the crash. Copy and replace below to the [sALIMITS] in you limit_adjuster_gta3vcsa.ini

Yes! That works! Now it looks awesome. Thanks dude. :^:

 

Right-Click -> Save As...

oh... please excuse my stupidity, heheh... :dontgetit:

Share this post


Link to post
Share on other sites
Gramps

Will try those limits tonight.

I even tried the limits from the Trilogy Core, to no avail. This should work since SergeantSavidge said he had the same problem as me and its fixed.

 

@EDIT

Yeah thats better. I knew from last time I used this I was missing something.

 

And yeah, those bugs are annoying. Very annoying.

My game starts running using 300mb of RAM and 60MB of Stream Mem Usage. Slowly starts to creep up and models slowly start appearing when I look around. Takes about a minute or so to load everything.

But when I use RoSa, it just stops loading anything half way through LS. Will have a look into this soon.

Edited by Methical

Share this post


Link to post
Share on other sites
BLlTZ

Interesting way you chosen there. What have you done to make those trees without LOD to appear. I haven't download your mod yet (I'm having heavy PC problems), but I'm notice them from your images published on your page one.

Edited by BLlTZ

Share this post


Link to post
Share on other sites
Gramps

But when I use RoSa, it just stops loading anything half way through LS. Will have a look into this soon.

I meant to say SRT.

Share this post


Link to post
Share on other sites
KELASHI

wow, a tiny mod did this trick.

Share this post


Link to post
Share on other sites
nWo51289

@BLITZ - LOD Distance=1500.0 in SALA & max_draw_distance_for_normal_objects = 1500.0 in IDE_DD_Tweaker increases the limit to how large of a draw distance you can set for the model to have a collision (game default is 299, anything above that the model in game gets treated as a Lod)

 

@Methical - I agree annoying, stops loading half way through LS? Did you fly anywhere else? Months ago when I had SRT installed & LODless the map would stop loading whenever I fly over the third city, no matter which city I flew over last, but never had it stop in LS. But I think the limits below does help with that problem you mentioned (remember flying around and the game kept on working and this was with Rosa installed), you need to kindly ask Link or ThirteenAG to add them to their limit adjuster (I haven't got visual studio installed right now)

ENV_MAP_MATERIAL_POOL 16000 // Default is 4096 [0x5DA08D] [0x5DA106] (Same as SetMatDataPool in SALA)ENV_MAP_ATOMIC_POOL 4000 // Default is 1024 [0x5DA0CA] (Same as SetAtmDataPool in SALA)SPEC_MAP_MATERIAL_POOL 16000 // Default is 4096 [0x5DA08E]
Edited by nWo51289

Share this post


Link to post
Share on other sites
dxivilea

Crashes @60% on a clean sa with project 2dfx and cleo yes I edited the .ini

Share this post


Link to post
Share on other sites
Gramps

Did you do the edits for Limit Adjuster and IDE DD Tweaker?

Share this post


Link to post
Share on other sites
Silent

(game default is 299, anything above that the model in game gets treated as a Lod)

300

Share this post


Link to post
Share on other sites
Gramps

300

keep-calm-this-is-sparta-24.png

Share this post


Link to post
Share on other sites
LINK/2012

Out of curiosity, did you take into account those issue while modifying the IPLs?

i.e. instead of removing the LOD line replace it with a dummy object in a dummy interior

 

We'll try to priorize the implementation of the limits posted here on the OpenLA.

Edited by LINK/2012

Share this post


Link to post
Share on other sites
nWo51289

300

Grumpy-Cat.jpg

 

@LINK/2012 - I did but forgot :facedesk: Next version will be done properly....hopefully.

 

While the screen below looks pretty bad, I couldn't be bothered to increase draw distances for models in LAe.ipl. Next version will also be SAMP compatible.

2fed5d350419613.jpg 1ad7a0350420268.jpg

Edited by nWo51289

Share this post


Link to post
Share on other sites
damiann69

Does it affect trees?

Share this post


Link to post
Share on other sites
legolaas

Error: This command requires archive to be opened, it isn't opened currently.

 

Edit: After install clean gta sa crashed loadscreen.

Edited by legolaas

Share this post


Link to post
Share on other sites
KELASHI

Are you having UAC enabled? Which makes all batch locate to system32. If so, Insert "cd /d %~dp0" as first line in SA_LODless.bat and run it as administrator.

Share this post


Link to post
Share on other sites
legolaas

Are you having UAC enabled? Which makes all batch locate to system32. If so, Insert "cd /d %~dp0" as first line in SA_LODless.bat and run it as administrator.

Thanks. Problem solved

Share this post


Link to post
Share on other sites
MrMateczko

I've tested LODless just now.

While I haven't had any crashes, the constant map holes, models not loading behind you, and with the popping vegetation (BSOR in my case), I have to say it's just an experiment, and not a suitable replacement for LOD Mod, at least in my case.

And yes, the enexes are screwed up.

And also, using the memory2048.cs might have the weird artifacts while moving the camera, with memory512.cs this doesn't happen, but isn't 512 too low for this?

Anyways, great work.

Edited by MrMateczko

Share this post


Link to post
Share on other sites
Savidge

does the enex issue have anything to do with no peds in any interior at all? or is that a bug on my end?

Share this post


Link to post
Share on other sites
nyolc8

Crashes at 60%, made all changes that suggested in this topic. The .bat command ran just fine without errors.

Share this post


Link to post
Share on other sites
Asdf92

Crashed on load. I have IDE_DD_Tweaker and OpenLA installed.

 

Edit: Solved using Limit Adjuster from 2dfx and value from above.

Edited by Rizky Rizaldi

Share this post


Link to post
Share on other sites
L€ON

crash at the end of loading screen and i can hear only the music

i've project2dfx, marty's enb, srt3 and PO installed

 

i've already set that values of nWo51289 on limit_adjuster_gta3vcsa.ini but still crashes

Share this post


Link to post
Share on other sites
BlackScout

Looks great :D

gta_sa%202014-09-24%2023-35-44-36.png

Comparison:

 

Before%20After%20LODLESS.png

 

Tons of mods installed *improvements and fixes only*, don't even know how it's not crashing...

Edited by BlackScout

Share this post


Link to post
Share on other sites
HPro

I'm spawning but CJ just keep droping like a glitch on the ground endlessly wtf? then he appear up nd drop again

It's a f*cking hole how to fix this?

Edited by HPro

Share this post


Link to post
Share on other sites
SilverRST

This tool is very great! Now I cannot live without it. It's always annoying to see those LOD models turns into HQ model when you cruising.

 

There is ony one downside about this mod: the lights corona's from Project 2dfx no longer spawn at far distance.

They appear as you are close in that area, or better said, just like the regular unmodded GTA SA.

I do not know which line is responsible for the streetlights corona's in IDE_Tweaker, I tried many times but still no luck.

So I just copied the entire .ini file from the stock IDE_Tweaker zip.

It works surprisingly.

 

EDIT

 

Since it's very difficult to have map mods, could you add the missing Four Dragons Casino stuff like lamps?

http://gtaforums.com/topic/738238-san-andreas-beta-edition/?p=1066212802

Edited by SilverRST

Share this post


Link to post
Share on other sites
HPro

Make my samp just crash..very great :panic:

Share this post


Link to post
Share on other sites
Marty McFly

Then it's either not SAMP compatible (I don't see why it should be anyways, SAMP is sh*t) or you failed the installation. But there's not much to fail so I'd guess on SAMP incompatibility. Did you test in Singleplayer (same folder but start the SA exe)?

Edited by Marty McFly

Share this post


Link to post
Share on other sites
HPro

Then it's either not SAMP compatible (I don't see why it should be anyways, SAMP is sh*t) or you failed the installation. But there's not much to fail so I'd guess on SAMP incompatibility. Did you test in Singleplayer (same folder but start the SA exe)?

 

Yes work for Singleplayer not for samp

Share this post


Link to post
Share on other sites
CallyW

Then it sounds like Marty McFly is right on the money then. I'm sure it did say at the start of the thread it's not for SAMP quite yet?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.